Development [CLOSED][ROM][13.0][hanoip] Android Open Source Project [Tiramisu] [G60/G40]

Status
Not open for further replies.
Search This thread

arsradu

Senior Member
Apr 28, 2011
3,695
3,408
Motorola One Action
Moto G40 / G60
Working fine here...

Location is on? Which app are you using to test that? I've tested Google Maps, and while it took a bit longer than usual to connect (it's also the first time using the app since I've installed this ROM, so that might be intended), it did in the end, and working perfectly fine.

You could try to test GPS reception with something like the GPS Test app. If you get a signal there, the problem is likely with the app.

Also, just in case this is a permissions issue, try to check Google Maps' permissions under Settings > Apps > Maps > Permissions > Location (should be allowed).

Update:
You might be on to something... I tried this on another phone, running Pixel Experience on Android 12. And that did work from the first time. Also, one thing I've noticed is that with this ROM, you don't get that green dot in the top right corner to let you now it's using certain things (in this case your Location).

I'll try a few more things and let you know if I find something useful.
 
Last edited:

aadi52002

Member
Aug 20, 2022
10
1
Moto G40 / G60
Working fine here...

Location is on? Which app are you using to test that? I've tested Google Maps, and while it took a bit longer than usual to connect (it's also the first time using the app since I've installed this ROM, so that might be intended), it did in the end, and working perfectly fine.

You could try to test GPS reception with something like the GPS Test app. If you get a signal there, the problem is likely with the app.

Also, just in case this is a permissions issue, try to check Google Maps' permissions under Settings > Apps > Maps > Permissions > Location (should be allowed).

Update:
You might be on to something... I tried this on another phone, running Pixel Experience on Android 12. And that did work from the first time. Also, one thing I've noticed is that with this ROM, you don't get that green dot in the top right corner to let you now it's using certain things (in this case your Location).

I'll try a few more things and let you know if I find something useful.
Ok let me see when outside. Tested with Google Map. One new discovery, Moto G40 has front flash light. Can turn it on with Gcam Video Recording Options.
 

arsradu

Senior Member
Apr 28, 2011
3,695
3,408
Motorola One Action
Moto G40 / G60
Ok let me see when outside. Tested with Google Map. One new discovery, Moto G40 has front flash light. Can turn it on with Gcam Video Recording Options.
G60 has it too. :) I haven't tried that option with GCam though. :))

I think there is an issue with GPS with this ROM... But I'm not yet quite sure why it's only with certain apps. Still, I'm confused as to why we don't have that green dot in the corner.

Update:

Tested two more navigation apps: Here we Go (ex Nokia Maps), and Waze. Both acquired location in a few seconds. So...looks like the problem might be with Google Maps only. Still not sure why, but will try a couple more things. :)
 
Last edited:
  • Like
Reactions: aadi52002

aadi52002

Member
Aug 20, 2022
10
1
Moto G40 / G60
Google Personal Safety Application seems not working.
 

Attachments

  • Screenshot_20220820-183040.png
    Screenshot_20220820-183040.png
    69.5 KB · Views: 24

arsradu

Senior Member
Apr 28, 2011
3,695
3,408
Motorola One Action
Moto G40 / G60
In few custom roms, I have seen update option built into settings only. Would we able to update this rom with the inbuilt update option too ?
I'm not sure. But yeah, that's what I was curious about, too.
Google Personal Safety Application seems not working.
Indeed. Even though it doesn't come with the ROM, it's crashing upon startup. At least I couldn't get it to stay open. Maybe it needs some support files built into the OS.
Google Contacts - Cannot set 'Default Account for New Contacts'
Confirmed.

I'd also like to add some weird design issues when searching Settings (screenshot below). That doesn't seem to be intended. :)

Screenshot_20220820-164558.png
 

aadi52002

Member
Aug 20, 2022
10
1
Moto G40 / G60
Google Play Services occasionally shows this message while using Google Applications (like messages etc). Although all applications including system applications have been granted all permissions.
 

Attachments

  • Screenshot_20220821-091701.png
    Screenshot_20220821-091701.png
    137.7 KB · Views: 20
  • Like
Reactions: arsradu

arsradu

Senior Member
Apr 28, 2011
3,695
3,408
Motorola One Action
Moto G40 / G60
Google Play Services occasionally shows this message while using Google Applications (like messages etc). Although all applications including system applications have been granted all permissions.
Confirmed. But I couldn't find a permission that says "files and media". So...maybe that's the problem?

Update:
Yep, there's no Files and Media permissions, so it can't be enabled.

Here's what it should look like (screenshot from PE Android 12 on another phone).
Screenshot_20220821-085430_Permission controller.png


By the way, can anyone confirm bluetooth working with this ROM? File transfers and audio.

I can't send anything to anyone... No BT icon between the sharing options.
Also, BT audio...doesn't seem to work either. You can connect a pair of headphones for example, but when you want to play something from Spotify for example, it plays in the speakers. Same for YouTube. It doesn't seem to actually connect to the headphones, even though the two devices are paired.
 
Last edited:

aadi52002

Member
Aug 20, 2022
10
1
Moto G40 / G60
Confirmed. But I couldn't find a permission that says "files and media". So...maybe that's the problem?

Update:
Yep, there's no Files and Media permissions, so it can't be enabled.

Here's what it should look like (screenshot from PE Android 12 on another phone).
View attachment 5691985

By the way, can anyone confirm bluetooth working with this ROM? File transfers and audio.

I can't send anything to anyone... No BT icon between the sharing options.
Also, BT audio...doesn't seem to work either. You can connect a pair of headphones for example, but when you want to play something from Spotify for example, it plays in the speakers. Same for YouTube. It doesn't seem to actually connect to the headphones, even though the two devices are paired.
 

Attachments

  • Screenshot_20220821-115934.png
    Screenshot_20220821-115934.png
    180.4 KB · Views: 16

arsradu

Senior Member
Apr 28, 2011
3,695
3,408
Motorola One Action
Moto G40 / G60
Interesting thing happened. I reflashed the ROM, and the Messages issue vanished in thin air. There's still no option for Files & Media (might have been removed in Android 13 and replaced with more "granular" options). But also, no issue opening/sending/receiving SMS anymore.

Not sure what changed...

Also, the "At a Glance" widget from the Google pack seems to be working fine (screenshot below). Only the one from the Launcher settings doesn't. Also, no way to turn it off (the option doesn't do anything when set to Off). However, this also occurs with PE ROM on Android 12. So...could be a bug with the launcher itself.

Screenshot_20220822-081954.png
Screenshot_20220822-081749.png
 
Last edited:
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Changelog Tue Aug 16 07:42:38 UTC 2022
    ============================

    • Based on android-13.0.0_r2
    • Improved system stability
    • User interface enhancements
    • Google security patch 2022-08
    • Built with prebuilt kernel , dtbo , dtb & vendor from stock
    • Google apps included
    • Built with pixel goodies ( launcher, wallpapers, icons, fonts & bootanimation)
    • Selinux enforced
    • Safety net pass out of the box
    5
    aosp-13.png



    Android Open Source Project for Moto G60 & G40



    About AOSP

    Android is an open source operating system for mobile devices and a corresponding open source project led by Google. This site and the Android Open Source Project (AOSP) repository offer the information and source code needed to create custom variants of the Android OS, port devices and accessories to the Android platform, and ensure devices meet the compatibility requirements that keep the Android ecosystem a healthy and stable environment for millions of users.

    As an open source project, Android's goal is to avoid any central point of failure in which one industry player can restrict or control the innovations of any other player. To that end, Android is a full, production-quality operating system for consumer products, complete with customizable source code that can be ported to nearly any device and public documentation that is available to everyone.

    Just as you can contribute code to AOSP, you can also contribute to AOSP documentation—and we want your input! Android's flexibility and ever-changing codebase means this site needs your feedback to keep content fresh, accurate, and relevant to Android implementors. We encourage you to check the changelog for details on recent AOSP updates and to report bugs or offer suggestions using the Site Feedback at the bottom of every page.



    Whats working?

    Wi-Fi
    RIL
    Volte
    Mobile data
    GPS
    Camera
    Flashlight
    Camcorder
    Bluetooth
    Fingerprint
    FM radio
    Sound
    vibration

    Known issues ?
    You tell me

    Installation process

    Click Here for Installation process



    Credits
    * AOSP for source
    * Motorola for prebuilt kernel , dtbo , dtb & vendor
    * Moderators (For Giving Freedom To Post Threads)



    3
    I need one help windows explorer does not showing the MTP what to do ? am stuck in Twrp couldn't able to move rom zip to phone storage
    Doesn't have to be on the phone (internal) storage. It can be anywhere. If you're using an external storage (SD Card), you can get it from there.

    Alternatively, you should be able to sideload the ROM, from your PC, using CMD prompt/Terminal, with this command:
    adb sideload /path-to-your-ROM.zip

    Just make sure adb is working (USB Debugging enabled, and fingerprinting allowed).
    3
    Potential bug: when trying to restore the backup from Google, it gets stuck in the "Just a few moments" screen.

    Screenshot below.
    Screenshot_20220818-115355.png


    Update:

    If anyone else encounters this issue, it looks like the problem is...permissions.

    If you get the Google Play services error, you need to change settings according.

    Screenshot_20220818-121142.png


    Basically this is what needs to be changed.

    Screenshot_20220818-121156.png


    Alternatively, you can simply go to Settings > Apps > Google Play Services > Permissions, and allow permissions for Contacts, Phone and SMS.

    After that, you can go back one step in the restore flow (in case it's stuck in loading) and try to restore again. This time, it should go through.
    2
    Just because you we able to enjoy Android 12 and now Android 13 you are great sir thank you very muxh