• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Comdirect photoTAN app detecting root [Fix found]

Search This thread

Conan179

Senior Member
Apr 28, 2010
841
86
xprivacylua

I have too devices.
a note 9 with android 10 and a note 20 ultra 5g Android 11.
Note 9 phototan app working.
Note 20 phototan app dont working, same setting, inntresting.


I know, the innstall on my note 9 was not correct, installed the apk again over it and the same message comes up that it is not allowed, downgrade ok and wait is now announced.


edit:
Now fry me a stork, I have downgraded the phototan app on my note9, now it works without problems on my Note 20.
I don't understand what's going on.

Please take a look at yourself to see if the phototan app, all options in magisk hidden, are activated?
 
Last edited:
  • Like
Reactions: Laptapper

Laptapper

Senior Member
Jan 17, 2016
842
317
xprivacylua

I have too devices.
a note 9 with android 10 and a note 20 ultra 5g Android 11.
Note 9 phototan app working.
Note 20 phototan app dont working, same setting, inntresting.


I know, the innstall on my note 9 was not correct, installed the apk again over it and the same message comes up that it is not allowed, downgrade ok and wait is now announced.


edit:
Now fry me a stork, I have downgraded the phototan app on my note9, now it works without problems on my Note 20.
I don't understand what's going on.

Please take a look at yourself to see if the phototan app, all options in magisk hidden, are activated?


Now fry me a stork? 🤣 English for runaways, I break together and also my english is not the yellow from the egg 😂😂😂
I didn't say something of the horse if I say you're a german like me🤣
 

huxx

New member
Jul 19, 2021
2
0
would some one be so nice and can give me a step by step noob friendly instruction maybe in german cause my english is very bad also ...

i just got a a fresh galaxy s4 rooted and os is lineageos 18.1 V1 would appreciate if you start the instruction from there i also give a donation for the help

i really need to get comdirect photo tan running or iam ****ed on 1st next month cause i have to do important bank transfers :(
 

Laptapper

Senior Member
Jan 17, 2016
842
317
would some one be so nice and can give me a step by step noob friendly instruction maybe in german cause my english is very bad also ...

i just got a a fresh galaxy s4 rooted and os is lineageos 18.1 V1 would appreciate if you start the instruction from there i also give a donation for the help

i really need to get comdirect photo tan running or iam ****ed on 1st next month cause i have to do important bank transfers :(

Unroot
Make transactions
Root again
Read this thread from the beginning and you will get your answer
 

huxx

New member
Jul 19, 2021
2
0
Unroot
Make transactions
Root again
Read this thread from the beginning and you will get your answer

i cant .. they made the apps uncompatible for my smartphone with android 5.0 thats the only os i can get unrooted :( thats why i did the root and installed lineageos .. and yes read again is good to say but i installed magisk and was that far i enabled hide and selected the app but the app still detect my phone as rooted i dont understand the module thing steps rio etc :( maybe i call them tomorrow and activate sms tan :\ but thanks
 

p3rsi2k

New member
Feb 16, 2011
3
2
Hi to phototan root users

For me the last method was unstable so I tried other ways...


Now I've got the easiest method to get phototan working on rooted phones:
Only installed riru and riru unshare
Magisk hide and magisk renamed
Then 3C toolbox and disabling only one service.... Voila
Worked awesome. Thank you for the tutorial.

It's also running the V8.3.2. with ONLY 3C.
 

Knotte

Senior Member
Nov 19, 2012
132
23
Munich
So guys
My favorite solution:
Magisk canary
Riru
Riru unshare
Riru lsposed
Xprivacilua 1.30

Safety net is ok
Phototan working
Thanks a lot.
The trick for me was using LSPosed instead of EdXposed. With EdXposed I failed the Safetynet check which obviously caused PhotoTAN not to work. With LSPosed Safetynet is passed and PhotoTAN finally working again!
I even restored Magisk (no need to rename/hide the app), MagiskHide ist active though just to be sure.
 
Last edited:
  • Like
Reactions: Laptapper
This is crazy, I just can't find a solution to get it to work on surya.
Any idea what could be the missing piece?

Screenshot_20210730-051858_Settings.png
Screenshot_20210730-051931_XPrivacyLua.png

Screenshot_20210730-052025_3C_All-in-One_Toolbox.png
Screenshot_20210730-052056_Settings.png
Screenshot_20210730-052537_LSPosed.png
Screenshot_20210730-052816_Settings.png
 
Yes, i have tickt all user apps +einstellungsspeicher&system framework
Thanks...
I started all over again:
-deinstalled phototan app (deleted cache and data before manually)
-wiped Dalvik and Cache in Twrp
-installed Magisk modules: riru, riru enhanced mode for magisk hide, riru lsposed
-reboot
-activated Xprivacylua in lsposed
-ticked all apps for Xprivacylua in lsposed
-reboot
-deactivated magisk hide, dehided magisk manager
-reboot
-hided magisk manager, activated magisk hide
-reboot
-checked safetynet status: passed
-installed phototan app
-hided all 3 services of phototan app within magisk hide
-ticked "read applications" within Xprivacylua for phototan app
-unticked service ComponentDiscoveryService from phototan app within 3c toolbox
-started phototan app - FAILED
 

Laptapper

Senior Member
Jan 17, 2016
842
317
Thanks...
I started all over again:
-deinstalled phototan app (deleted cache and data before manually)
-wiped Dalvik and Cache in Twrp
-installed Magisk modules: riru, riru enhanced mode for magisk hide, riru lsposed
-reboot
-activated Xprivacylua in lsposed
-ticked all apps for Xprivacylua in lsposed
-reboot
-deactivated magisk hide, dehided magisk manager
-reboot
-hided magisk manager, activated magisk hide
-reboot
-checked safetynet status: passed
-installed phototan app
-hided all 3 services of phototan app within magisk hide
-ticked "read applications" within Xprivacylua for phototan app
-unticked service ComponentDiscoveryService from phototan app within 3c toolbox
-started phototan app - FAILED
I've recognized if you've run in root acknowledge of phototan then it's not enough to delete app data and cache. and also don't reinstall phototan because trouble with 3c and xprivacylua settings.
If you delete app data and cache AND the vdex and odex file in subfolder of the phototan app, you can start and login to phototan. Now I've finished app setup and all is running well.

Of course with installing the necessary tools (see other posts)
 
Last edited:
I've recognized if you've run in root acknowledge of phototan then it's not enough to delete app data and cache. and also don't reinstall phototan because trouble with 3c and xprivacylua settings.
If you delete app data and cache AND the vdex and odex file in subfolder of the phototan app, you can start and login to phototan. Now I've finished app setup and all is running well.

Of course with installing the necessary tools (see other posts)
Excellent! That made it (y)
 
  • Like
Reactions: Laptapper

dahadd

Member
Jan 23, 2019
8
1
Hey @Laptapper

Which Apps?
3c and xprivacy also Install or not?
I've recognized if you've run in root acknowledge of phototan then it's not enough to delete app data and cache. and also don't reinstall phototan because trouble with 3c and xprivacylua settings.
If you delete app data and cache AND the vdex and odex file in subfolder of the phototan app, you can start and login to phototan. Now I've finished app setup and all is running well.

Of course with installing the necessary tools (see other posts)
 

B3r3av3d

Member
Aug 10, 2012
24
8
Karlsruhe
I've recognized if you've run in root acknowledge of phototan then it's not enough to delete app data and cache. and also don't reinstall phototan because trouble with 3c and xprivacylua settings.
If you delete app data and cache AND the vdex and odex file in subfolder of the phototan app, you can start and login to phototan. Now I've finished app setup and all is running well.

Of course with installing the necessary tools (see other posts)

Thank you, this helped me, as well.

But I needed to do some poking around to find where those files live.

Maybe this helps someone


Bash:
# in termux or another terminal app

su
cd /data/app

# Find comdirect app dir (on my phone these are kind of hidden in weird ~~48r9845...~~ folders)
cd "$(find . -name "*comdirect*")"

cd oat/arm64

rm -rf base.*
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Hey fellas I got it working and others apps detect magisk before.

    Update to latest v23
    Install modules riru and riru unshare
    Remove data from tan app
    Go to magisk hide and tick all process to hide included the isolated
    Start the tan app and do the activation again.

    Problem you need wait 2 days to activate because comdirect use new activation process for photo tan app.

    Working fine all version 8.3
    This works like charm. Just did it today
    Thank you so much been struggling for ages with that ****
    1. I deleted all data for photo tan app and prevented it from gaining any permissions (especiallo I disabled the permission to find what other apps are installed)
    2. I activated magisk hide for photo tan
    3. I installed "riru" from magis modules search from within the magisk app
    4. I googled for "riru unshare", downloaded the zip from github and installed it with magisk installer app (modules "install as zip"
    5. reboot
    6. open photo tan and it works (have to do a new activation though)

    noted: I did not have to do any further configuration of the modules
    1
    Any Changes in Phototan App?
    Since today nothing works

    8.3.2
    1
    @pa.pn2 probably a bit out of topic here, but I found several information that you will need to wipe when updating from A11 to A12 and keeping root so you are trying to re-setup now and application does not start?
    I dirty flashed android 12 yes.
    Maybe i will do a clean flash and we will see what happens.
    I also have problems with YouTube music. It doesn't play my music files somehow lol
  • 11
    Since version 8.3.0 additional measures to detect root have been added, do not update as MagiskHide won't be able to prevent detection. Until a solution is found I would recommend staying on the previous version for as long as possible.

    Finding out what exactly is causing the root detection is beyond my technical abilities but I would provide as much information needed to those willing to help.

    ---

    The solution found by @pxrave appears to be working:


    Hey fellas I got it working and others apps detect magisk before.

    Update to latest v23
    Install modules riru and riru unshare
    Remove data from tan app
    Go to magisk hide and tick all process to hide included the isolated
    Start the tan app and do the activation again.

    Problem you need wait 2 days to activate because comdirect use new activation process for photo tan app.

    Working fine all version 8.3


    Link to the Riru Unshare module:
    8
    Hey fellas I got it working and others apps detect magisk before.

    Update to latest v23
    Install modules riru and riru unshare
    Remove data from tan app
    Go to magisk hide and tick all process to hide included the isolated
    Start the tan app and do the activation again.

    Problem you need wait 2 days to activate because comdirect use new activation process for photo tan app.

    Working fine all version 8.3
    6
    So guys
    My favorite solution:
    Magisk canary
    Riru
    Riru unshare
    Riru lsposed
    Xprivacilua 1.30

    Safety net is ok
    Phototan working
    4
    Update to latest v23
    Install modules riru and riru unshare
    Remove data from tan app
    Go to magisk hide and tick all process to hide included the isolated
    Start the tan app and do the activation again.

    Problem you need wait 2 days to activate because comdirect use new activation process for photo tan app.
    Just went through this process. For me it was sufficiant to update to magisk v23, rename magisk, install riru and riru unshare, hide all processes of phototan app in magisk hide and *clear cache* only for phototan app. This way I did not have to re-activate the phototan app (nor to wait 2 days) again.
    4
    xprivacylua

    I have too devices.
    a note 9 with android 10 and a note 20 ultra 5g Android 11.
    Note 9 phototan app working.
    Note 20 phototan app dont working, same setting, inntresting.


    I know, the innstall on my note 9 was not correct, installed the apk again over it and the same message comes up that it is not allowed, downgrade ok and wait is now announced.


    edit:
    Now fry me a stork, I have downgraded the phototan app on my note9, now it works without problems on my Note 20.
    I don't understand what's going on.

    Please take a look at yourself to see if the phototan app, all options in magisk hidden, are activated?


    Now fry me a stork? 🤣 English for runaways, I break together and also my english is not the yellow from the egg 😂😂😂
    I didn't say something of the horse if I say you're a german like me🤣