Compiling Roms Thread: Build errors, bootloops, ...

Search This thread

GalaticStryder

Senior Member
Nov 20, 2014
1,326
4,753
0
Porto Alegre
yes i do

luckily i have a copy of the old vendor on my HDD so i can manually change sources

Upload it to your github as platform_vendor_lge so we can continue with updated builds. I'm using my modded SlimRoms device repos, so it won't be very helpful using them for flo's AOSP build.

A bit out of topic, SlimLP unofficial builds:
I have D800, D801, D802 and D803 is compiling. SlimLP UNOFFICIAL builds, I just need testers, thats why I created that thread and for every dev who wants a feedback beforehand. I have seen a ROM for D804, but I've never heard we had this variant haha. I don't think I'm gonna build F320, people usually say it has lots of bugs and so on. I'll post just when I have every device running properly, and next builds will have some performance tweaks.
 

arcardinal

Senior Member
Jul 25, 2010
622
1,667
0
Twin Cities
I'm running trough some error after a repo sync on SlimLP also, making me unable to build some other variants (already built D800, D802 and D801 / VS980) it's some commit they had merged in Telephony, I will check that.

Code:
 make: *** No rule to make target `/home/stryder/slim/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.hardware_intermediates/classes.jar', needed by `/home/stryder/slim/out/target/common/obj/APPS/Telecom_intermediates/classes-full-debug.jar'.  Stop.

Not a device specific error, but it's weird the last commit in
packages/services/Telephony on SlimRoms Repo were in Dec 8th.

Code:
logtags: /home/stryder/slim/out/target/common/obj/APPS/TeleService_intermediates/src/src/com/android/phone/EventLogTags.java <= packages/services/Telephony/src/com/android/phone/EventLogTags.logtags

:confused:

Did you sync my repos last night? I added a test commit in g2 common that causes that error. I've already reverted it.
 
  • Like
Reactions: GalaticStryder

GalaticStryder

Senior Member
Nov 20, 2014
1,326
4,753
0
Porto Alegre
Did you sync my repos last night? I added a test commit in g2 common that causes that error. I've already reverted it.

Saw it today Arcardinal, I reverted my fork as well from radio to system and deleted the radio.te sepolicy in the g2-common. The D802 build is running flawlessly, fast and stable, the D800 and D801 I don't know yet because I don't have these variants, waiting for testers. mkbootimg.mk I needed to change the dtbToolCM to dtbTool, it was not compiling without this change, at least for me.

All sources are fine Arcardinal, your work is amazing.
 
  • Like
Reactions: DeeZigneZ

Kalashnikitty

Senior Member
Jun 12, 2010
427
214
0
Saw it today Arcardinal, I reverted my fork as well from radio to system and deleted the radio.te sepolicy in the g2-common. The D802 build is running flawlessly, fast and stable, the D800 and D801 I don't know yet because I don't have these variants, waiting for testers. mkbootimg.mk I needed to change the dtbToolCM to dtbTool, it was not compiling without this change, at least for me.

All sources are fine Arcardinal, your work is amazing.

Mhh, strange my built this morning was pretty much unstable with random reboots and heating problems with USB connected.
 

Flo0008

Senior Member
Nov 2, 2013
719
2,215
0
So, finally, I made a logcat of this error:

As I said already, pure AOSP LP compiled on my own reboots 30 seconds. After the recent reboot the same, the device reboots again.
By the way, my baseband is unknown although I tried to flash the kitkat and jellybean baseband. Nothing helped.

Perhaps somebody can help me with this logcat how to fix my problems.

I am not too experienced with debugging logcats.

Thanks in advance!!
 

Attachments

  • logcat.txt
    272.4 KB · Views: 16

culot

Senior Member
Oct 11, 2014
432
175
63
Bay
Try this as soon as your device boots:

Code:
adb logcat -v time -b events -b main -b system –b radio > seespot.log

After you issue that command go and do whatever you suspect is breaking your stuff, and it'll capture it with gusto.

Then grab these, too:

Code:
adb shell cat /proc/last_kmsg > kmsg.log

You'll need ADB to be mounted as root, or your last_kmsg may be null; then just go into ADB shell and do:

Code:
su
cat /proc/last_kmsg > /sdcard/kmsg.log

Then pull the kmsg.log off, and debuggy good times will be had.

The bugreport also grabs the last_kmsg, among a heckton of other stuff, but does take longer to compile, and maybe won't return before your 30 seconds is up? Could be.

Code:
adb bugreport > buggy.log

If you've only got 30 seconds until your device reboots, it might be better to grab the one log at one boot, then grab another at the next boot, etc.

I am not too experienced with debugging logcats.

Get knee-deep in it and try anyway. :p
 
Last edited:

nasty007

Senior Member
Jan 6, 2010
612
1,186
133
Kutina
hello
im building Dirty Unicorns for G2, im using LG DEVS device tree, building is fine, rom boots but i dont have any sound.
I tried with all possible combinations of device tree and kernels and from locgat i pulled this
W/AudioTrack( 766): AUDIO_OUTPUT_FLAG_FAST denied by client
E/AudioTrack( 766): AudioTrack::set : Exit
Link to full logcat https://drive.google.com/file/d/0B0iMCEpMCG46aWoxZUhsY2Z6bjQ/view?usp=sharing
I really dont know anymore what to do, so if anyone have any idea, or know what is the problem it wuld be great to point me how to fix this.
Thanks

Edit:
Now im using CardinalTesting device tree and kernel and i cant pass this error
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/home/nasty007/du5-CAF/kernel/lge/msm8974'
make: *** [TARGET_KERNEL_BINARIES] Error 2
make: *** Waiting for unfinished jobs....

Edit 2:
Build succesfully finished, booted fine but still no sound :(
But now i have some new errors
01-17 16:22:46.508 899 2084 W AudioTrack: AUDIO_OUTPUT_FLAG_FAST denied by client
01-17 16:22:46.508 899 2084 E AudioTrack: AudioTrack::set : Exit
01-17 16:22:46.528 2633 2633 E ExtMediaPlayer-JNI: QCMediaPlayer could not be located....
01-17 16:22:46.538 2633 2633 E MediaPlayer-JNI: QCMediaPlayer mediaplayer NOT present
01-17 16:22:46.668 2633 2633 E MediaPlayer: Should have subtitle controller already set
full log link https://drive.google.com/file/d/0B0iMCEpMCG46MXFnczlUa0VGN0k/view?usp=sharing
 
Last edited:

GalaticStryder

Senior Member
Nov 20, 2014
1,326
4,753
0
Porto Alegre
Weird Error

Has someone ever faced the following issue?

Code:
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp: In member function 'virtual android::status_t android::CameraClient::sendCommand(int32_t, int32_t, int32_t)':
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:679:23: error: 'CAMERA_MSG_STATS_DATA' was not declared in this scope
         enableMsgType(CAMERA_MSG_STATS_DATA);
                       ^
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:681:24: error: 'CAMERA_MSG_STATS_DATA' was not declared in this scope
         disableMsgType(CAMERA_MSG_STATS_DATA);
                        ^
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:683:23: error: 'CAMERA_MSG_META_DATA' was not declared in this scope
         enableMsgType(CAMERA_MSG_META_DATA);
                       ^
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:685:24: error: 'CAMERA_MSG_META_DATA' was not declared in this scope
         disableMsgType(CAMERA_MSG_META_DATA);

It just happens because of the OPTS I've done, but I need them so...
 

arcardinal

Senior Member
Jul 25, 2010
622
1,667
0
Twin Cities
Has someone ever faced the following issue?

Code:
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp: In member function 'virtual android::status_t android::CameraClient::sendCommand(int32_t, int32_t, int32_t)':
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:679:23: error: 'CAMERA_MSG_STATS_DATA' was not declared in this scope
         enableMsgType(CAMERA_MSG_STATS_DATA);
                       ^
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:681:24: error: 'CAMERA_MSG_STATS_DATA' was not declared in this scope
         disableMsgType(CAMERA_MSG_STATS_DATA);
                        ^
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:683:23: error: 'CAMERA_MSG_META_DATA' was not declared in this scope
         enableMsgType(CAMERA_MSG_META_DATA);
                       ^
frameworks/av/services/camera/libcameraservice/api1/CameraClient.cpp:685:24: error: 'CAMERA_MSG_META_DATA' was not declared in this scope
         disableMsgType(CAMERA_MSG_META_DATA);

It just happens because of the OPTS I've done, but I need them so...

You need this
https://github.com/SlimRoms/android_system_core/commit/ed24da8141e20edf903dcdd14962a004b2f026ac
 
  • Like
Reactions: maniknarang

GalaticStryder

Senior Member
Nov 20, 2014
1,326
4,753
0
Porto Alegre
The precious error was fixed by using C_FLAGS = -Os in camera makefile, for all .cpp. I'll commit all the changes I've done for future people who want to use these OPTS. But first I need to fix all of them :fingers-crossed:

I already had it, I fixed this error today but I got one that regards to this commit, I'll try reverting the commit and reply later, I am compiling my based on Slim and Slim Saber ROM, the straight from the source is fine @arcardinal.

Edit, got an error related to qcom/media/... because of the heap_id_mask commit, I think editing the .h omx_video_base and changing the following line:

Code:
#ifdef _ION_HEAP_MASK_COMPATIBILITY_WA
    #define ION_HEAP_MASK heap_mask
#else
    #define ION_HEAP_MASK [U]heap_id_mask[/U]
#endif

to
Code:
[B]heap_mask[/B]
because it looks like ifdef _ION_HEAP_MASK_COMPATIBILITY_WA is not defined, so it takes else which is pointed to heap_id_mask. Let's see the next errors and fix them.
 
Last edited:

jfpsb

Senior Member
Nov 14, 2013
226
44
0
The precious error was fixed by using C_FLAGS = -Os in camera makefile, for all .cpp. I'll commit all the changes I've done for future people who want to use these OPTS. But first I need to fix all of them :fingers-crossed:

I already had it, I fixed this error today but I got one that regards to this commit, I'll try reverting the commit and reply later, I am compiling my based on Slim and Slim Saber ROM, the straight from the source is fine @arcardinal.

Edit, got an error related to qcom/media/... because of the heap_id_mask commit, I think editing the .h omx_video_base and changing the following line:

Code:
#ifdef _ION_HEAP_MASK_COMPATIBILITY_WA
    #define ION_HEAP_MASK heap_mask
#else
    #define ION_HEAP_MASK [U]heap_id_mask[/U]
#endif

to
Code:
[B]heap_mask[/B]
because it looks like ifdef _ION_HEAP_MASK_COMPATIBILITY_WA is not defined, so it takes else which is pointed to heap_id_mask. Let's see the next errors and fix them.

Do you know where _ION_HEAP_MASK_COMPATIBILITY_WA is defined? I can't find it anywhere.
 

zg85

Senior Member
Apr 25, 2013
267
322
103
CAF

Hello :) I'm wondering if I could bake PAC MAN ROM with CAF sources and working sensors (rotation).
Actually I have replaced original device/lge/g2-common + kernel/ + vendor/lge with dr87 ones :
Code:
git clone -b cleanaosp https://github.com/dr87/SimpleKernel.git
git clone https://github.com/dr87/4.4_g2-vendor
git clone https://github.com/dr87/4.4_g2-common.git
And modified hardware/qcom/display-caf/libhwcomposer/hwc_vsync.cpp with 5e80f34f57b5f9c2eb807d0e5ed1a0b28cccd3bd commit.

Compiled successfully but.. Starting up takes much longer than using CM sources and rotation is not working with any modem. Am I missing something or CAF wont work in PAC?
Is there a simple solution to repair that broken rotation?
Sources for hardware comes from CM - that could be the problem? Which sources should I use?
Code:
  <project path="frameworks/wilhelm" name="android_frameworks_wilhelm" remote="cm" />
  <project path="hardware/akm" name="android_hardware_akm" groups="pdk" remote="cm" />
  <project path="hardware/broadcom/libbt" name="android_hardware_broadcom_libbt" groups="pdk" remote="cm" />
  <project path="hardware/broadcom/wlan" name="android_hardware_broadcom_wlan" groups="broadcom_wlan" remote="cm" />
  <project path="hardware/cm" name="android_hardware_cm" remote="cm" />
  <project path="hardware/invensense" name="android_hardware_invensense" groups="invensense" remote="cm" />
  <project path="hardware/libhardware" name="android_hardware_libhardware" groups="pdk" remote="cm" />
  <project path="hardware/libhardware_legacy" name="android_hardware_libhardware_legacy" groups="pdk" remote="cm" />
  <project path="hardware/qcom/audio" name="android_hardware_qcom_audio" groups="qcom" remote="cm" />
  <project path="hardware/qcom/audio-caf" name="android_hardware_qcom_audio-caf" groups="caf" remote="cm" />
  <project path="hardware/qcom/bt" name="android_hardware_qcom_bt" groups="qcom" remote="cm" />
  <project path="hardware/qcom/camera" name="android_hardware_qcom_camera" groups="qcom" remote="cm" />
  <project path="hardware/qcom/display" name="android_hardware_qcom_display" groups="qcom" remote="cm" />
  <project path="hardware/qcom/display-caf" name="android_hardware_qcom_display-caf" groups="caf" remote="cm" />
  <project path="hardware/qcom/gps" name="android_hardware_qcom_gps" groups="qcom" remote="cm" />
  <project path="hardware/qcom/keymaster" name="android_hardware_qcom_keymaster" groups="qcom" remote="cm" />
  <project path="hardware/qcom/media" name="android_hardware_qcom_media" groups="qcom" remote="cm" />
  <project path="hardware/qcom/media-caf" name="android_hardware_qcom_media-caf" groups="caf" remote="cm" />
  <project path="hardware/qcom/msm8960" name="android_hardware_qcom_msm8960" groups="qcom_msm8960" remote="cm" />
  <project path="hardware/qcom/msm8x74" name="android_hardware_qcom_msm8x74" groups="qcom_msm8x74" remote="cm" />
  <project path="hardware/qcom/power" name="android_hardware_qcom_power" remote="cm" />
  <project path="hardware/qcom/sensors" name="android_hardware_qcom_sensors" remote="cm" />
  <project path="hardware/qcom/wlan" name="android_hardware_qcom_wlan" remote="cm" />
  <project path="hardware/ril" name="android_hardware_ril" groups="pdk"  remote="cm" />
  <project path="hardware/samsung_slsi/exynos5" name="android_hardware_samsung_slsi_exynos5" remote="cm" />
  <project path="hardware/ti/omap3" name="android_hardware_ti_omap3" remote="cm" />
  <project path="hardware/ti/omap4xxx" name="android_hardware_ti_omap4xxx" remote="cm" />
  <project path="hardware/ti/wlan" name="android_hardware_ti_wlan" remote="cm" />
  <project path="hardware/ti/wpan" name="android_hardware_ti_wpan" remote="cm" />
Please help :)

Best wishes !
 

Bx16

Senior Member
Oct 27, 2013
229
543
133
Poznań
Hi Guys!
I have problem with not booting ROMs (stuck on LG logo), I had to reinstall my Ubuntu and after this I setup my env for compiling, used extract-files script and build ROM. ROM builed without any problems but it's smaller than previous. (215MB vs 235MB) and not boot.. I have this problem with Candy5 and crDroid. :(
Things which may help:
1. My local manifest
<?xml version="1.0" encoding="UTF-8"?>
<manifest>

<project path="device/lge/g2-common" name="lg-devs/android_device_lge_g2-common" remote="github" revision="cm-12.0"/>
<project path="kernel/lge/msm8974" name="lg-devs/android_kernel_lge_msm8974" remote="github" revision="cm-12.0"/>
<project path="proprietary/vendor/lge" name="lg-devs/proprietary_vendor_lge" remote="github" revision="cm-12.0"/>
<project path="device/lge/d802" name="lg-devs/android_device_lge_d802" remote="github" revision="cm-12.0"/>
<project path="device/lge/qcom-common" name="lg-devs/android_device_lge_qcom-common" remote="github" revision="cm-12.0"/>

</manifest>
2. Build of not booting ROM: http://d-h.st/7AWp

Someone can tell what im doing bad and help fix it?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Its not booting because of hardware/qcom/display. You need this commit for now
    https://gerrit.slimroms.net/#/c/20632/

    If you look at the comments though, it breaks hammerhead from compiling. Until I can find a better solution, which may not happen, I won't be updating the g2 repos for slim.

    Also, slim for g2 needs to be compiled on slimlp-caf branch, even though our kernel is not caf.

    All my repos are up to date here
    www.github.com/CardinalTesting

    Vendor is here
    www.github.com/arcardinal/proprietary_vendor_lge

    lp5.0 branches for all my repos
    4
    Ok Good to know that you are working on a lollipop edition of Slim roms. I don't to be rube or something else, but Are you planning to release it asap it gets stable?

    Thanks in advance

    I think we are diverging the subject of the thread, so if you or anybody want to talk me just PM. I'm not creating a new thread for that in the meantime, and I wish we don't spam this thread because I intend and the OP as well, this thread to be a helpful thread for new developers, I just posted the screenshots here because we were talking about SlimLP some pages ago.

    Reworking on AOSP will be next step together maintaining the SlimLP unofficial.

    Thanks guys.
    3
    Also had the problem with AOSP going directly into fastboot menu, I have adapted everything I could. Using a prebuilt kernel the AOSP booted properly together some CM stuff I needed to add, now I just got some FC to handle, better, a lot of them. I'm using SimpleAOSP source code for now, It's quite modified but it keeps the AOSP base.
    About building SlimLP I did a test build for my D802 in December 11th and it ran properly, all apps and no force closes, got a very good result but I couldn't upload the modifications to GitHub because I was just learning how to git checkout, git rebase, git fetch/merge and so on...

    If you want help on the SlimLP I'm available to help you out whenever you want, are you planning to build for the other variants as well OP?

    Thanks for using the Dev section it's very useful for us to change ideas.
    3
    First:
    In root directory of rom: make clean -> this should fix build error.

    My proposition:
    1. repo init -u https://github.com/SlimRoms/platform_manifest -b lp5.0-caf
    2. roomservice.xml need to looks like:
    <?xml version="1.0" encoding="UTF-8"?>
    <manifest>

    # Device Specific part
    <project path="device/lge/d802" name="Flo0008/android_device_lge_d802" revision="lp5.0" remote="github" />
    <project path="device/lge/g2-common" name="Flo0008/android_device_lge_g2-common" revision="lp5.0" remote="github" />
    <project path="kernel/lge/msm8974" name="Flo0008/android_kernel_lge_msm8974" revision="cm-12.0" remote="github" />
    <project path="vendor/lge" name="Flo0008/proprietary_vendor_lge" revision="cm-12.0" remote="github" />

    </manifest>

    3. repo sync.

    4.
    . build/envsetup.sh
    brunch d802



    Try this if you want. :)

    ---------- Post added at 11:34 AM ---------- Previous post was at 11:24 AM ----------

    When finish building of DU will try SlimLP :)

    ---------- Post added at 11:36 AM ---------- Previous post was at 11:34 AM ----------

    SlimLP has a .zip size of aroung 195Mb.

    Size of compiled CM12 is about 240 MB -> something is missing in your build...

    ---------- Post added at 11:44 AM ---------- Previous post was at 11:36 AM ----------

    look here:
    https://github.com/TheMuppets/proprietary_vendor_lge/blob/cm-12.0/d802/d802-vendor-blobs.mk
    See how much blobs is there...


    insteed of using your blobs try TheMuppets's blobs:

    https://github.com/TheMuppets/proprietary_vendor_lge

    add this to roomservice.xml

    ---------- Post added at 11:50 AM ---------- Previous post was at 11:44 AM ----------

    My last proposition is to try using cm device tree and kernel...

    <?xml version="1.0" encoding="UTF-8"?>
    <manifest>

    # Device Specific part
    <project path="device/lge/d802" name="CyanogenMod/android_device_lge_d802" revision="cm-12.0" remote="github" />
    <project path="device/lge/g2-common" name="CyanogenMod/android_device_lge_g2-common" revision="cm-12.0" remote="github" />
    <project path="kernel/lge/msm8974" name="CyanogenMod/android_kernel_lge_msm8974" revision="cm-12.0" remote="github" />
    <project path="vendor/lge" name="TheMuppets/proprietary_vendor_lge" revision="cm-12.0" remote="github" />

    </manifest>


    Then make some changes in device/lge/d802 .

    :)
    3
    @RenderBroken

    Can you or anybody else help me with this build error on AOSP Lollipop?

    Target boot image: /data1/Flo0008/aosp_g2/out/target/product/d802/boot.img
    usage: mkbootimg
    --kernel <filename>
    --ramdisk <filename>
    [ --second <2ndbootloader-filename> ]
    [ --cmdline <kernel-commandline> ]
    [ --board <boardname> ]
    [ --base <address> ]
    [ --pagesize <pagesize> ]
    -o|--output <filename>
    device/lge/g2-common/releasetools/mkbootimg.mk:47: recipe for target '/data1/Flo0008/aosp_g2/out/target/product/d802/boot.img' failed
    make: *** [/data1/Flo0008/aosp_g2/out/target/product/d802/boot.img] Error 1
    make: *** Waiting for unfinished jobs....

    Thanks in advance.

    This error means that the mkbootimg tool you have is not the correct one. Apparently there are more than one out there and the other supports different flags. Use the one here:

    https://github.com/RenderBroken/mkbootimg_tools

    Also CAF (to me) doesnt seem to be ready as a Daily Driver. Are you just wanting to mess around or get out a fully functioning build? I do know that LG-Devs CAF branch is still being worked on. Not sure about TheMuppets but they are always solid. Still LP CAF is not stable yet.

    ---------- Post added at 02:19 PM ---------- Previous post was at 02:17 PM ----------

    First:
    In root directory of rom: make clean -> this should fix build error.

    My proposition:
    1. repo init -u https://github.com/SlimRoms/platform_manifest -b lp5.0-caf
    2. roomservice.xml need to looks like:


    3. repo sync.

    4.
    . build/envsetup.sh
    brunch d802



    Try this if you want. :)

    ---------- Post added at 11:34 AM ---------- Previous post was at 11:24 AM ----------

    When finish building of DU will try SlimLP :)

    ---------- Post added at 11:36 AM ---------- Previous post was at 11:34 AM ----------



    Size of compiled CM12 is about 240 MB -> something is missing in your build...

    ---------- Post added at 11:44 AM ---------- Previous post was at 11:36 AM ----------

    look here:
    https://github.com/TheMuppets/proprietary_vendor_lge/blob/cm-12.0/d802/d802-vendor-blobs.mk
    See how much blobs is there...


    insteed of using your blobs try TheMuppets's blobs:

    https://github.com/TheMuppets/proprietary_vendor_lge

    add this to roomservice.xml

    ---------- Post added at 11:50 AM ---------- Previous post was at 11:44 AM ----------

    My last proposition is to try using cm device tree and kernel...




    Then make some changes in device/lge/d802 .

    :)


    Great Info! Thanks for chiming in.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone