Connect to SD card in download mode?

Search This thread

stockings

New member
Jan 8, 2016
2
0
0
So I have been struck by the G4's evil bootloop problem. After the first reboot it never ended up booting into the OS again and after about 30 minutes of trying to get it to the recovery menu it wouldn't turn on at all. So I sent it in to LG to get repaired (they said they replaced the board chipset) and I just got it back - two minutes later it does the random shutoff thing and now we're back to bootlooping. So I'm not really sure that they did anything at all other than flashing it, which makes me every so slightly more hopeful for what I'm trying to do. This time, however, I am consistently able to get into download mode.

The goal of this, and I absolutely realize this is a very, very long shot, is to get a bitwise copy of the internal memory onto the SD card, then do some file recovery magic to get a few pictures back. The most important ones are in other locations, but I guess I have some extra time on my hands. Well.... I don't really, but I like messing around with this stuff. I've done a bunch of recovery work on regular computer hard drives, which is why I'm hoping this is a possibility. (Yes, I know it's probable they replaced the internal storage if they actually replaced the motherboard.) If not, well, I've learned a lot, so whatever.

So where does unrooted download mode get me? Not far it seems. I can get the Send_Command.exe to connect reliably. So in theory I should be able to do something along the lines of
Code:
dd if=/dev/block/mmcblk0 of=/path/to/sdcard
but this isn't really working, well, at all.

The good news is that I think it sees the sd card, because with a
Code:
cat /proc/partitions
is see
Code:
mmcblk1
and
Code:
mmcblk1p1
- which I imagine is the external SD card. (I'm pretty sure about that actually, since removing the sd card has the mmcblk1* vanish)

I'm not able to access it however, and an ls on /storage/external_SD/ returns blank, even though I dropped a few test files on it.

I did read that you could potentially get access to the SD card by editing something in /system/etc/permissions/platform.xml, but that is pretty much the end of what I've found - I'm not quite sure how to edit that over send_command either to be honest. I suppose you could try something like
Code:
echo "all the text" > /system/etc/permissions/platform.xml
but I tried testing that on a sample text file - it didn't work - and that's sadly the limit of my knowledge.


Any ideas? Did I miss something obvious here?
 

themike10452

Senior Member
Nov 15, 2012
2,518
3,498
0
25
Batroun
Been trying the same approach, got nowhere so far. I even tried to run "cat" command on some files and push the output into a file (through some java code), but I am unable to get input stream from send_command.exe :(