Constant notifications "Wi-Fi Calling preferences updated to optimize network exp."

Search This thread

xphyle1971

Senior Member
Apr 25, 2012
449
111
Constant notifications "Wi-Fi Calling preferences updated to optimize network exp."

So, aside from the common touchscreen and proximity sensor issues, I'm getting this notification constantly that is driving me crazy. If I swipe it away it comes back many times per day. It can't be disabled. I've seen reports of it, but it's not widespread. I've not had this issue on any of my other phones, Samsung or otherwise. The only way to get rid of it is to turn off Wi-Fi Calling. I suppose it could possibly be an issue with the wireless in my home. I use an eero router system. But like I said, it works with all my other devices no problem. Anyone else get this?
 
A

anaconda_bamn

Guest
what carrier?
so notification pops up only when the wifi-calling is on?

try this:
download samsung members app from galaxy store, click get help (bottom), send report. once you submit a ticket, samsung will be able to tell you what is causing the issue.
 

xphyle1971

Senior Member
Apr 25, 2012
449
111
what carrier?
so notification pops up only when the wifi-calling is on?

try this:
download samsung members app from galaxy store, click get help (bottom), send report. once you submit a ticket, samsung will be able to tell you what is causing the issue.

I'm on T-Mobile. And almost every instance I could find of this issue on a Samsung device (via google search), the user was also using T-Mobile. And yes, it only happens when WIFI calling is enabled.
 
Last edited:
E

Esormit88

Guest
T-Mobile here, and also having the same issue. I just muted/Silenced all the notifications, but they still pop up in the bar.
 

aarlee

New member
Jun 1, 2007
1
0
I have seen it a couple of times at home (also on T-Mobile), but this past weekend, when using a car hotspot (AT&T), it kept showing up over and over again.
 

phil1737

Member
Jul 17, 2013
28
11
S20 FE Unlocked purchased from Samsung directly. Just transferred from Verizon to T-Mobile. At my home, cellular signal is so weak that the phone is basically unusable for calls. Wi-Fi calling is a necessity so I set the Wi-Fi Calling network preference to "Wi-Fi preferred". It doesn't take long for these notifications to show up when the phone changes back to "Cellular preferred" mode on its own. My work around is to turn on Airplane Mode, wait for it to engage, then re-enable Wi-Fi. This works to keep Wi-Fi calling active and stops the constant notifications. I just have to remember to de-select Airplane Mode when I leave the house. A big PITA.

When I was on Verizon the phone would remain in whatever network preference I selected without issue.
 

crackers8199

Senior Member
May 11, 2010
697
94
i have a workaround for this using tasker, the catch being that you need to have the android 11 (one ui 3.0) update. if you're still on android 10, the custom setting this watches for doesn't exist yet...it was only introduced in the android 11 update.