Copied a very long string to the clip tray, phone restarts every time I open the keyboard

Search This thread
Jun 15, 2021
10
1
Alright, so I copied 1 million digits of Pi to my v60's clip tray (for educational purposes), and now it restarts when I open the keyboard. I have uninstalled or disabled every clipboard/keyboard related app I can find, including the stock LG keyboard (using adb shell pm uninstall --user 0 com.lge.ime). I have restarted the phone, used the Smart Cleaning app to clear memory and temp storage, and copied other (much shorter) phrases to the clipboard in an attempt to clear Pi from the clipboard history.

Evidently, something in the phone has stored Pi in some sort of history or backup, and now every time I open the keyboard (now using AnySoftKeyboard), it waits about 15-30 seconds, then stutters, freezes, crashes, and restarts.

What can I do, barring a factory reset?

Edit: I tried rebooting into safe mode, and it still crashed upon clicking a text input field, even though AnySoftKeyboard didn't come up (since it's not a system app).
 
Last edited:

pflatlyne

Senior Member
Apr 24, 2007
265
26
This is probably to late as you probably have figured it out by now, but for the next person who has this issue , try this. Go to settings, then apps, find the keyboard app , and go into storage and delete all its data.
 
Jun 15, 2021
10
1
I actually believe I tried that, and it didn't fix the issue. Eventually, the issue just went away - I think I had copied enough unique strings in normal usage that it just pushed Pi out of the clipboard history.
 

blackhawk

Senior Member
Jun 23, 2020
10,408
4,138
Samsung Galaxy Note 10+
Welcome to XDA 🤗

I've seen this happen. Been a long while. Clearing the cut/paste data using the Edge Clipboard may be how I solved it. It wasn't anything drastic. Also try clearing the system cache from the boot menu as that can resolve many strange issues.