Crazy Home Button!!!

Search This thread

Philux

Senior Member
Feb 25, 2007
487
86
Captivate8.jpg


I know this has been addressed before about the home button going crazy. It acts like it is getting pushed multiple times over and over. It mainly does this at random times and mostly when the phone has come out of sleep mode. Being that this is my 4th Cappy that I might be returning due to hardware issues. I am hesitant on returning because I am worried about getting a refurb with more serious issues. Every Captivate I seem to get has hardware issues.

I am wanting to put together a thread to figure out if this issue is due to changes in Kernel or if it is a true hardware issue that can not be fixed but maybe we can find a workaround.

I want to start finding out if there is a thresh-hold that can be adjusted on the button. Make the button not so sensitive to see if this effect will help anything.

Can this button be disabled altogether? Disable the home button and use the search button instead.

I never had this issue till I flashed a Froyo kernel. That is why I am skeptical on the hardware failure.
 

chirs

Member
Sep 4, 2009
45
1
I think it's hardware issue, my first one has this issue, unroot and runs stock 2.1, exchanged and never see it goes crazy again.
 

kangi26

Retired Forum Moderator
Nov 8, 2006
5,689
2,491
Seattle
I just got my phone exchanged about 2 hrs ago. I've run TONS of tests on it, different ROM's, kernels, modems, bare ass stock.
Here's what I came up with. My phone was a 1007 series(2nd I believe)
The best, cleanest luck I had with it was for 1 solid week running Assonance 2.0 with Set's 1.4.3 1200 kernel, and JK3. BUT, I had to go back to stock, and it STILL did it, then with Axura 2, 2.1 and 2.2; still did it. Finally went back to stock JF6 no root, nothing sideloaded, and it still did it. I went into my local service center this afternoon actually for a different reason, my headphone jack stopped working totally. The techs had seen the button pressing before, and they are pretty sure it's a firmware issue.
I'd recommend going to your local service center and get a new device. I suspect that it will only get worse
 

BradPitts137

Member
Jan 7, 2008
8
1
Spokane, Washington
Ive reflashed Axura about three times now. uninstalling apps (doing tibu restore every time) and the home button was still crazy, this last round did the usual odin3 back to stock, flashed axura, setiron kernal, and the jl3 modem but didnt tibu restore and everything is fine no more crazy home button:D still dont know what app was the problem but my phone is fixed... only bad part is manual app restore from market:(
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone