• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

crDroid (10) GSI ported to HUAWEI P10 Lite (Tested On WAS-LX1A)

Search This thread

ennadif

Member
Jun 23, 2016
18
2
Software installa failed! :( I have a WAS-LX1A 8.0.0.396 C432
Hi,

1 - connect your phone to pc
2 - open HISUITE
3 - in the main screen go to update firmware
4 - maybe HISUITE will give you android 7 as solution but no worry you will get your correct android build version
5 - download it and when finished try to do the same steps to have android 8 then latest according to your device maybe android 9 or 10
 

kanade266

Member
Mar 14, 2021
15
1
Moto G
Moto G 2014 LTE
It worked, I tried to degrade even more than what is recommended and it worked, I am trying everything although if there is a bug with the Audio FX and the music player the whole system hangs but it is fixed by turning off the equalizer how bad I can not find the option to Screen resolution as the emui 8 had that option helped me that the device would have more battery and more fluid in the games but the rest without any problem for daily use I am already testing in games
am testing on a Was-LX3
 
Mar 13, 2021
38
18
After 5 hours of continuous use of the system it started to crash and I had to restart perk it stayed in the logo and tried to enter the recobery twrp and eRecoberyal enter it restarts the 2 help!
Hmm, strange... worked perfectly fine for me.
I'll try port some other rom, but trust me not an easy job, most of them require a lot of workaround to fix the bugs.
I'm currently working on OctaviOS which is based on Android 11 but there are still some bugs.
 

kanade266

Member
Mar 14, 2021
15
1
Moto G
Moto G 2014 LTE
Hmm, strange... worked perfectly fine for me.
I'll try port some other rom, but trust me not an easy job, most of them require a lot of workaround to fix the bugs.
I'm currently working on OctaviOS which is based on Android 11 but there are still some bugs.
Yes, but I already ran out of phone when entering the recobery wtrp or eRecobery restarts and the only solution is for a box
 

Miller9207

New member
Jul 25, 2021
2
0
Huawei P10 Lite
how can i make root work in this rom
 

Attachments

  • Screenshot_20210724-214416048.jpg
    Screenshot_20210724-214416048.jpg
    149.4 KB · Views: 24

Miller9207

New member
Jul 25, 2021
2
0
Huawei P10 Lite
I was able to fix it by flashing the octavi-os android 11 rom magisk the phh magisk fork files
 

Attachments

  • Screenshot_20210726-081414125.jpg
    Screenshot_20210726-081414125.jpg
    202.9 KB · Views: 22
  • Screenshot_20210726-081343652.jpg
    Screenshot_20210726-081343652.jpg
    289.1 KB · Views: 22

speedson

Senior Member
Oct 10, 2016
220
46
my own little microcosmos
Ok just a little feedback

the Screenrecording doesnt work.
the screen mirroring to Chromcast Android Tv works but to other normal smart tv with screen mirroring does not work.
and last but not least...cts profil failed
installing apps from the ghost App installer (ghost-repo.com) doesnt work...it dont ask if it is ok to install from ghost app installer

solong
speedson
 
Last edited:

syraufsylutfi95

Senior Member
Aug 2, 2014
113
11
26
Kuala Terengganu
cant boot, i was on darkjoker aosp 10 rom recently then i follow the steps to flash crdroid10 rom. it stuck on android boot logo pretty long and it fail and boot to recovery. i give it a try to reboot again 2/3 times but it still the same. i thought it was twrp fault so i change twrp DarkJoker360_20200611 as mention. but the problem still the same. i was waiting for crdroid 11 too incase. i like this rom compare to octavios because it has more built in tweaking stuff.

EDIT: i manage to boot up the phone but its a little bit wierd. i flash darkjoker aosp 10 rom, after it boots up. then i try to dirty flash crdroid10 rom without wiping anything and the phone is boot up. the problem right now is it stuck at homescreen and it said phone is starting. but still can access to setting and ui. i still dont know what could be wrong.

my device build number: was-lx1A 8.0.0.378 (C432)
 
Last edited:
  • Like
Reactions: LoRDPaAT

LoRDPaAT

New member
Sep 8, 2021
2
0
cant boot, i was on darkjoker aosp 10 rom recently then i follow the steps to flash crdroid10 rom. it stuck on android boot logo pretty long and it fail and boot to recovery. i give it a try to reboot again 2/3 times but it still the same. i thought it was twrp fault so i change twrp DarkJoker360_20200611 as mention. but the problem still the same. i was waiting for crdroid 11 too incase. i like this rom compare to octavios because it has more built in tweaking stuff.

EDIT: i manage to boot up the phone but its a little bit wierd. i flash darkjoker aosp 10 rom, after it boots up. then i try to dirty flash crdroid10 rom without wiping anything and the phone is boot up. the problem right now is it stuck at homescreen and it said phone is starting. but still can access to setting and ui. i still dont know what could be wrong.

my device build number: was-lx1A 8.0.0.378 (C432)

cant boot, i was on darkjoker aosp 10 rom recently then i follow the steps to flash crdroid10 rom. it stuck on android boot logo pretty long and it fail and boot to recovery. i give it a try to reboot again 2/3 times but it still the same. i thought it was twrp fault so i change twrp DarkJoker360_20200611 as mention. but the problem still the same. i was waiting for crdroid 11 too incase. i like this rom compare to octavios because it has more built in tweaking stuff.

EDIT: i manage to boot up the phone but its a little bit wierd. i flash darkjoker aosp 10 rom, after it boots up. then i try to dirty flash crdroid10 rom without wiping anything and the phone is boot up. the problem right now is it stuck at homescreen and it said phone is starting. but still can access to setting and ui. i still dont know what could be wrong.

my device build number: was-lx1A 8.0.0.378 (C432)
 

speedson

Senior Member
Oct 10, 2016
220
46
my own little microcosmos
cant boot, i was on darkjoker aosp 10 rom recently then i follow the steps to flash crdroid10 rom. it stuck on android boot logo pretty long and it fail and boot to recovery. i give it a try to reboot again 2/3 times but it still the same. i thought it was twrp fault so i change twrp DarkJoker360_20200611 as mention. but the problem still the same. i was waiting for crdroid 11 too incase. i like this rom compare to octavios because it has more built in tweaking stuff.

EDIT: i manage to boot up the phone but its a little bit wierd. i flash darkjoker aosp 10 rom, after it boots up. then i try to dirty flash crdroid10 rom without wiping anything and the phone is boot up. the problem right now is it stuck at homescreen and it said phone is starting. but still can access to setting and ui. i still dont know what could be wrong.

my device build number: was-lx1A 8.0.0.378 (C432)
because of the bootloop...did you root the AOSP Firmware?

if yes...you need to restore the stock ramdisk image before flashing any other Rom

if not...restore the stock firmware (i use 8.0.0.394C432 on my was-lx1a) and start over.

good luck

solong
speedson
 

Attachments

  • RAMDISK[1].img
    16 MB · Views: 1

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Hi guys, i ported the crDroid gsi from here.
    I removed the unnecessary files from the rom, and included gapps.
    And AIO fixes thanks to @DarkJoker360.

    Install steps are easy.
    1. Download the ROM from HERE.
    2. Extract it.
    3. Download Pretoriano80's TWRP from "HERE" and flash it using "fastboot flash recovery_ramdisk <path to TWRP.img>".
    4. After that reboot to TWRP while holding the VOL+ and POWER button.
    5. In TWRP wipe internal storage and flash "THIS" to decrypt the phone.
    6. Reboot to TWRP again.
    7. Reboot to bootloader while in TWRP.
    8. Flash DarkJoker360's TWRP.
    9. Wipe everything except Vendor.
    10. Transfer the system.img from the rom to your device's internal storage.
    11. Tap on Install, then tap on install image, look for the system.img and flash it as System Image and reboot.

    I haven't had any bugs for now, if u find something tell me.
    1
    Hi guys, i ported the crDroid gsi from here.
    I removed the unnecessary files from the rom, and included gapps.
    And AIO fixes thanks to @DarkJoker360.

    Install steps are easy.
    1. Download the ROM from HERE.
    2. Extract it.
    3. Download Pretoriano80's TWRP from here and flash it using "fastboot flash recovery_ramdisk <path to TWRP.img>".
    4. After that reboot to TWRP while holding the VOL+ and POWER button.
    5. In TWRP wipe internal storage and flash this to decrypt the phone.
    6. Reboot to TWRP again.
    7. Reboot to bootloader while in TWRP.
    8. Flash DarkJoker360's TWRP.
    9. Wipe everything except Vendor.
    10. Transfer the system.img from the rom to your device's internal storage.
    11. Tap on Install, then tap on install image, look for the system.img and flash it as System Image and reboot.

    I haven't had any bugs for now, if u find something tell me.
    Hi...

    ok i will give you a method that i used to get it work on my p10 lite WAS-LX1A 4Gb Dual-Sim

    First...if you come from latest stock rom was-lx1a 8.0.0b398c432 you need to downgrade to was-lx1a 8.0.0b394c432 with dload or how ever you prefer. cause with b398 you system partition is just 3,7Gb and can not get rezise. but with the b394 you can rezise it but its no need to. cause after encrypting with fstab.hi6250b and the known following steps...format wipe and so on...the system partition have a size from 4.5gb.

    I use the Pretoriano80 TWRP 3.2.1.0 twrp_p10_lite_0.5_test.img
    then after initial boot and setup the first config....you can see in apps there is superuser app...its integrate in the Rom.


    IMG_20210614_142449.jpgIMG_20210614_142755.jpgIMG_20210614_142856.jpgIMG_20210614_143243.jpgIMG_20210614_143420.jpgIMG_20210614_143735.jpgIMG_20210614_143832.jpgIMG_20210614_144338.jpgIMG_20210614_144353.jpgIMG_20210614_144415.jpg


    For using magisk i did the following steps thanks to @Hami_Do

    hang-in the system and open file manager in TWRP

    delete the following
    system/bin/adb_root
    system/bin/abdb
    system/etc/init/adb_root.rc
    system/etc/init/adbd.rc
    system/etc/init/su.rc
    system/app/superuser
    system/bin/su
    system/xbin/su
    flash the stock ramdisk.img
    Screenshot_20210614-144525341~2.jpgScreenshot_20210614-144601824.jpgScreenshot_20210614-153127003.jpgScreenshot_20210614-162632739.jpgScreenshot_20210614-153153820.jpgScreenshot_20210614-153314970.jpgbtw camera works with different modi

    for magisk...thanks to @Hami_Do i use v23.0apk
    then roboot to TWRP
    there flash magisk v23.0-phh.zip
    1
    is there android 11 based crdroid gsi images you can port?
    My charging port is broken, i won't be able to do any ports until i get it fixed, btw Android 11 GSI's are still not stable as Android 10 GSI's.
    1
    Hi...

    ok a repeat again....if you come from Stock Rom with latest Version called WAS-LX1A 8.0.0.398 C432 your System Partition is just 3,7Gb. You need to downgrade to 1 Version before called WAS-LX1A 8.0.0.394 C432 then the System Partition is 4,5Gb. Now you can flash this custom Rom.

    For downgrade use dload method and
    download the package and in there you find software/dload and there are 4 folder and 1 update_sd.zip

    create a dload folder on your desktop and extrac the update_sd.zip and the 1 folder for your Device. so my is a WAS-LX1A (LX1A=L21A) cause of this i extrac the WAS-L21A folder.

    put the update_sd.zip and WAS-L21A folder from downloadet package into the createt dload folder on your desktop. Now copy/paste this dload folder from desktop to external-sd card in your Device, Power off the Device and restart it with press and hold Vol-up+Vol-down+Pwr (no usb cable plugged) now the firmware update should start and wait for progress is finished.
    1
    cant boot, i was on darkjoker aosp 10 rom recently then i follow the steps to flash crdroid10 rom. it stuck on android boot logo pretty long and it fail and boot to recovery. i give it a try to reboot again 2/3 times but it still the same. i thought it was twrp fault so i change twrp DarkJoker360_20200611 as mention. but the problem still the same. i was waiting for crdroid 11 too incase. i like this rom compare to octavios because it has more built in tweaking stuff.

    EDIT: i manage to boot up the phone but its a little bit wierd. i flash darkjoker aosp 10 rom, after it boots up. then i try to dirty flash crdroid10 rom without wiping anything and the phone is boot up. the problem right now is it stuck at homescreen and it said phone is starting. but still can access to setting and ui. i still dont know what could be wrong.

    my device build number: was-lx1A 8.0.0.378 (C432)