• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

crDroid (10) GSI ported to HUAWEI P10 Lite (Tested On WAS-LX1A)

Search This thread

kikooOOoo

Member
Apr 20, 2014
8
1
Flashed the ROM, was using the OctaviOS before it. Did everything step by step and so far so good. ROM is smooth and fast (probably the smoothest of all the ROMs I've tried so far), the fingerprint sensor stopped working on reboot but aside from that everything else works great. Thank you for the hard work I appreciate it. Cheers ! If anyone has a clue how to fix the fingerprint sensor please share.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Hi guys, i ported the crDroid gsi from here.
    I removed the unnecessary files from the rom, and included gapps.
    And AIO fixes thanks to @DarkJoker360.

    Install steps are easy.
    1. Download the ROM from HERE.
    2. Extract it.
    3. Download Pretoriano80's TWRP from "HERE" and flash it using "fastboot flash recovery_ramdisk <path to TWRP.img>".
    4. After that reboot to TWRP while holding the VOL+ and POWER button.
    5. In TWRP wipe internal storage and flash "THIS" to decrypt the phone.
    6. Reboot to TWRP again.
    7. Reboot to bootloader while in TWRP.
    8. Flash DarkJoker360's TWRP.
    9. Wipe everything except Vendor.
    10. Transfer the system.img from the rom to your device's internal storage.
    11. Tap on Install, then tap on install image, look for the system.img and flash it as System Image and reboot.

    I haven't had any bugs for now, if u find something tell me.
    1
    Hi guys, i ported the crDroid gsi from here.
    I removed the unnecessary files from the rom, and included gapps.
    And AIO fixes thanks to @DarkJoker360.

    Install steps are easy.
    1. Download the ROM from HERE.
    2. Extract it.
    3. Download Pretoriano80's TWRP from here and flash it using "fastboot flash recovery_ramdisk <path to TWRP.img>".
    4. After that reboot to TWRP while holding the VOL+ and POWER button.
    5. In TWRP wipe internal storage and flash this to decrypt the phone.
    6. Reboot to TWRP again.
    7. Reboot to bootloader while in TWRP.
    8. Flash DarkJoker360's TWRP.
    9. Wipe everything except Vendor.
    10. Transfer the system.img from the rom to your device's internal storage.
    11. Tap on Install, then tap on install image, look for the system.img and flash it as System Image and reboot.

    I haven't had any bugs for now, if u find something tell me.
    Hi...

    ok i will give you a method that i used to get it work on my p10 lite WAS-LX1A 4Gb Dual-Sim

    First...if you come from latest stock rom was-lx1a 8.0.0b398c432 you need to downgrade to was-lx1a 8.0.0b394c432 with dload or how ever you prefer. cause with b398 you system partition is just 3,7Gb and can not get rezise. but with the b394 you can rezise it but its no need to. cause after encrypting with fstab.hi6250b and the known following steps...format wipe and so on...the system partition have a size from 4.5gb.

    I use the Pretoriano80 TWRP 3.2.1.0 twrp_p10_lite_0.5_test.img
    then after initial boot and setup the first config....you can see in apps there is superuser app...its integrate in the Rom.


    IMG_20210614_142449.jpgIMG_20210614_142755.jpgIMG_20210614_142856.jpgIMG_20210614_143243.jpgIMG_20210614_143420.jpgIMG_20210614_143735.jpgIMG_20210614_143832.jpgIMG_20210614_144338.jpgIMG_20210614_144353.jpgIMG_20210614_144415.jpg


    For using magisk i did the following steps thanks to @Hami_Do

    hang-in the system and open file manager in TWRP

    delete the following
    system/bin/adb_root
    system/bin/abdb
    system/etc/init/adb_root.rc
    system/etc/init/adbd.rc
    system/etc/init/su.rc
    system/app/superuser
    system/bin/su
    system/xbin/su
    flash the stock ramdisk.img
    Screenshot_20210614-144525341~2.jpgScreenshot_20210614-144601824.jpgScreenshot_20210614-153127003.jpgScreenshot_20210614-162632739.jpgScreenshot_20210614-153153820.jpgScreenshot_20210614-153314970.jpgbtw camera works with different modi

    for magisk...thanks to @Hami_Do i use v23.0apk
    then roboot to TWRP
    there flash magisk v23.0-phh.zip
    1
    is there android 11 based crdroid gsi images you can port?
    My charging port is broken, i won't be able to do any ports until i get it fixed, btw Android 11 GSI's are still not stable as Android 10 GSI's.
    1
    Hi...

    ok a repeat again....if you come from Stock Rom with latest Version called WAS-LX1A 8.0.0.398 C432 your System Partition is just 3,7Gb. You need to downgrade to 1 Version before called WAS-LX1A 8.0.0.394 C432 then the System Partition is 4,5Gb. Now you can flash this custom Rom.

    For downgrade use dload method and
    download the package and in there you find software/dload and there are 4 folder and 1 update_sd.zip

    create a dload folder on your desktop and extrac the update_sd.zip and the 1 folder for your Device. so my is a WAS-LX1A (LX1A=L21A) cause of this i extrac the WAS-L21A folder.

    put the update_sd.zip and WAS-L21A folder from downloadet package into the createt dload folder on your desktop. Now copy/paste this dload folder from desktop to external-sd card in your Device, Power off the Device and restart it with press and hold Vol-up+Vol-down+Pwr (no usb cable plugged) now the firmware update should start and wait for progress is finished.
    1
    cant boot, i was on darkjoker aosp 10 rom recently then i follow the steps to flash crdroid10 rom. it stuck on android boot logo pretty long and it fail and boot to recovery. i give it a try to reboot again 2/3 times but it still the same. i thought it was twrp fault so i change twrp DarkJoker360_20200611 as mention. but the problem still the same. i was waiting for crdroid 11 too incase. i like this rom compare to octavios because it has more built in tweaking stuff.

    EDIT: i manage to boot up the phone but its a little bit wierd. i flash darkjoker aosp 10 rom, after it boots up. then i try to dirty flash crdroid10 rom without wiping anything and the phone is boot up. the problem right now is it stuck at homescreen and it said phone is starting. but still can access to setting and ui. i still dont know what could be wrong.

    my device build number: was-lx1A 8.0.0.378 (C432)