Customizable AVRCP Agent

Search This thread

superfougere

Member
Jun 18, 2008
23
3
Hi,
I have a problem using AVRCP on my HTC HD2. AVRCP crashes at startup ... no explaination provided, WM just propose to send a crash report ...

Someone managed to launch AVRCP on HD2 (Leo) ?
 

LEDJSTYLE

Senior Member
Apr 16, 2007
79
0
@ nhvoltagenh : i did evrything you wrote. I used resco to import your settings, i put AVRCP is in the start up windows folder + soft reset with and without the driver.
It's still not working.

It might be because AVRCP sometimes crashes at startup (@ superfougere : you're right same thing for me..) , due to Leo ? new config ?
Anyway, thanks again for your help, ive bought pocket player 4.01, it makes the job, it's not free but i was really in need of AVRCP ;)
 

psychosliver

Member
Dec 24, 2009
21
0
Very nice utility, Wolfman! I made Nitrogen & Kinoma Freeplay work with my Jabra BT3030 at first attempt. But it seems like the settings doesn't stack on one program to another, though. it's like it only functions at the previously configured program at a time.

I'm using it in my Xperia X1 with stock ROM and I wanted to ask for it's default settings that made the Windows Media Player and SE Experience Panel Media Player originally work with the bluetooth headset. Or is there a neat way to uninstall AVRCP agent from the registry, the Startup folder as well as the Program Files Folder?

Currently picking out which audio media player suits me best, of course, having A2DP and AVRCP support is a must.

Regards!
 

Jizzay1

Senior Member
Feb 19, 2006
111
4
SSF
ok my frist question is did you configure and properly run avrcp?

i have made a registry capture for nitrogen.

i will attach it here

import this into your registry,

and the next thing i would do is drop avrcp into your windows\startup folder.


reset phone.

and thats all you should need to do.

the registry settings attached are the settings for Nitrogen used by AVRCP

now let me explain something else.

on my phone avrcp will not Launch Nitro
or rather my Headset wont launch Nitrogen

dunno why, dont care as once nitro is launched it works perfect.

hit me up if this doesnt work.

also the tback driver, isnt (i dont think) a solution to this.

rather its a way for the phone to use the WM Bluetooth stack.

not really sure as i forgot, but i do use it.

I saw the reg file you created, but the app path looks funny:

"AppPath"="\"\\Program Files\\Nitrogen\\Nitrogen.exe"

Is this right? In ACRCP settings i have for "Path to Application:":

\Program Files\Nitrogen\Nitrogen.exe

and it still does not work. I've put in your the other settings as well.

Any ideas? I know my Nitrogen is in that correct folder and have put AVRCP in the startup like you asked. It is running, but won't translate the commands from my head set. Each time i press a button, i get this error: "Volume can not be controlled from this headset" even though i'm pressing the next song button on my headset.

With WMP, I can control everything perfect (without the help of AVRCP program of course).

Any ideas?
 

Jizzay1

Senior Member
Feb 19, 2006
111
4
SSF
Follow up:

My path must be correct: \Program Files\Nitrogen\Nitrogen.exe
because with this path, and when I press next song, i get kicked back to the Manila home screen. With any different path, nothing happens at all when i press a button.

I'm using MightRom newest vertion Sense 2.1

My messages are Play (40001), Forward (40003), and Backward (40002) and Window name is "Nitrogen".

Any ideas?
 

nhvoltagenh

Senior Member
Oct 17, 2008
729
0
Kitchener
www.thewebstation.ws
i wish to elaborate on this a bit more.

AVRCp is a control driver.

which says ok if you press this button on your headset, do this in this program.


And its working perfectly on my end for doing that.

But my second issue was to STOP conflictions of other programs looking for the same button presses.


the link i posted was written by me
http://www.skinzone.org/forum/viewtopic.php?f=3&t=266

on my quest to fix this issue which it did.

the registry settings i exported i use for when i flash my phone.

this way i dont need to reconfig AVRCP to nitrogen.

hell after i hard reset or flash,
i install avrcp into the windows startup folder.
import reg file

pair up my plantronics stereo headset.

reset phone so registry and AVRCP take into affect.

and play my music ;)



so, im almost betting this will work for almost everyone.

I had it on a Touch Pro, Touch Pro 2 and Xperia x1

all custom roms.


so dont get frustrated.
we will get ya fixed up im pretty sure.

i did some serious research in finding the fix. so i know the journey can get annoying.
 

Jizzay1

Senior Member
Feb 19, 2006
111
4
SSF
Thanks for the help with the cab nhvoltagenh. Unfortunately the behavior is the same. Once i press a button on my headset, windows gives me a message that the volume can not be changed...

Windows knows I'm pressing a button, but there seems to be a conflict between the OS and AVRCP getting the commands to Nitrogen.
 

Jizzay1

Senior Member
Feb 19, 2006
111
4
SSF
Yup, tried the tback driver. no luck.

I love how Nitrogen allows to you browse your library by folder. Do you know if Pocket Player or Core Player allows you to do this?
 

hero1453

New member
Oct 6, 2008
1
0
My System: Nitrogen + Motorola S9 HD

Path to application: "Program Files/Nitrogen/Nitrogen.exe" (if you installed on the device memory)
Window name: "Nitrogen"
Play: 40001
Forward: 40003
Backward: 40002

It Works!!!!!!!:D
Mauhahahahahahah
Thanks!
 
Last edited:

olsching

Member
Jan 2, 2010
20
0
nitrogen + Philips shb 7100 + acer neotouch not working

avrcp agent not working:

my device: acer neotouch S200 windows mobile 6.5 (original)

my player: nitrogen 1.2 alpha 4, installed on sd card

my bt headset: Philips SHB 7100

avrcp agent: stored in a folder on device

my settings in avrcp:

View attachment 280533

Procedure:
- headset starting, Bluetooth connection --> ok --> symbol in taskbar
- clicking avrcp (i did not click "ok" in the menu!)
- starting nitrogen

Problem:

play pause + forward backward not working


who can help...:confused:
 

axeaxeaxe

New member
Feb 20, 2010
1
0
avrcp killed when starting touchplayer

hai,

your tool is working fine on my phone, thanx for that! i've only got 1 thing that annoys me. i have a samsung omnia 2 with build in touch player. i don't like the touchplayer, that's why i've changed to nitrogen with your avrcp agent. but when i do start tochplayer (f.i. to watch a movie) the tochplayer says: to optimise tochplayer all media applications will be closed. apparently, avrcp.exe is being closed as well, because after that it doens't work anymore. when i manually start it again, everything works fine, but do you have any idea to avoid this?
 

MDavisiw

Senior Member
Mar 13, 2011
155
1
I am not having any luck getting this to work in coreplayer.. I followed the directions.. Play still makes htc player come up. Best Ive gotten so far is the button to make a cal pauses and plays
HTC Tilt2
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hello,
    here is my new version of the avrcp-agent. It is now customizable, so you can control every application from wich you know the messages to be send as WM_COMMAND.
    On startup you do not see anything from the app! When you start it a second time, you see an menu at the bottom (OK and SETTINGS) where you can configure various things like the path to the application you want to control and timings for double and triple clicks. Don´t click the OK button, because the app will exit after that! Just leave it run in background. The menu disappears after clicking somewhere else.

    Here are the sample Codes for the CorePlayer:

    WindowName: CorePlayer

    play/pause 1102
    PREV 1100
    NEXT 1101
    OpenFile Dialog 1105
    Switch Display 1037

    For the GSPlayer:

    WindowName: GSPlayer

    play/pause 40027
    PREV 40037
    NEXT 40038
    FastFF 40075
    FastBack 40074
    OpenFile Dialog 40018
    Switch Display 100

    You can customize the Agent for the functions of the headset by setting the message values to the buttons you want to.
    I hope you will enjoy.
    Greets,
    Thomas


    21.09.07 - BUG!
    There is a bug in the program. When you reset the device, it "forgets" the settings. I will correct this at monday!

    24.09.07 - FIXED! V1.11
    I have updated the file to the new version.
    -the settings will "survive" a reboot now.
    -the problem with the activation of the application to control is fixed
    -if you want to start any other program with an AVRCP command, you can now specify a path and the .exe file in the message field!!


    Remarks:
    -if you change settings, you must restart the agent.
    -in the "path" field of the settings you must put the COMPLETE path, including the .exe file to start!
    -COREPLAYER: if you want to use the agent with the CorePlayer, you must deactivate the "WMP UI plugin support" under settings/advanced!!!
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone