[CWM][RELEASE] Clockworkmod recovery for P1010

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
First CWM - Based recovery for Samsung Tablet P1010 by Skin1980










HOWTO:

1- Reboot your device in download mode;
2- open Odin;
3- Select the attached file in the PDA field;
4- Flash it.

Skin1980_P1010_CWM-RECOVERY-BETA-1.tar ---> this is for froyo only

Skin1980-P1010-NEW-CF-ROOT-GB.tar ----> this is for Gingerbread


Thanks to:

RussianDeveloper: Great tester and great person... without him you don't have the CWM Recovery
Drockstar, chris41g, koush: for the CWM source
Supercurio: for the explanation about RFS corruption
Chainfire: for the CF-ROOT files/code
 

Attachments

Last edited:

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
EXT4 - Conversion

STATUS: Untested

1st: Flash the new kernel attached that have the ext4 support;
2nd: Install this zip file in recovery ---> http://www.multiupload.com/CSZBZDL1F3

ATTENTION!!!! This will wipe all your data! Make a backup with titanium or similar so then you can restore it!

REMEMBER Also to do a nandroid backup before the zip installation so, if it doesn't work, you can restore easily.
 

Attachments

Last edited:

splattx_x

Senior Member
Mar 31, 2011
204
31
0
It's great to see this post! I was starting to lose all hope. I just want to let you know that I'm up for testing... only that my Girlfriend has borrowed my Tab for a trip so I won't have it available for a week or so. I just wanted to post so you can see there is people interested.
In the mean time, could you please tell more of what's in the PDA file? Is it only a custom kernel? or does it already contain a CWM attempt?
 

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
It's great to see this post! I was starting to lose all hope. I just want to let you know that I'm up for testing... only that my Girlfriend has borrowed my Tab for a trip so I won't have it available for a week or so. I just wanted to post so you can see there is people interested.
In the mean time, could you please tell more of what's in the PDA file? Is it only a custom kernel? or does it already contain a CWM attempt?
For now it's only the stock kernel with CWM.... when it will work i will add more features like OC, lagfix, init.d support, custom bootanimation etc...
 

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
A member called Agafonoff tested it and said that works.... need to test every function like backup and restore...

And please somebody post also the output of:
Code:
mount
 
G

GuestD0808

Guest
It boots on my p1010. I have FROYO.XWKM2 installed.

After booting, kernel version is 2.6.32.9 [email protected] #1

Booting to recovery, it is ClockworkMod Recovery v3.0.0.5.

I see the following output:

Code:
E:Missing bitmap icon_clockwork
(Code -1)
ClockworkMod Recovery v3.0.0.5
E:failed to open /etc/recovery.fstab (No such file or directory)
Checking for ext4 partitions...
Checking /system...
E:unknown volume for path [/system]
E:unknown volume for path [/system]
E:Unable to process volume! Skipping...
Checking /data...
E:unknown volume for path [/data]
E:unknown volume for path [/data]
E:Unable to process volume! Skipping...
Checking /cache...
E:unknown volume for path [/cache]
E:unknown volume for path [/cache]
E:Unable to process volume! Skipping...
Done!
E:unknown volume for path [/cache/recovery/command]
E:Can't mount /cache/recovery/command
E:unknown volume for path [/cache/recovery/log]
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:unknown volume for path [/cache/recovery/last_log]
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:unknown volume for path [/cache/recovery/command]
mount output

Code:
mount
rootfs / rootfs ro,relatime 0 0
tmpfs /dev tmpfs rw,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
tmpfs /app-cache tmpfs rw,relatime,size=12288k 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
/dev/block/stl9 /system rfs ro,relatime,vfat,log_off,check=no,gi
set=utf8 0 0
/dev/block/mmcblk0p3 /mnt/apk vfat ro,nodev,noatime,nodiratime,f
0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,err
 0
/dev/block/mmcblk0p2 /data rfs rw,nosuid,nodev,relatime,vfat,llw
d/rwx,iocharset=utf8 0 0
/dev/block/stl10 /dbdata rfs rw,nosuid,nodev,relatime,vfat,llw,c
rwx,iocharset=utf8 0 0
/dev/block/stl11 /cache rfs rw,nosuid,nodev,relatime,vfat,llw,ch
wx,iocharset=utf8 0 0
/dev/block/stl3 /efs rfs rw,nosuid,nodev,relatime,vfat,llw,check
iocharset=cp437 0 0
/dev/block/stl6 /mnt/.lfs j4fs rw,relatime 0 0
debugfs /debug debugfs rw,relatime 0 0
/dev/block/vold/179:1 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,n
diratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=002
,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
Unable to do a backup. can't find /sdcard either.
 
Last edited:

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
try with alpha 3 please and for every test please post the output like shilob have done.... thanks and sorry but without the device is more and more longer...
 
Last edited:
  • Like
Reactions: samcortez

colemab

Member
Nov 22, 2011
26
10
0
Birmingham
@Skin1980 I have sent you 5$ (USD) via your paypal donate link as good will for your initial work on getting CWM working on the p1010. If/when we get a working backup & recovery, I will be sure to send a larger donation. - thank you for your time and effort sir!

---------- Post added at 07:36 PM ---------- Previous post was at 07:16 PM ----------

Not that it should be any different but accessing the adb shell, running su and then mount on un-modified tab (i.e. no cwm beta/alphas) returns this:

Code:
# mount
mount
rootfs / rootfs ro,relatime 0 0
tmpfs /dev tmpfs rw,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
tmpfs /app-cache tmpfs rw,relatime,size=12288k 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
/dev/block/stl9 /system rfs ro,relatime,vfat,log_off,check=no,gid/uid/rwx,iochar
set=utf8 0 0
/dev/block/mmcblk0p2 /data rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/ui
d/rwx,iocharset=utf8 0 0
/dev/block/stl10 /dbdata rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/
rwx,iocharset=utf8 0 0
/dev/block/stl11 /cache rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/r
wx,iocharset=utf8 0 0
/dev/block/stl3 /efs rfs rw,nosuid,nodev,relatime,vfat,llw,check=no,gid/uid/rwx,
iocharset=cp437 0 0
/dev/block/stl6 /mnt/.lfs j4fs rw,relatime 0 0
debugfs /debug debugfs rw,relatime 0 0
/dev/block/vold/179:1 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,noatime,no
diratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437
,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
/dev/block/vold/179:9 /mnt/sdcard/external_sd vfat rw,dirsync,nosuid,nodev,noexe
c,noatime,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,co
depage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
/dev/block/vold/179:9 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,noati
me,nodiratime,uid=1000,gid=1015,fmask=0002,dmask=0002,allow_utime=0020,codepage=
cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
tmpfs /mnt/sdcard/external_sd/.android_secure tmpfs ro,relatime,size=0k,mode=000
 0 0
#
 
Last edited:
  • Like
Reactions: alexgogan

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
Please somebody post here the file vold.fstab that can be found under tge etc folder

Inviato dal mio GT-I9100 usando Tapatalk
 

chokitodopoder

Senior Member
Jul 1, 2011
111
35
0
Another beta tester here. I don't have much time available, but am willing to help. I was researching how to port ICS for us, but didn't have the time and hardware needed. Thanx!
 

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
Please someone that test the alpha 4 and also the alpha 5 and also alpha 6.
Need that the issue will be reported here.

Like i said in the OP i don't have this device so i need more tester as possible. Please test every of the three version (4 - 5 - 6) and report what works and what not. If you can post also the file /temp/recovery.log or the terminal output.

Thanks

P.S.: after we have a working CWM i promise you some tweaks to get 2000+ on quadrant
 
Last edited:
  • Like
Reactions: collide
G

GuestD0808

Guest
Alpha 4

boots

Bad mounts

Alpha 5

boots

Code:
ClockworkMod Recovery v3.0.0.5
Checking for ext4 partitions...
Checking /system...
Checking /data...
E:failed to mount /data (No such device)
/data may be rfs. Checking...
Checking /cache...
E:failed to mount /cache (No such device)
/cache may be rfs. Checking...
Done!
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/command
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:failed to mount /cache (No such device)
tried to backup

Code:
SD Card space free: 12928MB
Backing up boot image...
Error while backing up boot image!E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:failed to mount /cache (No such device)
Can only mount /sdcard and /system. Other mounts repeat in mount menu.

Code:
# cat recovery.log
cat recovery.log
Starting recovery on Tue Dec 13 04:21:57 2011
framebuffer: fd 4 (1024 x 600)
ClockworkMod Recovery v3.0.0.5
recovery filesystem table
=========================
  0 /tmp ramdisk (null) (null)
  1 /sdcard vfat /dev/block/mmcblk0p1 (null)
  2 /system ext4 /dev/block/stl9 (null)
  3 /system rfs /dev/block/stl9 (null)
  4 /cache ext4 /dev/block/stl11 (null)
  5 /cache rfs /dev/block/stl11 (null)
  6 /data ext4 /dev/block/mmcblk0p2 (null)
  7 /data rfs /dev/block/mmcblk0p2 (null)
  8 /dbdata ext /dev/block/stl10 (null)
  9 /dbdata rfs /dev/block/stl10 (null)
  10 /boot bml boot (null)

W:Unable to get recovery.fstab info for /sd-ext during fstab generation!
I:Completed outputting fstab.
Checking for ext4 partitions...
Checking /system...
Checking /data...
E:failed to mount /data (No such device)
/data may be rfs. Checking...
32512
Checking /cache...
E:failed to mount /cache (No such device)
/cache may be rfs. Checking...
32512
Done!
I:Processing arguments.
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/command
I:Checking arguments.
I:device_recovery_start()
Command: "/sbin/recovery"

ro.secure=0
ro.allow.mock.location=0
ro.debuggable=1
persist.service.adb.enable=1
ro.factorytest=0
ro.serialno=c16090d04b4792e
ro.bootmode=reboot_recovery
ro.baseband=unknown
ro.carrier=unknown
ro.bootloader=unknown
ro.hardware=p1lite
ro.revision=4
dpm.allowcamera=0
ro.build.id=FROYO
ro.build.display.id=FROYO.XWKM2
ro.build.version.incremental=XWKM2
ro.build.version.sdk=8
ro.build.version.codename=REL
ro.build.version.release=2.2.1
ro.build.date=Mon May 23 12:36:47 KST 2011
ro.build.date.utc=1306121807
ro.build.type=user
ro.build.user=root
ro.build.host=SE-S608
ro.build.tags=release-keys
ro.product.model=GT-P1010
ro.product.brand=samsung
ro.product.name=GT-P1010
ro.product.device=GT-P1010
ro.product.board=GT-P1010
ro.product.cpu.abi=armeabi-v7a
ro.product.cpu.abi2=armeabi
ro.product.manufacturer=samsung
ro.product.locale.language=en
ro.product.locale.region=GB
ro.wifi.channels=
ro.board.platform=omap3
ro.build.product=GT-P1010
ro.build.description=GT-P1010-user 2.2.1 FROYO XWKM2 release-keys
ro.build.fingerprint=samsung/GT-P1010/GT-P1010/GT-P1010:2.2.1/FROYO/XWKM2:user/r
elease-keys
ro.build.PDA=P1010XWKM2
ro.build.hidden_ver=P1010XWKM2
ro.build.changelist=1012194
ro.build.buildtag=
ro.sf.lcd_density=240
ro.sf.hwrotation=90
rild.libpath=/system/lib/libsec-ril-apalone.so
rild.libargs=-d /dev/ttyS0
wifi.interface=tiwlan0
jpeg.libskiahw.decoder.enable=0
jpeg.libskiahw.decoder.thresh=100000
ro.opengles.version=131072
dalvik.vm.heapsize=48m
keyinputqueue.use_finger_id=true
windowsmgr.max_events_per_sec=60
ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html

ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/
privacy.html
ro.com.google.locationfeatures=1
ro.setupwizard.mode=DISABLED
ro.com.google.gmsversion=2.2_r10
media.stagefright.enable-player=false
media.stagefright.enable-meta=false
media.stagefright.enable-scan=false
media.stagefright.enable-http=false
media.stagefright.enable-record=false
keyguard.no_require_sim=true
ro.config.ringtone=Minimal_tone.ogg
ro.config.notification_sound=01_Sherbet.ogg
ro.config.alarm_alert=Good_Morning.ogg
ro.config.media_sound=Media_preview_Touch_the_light.ogg
net.bt.name=Android
net.change=net.bt.name
dalvik.vm.stack-trace-file=/data/anr/traces.txt
ro.com.google.clientidbase=android-samsung
init.svc.console=running
init.svc.recovery=running
init.svc.adbd=running

I:Checking for extendedcommand...
I:Skipping execution of extendedcommand, file not found...
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:failed to mount /cache (No such device)
W:Can't unlink /cache/recovery/command
#
Alpha 6

boots

Code:
ClockworkMod Recovery v3.1.0.1
E:Can't mount /cache/recovery/command
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
tried to backup

Code:
SD Card space free: 12928MB
Backing up system...
Then nothing...
Can only mount /sdcard and /system
 
Last edited:

Skin1980

Inactive Recognized Developer
Nov 25, 2009
2,490
6,230
0
Alpha 4

boots

Bad mounts

Alpha 5

boots

Code:
ClockworkMod Recovery v3.0.0.5
Checking for ext4 partitions...
Checking /system...
Checking /data...
E:failed to mount /data (No such device)
/data may be rfs. Checking...
Checking /cache...
E:failed to mount /cache (No such device)
/cache may be rfs. Checking...
Done!
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/command
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:failed to mount /cache (No such device)
tried to backup

Code:
SD Card space free: 12928MB
Backing up boot image...
Error while backing up boot image!E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:failed to mount /cache (No such device)
Can only mount /sdcard and /system. Other mounts repeat in mount menu.

Code:
# cat recovery.log
cat recovery.log
Starting recovery on Tue Dec 13 04:21:57 2011
framebuffer: fd 4 (1024 x 600)
ClockworkMod Recovery v3.0.0.5
recovery filesystem table
=========================
  0 /tmp ramdisk (null) (null)
  1 /sdcard vfat /dev/block/mmcblk0p1 (null)
  2 /system ext4 /dev/block/stl9 (null)
  3 /system rfs /dev/block/stl9 (null)
  4 /cache ext4 /dev/block/stl11 (null)
  5 /cache rfs /dev/block/stl11 (null)
  6 /data ext4 /dev/block/mmcblk0p2 (null)
  7 /data rfs /dev/block/mmcblk0p2 (null)
  8 /dbdata ext /dev/block/stl10 (null)
  9 /dbdata rfs /dev/block/stl10 (null)
  10 /boot bml boot (null)

W:Unable to get recovery.fstab info for /sd-ext during fstab generation!
I:Completed outputting fstab.
Checking for ext4 partitions...
Checking /system...
Checking /data...
E:failed to mount /data (No such device)
/data may be rfs. Checking...
32512
Checking /cache...
E:failed to mount /cache (No such device)
/cache may be rfs. Checking...
32512
Done!
I:Processing arguments.
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/command
I:Checking arguments.
I:device_recovery_start()
Command: "/sbin/recovery"

ro.secure=0
ro.allow.mock.location=0
ro.debuggable=1
persist.service.adb.enable=1
ro.factorytest=0
ro.serialno=c16090d04b4792e
ro.bootmode=reboot_recovery
ro.baseband=unknown
ro.carrier=unknown
ro.bootloader=unknown
ro.hardware=p1lite
ro.revision=4
dpm.allowcamera=0
ro.build.id=FROYO
ro.build.display.id=FROYO.XWKM2
ro.build.version.incremental=XWKM2
ro.build.version.sdk=8
ro.build.version.codename=REL
ro.build.version.release=2.2.1
ro.build.date=Mon May 23 12:36:47 KST 2011
ro.build.date.utc=1306121807
ro.build.type=user
ro.build.user=root
ro.build.host=SE-S608
ro.build.tags=release-keys
ro.product.model=GT-P1010
ro.product.brand=samsung
ro.product.name=GT-P1010
ro.product.device=GT-P1010
ro.product.board=GT-P1010
ro.product.cpu.abi=armeabi-v7a
ro.product.cpu.abi2=armeabi
ro.product.manufacturer=samsung
ro.product.locale.language=en
ro.product.locale.region=GB
ro.wifi.channels=
ro.board.platform=omap3
ro.build.product=GT-P1010
ro.build.description=GT-P1010-user 2.2.1 FROYO XWKM2 release-keys
ro.build.fingerprint=samsung/GT-P1010/GT-P1010/GT-P1010:2.2.1/FROYO/XWKM2:user/r
elease-keys
ro.build.PDA=P1010XWKM2
ro.build.hidden_ver=P1010XWKM2
ro.build.changelist=1012194
ro.build.buildtag=
ro.sf.lcd_density=240
ro.sf.hwrotation=90
rild.libpath=/system/lib/libsec-ril-apalone.so
rild.libargs=-d /dev/ttyS0
wifi.interface=tiwlan0
jpeg.libskiahw.decoder.enable=0
jpeg.libskiahw.decoder.thresh=100000
ro.opengles.version=131072
dalvik.vm.heapsize=48m
keyinputqueue.use_finger_id=true
windowsmgr.max_events_per_sec=60
ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html

ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/
privacy.html
ro.com.google.locationfeatures=1
ro.setupwizard.mode=DISABLED
ro.com.google.gmsversion=2.2_r10
media.stagefright.enable-player=false
media.stagefright.enable-meta=false
media.stagefright.enable-scan=false
media.stagefright.enable-http=false
media.stagefright.enable-record=false
keyguard.no_require_sim=true
ro.config.ringtone=Minimal_tone.ogg
ro.config.notification_sound=01_Sherbet.ogg
ro.config.alarm_alert=Good_Morning.ogg
ro.config.media_sound=Media_preview_Touch_the_light.ogg
net.bt.name=Android
net.change=net.bt.name
dalvik.vm.stack-trace-file=/data/anr/traces.txt
ro.com.google.clientidbase=android-samsung
init.svc.console=running
init.svc.recovery=running
init.svc.adbd=running

I:Checking for extendedcommand...
I:Skipping execution of extendedcommand, file not found...
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:failed to mount /cache (No such device)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:failed to mount /cache (No such device)
W:Can't unlink /cache/recovery/command
#
Alpha 6

boots

Code:
ClockworkMod Recovery v3.1.0.1
E:Can't mount /cache/recovery/command
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
tried to backup

Code:
SD Card space free: 12928MB
Backing up system...
Then nothing...
Can only mount /sdcard and /system
On Alpha 6:

And the file /temp/recovery.log ?

menù works?
 
  • Like
Reactions: collide