• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Dasaita - Latest MCU and Updates for Dasita PX6 1280x720 MAX10

Search This thread

lim-popo

Senior Member
Dec 18, 2014
218
56
Lviv
Thanks for your answer!
I downloaded update here: https://www.dasaita.com/blogs/news/update-firmware

I inserted file "update.zip" in a pendrive and from recovery I click "apply update from USB".
Where can I download same rom not "Ota update"?
Try this one...
 

Ryckylyck

Member
Sep 14, 2021
8
1
Yep!
But try to take 8Gb memory stick (just suggestion)
Update:
I tried but it still the same, Google play services is not installed and all gapps don't work. So I decided to download manually Google Play Services apk and install it; then with "ES file explorer" in root mode, I copied gms folder placed in /data/app into /system/app with permission "rw-, r--, r--".

Now Gapps seems to start, but I can't add a Google account yet. I read about folder /system/priv-app but I don't know if it's work.
Before manually cut folder into /system/app I tried with "systemize magisk module" but when I write su-> systemize on terminal emulator, it says "systemize: command not found" 😪 Why? Can I solve? Maybe enable execute permission can I solve anything?
 

lim-popo

Senior Member
Dec 18, 2014
218
56
Lviv
Update:
I tried but it still the same, Google play services is not installed and all gapps don't work. So I decided to download manually Google Play Services apk and install it; then with "ES file explorer" in root mode, I copied gms folder placed in /data/app into /system/app with permission "rw-, r--, r--".

Now Gapps seems to start, but I can't add a Google account yet. I read about folder /system/priv-app but I don't know if it's work.
Before manually cut folder into /system/app I tried with "systemize magisk module" but when I write su-> systemize on terminal emulator, it says "systemize: command not found" 😪 Why? Can I solve? Maybe enable execute permission can I solve anything?
1. Did you Root your device? (Can this be the issue???)
2. Try MicroG to run Google account
 

dasaitamax10

Member
May 14, 2021
26
3
Hello. And what kind of pendrives do you use for updating? I had problems with updates as I tried to upload them from pendrives smaller than 8GB. Now I use 8 GB, 16 GB and 32 GB pendrives for uploading and the problems have disappeared. Regards.
Thanks suchar20 for your advice .. I downloaded your file and copied it from a compressed folder to a 16gb stick, and I was able to install the new MCU version .. How strange the usb sticks .. I used the 32 one and I could not install the 16gb one without problems instead .. Thanks a lot for the availability and the advice .. Despite the MCU update my problems with the steering wheel buttons still remain .. I can no longer have the functions with the car radio and steering wheel buttons .. I think I have to install the previous version .. Thanks for everything ..
 

suchar20

Member
Nov 4, 2020
29
9
And in what car do you have this radio installed. Maybe your CanBus settings have changed after updating the system software and MCU. Go to Settings> Vehicle> Factory Settings. Enter the code 126 and confirm. Set to CanBus and see if you have the correct car model set. My Toyota C-HR is 08.
20201221_140133.jpg
 

lim-popo

Senior Member
Dec 18, 2014
218
56
Lviv

Thanks suchar20 for your advice .. I downloaded your file and copied it from a compressed folder to a 16gb stick, and I was able to install the new MCU version .. How strange the usb sticks .. I used the 32 one and I could not install the 16gb one without problems instead .. Thanks a lot for the availability and the advice .. Despite the MCU update my problems with the steering wheel buttons still remain .. I can no longer have the functions with the car radio and steering wheel buttons .. I think I have to install the previous version .. Thanks for everything ..

suchar20 is right but be aware not always your Canbus will correspond to your settings. For My Citroen DS4 the correct settings for Canbus is Peugeot 204

 
  • Like
Reactions: dasaitamax10

dasaitamax10

Member
May 14, 2021
26
3
Hi guys, I take the opportunity to answer both lim-popo and suchar20, and thank you for your availability .. I am quite practical to go into the settings of the car radio, by now it is more than a week that this car radio haunts me, I have tried in all ways, but nothing to do .. My car is a peugeot 2008, until recently before installing the latest update 20210722 the car radio worked fine without any problems .. Unfortunately for me I am having problems with this latest update only with the functions buttons on the steering wheel .. Every now and then when the car radio "wakes up" it allows me to use the functions of the buttons, in a nutshell the car radio decides .. In my opinion there is some bug in the update .. Anyway tomorrow morning I reinstall the previous version I had, and it ran great .. Anyway, thank you very much for your support .. Hi guys, hello ..
 

Ryckylyck

Member
Sep 14, 2021
8
1
1. Did you Root your device? (Can this be the issue???)
2. Try MicroG to run Google account
SOLVED!
Thanks for your support lim-popo, now my Dasaita have again google services! I manually moved Google play services' folder from /system/app to /system/priv-app and i authorized it with rwx r-x r-x permissions. Now i've again account google, play store and assistant! I attached the Google play Services apk worked for me.

Now it remain a little problem: assistant don't call with phone. When i try to say "Call Riccardo", it says me "Sorry, i don't understand"... Other commands work very fine, like "bring me to home"! Only phone calls with voice commands don't work, i don't know why, but i will solve it this too!
 

dasaitamax10

Member
May 14, 2021
26
3
And in what car do you have this radio installed. Maybe your CanBus settings have changed after updating the system software and MCU. Go to Settings> Vehicle> Factory Settings. Enter the code 126 and confirm. Set to CanBus and see if you have the correct car model set. My Toyota C-HR is 08. View attachment 5411143
My car is a peugeot 2008 always working with the settings managed by canbus ..
 

dasaitamax10

Member
May 14, 2021
26
3
And in what car do you have this radio installed. Maybe your CanBus settings have changed after updating the system software and MCU. Go to Settings> Vehicle> Factory Settings. Enter the code 126 and confirm. Set to CanBus and see if you have the correct car model set. My Toyota C-HR is 08. View attachment 5411143
Hi suchar20, as I have already told you my car is a peugeot 2008 and it has always worked with these functions that I show you in the picture .. Today I have installed previous version of the update .. 20210507 works very well without problems, "for now I hope for always "thanks and greetings ..
 

saady002000

Member
Aug 19, 2012
22
0
Hi guys
I have a problem i tried to apply this uodate on my px6 but hang up and give me white screen and stopped response.
I cannot even reset it.
Finally i powered it off and waiting for solution.
Please help.
What to do to restore factory settings
 

Attachments

  • 20210919_183903.jpg
    20210919_183903.jpg
    710.8 KB · Views: 5

Pavel-71

Senior Member
Jul 9, 2020
120
63
Hi guys
I have a problem i tried to apply this uodate on my px6 but hang up and give me white screen and stopped response.
I cannot even reset it.
Finally i powered it off and waiting for solution.
Please help.
What to do to restore factory settings
Hi read the solution from suchar20 # 210 and # 196 in this thread:

 

saady002000

Member
Aug 19, 2012
22
0
Hi read the solution from suchar20 # 210 and # 196 in this thread:

Hi read the solution from suchar20 # 210 and # 196 in this thread:

Hi read the solution from suchar20 # 210 and # 196 in this thread:

Problem now looks not just update.
The unit is not response to any usb.
Sorry if i am asking stupid question, but Is there difference between update and orginal MCU?
Because i want to reach to any installation point or progress.
 

Pavel-71

Senior Member
Jul 9, 2020
120
63
Problem now looks not just update.
The unit is not response to any usb.
Sorry if i am asking stupid question, but Is there difference between update and orginal MCU?
Because i want to reach to any installation point or progress.
Upgrading the MCU will probably be different from the original, you can try downgrading to an older version. But first you will solve the problem with the screen, maybe it will also solve the problem with USB. Try another USB or microSD. The last option is SOM:
https://forum.xda-developers.com/t/...-flash-a-som-with-a-simple-usb-cable.3766892/
 

saady002000

Member
Aug 19, 2012
22
0
For Dasaita PX6

Updates on Dasaita website: https://www.dasaita.com/blogs/news/update-firmware

-----
Older versions:

Android 10:
HA3_rk3399_10.0_ota(20200915)升级包 : https://yadi.sk/d/ylg0cKBTQo4P1Q
HA3_rk3399_10.0_ota(20200724)升级包 : https://yadi.sk/d/AWDSmBsznvL3gQ

MCU images - unzip and copy "img" file to flash (sd/usb):
v3.57: View attachment 5111231
v3.60: View attachment 5111233
v3.62: View attachment 5111235

DMCU - unzip and copy to flash (sd/usb) together with MCU image:
for 1280x720 units: View attachment 5111237 - use it if you got a wrong resolution after flashing MCU image and you need to restore your unit to 1280x720 resolution

All works for me on Dasaita PX6 MAX10 (the unit came with Android 10 from the factory)
 

Attachments

  • IMG-20210920-WA0011.jpg
    IMG-20210920-WA0011.jpg
    92.7 KB · Views: 2
  • IMG-20210920-WA0013.jpg
    IMG-20210920-WA0013.jpg
    128 KB · Views: 2
  • IMG-20210920-WA0014.jpg
    IMG-20210920-WA0014.jpg
    87.9 KB · Views: 2

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hello everybody,
    Here are the latest updates for Dasaita HU, Android 10, as of 12/18/2020.
    Merry Christmas !!!
    1.Here the latest link with Android 10.0 system and updates:
    PX6 android 10 (1113)
    https://drive.google.com/file/d/1rO-wBK8rvVZsXT_5IjN3MyuMY00utZZX/view?usp=sharing

    Please download, You need to unzip the "HA2-rk3399" file and then ONLY put the file named "update.zip" to the USB stick (format the USB firstly).
    Finally, click the setting > system > system updates to update it.
    2.Here the latest link with MCU and updates
    V 3.67
    https://www.sendspace.com/file/u17fk5

    Please download then ONLY put the file named "dmcu" to the USB (format the USB firstly).
    Otherwise, the car radio can't find the file to update.
    Finally, click the setting > system > MCU update to update it.
    Hope the update can help you fix the issue.

    Notice: There can only be one update file in the USB stick or SD card when you update the system or MCU.
    2
    I don't want to invest any more money. I find the delay function quite good. But I did the update because of the problem with the reversing signal. Dasaita says you can not downgrade the device. Is this true?
    I am now afraid that the device will not work after the downgrade.
    Is it possible to reload the current software and MCU via the recovery mode at any time?
    I also wonder if the delay function is implemented in the MCU or in the software.
    I would think it is implemented in the MCU but enabled/disabled in the amplifier app. They just chose to remove that functionality so as to incrementally cripple the head unit. This is done so that those who update the firmware on every release will lose something to "gain" something else or just lose all the way around. They progressively cripple these head units in such ways to make you feel like the unit is worthless in a couple years to the point that you'll end up buying the next big thing or throwing it out for "another brand" which in many cases is really the same brand just presented under a different name. Then the cripple cycle with that unit starts.
    2
    Updating the MCU is not necessarily pointless. However it's not always recommended as it's usually unknown what the update is supposed to fix. But somebody's gotta try it I suppose.

    A lot of times the updates can break more than they fix so unless you know the update specifically fixes an issue you're experiencing, updating is not always recommended.

    Regardless, thank you @wwwryan for reporting your experience after the update. Sharing the findings can help others.
    2
    I have posted a tutorial with pictures on how to map the touch keys, might be helpful for you:

    2
    Thanks, will give it a test drive after work.
    By the way... I'm using this launcher for MAX10 HU