Dasaita - Latest MCU and Updates for Dasita PX6 1280x720 MAX10

mpj220

Member
Nov 9, 2008
33
3
28
How is your HU now? Does the downgrade firmware version help?
Please update if you are able to downgrade firmware on the Dasaita.
My current MCU and firmware are auto-launching both Z-Link and default navigation on boot up.

I tried to install an older firmware posted in this thread but, the unit stops, claims it cannot be downgraded, followed by exiting to bootloader.

I have contacted Dasaita many, many, many times over the past 2 weeks with no response.
They finally responded today with a link to an MCU image file.
It was the same image file I currently have. I loaded it anyway.
Still has the same problem.
 

win2k3pro

Member
Feb 18, 2021
5
0
11
Hello. Maybe someone could upload (CMU AND SYSTEM) and help me with my unit..

It should be:

{X6(1280x720)
Android 10
Buikd number
rk3399.....eng.htct2.20200924.101200 test-keys
Kernel version
4.19.111+

MCU version
MTCE_HXD_V3.56_3
Jun 15 2020

This would help me very very much :/

I updated to 1024x600 damn it.. and have no original files.
 

JigenKing

Member
Feb 9, 2021
8
2
13
How is your HU now? Does the downgrade firmware version help?
I found out it still does the same....
I did play around with the settings while it was doing it, and found out it might be a problem with screen brightness, or at least the controller for it. While my screen was turning on and off I clicked on the brightness setting and turned it to the lowest setting. That stopped the flickering for the time being. It takes awhile for me to replicate the flickering issue since it takes like 15+ minutes.

I'm still in contact with Dasaita about it. I think it might be a firmware issue controlling the back light.
 
  • Like
Reactions: storm14994

storm14994

Member
Aug 11, 2015
25
0
21
Please update if you are able to downgrade firmware on the Dasaita.
My current MCU and firmware are auto-launching both Z-Link and default navigation on boot up.

I tried to install an older firmware posted in this thread but, the unit stops, claims it cannot be downgraded, followed by exiting to bootloader.

I have contacted Dasaita many, many, many times over the past 2 weeks with no response.
They finally responded today with a link to an MCU image file.
It was the same image file I currently have. I loaded it anyway.
Still has the same problem.
Hi, I got the reply from Dasaita yesterday told me to try unplug and reinstall HU connections. I tried but nothing changed even I have reset the Factory settings. So, the seller told me to send the unit back for a replacement. It will take a while since my HU was sent from China to Canada. I will keep you update when the replacement one arrived.
 

storm14994

Member
Aug 11, 2015
25
0
21
I found out it still does the same....
I did play around with the settings while it was doing it, and found out it might be a problem with screen brightness, or at least the controller for it. While my screen was turning on and off I clicked on the brightness setting and turned it to the lowest setting. That stopped the flickering for the time being. It takes awhile for me to replicate the flickering issue since it takes like 15+ minutes.

I'm still in contact with Dasaita about it. I think it might be a firmware issue controlling the back light.
For the flickering screen issue, I am pretty sure that is a software bug as my unit does the same thing and the problem is solved when you reduce the screen brightness. But for my case the screen has out-of-fit issue most of the time which is really annoying to use. The seller from "dasaita Official Store" on Aliexpress told me to send it back to them and they will send me a new one.
 

mpj220

Member
Nov 9, 2008
33
3
28
I uploaded a video of what my Dasaita PX6 Max10 is doing.

The video was requested as Dasaita either doesn't believe me or there may be something lost in translation.


If anyone has any ideas, please feel free to share.

Thanks
 

marchnz

Senior Member
Nov 26, 2012
3,039
611
248
wombleton
I uploaded a video of what my Dasaita PX6 Max10 is doing.

The video was requested as Dasaita either doesn't believe me or there may be something lost in translation.


If anyone has any ideas, please feel free to share.

Thanks
Dasaita do not monitor this thread, you should contact them directly.
 

Al Ferro

Senior Member
Sep 26, 2016
195
61
28
I uploaded a video of what my Dasaita PX6 Max10 is doing.

The video was requested as Dasaita either doesn't believe me or there may be something lost in translation.


If anyone has any ideas, please feel free to share.

Thanks
I uploaded a video of what my Dasaita PX6 Max10 is doing.

The video was requested as Dasaita either doesn't believe me or there may be something lost in translation.

Have you tried factory settings (password 126) "other" tab , there is a setting there that remembers what app was opened before shutting off the head unit, it is called Default power or something like that.
 

JigenKing

Member
Feb 9, 2021
8
2
13
For the flickering screen issue, I am pretty sure that is a software bug as my unit does the same thing and the problem is solved when you reduce the screen brightness. But for my case the screen has out-of-fit issue most of the time which is really annoying to use. The seller from "dasaita Official Store" on Aliexpress told me to send it back to them and they will send me a new one.
I just got the same message. They asked me to buy a new unit and ship back the current one.
 

mpj220

Member
Nov 9, 2008
33
3
28
Dasaita do not monitor this thread, you should contact them directly.
The link was emailed to Dasaita days ago.

Since the customer service responses have been very slow and not helpful, I posted here in hopes that others may have experienced the same problem and could possibly share.
 

mpj220

Member
Nov 9, 2008
33
3
28
Thanks for the info.

Yes, I also thought that was the setting causing this. I went through each of those settings and also make certain that I close all background apps prior to removing accessory power.

When in the "off" setting: Apply power to accessory - unit stays off until you press the power button. Default navigation still auto launches on power up and power off.
When in the "on" setting: The video was taken in this state.

Did not try the "last used"?? setting. I figured since default navigation auto launches on power off, that would be what it launches on power up.

I will test all 3 states after work.
 

lim-popo

Senior Member
Dec 18, 2014
69
13
28
Lviv
Thanks for the info.

Yes, I also thought that was the setting causing this. I went through each of those settings and also make certain that I close all background apps prior to removing accessory power.

When in the "off" setting: Apply power to accessory - unit stays off until you press the power button. Default navigation still auto launches on power up and power off.
When in the "on" setting: The video was taken in this state.

Did not try the "last used"?? setting. I figured since default navigation auto launches on power off, that would be what it launches on power up.

I will test all 3 states after work.
I have completely the same unit in my Citroen DS4... But to be honest I'm using custom ROM from Malaysk and don't have this kond of isuue at all.
1. Try to update MCU that I send
2. If nothing will change try to install this ROM (light version) and test it again (if fine then you can buy an full version if not then you can return to stock) Sow...
Malaysk: https://forum.xda-developers.com/t/...k-rom-for-px6-rk3399-with-android-10.4176069/
Stock: https://www.dasaita.com/blogs/news/update-firmware
 

mpj220

Member
Nov 9, 2008
33
3
28
I have completely the same unit in my Citroen DS4... But to be honest I'm using custom ROM from Malaysk and don't have this kond of isuue at all.
1. Try to update MCU that I send
2. If nothing will change try to install this ROM (light version) and test it again (if fine then you can buy an full version if not then you can return to stock) Sow...
Malaysk: https://forum.xda-developers.com/t/...k-rom-for-px6-rk3399-with-android-10.4176069/
Stock: https://www.dasaita.com/blogs/news/update-firmware
Thanks!

I also have 2 of the same Dasaita units. One has been installed for 6 months with no issues.

When the second one was purchased from Amazon, Dasaita contacted via email and said that an MCU and firmware update was needed. I used the same "stock" link that you posted and updated both units.
The older unit works fine. The new one is doing this "auto launch" of navigation.

I contacted Dasaita and they claimed I was using the wrong firmware and sent this via email:

"Hi, Mark Johnson
you need to update the system.
Here you go for the update link:
MAX10
PX6 10.0 HA3_rk3399_10.0_ota(20201214) https://www.sendspace.com/pro/dl/f3gyol

PX6 android 10 (1113)
https://drive.google.com/file/d/1rO-wBK8rvVZsXT_5IjN3MyuMY00utZZX/view?usp=sharing

Please download, then ONLY put that zip format file to the usb (format the usb before you use it to make sure only one file in the usb)."


I updated with the first file and the unit was doing the same thing.
I tried to update with the second file and the unit begins upgrade and then gives an error that says I cannot downgrade firmware. After the error, it defaults to recovery menu.

Quick question on the Malaysk firmware:
Does this firmware have the Z-Link app? Or some way to use Android Auto?

Thanks!
 

lim-popo

Senior Member
Dec 18, 2014
69
13
28
Lviv
Thanks!

I also have 2 of the same Dasaita units. One has been installed for 6 months with no issues.

When the second one was purchased from Amazon, Dasaita contacted via email and said that an MCU and firmware update was needed. I used the same "stock" link that you posted and updated both units.
The older unit works fine. The new one is doing this "auto launch" of navigation.

I contacted Dasaita and they claimed I was using the wrong firmware and sent this via email:

"Hi, Mark Johnson
you need to update the system.
Here you go for the update link:
MAX10
PX6 10.0 HA3_rk3399_10.0_ota(20201214) https://www.sendspace.com/pro/dl/f3gyol

PX6 android 10 (1113)
https://drive.google.com/file/d/1rO-wBK8rvVZsXT_5IjN3MyuMY00utZZX/view?usp=sharing

Please download, then ONLY put that zip format file to the usb (format the usb before you use it to make sure only one file in the usb)."


I updated with the first file and the unit was doing the same thing.
I tried to update with the second file and the unit begins upgrade and then gives an error that says I cannot downgrade firmware. After the error, it defaults to recovery menu.

Quick question on the Malaysk firmware:
Does this firmware have the Z-Link app? Or some way to use Android Auto?

Thanks!
Yes, it contains Z-Link... But you need to consider that Android Auto works only via cable connection (just in case...)

Check last update by Malaysk

None of these head units are Android Auto. What you are referring to is an app that attempts screen mirroring.
You're bit wrong bro... :)
 

lim-popo

Senior Member
Dec 18, 2014
69
13
28
Lviv
Thanks!

I also have 2 of the same Dasaita units. One has been installed for 6 months with no issues.

When the second one was purchased from Amazon, Dasaita contacted via email and said that an MCU and firmware update was needed. I used the same "stock" link that you posted and updated both units.
The older unit works fine. The new one is doing this "auto launch" of navigation.

I contacted Dasaita and they claimed I was using the wrong firmware and sent this via email:

"Hi, Mark Johnson
you need to update the system.
Here you go for the update link:
MAX10
PX6 10.0 HA3_rk3399_10.0_ota(20201214) https://www.sendspace.com/pro/dl/f3gyol

PX6 android 10 (1113)
https://drive.google.com/file/d/1rO-wBK8rvVZsXT_5IjN3MyuMY00utZZX/view?usp=sharing

Please download, then ONLY put that zip format file to the usb (format the usb before you use it to make sure only one file in the usb)."


I updated with the first file and the unit was doing the same thing.
I tried to update with the second file and the unit begins upgrade and then gives an error that says I cannot downgrade firmware. After the error, it defaults to recovery menu.

Quick question on the Malaysk firmware:
Does this firmware have the Z-Link app? Or some way to use Android Auto?

Thanks!
One more... Here's v3.71d version

Don't need to thank :)... Shake your hand
 

Attachments

  • Like
Reactions: mpj220