Dasaita - Latest MCU and Updates for Rockchip CPU platform Stereos

Search This thread

ruinertt

Senior Member
Apr 28, 2008
531
25
Georgia
Im not sure if this is the right place for my question, but i got help in here once before. I have an issue while using my head unit with Android auto. Sometimes when i get notifications, my volume gets low. I've found that if i hit the Google microphone button, it will fix the volume. In looking for a solution, i found a YouTube video with the same issue. I hope it's ok to post this link. I'm not totally familiar with the rules here , but this is it-
. Any help would be appreciated. Thanks.
I have the same issue (Dasaita 10.2" running Android 10) and the only way to bring it back is to hit the microphone/voice button 2x quickly. It's been this way for a long time. At least we can fix it without getting a txt message.
 

graycorgi

Senior Member
Apr 23, 2010
335
90
Dallas
Just updated my MAX6/MAX10 to the 20220120 update. ZLink went from 4.0.32 in the December update to 4.0.39 in this January update.

If you use Android Auto, this update completely breaks it (especially wirelessly) if "HD Display" is ON in the ZLink settings. Previously, this was ON and it worked fine. I never could tell a visual difference but Android Auto WILL NOT WORK if this is ON in the 4.0.39 version. Just wasted about an hour troubleshooting that.

Also, if you are like me and have the radio power off (not sleep) after 30 seconds so it does a clean reboot, the bug where ZLink thinks your headlights are off until you turn them off and on again is still there. Still get blinded by bright google maps / waze screens on first boot at night and have to flick my lights off and on to fix it. Mildly irritating and hopefully one day they will fix that.
 

ravipe

Member
Dec 28, 2014
39
2
Hi guys, I have a PX5 on my BMW X5 E53 currently running MTCE_KGL_V2.80_2 Mar 1 2018. Can you please share can I get a safe update for my device? If you could also point me on the right direction regarding how to update it safely that would also be fantastic. PS: my px have both GPS and SD micro sd slots. Thank you in advance.
 

graycorgi

Senior Member
Apr 23, 2010
335
90
Dallas
Another annoying bug that seems to be introduced in the latest update: When I get a phone call, I see the caller's number in the HUD (screen between speedo and tacho) with prompt to press either answer or hang up. If I answer the call, that screen should get dismissed. Instead, it is staying on the screen all the way until I end the call. That blocks half the screen in the HUD. It was not doing this for me before the 20220120 update. Car is a 2014 Nissan Rogue

Edit: Anyone know the best way to report a bug to Dasaita? I posted this to their forum but this one is annoying enough that I'd really like them to fix it by the next update.
 
Last edited:

marchnz

Senior Member
Nov 26, 2012
4,755
954
NZ
Another annoying bug that seems to be introduced in the latest update: When I get a phone call, I see the caller's number in the HUD (screen between speedo and tacho) with prompt to press either answer or hang up. If I answer the call, that screen should get dismissed. Instead, it is staying on the screen all the way until I end the call. That blocks half the screen in the HUD. It was not doing this for me before the 20220120 update. Car is a 2014 Nissan Rogue

Edit: Anyone know the best way to report a bug to Dasaita? I posted this to their forum but this one is annoying enough that I'd really like them to fix it by the next update.
Reseller/dasaita - but they won't care or english with you :)

Another example of leave it if it's not broken on Chinese origin head units.
 

graycorgi

Senior Member
Apr 23, 2010
335
90
Dallas
Reseller/dasaita - but they won't care or english with you :)

Another example of leave it if it's not broken on Chinese origin head units.
Thanks, I emailed them anyway. Was hoping some of the ZLink bugs were fixed in the new version which is why I updated (something's always broken, so I always gotta try to fix it unfortunately)

In case anyone needs the version without this bug, this is the update from December: https://www.dropbox.com/s/bw8w2a1h7k16e1j/HA3_rk3399_10.0_ota(20211227)升级包.zip?dl=0
 

marchnz

Senior Member
Nov 26, 2012
4,755
954
NZ
Thanks, I emailed them anyway. Was hoping some of the ZLink bugs were fixed in the new version which is why I updated (something's always broken, so I always gotta try to fix it unfortunately)

In case anyone needs the version without this bug, this is the update from December: https://www.dropbox.com/s/bw8w2a1h7k16e1j/HA3_rk3399_10.0_ota(20211227)升级包.zip?dl=0

With respect, zlink on an Android headunit, I don't understand, think about a genuine Android auto unit for this use case.
 

graycorgi

Senior Member
Apr 23, 2010
335
90
Dallas
With respect, zlink on an Android headunit, I don't understand, think about a genuine Android auto unit for this use case.
I couldn't find any genuine ones that had a 10" display and fit my car with a factory look. ZLink sucks, but the problem I'm having now with the phone call showing on the HUD isn't even a ZLink problem, that's a problem with the Dasaita firmware itself.
 
  • Like
Reactions: marchnz

ruinertt

Senior Member
Apr 28, 2008
531
25
Georgia
Just updated my MAX6/MAX10 to the 20220120 update. ZLink went from 4.0.32 in the December update to 4.0.39 in this January update.

If you use Android Auto, this update completely breaks it (especially wirelessly) if "HD Display" is ON in the ZLink settings. Previously, this was ON and it worked fine. I never could tell a visual difference but Android Auto WILL NOT WORK if this is ON in the 4.0.39 version. Just wasted about an hour troubleshooting that.

Also, if you are like me and have the radio power off (not sleep) after 30 seconds so it does a clean reboot, the bug where ZLink thinks your headlights are off until you turn them off and on again is still there. Still get blinded by bright google maps / waze screens on first boot at night and have to flick my lights off and on to fix it. Mildly irritating and hopefully one day they will fix that.
Good looking out. I have YET to find a solution to the 'headlight/bright map' issue with Android Auto, either. It's been an issue since I can remember (well over a year ago). That includes both zLink and AA updates as well. I think that it has to deal with perhaps my truck's DRLs (Daytime Running Lights?) but I'm not entirely sold on that. It's funny because my headunit will illuminate the 'dark' lights at the bottom, but AA won't change until I turn my lights completely off/on (like you have to do). I've tried all permutations of using the auto/dark/light settings in AA as well. Go figure.
 

ruinertt

Senior Member
Apr 28, 2008
531
25
Georgia
I couldn't find any genuine ones that had a 10" display and fit my car with a factory look. ZLink sucks, but the problem I'm having now with the phone call showing on the HUD isn't even a ZLink problem, that's a problem with the Dasaita firmware itself.
Maybe you can try and revert. The latest MCU is what...3.78? I have a Dasaita 10.2" head unit so I am in the same boat. By the way, while using AA, do the callers on the other end have a hard time hearing you while driving?
 

graycorgi

Senior Member
Apr 23, 2010
335
90
Dallas
Maybe you can try and revert. The latest MCU is what...3.78? I have a Dasaita 10.2" head unit so I am in the same boat. By the way, while using AA, do the callers on the other end have a hard time hearing you while driving?
Yeah, but I've been using mcu 3.78 for months now without issue so it isn't the mcu this time. Its a problem with the 20220120 software version for the system, and unfortunately it doesn't let you flash an older version of that.

I've been told my mic sucks, but I was also told that with the factory mic in my car lol. I use the mic in the unit. There is a mic boost option in the MCU which I tried. I was told it still sounds sucky, but louder. I do have a hard time hearing people in my car who call me from an iPhone on speakerphone, for some reason I have to have the volume on 30 and I can still barely hear them if there's road noise. But they can usually hear me fine.
 

ruinertt

Senior Member
Apr 28, 2008
531
25
Georgia
Yeah, but I've been using mcu 3.78 for months now without issue so it isn't the mcu this time. Its a problem with the 20220120 software version for the system, and unfortunately it doesn't let you flash an older version of that.

I've been told my mic sucks, but I was also told that with the factory mic in my car lol. I use the mic in the unit. There is a mic boost option in the MCU which I tried. I was told it still sounds sucky, but louder. I do have a hard time hearing people in my car who call me from an iPhone on speakerphone, for some reason I have to have the volume on 30 and I can still barely hear them if there's road noise. But they can usually hear me fine.
Maybe I'll try the on-board mic again. I switched out my external mic a few times and am working with Iris to perhaps replace the chip/mainboard. I dunno. Everything else works well, but people just have a hard time hearing me (sound like a lot of background noise I am told). By the way, I just installed a front cam (it was very easy to do). Paid about $15 for the camera and it is quality. Helps me 'better' park my truck for sure.
 

NikosPot

Senior Member
Sep 27, 2011
92
7
Hello. I have a PX5 rk3368 - 4GB ram, MTCE with Android 9. I flashed the latest MCU 3.78 from this thread but I am a little confused with the roms. Which rom is the latest and suitable for my unit? Thank you!
 

graycorgi

Senior Member
Apr 23, 2010
335
90
Dallas
Yeah, but I've been using mcu 3.78 for months now without issue so it isn't the mcu this time. Its a problem with the 20220120 software version for the system, and unfortunately it doesn't let you flash an older version of that.

I've been told my mic sucks, but I was also told that with the factory mic in my car lol. I use the mic in the unit. There is a mic boost option in the MCU which I tried. I was told it still sounds sucky, but louder. I do have a hard time hearing people in my car who call me from an iPhone on speakerphone, for some reason I have to have the volume on 30 and I can still barely hear them if there's road noise. But they can usually hear me fine.
I rolled back to the december firmware and it was still doing it. I installed the generic HCT7 firmware from here and now it's not doing it anymore. I think i'll just keep using this one, the interface is better than the dasaita HA3 one anyway: https://www.dropbox.com/s/vd8xf4qirre8vw5/HCT7_rk3399_10.0_ota(20211009)升级包.zip?dl=0
 

ruinertt

Senior Member
Apr 28, 2008
531
25
Georgia
I rolled back to the december firmware and it was still doing it. I installed the generic HCT7 firmware from here and now it's not doing it anymore. I think i'll just keep using this one, the interface is better than the dasaita HA3 one anyway: https://www.dropbox.com/s/vd8xf4qirre8vw5/HCT7_rk3399_10.0_ota(20211009)升级包.zip?dl=0
i switched out my launcher a long time ago. I think that I use the FCC launcher right now (I've been through many). It's not bad.
 

gvillo89

Senior Member
Jan 5, 2018
84
6
33
Buenos Aires
the workaround that I found for the headlights issue (bright map) it's to put the key to accesories let the headunit starts and then start the car (it's like 15 seconds), headlights will light up when I move the key to contact and start the engine. At least for my car. But it is still an annoying bug
 

graycorgi

Senior Member
Apr 23, 2010
335
90
Dallas
the workaround that I found for the headlights issue (bright map) it's to put the key to accesories let the headunit starts and then start the car (it's like 15 seconds), headlights will light up when I move the key to contact and start the engine. At least for my car. But it is still an annoying bug
Good point - I noticed I don't have the problem when I use my remote start and I think that's because it doesnt turn on the headlights.
 

drstoms

Member
Feb 14, 2016
43
2
Go to dasaita.com. there are published all the firmwares for bmw series units
Thank you for your answer, but when I enter desaita, I only see sales when I enter bmw px3, nothing is found when I enter the firmware, I have no idea where to find the firmware for the bmw px3. she fell into bootloop, she needs to connect to the power supply outside the car and upload the firmware, but when I connect the cables yellow red to plus and gnd to minus, no signal pops up on the screen. I connected other radios to the power supply and there was no problem and here, however I did not connect, no signal pops up
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    You have a rare MCU version, I couldn't find MTCE_AW anywhere. You don't need to update the MCU, 3.75 is a fairly new update. Crossing MCU manufacturers is not recommended. You can also update the firmware(rom) from other manufacturers, but no one can guarantee that the Z-link will work. You have to try it yourself. First, try contacting the vendor to see if they have firmware and MCU updates. Z-link can be updated separately but you have to ROOT but it doesn't work very well see the thread below. If everything works for you, leave it as it is, you may cause yourself more problems than now, there have already been many cases where updates have been bricked. Especially Dasaita(HA) has white screen issues after firmware update. It can be fixed, but why add more work.Please read the MTCD threads thoroughly first.
    Z-link:

    Here you will find the firmware of all px6 android 10 manufacturers, including HCT, there are attached screens that you can use to identify your ROM:
    1
    Why is everyone wanting to update to A11 I see pretty much anyone running Vivid 10 and Android 10 wanting to upgrade to vivid 11 and Android 11. To get vivid 11 do you need to have android 11?
    Vivid 10 = Vivid running on Android 10. Vivid 11 = the same exact Vivid but on Android 11. You aren't missing anything and Dasaita's Android 11 builds are plagued with Bluetooth issues. Stay on 10
    1
    Yes , but only the Rom....the MCU is better to upgrade only with the AW manufacturer.
    1
    hi, is my head unit compatible with these upgrades ? (PX6) (1024x600).

    I noticed that the MCU in my unit is MTCE_AW and I can't find any files related to this type ... any idea ?
    MTCE_AW is a SYGAV unit to get their latest firmware you will need to email them a screen shot of the about page and they will provide you a download link. They were very responsive to my request for the latest updated firmware (they responded within 24h of my request). My head unit is SYGAV and has MTCE_AW.


    Worth noting that the DASAITA firmware updates will work with your unit but I would recommend getting them from SYGAV in case there might be any compatibility issues.
  • 75
    Warm Notice:

    If your system is working well, please do not upgrade it !!!
    Because the upgrade is risky, it might lead to CRASH, BLACK SCREEN, OR SYSTEM ERROR;

    Unless there is a major bug in the car system, it unable to be used normally.
    At this time, you can choose to upgrade the system to solve it.

    contact your dealer to make sure you are choosing the right firmware and right update steps



    MTCH

    3.80 : https://www.dropbox.com/s/4kl7j2gsgdjt527/MTCH_HA_V3.80.rar?dl=0

    MTCE MCU

    3.78:https://www.dropbox.com/s/3hd3ci3rp07ddnt/dmcu.img?dl=0

    Android 11 Update

    MAX11 Version
    Make Sure your unit is PX6 Andorid 11

    HA3_rk3399_11.0_ota(20220601)


    Vivid 11 Version Make Sure your unit is PX6 Andorid 11

    telenav_vivid_rk3399_11.0_ota(20220518)


    HCT Firmware PX6 Android 11 Make Sure your unit is PX6 Andorid 11

    HCT8_rk3399_11.0_ota2820220412


    Android 10 Update

    MAX10 Version
    Make Sure your unit is PX6 Andorid 10

    HA3_rk3399_10.0_ota(20220521)


    Vivid 10 Version: Make Sure your unit is PX6 Andorid 10

    telenav_vivid_rk3399_10.0_ota(20220518)


    Scout 10 Version : Make Sure your unit is PX6 Andorid 10

    telenav_scout_rk3399_10.0_20220527

    8
    @hotaudio

    It would be great if you can share what's on your mind for the future of this device... Would it be updated to 7.0? Are you guys thinking on moving directly to 8.0 as some post suggested? Or are you focusing on further cleaning/bug removal on Android 6 for the foreseeable future?

    While upgrading for the sake of being able to claim compatibility with latest android release is not really helpful for the users (everybody prefers a stable device rather than latest SW), what Google is doing with the assistant seems quite nice :) and I understand there's no possible dirty trick to get Assistant on Android 6 (while there're some "options" posted for Android 7)

    Kr

    Max

    Hi Max

    the latest news is PX5 will update to 8.0 , and it will be very cool system .
    now the 8.0 version still have some bugs . probably they will release at the end of this month
    when firmware is ready , I will post it on this link

    regards
    Quick
    7
    Has someone already downloaded the firmware HA_PX5_8.0_ota (20181124) and could upload it to another hoster? the download on sendspace takes forever.

    Thank you

    MCU HA V2.99
    https://drive.google.com/file/d/1PvOgTGATI4ltMIeEh7cw0ggMdZ7-d7ew/view

    Blue UI HA_PX5_8.0_ota(20181124)
    https://drive.google.com/file/d/1Yo9Zmnlwx5Gf-jM9DMZlrsmj4xIlJw2K/view