• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Dasaita - Latest MCU and Updates for Rockchip PX5 Octa-Core 2G RAM 32GB

Search This thread

scythe000

Senior Member
Nov 17, 2008
99
1
Hi folks, I wound up switching from a non JBL Highlander to a Highlander with JBL. Had the issue with the static, got the RCA adapter from Dasaita. It fixed the static, but the volume level is much, much lower. She says that having the amp setting at 0db is already as high as it can go, and using the adapter will make things much quieter. Does anyone have any solution for the huge loss of volume?
 

checksum123

Senior Member
Jan 27, 2012
229
34
See my signature links
Thank you!
I will try the USB way with the unit connected to the PC. Awaiting my USB-A to USB-A cable.

Do you know where I can get the android 10 .IMG to start with before installing my ota?
dasaita3.jpg
 
Last edited:

turquan

New member
Jan 22, 2021
1
0
Hey guys, hoping someone has seen this before. I am flashing my PX6 (1024x600) MAX6 and I seem to be getting the same error regardless of which Android 10 update I use. I saw some earlier posts with the same issue that were due to not having a 3399 chip, which I do have. Thes updates were located on a 16GB USB key and I did try to run them both from recovery mode and through the standard system update in settings.

Last attempted updates
HA3_rk3399_10.0_ota(20201214)升级包
HA3_rk3399_10.0_ota(20201113)升级包2

assert failed: update_dynamic_partitions (package_extract_file("dynamic_partition list")) (Status 7)

Current Versions
Build -rk3399-userdebug 9 pi 20200521.144002 test-keys
Kernel - 4.4.167
MCU -MTCE_HA_V3.62_1
 
Last edited:

checksum123

Senior Member
Jan 27, 2012
229
34
I have the Dasaita MAX 10 PX6 rk3389 with android10 and trying to enter recovery mode to install the IMG image , with no luck.

I can't seem to enter Recovery Mode

I tried pressing the reset button until the LEDs blink, then release and press again, but that does not work, it just reboots the unit.

Is the following screen considered Recovery Mode?
I can get to this screen by trying to downgrade with an older image, but when I plug in my usb-a to usb-a cable, i do not hear nothing on my win10 laptop, and nothing shows up on RKDevTool. I already installed the driver, and rebooted the laptop. I tried all usb ports:1,2 and A
20210116_181252.jpg
 

talrhv

Senior Member
Mar 17, 2020
51
0
Hey guys, hoping someone has seen this before. I am flashing my PX6 (1024x600) MAX6 and I seem to be getting the same error regardless of which Android 10 update I use. I saw some earlier posts with the same issue that were due to not having a 3399 chip, which I do have. Thes updates were located on a 16GB USB key and I did try to run them both from recovery mode and through the standard system update in settings.

Last attempted updates
HA3_rk3399_10.0_ota(20201214)升级包
HA3_rk3399_10.0_ota(20201113)升级包2

assert failed: update_dynamic_partitions (package_extract_file("dynamic_partition list")) (Status 7)

Current Versions
Build -rk3399-userdebug 9 pi 20200521.144002 test-keys
Kernel - 4.4.167
MCU -MTCE_HA_V3.62_1
If you upgrade from android 9 to 10 you need to purchase modinstaller 2 from hal9k website it is the easiest way to upgrade.
10 euro.

I tried other ways all failed.
 

checksum123

Senior Member
Jan 27, 2012
229
34
I was finally able to get into recovery mode, and was able to use the OTG method without any issues.
On my unit, which is the Dasaita Max 10 RK3399 Android 10, you have to press the reset button until LEDs start flashing, then do not release, keep pressing for an additional 10sec, then release and press again.
Thank you @marchnz
 
  • Like
Reactions: marchnz

ruinertt

Senior Member
Apr 28, 2008
505
25
Georgia
I have couple of questions. Does the dasaita px6 max6/10 support wireless android auto?
Is there a way to manually trigger zlink to connect to wireless carplay?

thanks.
Yes, it supports it, BUT you need to be at a higher ZLINK level. I think 4.x.x to support wireless Android Auto (if you are still on the 3.0.x code it only supports wireless Carplay). I'm currently using ZLINK v 4.0.14 I believe. Typically ZLINK is packaged with the Android 10 update, so when you update your OS it updates the ZLINK package as well (as the OS upgrade comes from Dasaita I believe).

I'm currently running the below code (both the Android 10 12/17/2020 update and the MCU update 3.69c as well). I can confirm that wireless android auto works (although ZLINK is more of a mirroring software, it does the job).

PX6 android 10 (12.17.2020) https://drive.google.com/file/d/10swfJDl25Up7byPP6IMWOgXY4-2giuQD/view?usp=sharing
3.69c MCU https://drive.google.com/file/d/1zJzcz1P57VDSDxB7lKnpB0tZwWGSCMS5/view?usp=sharing
 

talrhv

Senior Member
Mar 17, 2020
51
0
Yes, it supports it, BUT you need to be at a higher ZLINK level. I think 4.x.x to support wireless Android Auto (if you are still on the 3.0.x code it only supports wireless Carplay). I'm currently using ZLINK v 4.0.14 I believe. Typically ZLINK is packaged with the Android 10 update, so when you update your OS it updates the ZLINK package as well (as the OS upgrade comes from Dasaita I believe).

I'm currently running the below code (both the Android 10 12/17/2020 update and the MCU update 3.69c as well). I can confirm that wireless android auto works (although ZLINK is more of a mirroring software, it does the job).

PX6 android 10 (12.17.2020) https://drive.google.com/file/d/10swfJDl25Up7byPP6IMWOgXY4-2giuQD/view?usp=sharing
3.69c MCU https://drive.google.com/file/d/1zJzcz1P57VDSDxB7lKnpB0tZwWGSCMS5/view?usp=sharing


Thanks, I have the same version installed, I haven't try that yet I was just wondering (I have an iphone).

what about my second question? I know that in branded head units is can be achieved when pressing to Voice command button (if you have one in your car) but It doesn't work on the Dasaita unit.
 

Sylvan151

Senior Member
Jul 9, 2009
74
3
Kuala Belait
I was finally able to get into recovery mode, and was able to use the OTG method without any issues.
On my unit, which is the Dasaita Max 10 RK3399 Android 10, you have to press the reset button until LEDs start flashing, then do not release, keep pressing for an additional 10sec, then release and press again.
Thank you @marchnz

Questions;

I am on Android Version 8. Can i upgrade to Android Version 10? How?

The Build Number has HCT on it. Can i update with HA? Or need to update with HCT?

What does OTG stands for?

I am on PX5. I shud not install PX6 correct?

I am on MTCE HA. I have already update to the latest (image is the one not yet updated)

Thanks for your reply.
20210126_224148.jpg
20210126_224136.jpg
20210127_004108.jpg
 

talrhv

Senior Member
Mar 17, 2020
51
0
Questions;

I am on Android Version 8. Can i upgrade to Android Version 10? How?

The Build Number has HCT on it. Can i update with HA? Or need to update with HCT?

What does OTG stands for?

I am on PX5. I shud not install PX6 correct?

I am on MTCE HA. I have already update to the latest (image is the one not yet updated)

Thanks for your reply.View attachment 5199689View attachment 5199691View attachment 5199697

You need to get the update for PX5 unit PX6 will not work for you.
OTG is the usb port that is used for CarPlay\android auto.
you can use the HA version of PX5.
HA = Hot audio = Dasaita, but it can be used with all PX5 units even of other brands.
 

mel0ntek

New member
Jan 26, 2021
2
1
Hey all, been lurking a few days and read through the entire thread. I do embedded software engineering at my current job, so I hope I may be able to apply some of that knowledge here.

I just picked up a PX6+DSP unit for my WRX.
I am using this with a Pixel 4xl.

My unit had some pretty old revisions running on it out of the box:
RK3399-10-2020.06.09
MTCE_HA_V3.57_1
(factory settings password:126)

Android Auto was working sporadically over USB on this version and no wireless capability.

I updated to the 12.17.2020 OTA update and 3.69c. Upon rebooting, Android Auto connected itself automatically over bluetooth and setup the wifi connection. Seems to be working great, however I would prefer to use the head unit normally and only connect AA when I want to. Disabling wireless in AA settings on my phone prevents it from auto-starting every time I connect the phone/HU.

I also went into the factory settings and enabled BT network sharing (BT tether on phone settings) and rebooted. I now have the <--> icon at the top of the HU display. However, I cannot get any network connectivity (load a webpage for example) on the HU.

Yes, it supports it, BUT you need to be at a higher ZLINK level. I think 4.x.x to support wireless Android Auto (if you are still on the 3.0.x code it only supports wireless Carplay). I'm currently using ZLINK v 4.0.14 I believe. Typically ZLINK is packaged with the Android 10 update, so when you update your OS it updates the ZLINK package as well (as the OS upgrade comes from Dasaita I believe).

I'm currently running the below code (both the Android 10 12/17/2020 update and the MCU update 3.69c as well). I can confirm that wireless android auto works (although ZLINK is more of a mirroring software, it does the job).

PX6 android 10 (12.17.2020) https://drive.google.com/file/d/10swfJDl25Up7byPP6IMWOgXY4-2giuQD/view?usp=sharing
3.69c MCU https://drive.google.com/file/d/1zJzcz1P57VDSDxB7lKnpB0tZwWGSCMS5/view?usp=sharing

Are you able to tether data over BT while connected or otherwise?

The issue I am seeing here is that since the HU acts as a hotspot when AA is connected, it doesnt seem to know what to do for its own internet access. Android falls back to Mobile data if it's available when a wifi connection doesnt have internet access, so the phone still works fine. I would assume that the HU would do the same even in hotspot mode and fallback to "ethernet" (<--> symbol) but it doesn't seem to in my case.

Then again with AA disabled I cant get bluetooth tethering to work for mobile data either even though the <--> shows up. Have any of you done any testing with these connection scenarios/sharing data while AA is connected?
 

[email protected]

Senior Member
Apr 21, 2007
93
1
From the Land Down Under!!
Yes, it supports it, BUT you need to be at a higher ZLINK level. I think 4.x.x to support wireless Android Auto (if you are still on the 3.0.x code it only supports wireless Carplay). I'm currently using ZLINK v 4.0.14 I believe. Typically ZLINK is packaged with the Android 10 update, so when you update your OS it updates the ZLINK package as well (as the OS upgrade comes from Dasaita I believe).

I'm currently running the below code (both the Android 10 12/17/2020 update and the MCU update 3.69c as well). I can confirm that wireless android auto works (although ZLINK is more of a mirroring software, it does the job).

PX6 android 10 (12.17.2020) https://drive.google.com/file/d/10swfJDl25Up7byPP6IMWOgXY4-2giuQD/view?usp=sharing
3.69c MCU https://drive.google.com/file/d/1zJzcz1P57VDSDxB7lKnpB0tZwWGSCMS5/view?usp=sharing

Care to share how you got wireless android auto to work? I've installed versions you suggested but for the life of me I can't get wireless android auto to work!
I have a Pixel 2xl running Android 11....all stock.
Thanks heaps!
 

Top Liked Posts