Dasaita - Latest MCU and Updates for Rockchip PX5 Octa-Core 2G RAM 32GB

Search This thread

jlbooth

Senior Member
Feb 5, 2013
55
34
OnePlus 6T
Regarding the March PX6 Dasaita update. I installed it this evening and it comes with ZLink 4.0.17 and fixes one of the most annoying problems that I was experiencing before. The day/night theme finally defaults to day mode when headlights off and switches to dark mode only when headlights on. At least this is the case with my particular head unit. Previously the only way to get to day mode during the day was to switch headlights on and back off.

I got to looking and discovered Google Play updated the Android Auto app on my phone this morning so I'm not certain which actually fixed it. Phone update or headunit firmware. Regardless it's now working as I would like.
 
Last edited:
  • Like
Reactions: PoppaRoxie1986

ikerg

Senior Member
Dec 19, 2007
2,414
703
Would you mind to share that 4.0.17?
I have the 4.0.14 and I notice a erratic black & white screen on android auto.
In the same way I couldn't connect my galaxy s10+ (android 11) wirelessly

Any tips on both Issues?
 

Attachments

  • 20210415_130854.jpg
    20210415_130854.jpg
    436.4 KB · Views: 51

ikerg

Senior Member
Dec 19, 2007
2,414
703
This has been working since the Dec 2020 update.

I had to check the "wireless projection" in developer settings in Android Auto on the phone. Then had to unpair/re-pair the phone with Bluetooth. I have a OnePlus 6T with Android 10 and of course a PX6 SYGAV/DASAITA head unit also running Android 10.

It's counter intuitive that it sets up the wireless hotspot on the headunit but uses mobile data from the phone, but it works quite well.
Which are the steps for.wireless connection?
Tried it on 4.0.14 but no success.
I did check the "wireless projection option" on developer settings...when tried to connect wirelessly the Bluetooth option appears asking me to connect phone to unit (but already enabled/paired/connected to the unit)
Must wifi connection be established or the android auto does this step.automatically?
 

jlbooth

Senior Member
Feb 5, 2013
55
34
OnePlus 6T
I manually removed my phone Bluetooth pairing on both the head unit and on my phone. Then re- paired to the head unit. Upon bluetooth pairing ZLink configured and enabled the wifi hotspot on the head unit. The re-pairing seems to be the critical step.

Apparently ZLink must have provided the wifi password for the head unit hotspot to my phone perhaps via bluetooth maybe. I didn't have to do anything special to manually establish the wifi connection to the head unit hot spot.

Once it's setup like it should be you should see the Bluetooth icon at the top of the head unit screen and see the mobile hotspot icon next to it.

I may do an instructional how to with pictures and start a new thread here on XDA

You can apply the March update to your device without wiping data from the head unit. The Google drive link provided by @thienthanty in post #4018 above to download the March update was very fast.
 
Last edited:

Hoffy76

Member
Aug 15, 2017
10
0
I updated the MCU in my HA V600 unit but didn't backup my config. Never had to before. Now after update, my hard buttons down the side of the screen no longer work.
Is there any way to fix this? I've been searching for answers here for hours.
 

Guillermo h

Senior Member
Oct 21, 2018
64
1
53
Colombia
Would you mind to share that 4.0.17?
I have the 4.0.14 and I notice a erratic black & white screen on android auto.
In the same way I couldn't connect my galaxy s10+ (android 11) wirelessly

Any tips on both Issues?
Hello Ikerg, you must make sure in network configuration that the shared connection point is activated so that android auto works, otherwise it will not work; it happened to me with CarPlay.
 

jlbooth

Senior Member
Feb 5, 2013
55
34
OnePlus 6T
Edited my previous post here. Good luck @ikerg with 4.0.17. I wasn't for sure how I could get that apk and know if it would work. Did not want to risk adding an additional layer of complexity for you.
 
Last edited:

ikerg

Senior Member
Dec 19, 2007
2,414
703
Hello Ikerg, you must make sure in network configuration that the shared connection point is activated so that android auto works, otherwise it will not work; it happened to me with CarPlay.
Tries to repair again. I did enable wifi sharing on headunit and even changed password and network name to manually connect to unit.
Now I have both bluettoh and wifi connection to headunit simultaneously but zlink does not detect connection.
 

ikerg

Senior Member
Dec 19, 2007
2,414
703
Tries to repair again. I did enable wifi sharing on headunit and even changed password and network name to manually connect to unit.
Now I have both bluettoh and wifi connection to headunit simultaneously but zlink does not detect connection.
I think I am.gonna update to 4.0.17
 

Hoffy76

Member
Aug 15, 2017
10
0

Hoffy76

Member
Aug 15, 2017
10
0
Another question now. I was updating to hopefully solve an issue with Bluetooth dropping connection regularly but it doesn't seem to have helped.

The Bluetooth connection to my Samsung S9 phone seems very unreliable. It used to work flawlessly but now not. Sometimes it will connect and stay connected, other times it will continuously drop out and reconnect. Sometimes it will do this a few times and then stay connected, other times it will dropout and reconnect endlessly.

Anyone experienced this and give some suggestions.
 

ikerg

Senior Member
Dec 19, 2007
2,414
703
Another question now. I was updating to hopefully solve an issue with Bluetooth dropping connection regularly but it doesn't seem to have helped.

The Bluetooth connection to my Samsung S9 phone seems very unreliable. It used to work flawlessly but now not. Sometimes it will connect and stay connected, other times it will continuously drop out and reconnect. Sometimes it will do this a few times and then stay connected, other times it will dropout and reconnect endlessly.

Anyone experienced this and give some suggestions.
With my s10+ and my previous s8 I did not experience any bluetooth connection drops
 

ikerg

Senior Member
Dec 19, 2007
2,414
703
I am having trouble locating your link. Would love to try upgrading my Zlink on my head unit if apk is available. Thanks!
Strange...I did upload the file. Let me try again. (it was due to the size, i compressed the apk into a Zip file)
 

Attachments

  • ZLINK_4.0.17.zip
    8.2 MB · Views: 110

talrhv

Member
Mar 17, 2020
49
0
Hi, do any of you guys have a random disconnecting problem with zlink?
my wireless and wired carplay disconnects every couple of minutes and reconnects after a few seconds.

I tried everything I can think of.
thanks.
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone