• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Dasaita - Latest MCU and Updates for Rockchip PX5 Octa-Core 2G RAM 32GB

Search This thread

argwallace

Member
Mar 8, 2020
30
0
You will probably have to migrate to android 10, the exact same thing happened to me and with the last two OTA updates the problem was solved. With MTCE 3.71 I had already solved the problem but with the OTA update of 11032021 for PX6 MAX10, which guides me to define that you must update your Android version.
Greetings
Thanks for your reply. Is there an official way to do that? I would prefer not to modify the ROM and other hacks. I downloaded the official update for this version believing that would fix any bugs or issues. But it seems that now the update in itself is flawed since if it requires an update to Android 10 in order to work. A bit frustrating.
 
Aug 25, 2019
21
13
Munich
Hello,

i have updated my Dasaita MAX 6 PX6 4/64GB Android 9 to MCU 3.71d and PX6 HA2_rk3399_9.0_ota(20210301).

I noticed the "delay" button disappeard in the equalizer screen.

But what's really bad is that the "Music Player" app crashes every time i want to use it!!
The source makes no difference....

Any ideas??

Best regards

Martin
 

marchnz

Senior Member
Nov 26, 2012
3,591
716
wombleton
Hello,

i have updated my Dasaita MAX 6 PX6 4/64GB Android 9 to MCU 3.71d and PX6 HA2_rk3399_9.0_ota(20210301).

I noticed the "delay" button disappeard in the equalizer screen.

But what's really bad is that the "Music Player" app crashes every time i want to use it!!
The source makes no difference....

Any ideas??

Best regards

Martin

Go back to the version you were on?
 

argwallace

Member
Mar 8, 2020
30
0
Another issue I am experiencing on my MAX6 with the latest release is that whenever I turn off the vehicle and turn it back on later, it used to open up the last app I was on. now it just goes to the main Home Screen. I would like it to open CarPlay again when I had it open before turning off the car. Any thoughts? Also, to go to an earlier version, do we just install that update.zip or is there more to the process? Thanks for any help!
 
Aug 25, 2019
21
13
Munich
Another issue I am experiencing on my MAX6 with the latest release is that whenever I turn off the vehicle and turn it back on later, it used to open up the last app I was on. now it just goes to the main Home Screen. I would like it to open CarPlay again when I had it open before turning off the car. Any thoughts? Also, to go to an earlier version, do we just install that update.zip or is there more to the process? Thanks for any help!
......i don't have that issue - i use Radio & tomtom - working well
 

jlbooth

Senior Member
Feb 5, 2013
150
84
OnePlus 6T
@kilgil27 thank you for sharing. ZLink 4.0.21 broke wireless AA for me as well. Ended up reverting back. Thought about rooting so could just revert ZLink back to 4.0.17 but decided to just roll back whole update.

My phone (OnePlus 6T) would eventually say that Android Auto is available - continue on car screen (or something to that effect). Problem is that they didn't provide a way to start the phone projection from the ZLink app. I guess the XDA community are the software testers for ZLink. There's no way they tested wireless AA on 4.0.21 before release.
 
Last edited:

jlbooth

Senior Member
Feb 5, 2013
150
84
OnePlus 6T
I rolled back to the one found in this post:


It's the March update that contains ZLink 4.0.17.
HA3_rk3399_10.0_ota(20210311)
 
Last edited:
  • Like
Reactions: mafkikker

mafkikker

Member
Feb 25, 2007
9
0
I rolled back to the one found in this post:


It's the March update that contains ZLink 4.0.17.
HA3_rk3399_10.0_ota(20210311)
@jlbooth did you install mcu 3.75?
 

jlbooth

Senior Member
Feb 5, 2013
150
84
OnePlus 6T
@mafkikker I did not and my system is on 3.71. I wonder if there would be any benefit of updating to that MCU along with the latest ROM update? My biggest concern is whether it would help with the ZLink 4.0.21 wireless AA connectivity issues (have my doubts but....).

Android Auto app on my phone was updated to 6.4.611714-release. I tried again with ZLink 4.0.21 and still did not work wirelessly or wired. So I reverted the head unit back to the 20210311 version which includes 4.0.17 and still works with the latest AA update.
 
  • Like
Reactions: mafkikker

sisedan07

New member
Jun 27, 2011
3
0
Los Angeles, CA.
hi guys

I will share the latest link with MCU and updates here :)
MCU:
V2.40 https://drive.google.com/open?id=0B_wOizoYdqYQcUpEVDc0ZHVDaG8
MTCD
V2.59 https://www.sendspace.com/pro/dl/umwqaj
MTCE
V3.71d https://www.sendspace.com/pro/dl/bmo68b


Android 10 Update
MAX10 HA3_rk3399_10.0_ota(20210311) https://www.sendspace.com/pro/dl/9ewqy9
V10 HA3_px5_10.0_ota(20201019)https://www.sendspace.com/pro/dl/ybz2ke
S10 HCT7_px30_10.0_ota(20210419) https://www.sendspace.com/pro/dl/9me30v

Android 9.0 Update
MAX6 Version : PX6 HA2_rk3399_9.0_ota(20210301)https://www.sendspace.com/pro/dl/2j8qks
V940 Version : PX5 HA_px5_9.0_ota(20210420) https://www.sendspace.com/pro/dl/hc8fyd

S920 Version : PX30 HCT4_px30_9.0_ota(20200507) https://www.sendspace.com/pro/dl/io99ys


Carplay Dongle Autoplay APK : https://www.sendspace.com/pro/dl/adkfk1


V840-8 Version :8.0 SYSTEM Update
ha_px5_8.0_ota(20190731) https://www.sendspace.com/pro/dl/by788u

PX5_8.0_hct3_1_ota_20170108

Blue UI HA_PX5_8.0_ota(20181124) https://www.sendspace.com/pro/dl/yi64y9
Blue UI HA_PX5_8.0_ota(20181210)https://www.sendspace.com/pro/dl/q1fy9q
Blue UI HA_px5_8.0_ota(20190428)https://www.sendspace.com/pro/dl/gh6ygx

S720 Version :7.1 SYSTEM UPDATE


HCT2_px3_7.1(20180815)https://www.sendspace.com/pro/dl/xfrm2r
HCT2_px3_7.1(20181012) https://www.sendspace.com/pro/dl/c0bcpn
HCT2_px3_7.1(20181225) https://www.sendspace.com/pro/dl/6myzzw

V600 Version : 6.0 SYSTEM UPDATE
PX5_6.0 UPDATE (20170304)

PX5 6.0 UPDATE HA (20171214)
PX5 6.0 UPDATE HA (20180201)https://www.sendspace.com/pro/dl/efdbag

BMW K720-Series Update
PX3 7.1 https://www.sendspace.com/pro/dl/9l5zkf

BMW K820-Series Update
PX6 8.1 https://www.sendspace.com/pro/dl/4sc9t5

BMW K940
PX6 9.0 px6-9.0_2019121101T https://www.sendspace.com/pro/dl/v0wdfs

5.1 SYSTEM UPDATE
PX3 new4_rk3188_5.1(20170307) https://www.sendspace.com/pro/dl/agxhv8

Mirror link APP
PX3 5.1 easylink APP support 7.1 android phone https://www.sendspace.com/pro/dl/hshl83
PX5 6.0 easylink APP support 7.1 android phone https://www.sendspace.com/pro/dl/fgu9yr
Can anyone help? I updated the mcu and it won't take the system update. Keep seeing this after trying. I am on mcu 3.62_1 now. From 3.37_1. Any help please?
 

Attachments

  • 20210522_095553.jpg
    20210522_095553.jpg
    1 MB · Views: 67

kebo3473

Member
Sep 2, 2012
32
5
I don't think my question really goes here, but i figured I'd ask anyway because i didn't know where to go. I've updated my dasaita px6 radio to the HA3_rk3399_10.0_ota(20210311). I noticed even before the update that if I'm on a call and someone else calls, the incoming call is sent to voicemail. It pops up on my screen for a second then disappears. I have tried to find a solution to this, but have been unable to. I verified that do not disturb wasn't on as well. If anyone here has any suggestions or could direct me to another forum, I'd appreciate it. Thanks.
 

ruinertt

Senior Member
Apr 28, 2008
505
25
Georgia
I don't think my question really goes here, but i figured I'd ask anyway because i didn't know where to go. I've updated my dasaita px6 radio to the HA3_rk3399_10.0_ota(20210311). I noticed even before the update that if I'm on a call and someone else calls, the incoming call is sent to voicemail. It pops up on my screen for a second then disappears. I have tried to find a solution to this, but have been unable to. I verified that do not disturb wasn't on as well. If anyone here has any suggestions or could direct me to another forum, I'd appreciate it. Thanks.
I like easy answers! I had this problem as well. You need to go into the factory settings menu and turn on 3-way calling.

Settings --> Car --> Factory Settings --> Other
Three-way Calling field...toggle that to "yes"
 
Last edited:
  • Like
Reactions: kebo3473

kebo3473

Member
Sep 2, 2012
32
5
I like easy answers! I had this problem as well. You need to go into the factory settings menu and turn on 3-way calling.

Settings --> Car --> Factory Settings --> Other
Three-way Calling field...toggle that to "yes"
OMG!!! This has been killing me for months. I finally reached out to Dasaita, but they didn't answer. Thanks so much for your help. Cheers to you my friend🍻!!! I appreciate your help!!!
 

Top Liked Posts