• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Dasaita PX6 SD unmounted on every boot

Search This thread

Lum_UK

Senior Member
May 24, 2012
594
211
Bristol
dj.lum.uk
I've got a PX6 unit running the latest firmware from Dasaita: HA3_rk3399_10.0_ota(20210311). It's rooted but otherwise stock. I'm running Car Launcher Pro as my launcher, and Poweramp as my music player. My SD card is a Samsung Evo Plus 128GB formatted to FAT32.

After a warm boot, the SD card is not mounted, causing Poweramp to lose all its music. To get it back I have to physically eject the SD card and re-insert it, which is incredibly annoying at the start of every journey.

I have contacted Dasaita but have not yet received a reply.

Does anyone know how to fix this?
 

Knightbird68

Senior Member
May 27, 2010
132
8
Elyria, OH
I've got a PX6 unit running the latest firmware from Dasaita: HA3_rk3399_10.0_ota(20210311). It's rooted but otherwise stock. I'm running Car Launcher Pro as my launcher, and Poweramp as my music player. My SD card is a Samsung Evo Plus 128GB formatted to FAT32.

After a warm boot, the SD card is not mounted, causing Poweramp to lose all its music. To get it back I have to physically eject the SD card and re-insert it, which is incredibly annoying at the start of every journey.

I have contacted Dasaita but have not yet received a reply.

Does anyone know how to fix this?
I have the PX6 unit running the latest MCU, but only Android 9 ROM (none of the downloaded Android 10 ROMs seem to work) and I have a similar issue with my USB1 not being read always. But USB2 or 3 is always available Would love to know where you got a working ROM? The one from Dasaita website will not load.
 

marchnz

Senior Member
Nov 26, 2012
3,575
714
wombleton
I have the PX6 unit running the latest MCU, but only Android 9 ROM (none of the downloaded Android 10 ROMs seem to work) and I have a similar issue with my USB1 not being read always. But USB2 or 3 is always available Would love to know where you got a working ROM? The one from Dasaita website will not load.

You are not missing anything running Android 10.

The most stable working version I believe is 8, all versions post 8 are rushed ported bug fests.

Stop chasing a higher number.
 

jlbooth

Senior Member
Feb 5, 2013
146
83
OnePlus 6T
I've got a PX6 unit running the latest firmware from Dasaita: HA3_rk3399_10.0_ota(20210311). It's rooted but otherwise stock. I'm running Car Launcher Pro as my launcher, and Poweramp as my music player. My SD card is a Samsung Evo Plus 128GB formatted to FAT32.

After a warm boot, the SD card is not mounted, causing Poweramp to lose all its music. To get it back I have to physically eject the SD card and re-insert it, which is incredibly annoying at the start of every journey.

I have contacted Dasaita but have not yet received a reply.

Does anyone know how to fix this?
My suggestion is to copy the music (some or as much of it as you can get) from the SD card to the internal memory and set that folder as the primary folder for PowerAmp. These units seem to have more difficulty mounting SD cards, especially higher capacity ones.

I've had a little better luck with having fewer folders with more files than the other way round. By at least having some music files in the head unit storage, this should get PowerAmp playing music sooner and it should catalog the files on the SD as needed in the background once the SD card is mounted.
 

jlbooth

Senior Member
Feb 5, 2013
146
83
OnePlus 6T
I've been kind of torn between using the "warm boot/auto sleep" capability vs just having the head unit shut down every time. It seems the "auto sleep" function never brings the head unit back up the way it was when the car was turned off.

Since the cold boot time is so "short" (I use that word rather loosely here) it's probably just as well to let the unit shut down after n minutes/seconds. Like what's the use if the "fast warm boot" requires us to have to fiddle with stuff every time (e.g. popping SD card out/in, etc)?
 

Knightbird68

Senior Member
May 27, 2010
132
8
Elyria, OH
You are not missing anything running Android 10.

The most stable working version I believe is 8, all versions post 8 are rushed ported bug fests.

Stop chasing a higher number.
I appreciate your input! I am not "chasing a higher number", I am just trying to realize the features that were supposed to be in the product I purchased, such as split screens, 1280x1024 resolution and Android 10. Instead I got 1024x600 and Android 9 and very unstable. Navigation link fails to launch Wayze or Google Maps, VLC cannot display any video , they play but there is no video (audio sounds great) and an awful looking radio app.

I hear great things about the stability of the PX6 Android 9 version rk3399-userdebug 9 PQ2A.190305.002 20191210.152625 test keys. Supposed to be VERY stable and fast. Anyone have this version?
 
  • Like
Reactions: marchnz

marchnz

Senior Member
Nov 26, 2012
3,575
714
wombleton
I appreciate your input! I am not "chasing a higher number", I am just trying to realize the features that were supposed to be in the product I purchased, such as split screens, 1280x1024 resolution and Android 10. Instead I got 1024x600 and Android 9 and very unstable. Navigation link fails to launch Wayze or Google Maps, VLC cannot display any video , they play but there is no video (audio sounds great) and an awful looking radio app.

I hear great things about the stability of the PX6 Android 9 version rk3399-userdebug 9 PQ2A.190305.002 20191210.152625 test keys. Supposed to be VERY stable and fast. Anyone have this version?
No option to send it back/warranty/product not as advertised?
 

Knightbird68

Senior Member
May 27, 2010
132
8
Elyria, OH
No option to send it back/warranty/product not as advertised?
Sadly was an eBay purchase that was "NEW IN BOX", but according to the stickers was an Amazon return.. All packing was perfect, I suspect that the purchaser got the wrong unit for his A/C controls.
Dasaita model is HA-5226-MAX6-CP, also shows X002F1YJQ9.

Instructions were clear, all components were still factory packaged, I just want a stable usable preferably factory (unmodified) ROM.
And I'd be happy if I could find a stable A9 ROM. Two weeks of searching and enough is enough.
 

Lum_UK

Senior Member
May 24, 2012
594
211
Bristol
dj.lum.uk
Mine came with 10, I just updated it to a slightly newer version. Was really hoping not to use internal memory as its a pain copying stuff over when you want to chop & change music around, vs just bringing the car inside and doing it on the computer, especially as updates tend to wipe the internal memory, or require a factory reset (which doesn't preserve userdata on these units)

Will try the cold boot and see if I can live with that, otherwise it may be back to Malaysk ROM (which worked great on my PX5). Anyone know if the issue is resolved on that ROM?

I'm also annoyed that it was sold as supporting bluetooth tethering, but does not actually do so, but turning that option on is what killed my PX5, so I'm reluctant to mess with that.
 

Lum_UK

Senior Member
May 24, 2012
594
211
Bristol
dj.lum.uk
Just seen that a new firmware is out, so might try that.

UPDATE2: Ignore below. Firmware update didn't fix it.

UPDATE:
Firmware HA3_rk3399_10.0_ota(20210507)升级包 seems to have solved it, and also solved the issue where Car Launcher wasn't updating track names and album art reliably.

I'll confirm tomorrow when the radio has had more time to idle, but I think this is the fix!

As a bonus, I was able to dirty flash without issue. Had to re-root but that's to be expected.

I first updated the MCU to 3.75B and that did not fix it, so an MCU update probably isn't necessary.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    You are not missing anything running Android 10.

    The most stable working version I believe is 8, all versions post 8 are rushed ported bug fests.

    Stop chasing a higher number.
    I appreciate your input! I am not "chasing a higher number", I am just trying to realize the features that were supposed to be in the product I purchased, such as split screens, 1280x1024 resolution and Android 10. Instead I got 1024x600 and Android 9 and very unstable. Navigation link fails to launch Wayze or Google Maps, VLC cannot display any video , they play but there is no video (audio sounds great) and an awful looking radio app.

    I hear great things about the stability of the PX6 Android 9 version rk3399-userdebug 9 PQ2A.190305.002 20191210.152625 test keys. Supposed to be VERY stable and fast. Anyone have this version?