• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[DEAD][MOD][ICS] Google Now for ICS -Updated for Multi-Language (4 Feb 13) [DEAD]

Search This thread


Senior Member
Jul 31, 2010
Princeton, NJ
I tried installing it exactly how it says in the instructions but it does not work. I still get the stock ICS search UI. Anyone have an idea of what is wrong? I am running AOKP on my SGSII i777

EDIT: nvm, it worked. Simply renaming the old GoogleQuickSearchBox.apk to something else and then pasting the new one does not work. I had to move the old apk out of the app folder completely.


Senior Member
Oct 26, 2010
Stock/Leak .211 ICS 4.0.4 on XT912 RAZR

Followed the instructions to install that included changing the permissions, and cards are working, only thing obviously is the voice. Just thought you might like to know it works on MOTO/VZW bloated as much as AOSP ROM's



Senior Member
Feb 5, 2012
In theory it should provide custom information depending what you're doing or where you are. But I can't see any of this here, and I find it far more useful than voice search.

Any ideas?


Senior Member
Jul 2, 2011
About the sample cards. Are they all beta because I like to add my favorite team on Google Now.

Sent from my DROIDX using xda app-developers app


Senior Member
Jan 28, 2012
The land of no-iPhones
Woah, this thread blew up!
Wow, well this is weirs, the OP hasn't paid attention and BAM there we go, big discussion and all. I followed the directions in post #142 and I have a question.....

-does this work on tablets? I installed it on my rooted Nook Tablet running CM9 and even though I press the voice search on the home screen it just does the normal voice search.

Please help an OP put and explain to me wtf is going on!?!?

Sent from my NookTablet using XDA Premium HD app


Jan 12, 2012
Will this work without root? Are there plans for that? I have a non-rooted Razr Maxx that I would love to have this on.


Senior Member
Apr 4, 2012
Samsung Galaxy SII T989
AOKP Build 40 (eugene's fix)

Installed it as per the instructions on page 15, rebooted, but when I try to ask it a question it goes to "Initializing" then I get the message "Didn't catch that. Try speaking again." and when I click "Retry" it does the same thing.


Senior Member
Aug 10, 2010
Samsung Galaxy SII T989
AOKP Build 40 (eugene's fix)

Installed it as per the instructions on page 15, rebooted, but when I try to ask it a question it goes to "Initializing" then I get the message "Didn't catch that. Try speaking again." and when I click "Retry" it does the same thing.

Voice search doesn't work yet.

Sent from my DROID RAZR using Tapatalk 2


Senior Member
Feb 1, 2012
Samsung Galaxy SII T989
AOKP Build 40 (eugene's fix)

Installed it as per the instructions on page 15, rebooted, but when I try to ask it a question it goes to "Initializing" then I get the message "Didn't catch that. Try speaking again." and when I click "Retry" it does the same thing.


The complete and utter laziness in this thread is disgusting. Read the thread so the people trying to figure this out for you don't have deal with all this crap.

Also; voice will probably never work as apparently it is kernel level tweaks. You don't have a JB kernel, so it will not run.


Senior Member
Apr 4, 2012

The complete and utter laziness in this thread is disgusting. Read the thread so the people trying to figure this out for you don't have deal with all this crap.

Also; voice will probably never work as apparently it is kernel level tweaks. You don't have a JB kernel, so it will not run.

Calm down little boy. When it was mentioned that voice wasn't working I thought people meant the female voice speaking the answers. I didn't see much use in a voice search app where you have to type the questions, so I never thought that was the "voice" part that was broken.

Top Liked Posts

  • There are no posts matching your filters.
  • 540
    Google Now flashable zips with Noob-friendly instructions

    Head to the first post for any updates.
    This is the original Google Now version without sport team adding or stocks. This will not be updated any further. Use a Jellybean ROM if you want to see the updated features. Do not ask about updates. If you do not read these posts and ask a question which has already been answered, you will be mocked.

    Read through the entire first and second post before asking a question. By clicking the "Show Content" button below, you agree that you forfeit any right to get upset when someone makes fun of you for posting a question that has been covered. We will work tirelessly to help you solve issues when you have them. All that's asked of you in return is to at least attempt to solve them yourself by reading these first two posts.

    The JellyBean update for Google Now, which includes manually adding sports teams, has not yet been ported. Please refrain from asking about this update, since all we're going to do is give you a silly answer to match the silly question.

    • Follow the simple instructions here.
    • You must be on Ice Cream Sandwich.
    • You MUST be rooted
    • You must be on a deodexed ROM. If you aren't sure, ask your chef.
    • You should be running a custom recovery like ClockWorkMod Recovery (CWM) or Team Win Recovery Project (TWRP). I use CWM, so this guide is based on that.
    • WVGA resolution or higher. (480 x 800)
    • Your device must be using ARMv6 or v7 CPU architecture. If you aren't sure what that is, check this thread.
    • You must have a file explorer that has root permissions. I use ES File Explorer, so this guide is based on that.
    • You need at least 60MB of system space for the full offline installation. (30MB for online only version) If you don't know how to check, simply download Titanium Backup from the market. It tells you right on the main screen. (pic)


    1. Download whichever file you want and flash it in recovery. Always be sure to make a backup just in case.
    2. File descriptions:
      • Online only zip is for those of you who need to save /system space. It removes the offline voice files, so that offline voice dictation does not work. You must always have some sort of data connection for this type of zip.
      • Offline/Online zip is for those with no /system space restrictions. It contains the full Google Now package with offline voice dictation.
      • Update zip is for those who already have a version of GN installed. All it does is change your version to the one your choose without having to download a big file. If you are already on an Offline version, it will update you to the Offline version of whichever you choose. Same goes for Online versions and manual installations.
      • APK only is for those who have already flashed a zip. You may simply push the new apk to /system/app (overwrite or remove the previous version), set permissions to rw-r-r (0644), and reboot to enjoy the latest version of Google Now. DO NOT TRY TO INSTALL THE APK BY ITSELF.

    If you aren't sure which one to use, or if this is too much information or is otherwise overwhelming for you, just flash the L4 version - Offline/Online, since it's the latest. Be sure to scroll down a bit and read about it, though.

    Before doing anything, you need to make sure you have at least 60MB of free space on your /system partition for Offline/Online files and 30MB of free /system space for Online Only files. The L4 Full Zip only requires 20MB of free space.​

    Easy installation:

    reekotubbs created an installer/restorer that can be used to easily pick which zip you want. It also backs up relevant files for you in case you want to restore later. The thread link is below. Please ask any questions regarding this installer in his thread. [APP][4.0] Google Now for ICS Installer/Restorer [flashable Aroma Zip]

    Alternately, if you aren't sure which recovery you're using, or your recovery messed up a flash, try out reekotubbs' app. It does the same thing as his aroma zip linked above, but it works through a standard Android app available for download on the Amazon app store and slide me market. As before, please ask questions about this app in his thread. GNow Handlebars

    Flashable ZIPs

    As per the new XDA rule on sharing, I am requesting that these zips not be shared elsewhere. I can't troubleshoot issues outside this thread, so please direct people here instead of redistributing the zips.


    How to:

    • Move the file you picked to the root of your SD card. Don't put it in any folder. This just makes it easier to find.
    • Reboot your device into recovery. See your device's specific instructions on how to do this if you are not sure. Google it for a faster answer.
    • Backup your current ROM.
    • In CWM, navigate to "Install zip from SD" and select that.
    • Next, highlight "Choose zip from SD card" and select it.
    • Scroll down to the Google Now zip you loaded onto your SD card, then select it.
    • Scroll down and select the option that says "Yes - Install Google Now....zip"
    • Once it has flashed, go back to the main CWM menu and select "Reboot system now".
    • Launch Google Now by opening your App Drawer and selecting the Google Icon (pic), or by adding the Google Search Widget (pic) to your home screen, then doing a normal search. (pic)
    • Go into the settings menu for Google Now and set it up for your Google account and various other settings.

    Manual Installation:

    Some Recoveries do not do a good job of retaining the permissions being set by the zips. Some don't even properly flash the files. If you aren't using CWM or TWR or it seems as though Google Now hasn't been flashed properly, then please follow these steps to manually install everything.

    • Download the Google Now zip of your choice from above and extract the /system folder into your SD card.
    • Fire up ES File Explorer (or whichever one you feel like using).
      1. If you haven't used ES File Explorer before, open it, then hit menu.
      2. Tap settings, then scroll all the way down.
      3. Tap the entry that says "Root Settings" and make sure everything in there is checked.(pic).
      4. Allow root access when the dialogue box for Superuser pops up.
      5. After that, check off "Mount file system", then back out of the menu.
    • Navigate to the SD card with the Google Now /system folder.
    • Long press on the /system folder and select "Copy" from the menu.
    • Navigate up to the root directory and then press the "Paste" button on your menu bar at the top. (pic)
    • It will ask if you want to overwrite the files. Tell it yes.
    • Delete GoogleQuickSearchBox.apk from /system/app or rename it to "GoogleQuickSearchBox.apk.bak"
    • Now we need to set permissions.
      1. Move into /system/app and scroll down to find GoogleTTS.apk.
      2. Long press GoogleTTS.apk and select "Properties".
      3. Change the permissions to rw-r-r. (pic)
      4. Scroll down and find Velvet.apk.
      5. Long press Velvet.apk and select "Properties".
      6. Change the permissions to rw-r-r. (pic)
      7. Navigate to /system/usr/srec/ and find two folders named "config" and "en-US"
      8. Tap and hold on the "config" folder icon to bring up the options menu, then scroll down to Properties.
      9. Tap properties, then tap change and see if the check boxes match this picture.
      10. If it matches, leave it alone and head back to your home screen to enjoy using Google Now! If it doesn't match, change it so it does.
      11. Do the same thing for the "en-US" folder.
    • Launch Google Now by opening your App Drawer and selecting the Google Icon (pic), or by adding the Google Search Widget (pic) to your home screen, then doing a normal search. (pic)
    • Go into the settings menu for Google Now and set it up for your Google account and various other settings.


    ARMv7 zips do not work on ARMv6 devices. If your device is ARMv6, then unfortunately, you won't receive the latest and greates Google Now updates, but you can still try it out until you get a Jellybean ROM for your device. The voice search still does not work for ARMv6. There is a workaround for it, though.

    The Easy Way:
    The Hard Way:
    1. Back up your current ROM.
    2. Using your favorite file explorer, navigate to system/app and rename GoogleQuickSearchBox.apk to GoogleQuickSearchBox.bak. This is now your backup file.
    3. Download this file, and rename it to "GoogleQuickSearchBox.apk"
    4. Move this file to your SD card if you downloaded it from your PC. Move it to /system/app using your favorite root file explorer.
    5. Set the permissions to rw-r-r
    6. Reboot and enjoy
    7. If you want to use the voice search workaround, visit this thread and install the apk.

    Now What?

    1. So, you flashed Google Now. You're wondering what you can do with it, right? Well, thankfully, Killer-B has a handy little guide to get you up to speed on all the cool stuff Google Now can do as well as how to do it!
      Commands & Now Cards For Google Now!!! Now Video, and custom widget
    2. At this point, I'd suggest looking through your contact list for people with unusual, or difficult to pronounce names. Go into their contact card, and add in a nickname for them of their phonetically spelled name. Google Now has trouble parsing these unusual names, and there isn't a way to make it learn. Spelling the names like they sound allows you to send texts and place calls via Google Now without any voice issues.
    3. Open up the red mic screen and "Do a barrel roll."


    If you are having an issue with Google Now, please read this and the second post to see if it's been addressed already. Failing to do this will result in someone making fun of your inability to properly read. You have been warned.

    1. The red mic screen won't display.
      • To fix this, press the normal mic within the Google Now app. While it is listening (after it beeps), press menu > refresh. Now you're at the red mic.
    2. Google Now Force Closes.
      • Make sure you have enough space on your /system partition before installing this. You need at least 60MB free for the Offline versions and 30MB free for the Online versions.
        About the permission denied fc, I'm guessing the users with the issue have an old gmail? Try updating or using tsjoklats patched one and the note to self fc will go away. See what logs do?

        Oh and just to explain, the old gmail allows stuff based on signature, so as this apk is resigned it will not be allowed. The new.gmail marks it as.dangerous and will create a.notification for you to allow permission, or the patched one marks it as normal and allows it silently.
    3. My phone gets worse battery life or uses more data.
      • Read this post by Racer Of All and follow the directions using apktool. This is for advanced users running a Sense 4.0 ROM only. Sense 4.1 and higher is unsupported.
    4. Sports cards aren't showing up.
      • It won't add teams that aren't in regular season. To add new teams, simply do a search for them. You can also backup your ICS ROM with a nandroid, flash a Jellybean ROM, manually add teams after updating apps through the market, and then restore the ICS nandroid.
    5. My Galaxy SIII just received the new update which blocks local search, and Google Now won't work properly.
      • This following post only applies currently to the stock rooted LH2 rom for the Galaxy S III TMO and Google Now installation.

        The Samsung Kies update that removed the universal search function won't allow this to install via regular methods.

        All files are on the device with the correct permissions except because of the different search apk (GoogleQuickSearchBox_USA.apk) the method mentioned in the OP won't work until you delete the _USA part of the file and then reboot into recovery and reflash following the OP instructions.
    6. I can't open any search links!
      • This is a quirk in the later apks. You may need to hit the little magnifying glass icon next to the search link. This will allow you to open those links properly.
    7. My phone exploded.
      • Have a muffin.

    Have a question?

    Please read this entire post and post #2 for solved problems before you post or you will be mocked. If your question has not been covered in either post, please feel free to describe your problem for us to help you. Here is the proper way to ask for help. Make sure to list the following things:
    • apk/zip FULL file name
    • Android version number
    • ROM
    • Recovery
    • UI (Sense/TW/AOKP/CM/AOSP)
    • /system size and free MB (example: 300MB/60MB) - Since some people don't understand this bit, just post a screenshot of the home screen of Titanium Backup.
    • LOGCAT or GTFO
    Only after you list these things should you describe in excruciating detail what your problem is. Don't report anything that's already mentioned as not working or we'll just have a hearty laugh at your expense. :)

    Back to stock:

    If, for some reason, you want to remove Google Now and return to how you were before, flash the following zip. It removes all Google Now files, and returns the original Google Search app and voice files, as well as sets permissions for the Search app. Make sure to uninstall talkback and then reinstall it once you reboot to get voice search working again.

    If you have a question, make sure you've read through the first two posts. If you don't, we will make fun of you.

    Please don't thank me. Find one of these guys' posts and thank them. They made it happen, not me.
    reekotubbs, MikeyXda, and Lenny_kano for creating the hacked GN for ICS
    homeslice976 for taking on the FAQ
    Killer-B for an awesome write up of the cards and commands of GN
    slickdaddy96, SinisterChedda, Kameirus, mf2112, jdcasino, Captain_Throwback, xCovErtWolFx757, UndeadSquirrel, and Naddict for troubleshooting, work-arounds, bug reports leading to fixes, and/or just making me laugh
    silentstormer for handling the original OP
    paxChristos for being our trusty mod
    - If I missed you, let me know.

    Disclaimer: I am in no way responsible for the well being of your cool gadget. By using any piece of software provided here, you are agreeing that all risks fall on you and you alone. If you do not agree to this, then exercise your God-given right to not flash this. Please press CTRL+F4 or the back button to leave this thread. Also, if you ask a stupid question, or one which has already been answered, you are also held responsible for the verbal fodder you post. You will be mocked severely. I, nor anyone else posting in this thread, is to be held accountable for your actions, wording, or ensuing butthurt. Please exercise caution before posting. Read until your eyes hurt, then search until your fingernails fall off. If your question has not been previously addressed, it will be handled as quickly as possible.
    Now Cards & Commands (updated 8/3)

    I really like the cards and I want G-Now to give me updates

    So I played around with it:
    Here are some commands that will bring up those cards


    Now cards will update automatically based on your location, and search.
    "Now Cards" are the ones that show at all times when you open Google Now, like the ones shown in the picture above.(blue)

    Using Google Chrome at home? Sign in with your Gmail and things you have search on your computer will update on the Google Now Cards, COOL RIGHT!:D:D:D

    Google Apps that update the NOW Cards
    -Google Maps
    +Search a city on Maps and get direction and Google Now will update your traffic to the searched location.
    + Search a Place on Maps and get direction and Google Now will update the traffic to that location and it will tell you how far you to that place.

    *If you want it to give traffic information from home to work make sure your home and work location is set on latitude, it will update it self and give you traffic information from where ever you are at. (Now Card)
    -Navigate to_______.
    -Directions to ______.
    -Take me to _______.

    -Stock price of ______.

    *A Now card will appear of a flight you've searched for.(Now Card)
    -Flight name + flight number (ex. "Delta Air Lines flight 4183")

    * It will read your calendar and post it on G-Now, if you don’t want it to, just go to setting and change it(Now Card)
    **also appointments with a certain destination will show up on the Now card and it will give traffic information to your appointment's destination.*Furthermore, It will notify you when you should leave so you can be able to make it to your destination on time. :D(Now Card)
    -Note to self:_______
    - Set Alarm for________
    -Remind me to________ in 2 hours

    now with the latest .apk your weather will be in the notification bar
    *Weather will update by itself on G-Now based on your location. (Now Card)
    -What's the weather like
    - What's the weather like in__________
    -Will I need a jacket today?
    -What is the weather (today/ tomorrow/ specific day) in (location)?
    -Do I need an umbrella (today/ tomorrow/ specific day)?

    *A now card will display the places you have searched when traveling so you can find your best restaurant near by.(Now Card)
    -call + (places name)
    - map of (places name)
    - (place name) near by

    For You
    -Call + (contacts name)
    -Text + (contacts name) + (message)
    -Send email to (contact name)(,)(message)

    -Play (artist name)
    -Play (songs title)

    *Based on what teams you search, Google Now will give a Now card of the scores of those teams to keep you updated. (Now Card)
    -Score for (teams name)
    -When is the next (teams name) game
    -How are the (team) doing
    -Did the (team) win

    -______Percent or % of _____. (ex. Bill Tip fpr 15%. Type "15% of 84.51" it will answer 12.68)
    - 9 x 9
    - 10 + 117
    -How many inches are in ___ feet
    - ask it whatever simple math problem I guess

    *If travel to a place with a differnt currency, a Now Card will automatically display the exchange rate for you.(Now Card)
    -Amount + current currency name + (currency name) - for ex. (100 dollars in euro)
    -What is the currency of (country)

    Question and Holidays
    -Who is the current president of the US
    -When is (holiday) in (what year)
    -Whats the capital of _____
    - How old is_______ (almost anything)
    - how tall is_______ (person or building, etc.)
    -How much does (famous person) weigh?
    -When does (season{spring,ect}) start?
    -What time zone is (state/country) in?

    *If you travel to a different timezone a now card will display the current time now(Now Card)
    -Today's date?
    -What time is it?
    -What time is it in (location)?
    -When is sunrise/sunset in (location)?
    -What timezone is (location) in?

    Image Search
    -Pictures of_____
    -What does_______ look like

    *A Now card will display the translation lanugaue for you when you travel to a diffent country with a diffent language, so you can be able to understand what other people are saying about you :p :)(Now Card)
    -Definition of__________
    -What does_________ mean.
    -What is the National Anthem of (country)
    -What is the capital of (state or country)
    -What language is spoken in ?
    -What is the state bird of (state)?

    Movies or Shows
    - Cast of______(movie or shows name)
    -Run time of (movie or shows name)
    -When is the release date for (name of movie)
    -Director of (movie or shows name)
    -What movies has (actor's name) started in

    public transit
    -I live in a small town so I have my own car, I was told it will update automatically based on your location.

    For Fun
    - Do a barrel roll
    - What's the answer to life the universe and everything
    - I'm hungry

    -Open (website's name + .com or .net)
    -Browse to (website's name)

    These commands and cards are confirmed to work in the US

    1. Is my device ARMv6 or ARMv7?
    Generally, new devices are ARMv7, older are ARMv6. There are lists all over the web. Here’s one:

    2. Will this work on my device?
    There have been reports of multiple devices and UI’s working. The only way to know for sure is to flash it and find out. MAKE A NANDROID BACKUP FIRST. This way, if something goes wrong, you have a way back.

    2a. Will this work on a stock/odexed ROM?
    Again, there have been some successful reports of this working on odexed roms..but YMMV - so backup first.

    3. Do I have to use CWM Recovery, or will other recoveries work?
    CWM is the only recovery that’s been thoroughly tested, though there have been reports of TWRP, EXT4, and others working as well.

    4. I'm getting a notification that there is a new version available, but when I try to install it, I'm told my device isn't compatible?
    Well, that's because you're trying to install an official JB app on an ICS device. That's not going to work. This is a hacked version, made to be compatible with ICS. Simply swiping away the card will get rid of the update notification. There is no new version for ICS. Please do not ask for it as it's been asked for multiple times. If someone is able to hack the newer version, the OP will be updated. Til then, be happy with what you have.

    5. Google Now is force closing on my device, why?
    Could be a few reasons. First, make sure you have at least 60MB free space on your /system/ partition (for offline) or 30MB free space (for online). Then check permissions as specified in cajunflavoredbob’s post (http://forum.xda-developers.com/showpost.php?p=29756226&postcount=2856) (RW/R/R for .apk and lib files, RWX/RX/RX for folders). If this doesn’t work, try clearing data and cache from Google Search, Force Quit Google Search, and reboot. Also, make sure you only have 1 active Velvet.apk in /system/app/ at a time

    6. Voice search isn’t working, but other functionality seems OK, what’s up?
    You may have installed a standalone Velvet.apk, rather than flashing a .zip from cajunflavoredbob’s post. The flashable .zip packages contain libs and other resources that are necessary for Voice search to work. Once you’ve flashed one of these .zip packages, all you need to do in the future is replace Velvet.apk in /system/app/ with the newly released .apk, change permissions to RW/R/R, and reboot. Though, if you prefer, flashing the new .zip on top of the old one won’t hurt. Just make sure you don’t have multiple Velvet.apk files in /system/app/ at any given time. Alternatively, try the response to the last FAQ (google now remover). Also, make sure you have enough freespace in /system/app/

    7. When I try to make a Note to self or send an email from Now, it doesn’t actually send, or it force closes or gives another error..., what gives?
    Since Velvet.apk has been resigned (not with Google’s key,) it doesn’t pass GMail’s authentication check. Here (http://forum.xda-developers.com/showthread.php?t=1199518) is a patched GMail application that will skip/trick the signature check, and allow Now to access it.

    7a. When sending a Note to self, it gives me an error about the Audio File not being attached?
    Some users on some devices/ROMs have reported this problem. The email will still send, but the Audio attachment (the voice note) will not come along with it. Sorry.

    8. Why can’t I back out of the Google Now Cards page?
    This is currently a known issue. In the mean time, after pressing your Back key on the Cards page, press Menu then Refresh, and it will back out of the app properly.

    9. My persistent search bar says “Google” where the microphone icon used to be?
    This is a known issue. You’ll need to ditch the persistent search bar, and add the Google Search widget for the time being.

    10. I flashed the .zip, but nothing happened, I don’t see Google Now ANYWHERE?
    Just because you don’t see “Google Now” as an available app doesn’t mean it didn’t work. Open the “Google” app or add the “Google Search” widget. These will launch Google Now

    If it's really not there, your recovery probably isn't playing nicely with the flashable .zips, in which case follow the Manual Installation instructions in the OP

    11. I can’t add calendar entries via Google Now?
    This seems to be an issue, but here’s a work around that should work. Google has a feature where you can text a number to add stuff to your calendar. First, you need to setup your Phone as a registered device. Go to www.google.com/calendar, and go to Calendar Settings. Click the Mobile Setup tab, enter your number, choose your carrier (not necessary), and click Send Verification code. Enter the verification code that you get via text, click Finish Setup. Now click Save and we're halfway there.

    Now create a new contact on your phone called Calendar, and make the primary number 48368 (which is GVENT). Now you can use Google Now to "Text Calendar Lunch with Mom at Applebee's 1pm on Saturday". The event will be created on your calendar. Doing it this way, you will receive a confirmation text that the event was added as well. Don't know if that's a good thing or a bad thing, but either way, still cool....

    12. Why won't NFL Teams show up?
    It looks like NFL teams are slowly rolling out. There have been a number of reports of users with m7 getting Football teams (myself included). Also, if you have access to a JB ROM, you can login to now on JB, manually add the football team, go back to your ICS ROM, and the team will still be there. Unfortunately in our version it's still a baseball icon for football :)

    12a. Why can't I manually add sports teams?
    AS PER THE OP: The JellyBean update for Google Now, which includes manually adding sports teams, has not yet been ported. Please refrain from asking about this update, since all we're going to do is give you a silly answer to match the silly question.

    13. Voice seems to be working, but when responding, Now is cutting off the last word of the response?
    Thanks to XDA user educ for finding this - I can’t confirm first hand it works but it looks promising and he said it worked for him - http://forum.xda-developers.com/showthread.php?t=1780585

    14. I installed the “Offline” version, but Now won’t respond to my questions when I don’t have internet connection?
    cajunflavoredbob addressed this best - “‘Offline’ means that offline message dictation works. Perhaps that should be made more clear in the op, but even the noobiest should realise that searching the Internet does in fact require the Internet. The offline version doesn't magically cache the whole google network.”

    15. Double tapping the home key no longer launches S-Voice?
    Install Home2Shortcut - Thanks to ilkevinli for the setup instructions:

    “Home2 Shortcut does work. Your just not setting it up right.

    1. Go into S-Voice settings and uncheck the "Lauch S Voice by double pressing ..."
    2. Lauch Home2 Shortcut
    3. In Step 1, choose S Voice
    4. In Step 2, choose what you like
    5. In Step 3, choose TouchWiz Home
    6. In Step 4, hit close

    Now when you double click the home button, choose Home2 Shortcut

    Have fun.”

    16. How can I get the “Swipe Up” gesture to launch Google Now?
    Some launchers don’t support this. Two that have been confirmed to work are Holo Launcher and Nova Launcher. You can set the Swipe Up action to launch the “Google” app in Holo, and “Assigning swipe up to Nova setting Voice works AMAZING!!!” (Thanks crutzulee). Other launchers may support this, Sense (Rosie) doesn’t. Let me know about any more confirmed working or not working launchers, stock or otherwise (homeslice976 on xda)

    APEX Launcher also works "The "swipe up" gesture works well with these steps: menu>Apex settings>behavior settings>select "swipe up">select "launch app">select "Google">"OK">home. Works great, launches reliably." - @gershomww Thank!

    17. After installing this, when pressing the button on my BT headset, it launches the crappy ICS Voice Dialer, can I change this to Google Search?
    We've come across 2 ways to accomplish this, however, once you default it to the Google Now Voice Search, it won't listen through the headset, or play Now's audio through the headset, this will all be done via the speaker and mic on the device. But at least it will launch Now Search, and as long as the phone is close to you, your mic should pick you up (Now's voice recognition seems to be awesome). Anyone smart enough to figure out how Voice Dialer can listen through the headset and play it's audio through the headset and can apply it to Velvet?

    Method 1: Install Bluetooth Launch from the Market. Move Velvet.apk from /system/app/ to /data/app/ and reboot. Setup Bluetooth Launch to launch Google Search/com.google.android.googlequicksearchbox.VoiceSearchActivity. A few users have reported this working for them (though you may need to setup Google Now again).

    If after moving Velvet.apk to /data/app/ and rebooting you no longer have Google Search anywhere (app, widget, etc), or if this for some other reason doesn't work, move Velvet.apk back to /system/app/, reboot, and verify Now is working again. Then do this:

    Method 2: Uninstall Bluetooth Launch from your phone and reboot. Ensure it's still uninstalled, and no longer in /data/app/ (com.kin.bluetooth_launch-1.apk). Place this (waiting for permission from Bluetooth Launch's dev, Guardian Bob, before sharing publicly. In the meantime, shoot me a PM) modified Bluetooth Launch apk in /system/app/, set permissions to RW/R/R, and install it. Once installed, open the app and set it to launch Google Search/com.google.android.googlequicksearchbox.VoiceSearchActivity, then reboot. Now your BT button on your headset should launch Google Now.

    18. Google Now seems to have installed properly, and is working, but everytime I open Google Now I have to go through the setup process where I tell it "I'm in", why?
    A couple users have reported this issue, and said that by simply flashing the uninstall .zip, then reflashing the mod, it began working properly

    19. Other weird issues? Still having trouble and don’t know what to do?
    Try flashing the Google Now Remover (http://www.mediafire.com/?whihy17x6q8l31f) and then try flashing the Google Now flashable .zip of your choice and see what happens.
    can you guys with the network error try this one (and log if possible)

    push it to /system/app and replace the old one velvet apk if there's any.

    looks like a google account issue to me ??
    are you properly logged in etc. on other google services?

    I just replaced the Original one and it worked perfect first go :)
    No APK file removed or anything.


    For other people, Use the link above.

    1, Rename the APK to GoogleQuickSearchBox.apk
    2, Go to System/App and rename the original GoogleQuickSearchBox.apk to 3, something else (Or delete it)
    4, Copy in the GoogleQuickSearchBox.apk the one you renamed from (Velvet-theos0o.apk)
    5, Set the permissions, to the /System/App/GoogleQuickSearchBox.apk to RW-R--R--
    6, Reboot and it should work