[DEPRECATED] Greenify4Magisk [v4.5.1]

Status
Not open for further replies.
Search This thread

Rom

Senior Member
Jul 1, 2013
2,517
1,043
Lyon
Wrong zip

Updated to 3.8.5

Cheers.
Hello :)
I have just tried to flash via Magisk Manager your last zip (3.8.5) and its display me an flash install error on Magisk v14, i have extract and build the zip again with Root Browser Classic and trying again its has works fine so i think you have choose an wrong compression level or another wrong things in your compression process.
 

zsandras

Senior Member
Nov 14, 2007
712
136
BUjfalu
Hello :)
I have just tried to flash via Magisk Manager your last zip (3.8.5) and its display me an flash install error on Magisk v14, i have extract and build the zip again with Root Browser Classic and trying again its has works fine so i think you have choose an wrong compression level or another wrong things in your compression process.
Same install error with Magisk v14.2, went back to the previous version Greenidy4Magisl v3.8.3 and no problem at all.
 

abacate123

Senior Member
Feb 22, 2015
1,266
1,800
Hello :)
I have just tried to flash via Magisk Manager your last zip (3.8.5) and its display me an flash install error on Magisk v14, i have extract and build the zip again with Root Browser Classic and trying again its has works fine so i think you have choose an wrong compression level or another wrong things in your compression process.

No errors here fellow. Flashed through manager and twrp. I usually test the updates before publish them. Are you trying to flash the manager one or the afh one?
 
Last edited:

Rom

Senior Member
Jul 1, 2013
2,517
1,043
Lyon
No errors here fellow. Flashed through manager and twrp. I usually test the updates before publish them. Are you trying to flash the manager one or the afh one?
At wich level have u make the zip compression ?
I tried to flash your last zip by Magisk Manager and i get the mentioned error.
Apparently i am not alone to get this issue.
 

abacate123

Senior Member
Feb 22, 2015
1,266
1,800
At wich level have u make the zip compression ?
I tried to flash your last zip by Magisk Manager and i get the mentioned error.
Apparently i am not alone to get this issue.

You didn't answer my question, are you trying to flash the zip downloaded through the manager repo, or the afh mirror one? I tested the zip downloaded through the manager app repo, installed it there and flashed through twrp as well, and it's fine for me.
 
  • Like
Reactions: Sam Nakamura

de.er

Senior Member
Aug 29, 2014
307
183
You didn't answer my question, are you trying to flash the zip downloaded through the manager repo, or the afh mirror one? I tested the zip downloaded through the manager app repo, installed it there and flashed through twrp as well, and it's fine for me.

Can confirm zip downloaded through the repo working absolutely fine
 

abacate123

Senior Member
Feb 22, 2015
1,266
1,800
@Rom, if somehow you're talking about the AFH mirror zip, I'll re-upload it soon then under "_v2", if you can test and tell me, because I only flash through the main manager repo (because that's what really should work fine firstly tho, mirror is not the main download repo, just a backup).

Thanks for the heads up :)

EDIT: Added there already.
 
Last edited:
  • Like
Reactions: zsandras

ACardAttack

Senior Member
Aug 10, 2013
1,114
203
Anyone have issues with this module keeping their phone awake? It had issues where I needed to reset my phone every morning due to my phone being awake

I eventually removed this app/module and the awake bug has been mostly gone.

I guess something in my custom rom could be conflicting with what this app does. Not sure if it is greenify over all or just the module and how it handles it

I just installed amplify and I'll see how things are before retrying just the regular app, but was curious if anyone had any issues like this
 

abacate123

Senior Member
Feb 22, 2015
1,266
1,800
Anyone have issues with this module keeping their phone awake? It had issues where I needed to reset my phone every morning due to my phone being awake

I eventually removed this app/module and the awake bug has been mostly gone.

I guess something in my custom rom could be conflicting with what this app does. Not sure if it is greenify over all or just the module and how it handles it

I just installed amplify and I'll see how things are before retrying just the regular app, but was curious if anyone had any issues like this

Uhh, no.

Never heard of such issue before.
 

zsandras

Senior Member
Nov 14, 2007
712
136
BUjfalu
@Rom, if somehow you're talking about the AFH mirror zip, I'll re-upload it soon then under "_v2", if you can test and tell me, because I only flash through the main manager repo (because that's what really should work fine firstly tho, mirror is not the main download repo, just a backup).

Thanks for the heads up :)

EDIT: Added there already.
Thank you for the new update, now _v2 upload works perfect.:good:
 
  • Like
Reactions: abacate123

Yourboymusti

Senior Member
Mar 12, 2017
58
8
Hello, I'm new to this community but I've been using the mod for a while now. I recently switched to the Pixel 2 XL.

Whenever I try to install this module via the Magisk app I get an error. I'm using v14.4 (specific for the Pixel 2). Is the error due to this Magisk version not being supported or something else?
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 237
    Greenify4Magisk
    hqRA7JT.png


    Module Explanation:
    A very simple module just to make Greenify work as a rom-integrated (privileged) app systemlessly (also known as Boost Mode), so you'll achieve the best hibernating performance it could give, and faster than using the root option only. Best part is that it doesn't need Xposed, so you'll stay with your beloved green SafetyNet check, since Xposed breaks it. It'll simply inject a folder with the apk into the path: /system/priv-app. If it shows Privileged at the app settings, then you're good. Read this for extra explanation.

    * Note: You won't get any xposed-side features, since magisk is NOT xposed!

    Requirements:
    - Android 5.0 - 8.1.0
    - Magisk v15.3+

    Installation:
    - This module already has the latest apk inside, just download one of zips from the mirror and install through the Magisk Manager app or TWRP. As simple as that. Or you can download and install directly through Magisk Manager "download" section.

    ---

    Downloads:

    The module is now available at the Magisk Manager "download" section (beta and stable apks), so you can download and install directly through there, or you can grab a copy on the mirror below.

    ---

    Or
    AFH Mirror


    ---

    How to remove:
    - Since v3.9.7-U you can simply flash the same zip again to remove the module, or you can remove through the Magisk Manager "modules" section as well.

    ---

    Follow:
    -

    ---

    About the apk:
    - Apk downloaded directly from APKMirror, original and not tampered in any way, check below:

    Code:
    MD5 for 4.5.1:
    1af65a03bf425039cc1308e957b4d223

    ---

    Credits:
    - Greenify Developer/Creator - Oasis Feng (XDA Thread and Play Store Page).
    - Magisk Developer - Topjohnwu (Official Thread).
    - Unity Template Developers - Zackptg5 and Ahrion (Official Thread).
    - Thread Logo By @MickyFoley.

    - Useful Repositories:
    Module Repository
    Unity Repository
    68
    I'm too tired of this... See you guys later. It was nice enough to support this module and thread for almost two years! Thanks for everything.

    Cheers.
    30
    Updated to 3.8

    Cheers.


    EDIT:
    I've created a Telegram channel for the module today, so you'll get notified on the go there, with new links and stuff related to the module.

    Join with the link below:
    https://t.me/Greenify4Magisk

    :)
    27
    The v3.9.7-U update brings an overall new template!

    - - - - -

    Thanks to Zackptg5/Ahrion's Unity project, now Greenify4Magisk is more intelligent when it comes to the installing and uninstalling process.

    This update includes (but not limited to):

    1. You don't need the external uninstaller zip anymore, since this update you can simply flash the same zip again and it'll remove the module as well.

    2. You can install it even if you have no magisk installed now, it'll automatically detect whether you have magisk or not, if not, it'll install directly to system.

    3. It'll now detect automatically which Android API you are, this way the module can detect the Android version and block the installation for users using an Android lower than 5.0, and support is up to Android P.

    4. It'll also detect if an older module version is installed and will uninstall it first then install the updated module content afterwards. This will (probably) avoid some issues for some users.

    And some other tiny details that I may have forgot. Credits are given for the original authors of the template on the OP.

    * If you face any issues, please report (I accept positive reports as well haha).

    - - - - -

    PS.: The U beside the module version stands for Unity, if you are wondering.

    Cheers.
    26
    Updated the zip to the latest magisk module template v4, just that, no greenify related changes.

    Edit: Sorry, there was an issue with the zip, I re-uploaded it.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone