[DEV|ROM] CM12 non-scheduled builds

Status
Not open for further replies.
Search This thread
T

Thyrus

Guest
@K900

I have fixed the jumping icon when there is WIFI or Data activity that causes so much OCD with everyone

It was a simple sizing issues in drawable-xhdpi in SystemUI.

Icons (stat_sys_signal in, inout out etc) are 39*36 by default in CM12, you need to resize them to 36*34 or 36*3. Same with the 3g/4G/E icons
 

Ferranza

Senior Member
Nov 13, 2010
1,188
202
imperia
gps is working indoor.... took a lot of time but it works... in my little experience the two bugs that I've been facing are: 1. clear all button causes system ui fc, 2. video is still back...
 
Last edited:

dreamtheater39

Senior Member
Oct 3, 2004
1,270
68
38
Bangalore
www.youtube.com
After r4, my Google now launcher no longer works....even though its installed the os and other apps don't recognize the existence of now launcher....I tried uninstalling and reinstalling, the os never recognizes that Google now launcher exists....any of you guys with the same issue?
 

gianton

Recognized Contributor
Feb 5, 2009
12,016
9,925
Thessaloniki
All of the videos i'm capture, shows black screen but with sound. tried on the stock gallery and on other.
What can i do?
Thanks!

Same here, we can't do anything but wait. These builds are not even in Alpha official state by CM.

Wheater location not work.

Gesendet von meinem A0001 mit Tapatalk

Same here, WiFi/Data location not working.
 

liop

Member
Jun 6, 2007
14
2
Evrythings seems to works but I can't connect my moto 360. my OPO find the device, propose to connect to it and ... failed.
Any Idea ?
Thnaks.
 

zaphodbeeb

Senior Member
Mar 29, 2011
706
492
Betelgeuse
xformit.co.uk
Hi,
wifi and mobile seem to be working fine with this release. No capacitive button lights though. Very responsive and no sign of any lag. By far the smoothest rom Ive used on the oneplus one. Excellent work, could even be my daily if I can work out how to get it working with f2fs.
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 214
    Since everyone's asking for a separate thread (and I want a sticky post), here's one.

    BIG IMPORTANT ANNOUNCEMENT
    Seriously, read this
    I'm trying a thing here - discussion and all that for version 5 (and yes, there's a version 5) will be on Reddit, more specifically, here: http://www.reddit.com/r/oneplus/comments/2moqig/cm12_nonscheduled_builds_discussionupdate_thread/

    This is my attempt at keeping things clean. We'll see how it goes. I won't be reading this thread.

    Version 4:
    • Updated to Android 5.0.0_r6 across the board
    • Features!
      • Reboot, airplane mode, etc. in power menu
      • Hardware key rebinding
      • Battery percentage in statusbar
      • Call blacklist
      • Dialer lookup
      • Protected apps
      • Profiles
      • Kill all apps button
      • More?
    • HSPA+ also has the correct statusbar icon now
    • Clean build, so things will hopefully stop regressing randomly

    Fixed in version 3.1:
    • Mobile network icon showing 3G when actually on 4G

    Fixed in version 3:
    • Bluetooth
    • Some miscellaneous improvements

    Fixed in version 2:
    • Slow boot (for real this time!)
    • Settings alarms causing a bootloop
    • Download limit exceeded, save the file to your Yandex.Disk

    Also, face unlock works with new Gapps!

    Fixed in version 1:
    • NFC
    • Slow boot
    • Enabled multi-user

    Not fixed:
    • Keyboard crashes on swipe input (upstream, use the Play Store version)
    • Video recording only captures sound
    • More?

    How to install:
    1. Boot to recovery
    2. Flash the latest build: https://www.androidfilehost.com/?w=files&flid=21188
    3. Flash GApps: https://s.basketbuild.com/gapps
    4. Flash SuperSU: http://download.chainfire.eu/593/SuperSU/BETA-SuperSU-v2.19.zip
    5. Reboot

    Full wipe before upgrading from CM11, things will go horribly wrong if you don't.
    Might also need a wipe between versions, at least it didn't work right until I wiped.

    DON'T flash custom kernels on this, it may or may not break horribly and you don't want to try

    For developers: this is built from the latest CM12 source, here's what's different:
    • Removed com.qualcomm.location.apk, the new version depends on CM's MSim code which is not (yet) in L, and I can't be arsed to find an old one that works
    • Added overlays to enable multi-user
    • Last sync time: ~14:00 Moscow Standard Time, 2014-11-13


    FAQ:
    Q: AAAAEVERYTHINGISHORRIBLYBROKENAAAAAAAAAAAAAAAA
    A: Don't flash experimental development builds if you're not expecting that.

    Q: Where's Google Now Launcher?
    A: It's no longer in the GApps package, install it from the Play Store.

    Q: I dirty flashed this on top of a previous build and nothing/something/almost everything works.
    A: Wipe data.

    Q: I'm using MultiROM and ...
    A: Don't use MultiROM. This is not tested for MultiROM at all. If you use MultiROM and something goes wrong, blame MultiROM.

    Q: How do I enable softkeys?
    A: Add qemu.hw.mainkeys=1 to your build.prop

    Q: When?
    A: Soon.

    Important note
    This is not feature complete. Please try to keep this thread clean, and don't post useless comments like "works well" or "I also have this bug". If me or some other developer needs confirmation on a specific bug, we'll ask. kthxbai
    67
    Sorry guys, but I'm really sick, and the amount of information here (and, frankly, the signal/noise ratio), is overwhelming. So I'm going write-only for a while. I'll still be posting new builds when interesting stuff gets merged, but I can't keep up with the thread right now.
    48
    Hi Everyone,
    Well, I was going to clean this thread, but it seemed a hopeless task, so I closed it instead. Seriously, take a look at the OP of this thread and you will realize that this thread has been abandoned because all the non-development related posts. Most OPs subscribe to the thread so they get notified about every post. So the poor developer stops what he is doing to see what is going on and is greeted by: requests for ETAs, repeat questions, questions that were answered in the OP, discussions of other people's builds/mods, bug reports from dirty flashes, people yelling at other people for making these stupid kinds of posts, people yelling at the people yelling because those are also stupid kinds of posts, and so on.

    Please use a little common sense with your posts, and please, please, please, do not destroy another developer's thread with this noobish behavior...consider this a strict warning!

    Thanks!
    30
    r4 is done, I'm testing it on my end now, will upload if everything goes right.
    28
    r4 is uploading now.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone