Device in Fastboot mode not recognized at all as USB device

Search This thread

holgers0n

New member
Mar 4, 2021
3
0
11
Hey everyone,
im trying to unlock the bootloader of my LG G5, but am unable to do so as the phone is not detected at all when in fastboot mode.

While it is recognized just fine as an adb device, after rebooting into fastboot mode via adb reboot bootloader it is not recognized as an USB Device in Windows (The device manager does not show any device with wrong drivers and does not react to replugging the device). I also tried it on a different machine with the same results.

Ubuntu also does not recognize the device at all, lsusb does not output the device anywhere. It also does get recognized as an adb device when booted up normally.

I installed the necessary (I tried LG and Google) drivers and tried different USB ports (2.0 and 3.0) and cables. The phone just is not noticed as an usb device at all when in fastboot mode.

Could this be due to a broken usb port? Which seems odd because the phone is recognized when not in fastboot mode.

What else could cause this weird behaviour?

Thank You!
 

paulhauth25

Member
Jul 5, 2016
46
8
8
Hey everyone,
im trying to unlock the bootloader of my LG G5, but am unable to do so as the phone is not detected at all when in fastboot mode.

While it is recognized just fine as an adb device, after rebooting into fastboot mode via adb reboot bootloader it is not recognized as an USB Device in Windows (The device manager does not show any device with wrong drivers and does not react to replugging the device). I also tried it on a different machine with the same results.

Ubuntu also does not recognize the device at all, lsusb does not output the device anywhere. It also does get recognized as an adb device when booted up normally.

I installed the necessary (I tried LG and Google) drivers and tried different USB ports (2.0 and 3.0) and cables. The phone just is not noticed as an usb device at all when in fastboot mode.

Could this be due to a broken usb port? Which seems odd because the phone is recognized when not in fastboot mode.

What else could cause this weird behaviour?

Thank You!

Do you have usb debugging on because some devices require it to be on in order to be able to use fastboot on the computer.
 

holgers0n

New member
Mar 4, 2021
3
0
11
I forgot to mention that, oem unlock and USB debugging is enabled.
I tried installing the LG and android USB driver. But there is no way I can install these drivers to my fastboot device, as it is not recognized as an USB device at all, its like I'm plugging an USB cable with nothing attached to it into the computer.
QUOTE="User699, post: 84602251, member: 11475773"]
Just to be clear. After you booted into fastboot mode, did you try
Code:
fastboot devices
and it just showed nothing?
[/QUOTE]


Fastboot devices does not show anything.
 

holgers0n

New member
Mar 4, 2021
3
0
11
The "Android USB Driver" is a Windows OS driver, hence it must get installed in Windows OS.

Yes i am aware of that. As mentioned i installed the driver, my phone is recognized as an adb device. I have seen some solutions suggesting installing the driver manually when the fastboot device is not recognized correctly but the device is not recognized at all. I also tried installing the drivers as legacy hardware (Android ADB interface, Android Bootloader Interface etc.) via device manager, which results in an error ( error code 10, device can not be started)
 

User699

Senior Member
Feb 28, 2021
99
1
12
8
@holgers0n
I tried lsusb on my Xiaomi (I don't have lg) and it worked in fastboot also.
Since it doesn't show anything if you do fastboot devices, you could try to do the standard things:
1) Change usb port on your computer
2) Try another cable
3) If it's a usb type c, plug it into your smartphone, try if it works and if it doesn't, try around that cable and retry.

I am not 100 % sure but since you said
Ubuntu also does not recognize the device at all, lsusb does not output the device anywhere. It also does get recognized as an adb device when booted up normally.
maybe you need to install non-free firmware as well.
 

Narrry84

Member
May 6, 2013
48
4
28
Surendra Nagar
I also had same issue. my redmi note 6 pro and asus zenfone max pro m1 can be detected in adb but not in fastboot. tried everything. changing driver/disble signature verification. also tried virtual box ubuntu/window 7. but not succeeded. It is actually an issue with usb 3. so I bought usb 2 hub. now everything works fine.