[DEVONLY] LineageOS 15

Search This thread

mcgi5sr2

Senior Member
Oct 15, 2012
1,058
1,810
Sheffield
@modpunk I'll start by saying I totally understand if you don't want to help, as you are under no obligation to do so, and its probably my lack of knowledge causing this issue.

However I am currently unable to get a build made from your sources to boot past the sony logo.

I am using the `lineageOS-15.1` branches from all your repos, and I have tried extracting the vendor blobs from both the Beta 7 build, and from the latest firmware (XperiFirm, UnSin, extract-files.sh). I have included both `oreo oem group` commits from the lineageOS gerrit as well. So now I am at quite the loss.

I have previously been able to build with ease, and this is really getting my goat that I can't figure out why these builds won't boot. Any advice would be super welcome.
 
  • Like
Reactions: nailyk

modpunk

Recognized Contributor
Oct 14, 2011
1,718
6,643
Sony Xperia XZ1 Compact
Samsung Galaxy S10
@modpunk I'll start by saying I totally understand if you don't want to help, as you are under no obligation to do so, and its probably my lack of knowledge causing this issue.

However I am currently unable to get a build made from your sources to boot past the sony logo.

I am using the `lineageOS-15.1` branches from all your repos, and I have tried extracting the vendor blobs from both the Beta 7 build, and from the latest firmware (XperiFirm, UnSin, extract-files.sh). I have included both `oreo oem group` commits from the lineageOS gerrit as well. So now I am at quite the loss.

I have previously been able to build with ease, and this is really getting my goat that I can't figure out why these builds won't boot. Any advice would be super welcome.

Did you get any errors from the extract-files.sh script. Also did you do an engineering build to get logs?
 

oF2pks

Senior Member
May 22, 2016
807
1,108
...to boot past the sony logo...
(jic,) it does that for me when I use export OUT_DIR_COMMON_BASE= , whatever Oreo rom I tried.
To solve boot process, I have to build boot.img FIRST on same OUT than source, then use export OUT_DIR_COMMON_BASE= to build "heavy" zip elsewhere and repack first boot.img into it (?!).
 
  • Like
Reactions: mcgi5sr2

mcgi5sr2

Senior Member
Oct 15, 2012
1,058
1,810
Sheffield
Created the Eng build, phone doesn't even create a last_kmsg never mind get into a state where adb can be used. At this point I'm at a bit of a loss

will try oF2pks method, although I can't work out why it would work, fingers crossed?

no back to the drawing board again
 
Last edited:

mcgi5sr2

Senior Member
Oct 15, 2012
1,058
1,810
Sheffield
Code:
Extracting 35 files in ./proprietary-files-twrp.txt from adb:
  - /system/recovery/root/vendor/firmware/cmnlib.b00 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b01 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b02 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b03 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b04 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b05 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b06 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.mdt .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b00 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b01 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b02 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b03 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b04 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b05 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b06 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.mdt .. 
    !! file not found in source
  - /system/recovery/root/etc/firmware/touch_module_id_0xf0.img .. 
    !! file not found in source
  - /system/recovery/root/etc/firmware/touch_module_id_0xf1.img .. 
    !! file not found in source

are the only files not found from the extract files script, I have older copies of these, but chose not to build with them, as I am not compiling TWRP.
 

Erreur_418

New member
Jun 17, 2018
2
0
upgrade from 0612

Hello, my device uses the 20180612 update, can i directly upgrade to 20181022 update without problem ? And how can i do that ?

Thanks in advance :)
 

moridin1983

Member
Nov 6, 2018
20
4
Hello,

I am trying to build this rom, but I keep running into problems. The extract-files script can not find a large number of files and exits with:
Code:
sed: can't read ./../../../vendor/sony/lilac/proprietary/recovery/root/sbin/qseecomd: No such file or directory
.
I have tried to extract the files via adb and also from the unzipped ROM, without luck.
Here is an excerpt of the outout of the extract-files script, as I am not yet allowed to post links, and the complete list is to long to post:
Code:
- /system/vendor/lib/libjni_filtergenerator.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_hazebuster.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_imageutil.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_makeupV2.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_optizoom.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_panorama.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_seestraight.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_sharpshooter.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_snapcammosaic.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_snapcamtinyplanet.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_stillmore.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_trackingfocus.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_trueportrait.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_truescanner_v2.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_ubifocus.so ..
    !! file not found in source
  - /system/vendor/lib/liboptizoom.so ..
    !! file not found in source
  - /system/lib/libqti-perfd-client_system.so ..
  - /system/lib/libqti-util_system.so ..
  - /system/lib/libqti_performance.so ..
  - /system/lib/librcc.so ..
  - /system/vendor/lib/libscveBlobDescriptor.so ..
    !! file not found in source
  - /system/vendor/lib/libscveBlobDescriptor_skel.so ..
    !! file not found in source
  - /system/vendor/lib/libscveBlobDescriptor_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscveCommon.so ..
    !! file not found in source
  - /system/vendor/lib/libscveCommon_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceLandmark_skel.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceLandmarks.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceLandmarks_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceRecognition.so ..
    !! file not found in source
  - /system/vendor/lib/libscveImageCorrection.so ..
    !! file not found in source
  - /system/vendor/lib/libscveObjectSegmentation.so ..
    !! file not found in source
  - /system/vendor/lib/libscveObjectTracker.so ..
    !! file not found in source
  - /system/vendor/lib/libscveObjectTracker_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscvePanorama.so ..
    !! file not found in source
  - /system/vendor/lib/libscvePanorama_lite.so ..
    !! file not found in source
  - /system/vendor/lib/libscveT2T_skel.so ..
    !! file not found in source
  - /system/vendor/lib/libsdm-disp-apis.so ..
    !! file not found in source
  - /system/vendor/lib/libseemore.so ..
    !! file not found in source
  - /system/vendor/lib/libseestraight.so ..
    !! file not found in source
  - /system/vendor/lib/libtrueportrait.so ..
    !! file not found in source
  - /system/vendor/lib/libtruescanner.so ..
    !! file not found in source
  - /system/vendor/lib/libubifocus.so ..
    !! file not found in source
  - /system/lib/sensors.hal.tof.so ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib64/[email protected] ..
  - /system/vendor/lib64/hw/libdisplay.default.so ..
    !! file not found in source
  - /system/lib64/lib-imscamera.so ..
  - /system/lib64/lib-imsvideocodec.so ..
  - /system/lib64/lib-imsvt.so ..
  - /system/lib64/lib-imsvtextutils.so ..
  - /system/lib64/lib-imsvtutils.so ..
  - /system/lib64/libMiscTAApi.so ..
  - /system/lib64/libMiscTaWrapper.so ..
  - /system/lib64/libaptXHD_encoder.so ..
  - /system/lib64/libaptX_encoder.so ..
  - /system/vendor/lib64/libblurbuster.so ..
    !! file not found in source
  - /system/lib64/libcacao_client.so ..
  - /system/lib64/libcacao_pal.so ..
  - /system/vendor/lib64/libchromaflash.so ..
    !! file not found in source
  - /system/vendor/lib64/libclearsight.so ..
    !! file not found in source
  - /system/lib64/libdiag_system.so ..
  - /system/vendor/lib64/libhazebuster.so ..
    !! file not found in source
  - /system/lib64/libiddjni.so ..
  - /system/lib64/libimageprocessorjni.so ..
  - /system/lib64/libimscamera_jni.so ..
  - /system/lib64/libimsmedia_jni.so ..
  - /system/vendor/lib64/libjni_blurbuster.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_chromaflash.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_clearsight.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_dualcamera.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_filtergenerator.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_gallery_eglfence.so ..
  - /system/vendor/lib64/libjni_gallery_filters.so ..
  - /system/vendor/lib64/libjni_gallery_jpegstream.so ..
  - /system/vendor/lib64/libjni_hazebuster.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_imageutil.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_makeupV2.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_optizoom.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_pacprocessor.so ..
  - /system/vendor/lib64/libjni_panorama.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_seestraight.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_sharpshooter.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_snapcammosaic.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_snapcamtinyplanet.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_stillmore.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_trackingfocus.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_trueportrait.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_truescanner_v2.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_ubifocus.so ..
    !! file not found in source
  - /system/vendor/lib64/liboptizoom.so ..
    !! file not found in source
  - /system/lib64/libqti-perfd-client_system.so ..
  - /system/lib64/libqti-util_system.so ..
Could someone point me in the right direction to fix this?

Cheers
 

mcgi5sr2

Senior Member
Oct 15, 2012
1,058
1,810
Sheffield
Hello,

I am trying to build this rom, but I keep running into problems. The extract-files script can not find a large number of files and exits with:
Code:
sed: can't read ./../../../vendor/sony/lilac/proprietary/recovery/root/sbin/qseecomd: No such file or directory
.
I have tried to extract the files via adb and also from the unzipped ROM, without luck.
Here is an excerpt of the outout of the extract-files script, as I am not yet allowed to post links, and the complete list is to long to post:
Code:
- /system/vendor/lib/libjni_filtergenerator.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_hazebuster.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_imageutil.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_makeupV2.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_optizoom.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_panorama.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_seestraight.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_sharpshooter.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_snapcammosaic.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_snapcamtinyplanet.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_stillmore.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_trackingfocus.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_trueportrait.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_truescanner_v2.so ..
    !! file not found in source
  - /system/vendor/lib/libjni_ubifocus.so ..
    !! file not found in source
  - /system/vendor/lib/liboptizoom.so ..
    !! file not found in source
  - /system/lib/libqti-perfd-client_system.so ..
  - /system/lib/libqti-util_system.so ..
  - /system/lib/libqti_performance.so ..
  - /system/lib/librcc.so ..
  - /system/vendor/lib/libscveBlobDescriptor.so ..
    !! file not found in source
  - /system/vendor/lib/libscveBlobDescriptor_skel.so ..
    !! file not found in source
  - /system/vendor/lib/libscveBlobDescriptor_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscveCommon.so ..
    !! file not found in source
  - /system/vendor/lib/libscveCommon_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceLandmark_skel.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceLandmarks.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceLandmarks_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscveFaceRecognition.so ..
    !! file not found in source
  - /system/vendor/lib/libscveImageCorrection.so ..
    !! file not found in source
  - /system/vendor/lib/libscveObjectSegmentation.so ..
    !! file not found in source
  - /system/vendor/lib/libscveObjectTracker.so ..
    !! file not found in source
  - /system/vendor/lib/libscveObjectTracker_stub.so ..
    !! file not found in source
  - /system/vendor/lib/libscvePanorama.so ..
    !! file not found in source
  - /system/vendor/lib/libscvePanorama_lite.so ..
    !! file not found in source
  - /system/vendor/lib/libscveT2T_skel.so ..
    !! file not found in source
  - /system/vendor/lib/libsdm-disp-apis.so ..
    !! file not found in source
  - /system/vendor/lib/libseemore.so ..
    !! file not found in source
  - /system/vendor/lib/libseestraight.so ..
    !! file not found in source
  - /system/vendor/lib/libtrueportrait.so ..
    !! file not found in source
  - /system/vendor/lib/libtruescanner.so ..
    !! file not found in source
  - /system/vendor/lib/libubifocus.so ..
    !! file not found in source
  - /system/lib/sensors.hal.tof.so ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib/[email protected] ..
  - /system/lib64/[email protected] ..
  - /system/vendor/lib64/hw/libdisplay.default.so ..
    !! file not found in source
  - /system/lib64/lib-imscamera.so ..
  - /system/lib64/lib-imsvideocodec.so ..
  - /system/lib64/lib-imsvt.so ..
  - /system/lib64/lib-imsvtextutils.so ..
  - /system/lib64/lib-imsvtutils.so ..
  - /system/lib64/libMiscTAApi.so ..
  - /system/lib64/libMiscTaWrapper.so ..
  - /system/lib64/libaptXHD_encoder.so ..
  - /system/lib64/libaptX_encoder.so ..
  - /system/vendor/lib64/libblurbuster.so ..
    !! file not found in source
  - /system/lib64/libcacao_client.so ..
  - /system/lib64/libcacao_pal.so ..
  - /system/vendor/lib64/libchromaflash.so ..
    !! file not found in source
  - /system/vendor/lib64/libclearsight.so ..
    !! file not found in source
  - /system/lib64/libdiag_system.so ..
  - /system/vendor/lib64/libhazebuster.so ..
    !! file not found in source
  - /system/lib64/libiddjni.so ..
  - /system/lib64/libimageprocessorjni.so ..
  - /system/lib64/libimscamera_jni.so ..
  - /system/lib64/libimsmedia_jni.so ..
  - /system/vendor/lib64/libjni_blurbuster.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_chromaflash.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_clearsight.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_dualcamera.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_filtergenerator.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_gallery_eglfence.so ..
  - /system/vendor/lib64/libjni_gallery_filters.so ..
  - /system/vendor/lib64/libjni_gallery_jpegstream.so ..
  - /system/vendor/lib64/libjni_hazebuster.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_imageutil.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_makeupV2.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_optizoom.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_pacprocessor.so ..
  - /system/vendor/lib64/libjni_panorama.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_seestraight.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_sharpshooter.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_snapcammosaic.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_snapcamtinyplanet.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_stillmore.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_trackingfocus.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_trueportrait.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_truescanner_v2.so ..
    !! file not found in source
  - /system/vendor/lib64/libjni_ubifocus.so ..
    !! file not found in source
  - /system/vendor/lib64/liboptizoom.so ..
    !! file not found in source
  - /system/lib64/libqti-perfd-client_system.so ..
  - /system/lib64/libqti-util_system.so ..
Could someone point me in the right direction to fix this?

Cheers

You will probably need to download the firmware using xperifirm, and then using the UnSin program to decompress the system and vendor files from the firmware. Both Xperifirm and UnSin run well in the mono environment. You can then use the extract files script but point it at the folder you decompressed the .sin files into. A guide on how to use the extract-files.sh script is available on most build guides for lineageOS on their official sites.
 
  • Like
Reactions: nussbaum

moridin1983

Member
Nov 6, 2018
20
4
You will probably need to download the firmware using xperifirm, and then using the UnSin program to decompress the system and vendor files from the firmware. Both Xperifirm and UnSin run well in the mono environment. You can then use the extract files script but point it at the folder you decompressed the .sin files into. A guide on how to use the extract-files.sh script is available on most build guides for lineageOS on their official sites.

Ah, okay, I have not tried this yet. Until recently I was building Lineage for the S4mini, where I could extract proprietary blobs from the zip with sdat2img.
i will give it another try.
Thank you very much!
 

moridin1983

Member
Nov 6, 2018
20
4
Okay, it worked with the stock firmware. Tanks again for the help. The extract-files script finished without any errors.
I also was able to compile the rom without errors.
However now my phone hangs at the sony logo during boot.
I will now try an engineering build to see if i get useful logs
 

derf elot

Senior Member
May 7, 2011
868
1,879
Okay, it worked with the stock firmware. Tanks again for the help. The extract-files script finished without any errors.
I also was able to compile the rom without errors.
However now my phone hangs at the sony logo during boot.
I will now try an engineering build to see if i get useful logs

You need to revert these two reverts:

https://review.lineageos.org/#/c/LineageOS/android_bionic/+/207611/
https://review.lineageos.org/#/c/LineageOS/android_build/+/208389/

Then it should work fine.
 
  • Like
Reactions: moridin1983

moridin1983

Member
Nov 6, 2018
20
4
Thanks for the advice. I tried it, but still can not get past the sony logo when booting.
I also encountered another problem:
I did a complete backup in TWRP before flashing the self-compiled rom. But when i restored the backup, the phone was still hanging at the sony logo.
I had to reflash BETA8 to make the phone boot again.
I will keep trying.

Cheers
 
  • Like
Reactions: .:B:.

mcgi5sr2

Senior Member
Oct 15, 2012
1,058
1,810
Sheffield
Thanks for the advice. I tried it, but still can not get past the sony logo when booting.
I also encountered another problem:
I did a complete backup in TWRP before flashing the self-compiled rom. But when i restored the backup, the phone was still hanging at the sony logo.
I had to reflash BETA8 to make the phone boot again.
I will keep trying.

Cheers

These are the exact issues I had, I don't know why the backups don't restore correctly, but I suspect the reason the phone won't boot is that the /priv-apps/ and /apps/ you are using are the ones taken directly from the firmware. These have been ?dexed? against the stock rom, and will need unpacking, deodexed and built inline with the ROM. You could try pulling just those apps off a working device with beta8 installed and build against them instead.

Let me know how you get on, I am currently doing my thesis corrections, but post that I am going to get some books and start learning for real. If anyone on the thread has any recommendations of good books or resources to read, I would be very interested to hear.
 
  • Like
Reactions: .:B:.

moridin1983

Member
Nov 6, 2018
20
4
I figured out a way to extract the vendor blobs from my phone.
After messing around a little in the adb shell, I saw, that all the missing files I mentioned in a previous post, were actually on the phone, the standard user just could not read them.
After setting selinux to permissive (temporarily), the extract-files script could copy everything, without errors.
I will build again tomorrow, and see if the phone boots properly.

Cheers
 
  • Like
Reactions: oF2pks

moridin1983

Member
Nov 6, 2018
20
4
Hey Guys,

sorry to bother you again.
I was able to extract most files from the BETA8.zip, without erros.

The only files missing are these, exactly the same as mcgi5sr2 mentioned in post #309https://forum.xda-developers.com/showpost.php?p=77936293&postcount=309
Code:
Extracting 35 files in ./proprietary-files-twrp.txt from adb:
  - /system/recovery/root/vendor/firmware/cmnlib.b00 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b01 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b02 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b03 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b04 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b05 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b06 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.mdt .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b00 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b01 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b02 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b03 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b04 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b05 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b06 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.mdt .. 
    !! file not found in source
  - /system/recovery/root/etc/firmware/touch_module_id_0xf0.img .. 
    !! file not found in source
  - /system/recovery/root/etc/firmware/touch_module_id_0xf1.img .. 
    !! file not found in source
I can extract the missing files from the stock firmware, but wether or not I'm using them to compile the rom, it does not boot past the sony logo.
I also reverted the reverts mentioned by derf elot using this commands:
Code:
repo forall -c "git revert 784fbae86ac177f820777d47c2fe8b121c6960ab"
repo forall -c "git revert 2de89a8d9d552f7bc4cd68f23c1a22b0715fd9c1"
Are these commands correct?

Anyway I'm still stuck at the boot logo.

Cheers
 

derf elot

Senior Member
May 7, 2011
868
1,879
Hey Guys,

sorry to bother you again.
I was able to extract most files from the BETA8.zip, without erros.

The only files missing are these, exactly the same as mcgi5sr2 mentioned in post #309https://forum.xda-developers.com/showpost.php?p=77936293&postcount=309
Code:
Extracting 35 files in ./proprietary-files-twrp.txt from adb:
  - /system/recovery/root/vendor/firmware/cmnlib.b00 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b01 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b02 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b03 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b04 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b05 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.b06 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib.mdt .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b00 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b01 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b02 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b03 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b04 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b05 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.b06 .. 
    !! file not found in source
  - /system/recovery/root/vendor/firmware/cmnlib64.mdt .. 
    !! file not found in source
  - /system/recovery/root/etc/firmware/touch_module_id_0xf0.img .. 
    !! file not found in source
  - /system/recovery/root/etc/firmware/touch_module_id_0xf1.img .. 
    !! file not found in source
I can extract the missing files from the stock firmware, but wether or not I'm using them to compile the rom, it does not boot past the sony logo.
I also reverted the reverts mentioned by derf elot using this commands:
Code:
repo forall -c "git revert 784fbae86ac177f820777d47c2fe8b121c6960ab"
repo forall -c "git revert 2de89a8d9d552f7bc4cd68f23c1a22b0715fd9c1"
Are these commands correct?

Anyway I'm still stuck at the boot logo.

Cheers

Could you post your manifest please?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 46
    Hi,

    this is the development thread for LineageOS development. The first release is out and this thread is for developer collaboration!

    Everyone who knows C, Java and strace is welcome to participate. Please send git formatted patches!

    HELP NEEDED
    • mixer_paths_tasha.xml and audio_platform_info.xml need tweaking
    • VoIP needs testing
    • WifiDisplay support
    • VoLTE (I can't test this)

    Device Trees
    https://github.com/cryptomilk/android_kernel_sony_msm8998
    https://github.com/cryptomilk/android_device_sony_common-treble
    https://github.com/cryptomilk/android_device_sony_yoshino
    https://github.com/cryptomilk/android_device_sony_lilac
    23
    SUCCESS

    I have a working recovery with File Based Encryption now! So backups are working, hooray! :)
    18
    I got the camera working!
    17
    Google broke a lot of stuff with Android 8.1.

    They introduced versioned libraries with 8.0 and removed them again with 8.1. Several services do not find their required symbols etc.

    Project Treble at work ... they should have named it Project Trouble.
    17
    Bro, I get a lot of messages, sorry. :D I have a working (touch, flashing, ...) TWRP for XZ1 Compact & XZ1 (they are 99% the same), but no working FBE.
    If there still exists a problem with your build, check the fstab. The XZP has no vendor partition and the Myself5 build for lilac (based on maple) has no vendor partition in fstab.
    I included it and it fixed some bugs...

    Also the sbin/libminuitwrp.so causes blackscreen issues on Oreo. I found a working library in a unofficial build for the OnePlus (Oreo) which works like a charme... hahaha... yepp, I'm lazy...
    If you have a working recovery, it would be awesome to test it with XperiFIX, too. I have a DRM-Patch for XZ1/c here, but first we need a fully working recovery and root...

    I will search your PM and answer to it :cyclops:

    I have a working TWRP without any black screen issues and FBE working. I'm preparing a release right now.