Diagnosing USB Driver and ADB issues in Windows

Search This thread

MaxRabbit

Senior Member
Oct 21, 2010
778
227
73
Austin
Are you getting errors like "device not found" or "device offline" while trying to run ADB commands? Here's a quick way to troubleshoot your problem on Windows.

Steps
1. Ensure USB Debugging is enabled in Developer Options.
2. Verify current Google USB Driver is installed and that Device Manager is using that driver.
3. Update to latest version of ADB.

  • 1. Ensure USB Debugging is enabled in Developer Options.
Enable Developer Options by going to Settings -> About Phone and tapping on "Build Number" multiple repeated times. You will be greeted with "You are a developer."

Now, under Settings -> Developer Options, ensure you check the box for "USB debugging."

  • 2. Verify current Google USB Driver is installed and Device Manager is using that driver.
You may skip this step if Device Manager lists your phone as "Android Phone -> Android Composite ADB Interface." If it does not, this is likely your root cause.

Go to the Google USB Driver page and download the latest driver directly from Google. Extract the zip file to a folder you know and will remember in the future.

Open up Device Manger in Windows with your Nexus 5 connected. Whatever your Nexus 5 is currently detected as, right click on it and select Properties. Then, in the Driver tab, hit "Uninstall." If available, select "Delete the driver software for this device." and hit "OK." It will remove the old drivers.

Restart your computer.

After restarting, reconnect your Nexus 5. It should be recognized as an unknown device in the Device Manager. (If it isn't, try the previous driver deletion steps again.)

Right click on the unknown Nexus 5 device, choose Properties, and in the Driver tab again select "Update driver." Browse your computer manually by putting in the path to the new Google USB Drivers you unzipped to a folder of your choice in the beginning of this step. Choose next and your drivers should install! You'll know everything completed successfully when you see the phone listed under "Android Phone -> Android Composite ADB Interface" in Device Manager.

This is the most finicky process, so don't be afraid to reboot your computer a time or two and repeat these steps if they don't work on the first try.

  • 3. Update to latest version of ADB.
This is a crucial step. The new version of ADB is required to work with the "USB debugging authorizations" setting.

Perhaps you know how to update ADB, in which case, just do it. However, here's a detailed manual approach to download JUST the adb suite from the SDK:
Go to the Google Android SDK website and choose "Use An Existing IDE" and click the "Download the SDK Tools for Windows." This will allow you to download only an 80 MB file rather than the whole 400 MB suite.

Install the SDK tools exe to a folder of your choosing.

Run SDK Manager and uncheck everything except for "Android SDK Platform-tools." This is the ADB and Fastboot bundle. Install that.

Navigate to your SDK Path as indicated at the top of your Android SDK Manager window. You will now see a freshly downloaded platform-tools folder containing ADB.exe, Fastboot.exe, and a host of other files. That folder is now your updated, portable ADB tools folder. You can move it anywhere you like as long as you run ADB from a command prompt window set to that directory.

After you've followed these procedures, running "ADB Devices" should trigger a prompt on your device to accept the RSA fingerprint of your computer. Accept it, and now all should be working as intended!

Questions? Ask below!
 
Last edited:

MaxRabbit

Senior Member
Oct 21, 2010
778
227
73
Austin
Crowd-sourced solutions.

Windows 8 Diagnosis
Yorus said:
The following worked for me, since all of the suggestions mentioned here didn't work for me:
If you use a Windows 8.1 enterprise N or KN edition, install the Microsoft Media Feature Pack :
http://support.microsoft.com/kb/2929699/en
Sounds too simple to be true but work instantly for me.
Hope it works you some of the people here looking for a solution

Setting up ADB and Fastboot commands to work from ANY path (credit to original author in quote).
Setup, Preparation and Prerequisites

  • ADB and Fastboot Installation
  1. Download the full Android SDK here (scroll to the bottom of the page>DOWNLOAD FOR OTHER PLATFORMS>SDK Tools Only) or get a slimmed version containing only the essential components here (Thanks @El Daddy)
  2. Extract the zip and place the android-sdk-windows folder on the root of your hard drive. (the path should be like this: C:\android-sdk-windows)
    **If you chose to download the slimmed sdk skip to step 5**
  3. Only if you downloaded the full sdk: Go into the folder and run SDK Manager.exe. Install the following packages (there are a total of 4 packages):
    - Tools > Android SDK Tools, Android SDK Platform-tools
    - Extras > Android Support Library, Google USB Driver

  4. Only if you downloaded the full sdk: Go back into the android-sdk-windows directory, and you should see a new folder named platform-tools. If not, repeat the step above.
  5. Open a command prompt window and run "sysdm.cpl" (without the quotes) and a new window should popup. Go to the Advanced tab > Environmental Variables
  6. Now focus your attention to the System variables box (the lower box). Scroll down and look for the Path variable > highlight it > click Edit > go all the way to the end of the Variable value text box, and paste the following entry:
  7. Code:
    ;C:\android-sdk-windows\platform-tools
    (OR WHATEVER PLATFORM-TOOLS DIRECTORY YOU PICKED)
  8. Click OK then close all of the System Properties windows
  9. You should now be able to use adb/fastboot commands no matter what location your command prompt is in. To confirm that it is indeed working, open a command prompt window and enter "adb version" (without the quotes). If it displays "Android Debug Bridge version x.x.xx" it is working. If it is gives an error saying that adb is not a recognized command, it has not been successful. Carefully repeat the steps above if this is the case.

The importance of being careful with your command choices.
"Be sure to use the CORRECT adb/fastboot commands, double-check the path on all commands, and double-check the existence of each file you are working with."

I hate to admit this, but I couldn't figure out why nothing was appearing in the device list when I did "adb devices", while the phone was in Fastboot. I did everything from A-Z and tore my hair out for 30 minutes until it hit me, my phone's in Fastboot. I've been messing with Android for 3+ years and made a newbie mistake lol.

Fixing MTP device not showing up after installing ADB drivers.
I'm not sure what happened but on my WINDOWS 7 (64 bit) OS I had to modify "%WINDIR%\inf\wpdmtp.inf" as shown here: "http://forum.xda-developers.com/showpost.php?p=37930602&postcount=937". I then uninstall the device and drivers and performed a hardware scan to get it to work. I also added a "...PID_4EE2&MI_01" line but I am not positive that was required.

Hope that helps someone.

You should also mention what worked for me in post #16 (& confirmed by a few others in other threads). That is to toggle Settings - Storage - USB Connection type from Camera to Mass storage & also the debugging mode on & off.

Op might wanna tack this onto the bottom of the main post as a last resort for folks to "start over" and be sure they have no old drivers installed.

http://www.nirsoft.net/utils/usb_devices_view.html

i had to use this program (right click run as admin if permissions are set) to remove EVERY single android related driver in order to get mine working.. turns out i had so many old ones in my system and some i couldn't remove from the device manager, the buttons wouldn't become click able..

I've tried everything and cannot get the authorization prompt to pop up on my Nexus5 so when I run adb devices the phone shows up as "unauthorized". Any suggestions? This is with updated sdk and USB drivers. Device manager shows phone as "Android Phone->Android Composite ADB Interface" and "Portable Device->Nexus 5". Tried toggling between MTP/PTP, USB Debugging on/off, stopping and starting the adb server (latest version 1.0.31).

Thanks in advance!

EDIT: Finally got the ba$tard! Run this for some adb debug logging:

adb kill-server
set ADB_TRACE=all
adb nodaemon server

Go and look back at the output from the start for any errors. In my case it couldn't mkdir in c:\users\administrator, which for me doesn't exist. I changed the Windows environment variable "ANDROID_SDK_HOME" to point to "C:\users\<my account dir>", closed the DOS window, re-ran the commands and I got prompted for the permission on my phone. Yee ha! Now I can fire up hello world with the SDK on my phone. Praise be to Google search for turning up this thread that told me about the debug logging.

I just rooted my N5 (using the guide on this forum so I had no other drivers other than Google's SDK) and after unlocking my bootloader windows did not recognize my phone so I couldn't go further. Upon checking device manager I saw something called "AOSP on Hammerhead", a quick online search found a lot of very complicated answers (uninstall all drivers, restart, install adb drivers was one example).

Instead of all that I just right clicked "AOSP on Hammerhead", chose Update Driver, manually choose driver, went to "Android bootloader", chose the default driver from "Google inc" manually and that for some reason worked.

I figured this might help someone since the other solutions I found really were very long.

Questions? Ask below!
 
Last edited:

KTT16

Senior Member
Aug 26, 2011
1,122
219
0
Fremont
What step exactly did you take that fixed it?

Open a command prompt window and run "sysdm.cpl" (without the quotes) and a new window should popup. Go to the Advanced tab > Environmental Variables
Now focus your attention to the System variables box (the lower box). Scroll down and look for the Path variable > highlight it > click Edit > go all the way to the end of the Variable value text box, and paste the following entry:

Code:
;C:\android-sdk-windows\platform-tools

Click OK then close all of the System Properties windows
You should now be able to use adb/fastboot commands no matter what location your command prompt is in. To confirm that it is indeed working, open a command prompt window and enter "adb version" (without the quotes). If it displays "Android Debug Bridge version x.x.xx" it is working. If it is gives an error saying that adb is not a recognized command, it has not been successful. Carefully repeat the steps above if this is the case.
 

MaxRabbit

Senior Member
Oct 21, 2010
778
227
73
Austin
Open a command prompt window and run "sysdm.cpl" (without the quotes) and a new window should popup. Go to the Advanced tab > Environmental Variables
Now focus your attention to the System variables box (the lower box). Scroll down and look for the Path variable > highlight it > click Edit > go all the way to the end of the Variable value text box, and paste the following entry:

Code:
;C:\android-sdk-windows\platform-tools

Click OK then close all of the System Properties windows
You should now be able to use adb/fastboot commands no matter what location your command prompt is in. To confirm that it is indeed working, open a command prompt window and enter "adb version" (without the quotes). If it displays "Android Debug Bridge version x.x.xx" it is working. If it is gives an error saying that adb is not a recognized command, it has not been successful. Carefully repeat the steps above if this is the case.

Ahh, your problem with my instructions then were that you weren't running ADB from inside the platform-tools folder :)
 

KTT16

Senior Member
Aug 26, 2011
1,122
219
0
Fremont
Definitely! I seriously got frustrated for a second and forgot how to read! :)

Sent from my Nexus 5 using XDA Premium 4 mobile app
 

JonnyRock

New member
Sep 24, 2010
2
0
0
Not showing up as removable storage

Hi, maybe you can help me.

Last night I unlocked my N5 using CF-Root, and flashed TWRP using Flashify. However, when I plug my N5 into my home computer it doesn't ever show up under 'My Computer' with other removable storage devices. It is present in the device manager under 'Android Phone -> Google Nexus ADB Interface'.

I've tried restrarting my computer, uninstalling the drivers and reinstalling them. Developer mode is enabled and if I switch from MTP to PTP then is shows up under removable storage, but I only have access to the DCIM folder. Switching back to MTP makes it disappear.

On my work computer it shows up correctly no problem.

My personal computer has had multiple installations of WugFresh Root toolkit and ADB/SDK files for my previous Galaxy Nexus and Nexus 7 but I uninstalled most of that before setting up the N5.

Thanks!
 

aluxzen

Senior Member
Jan 6, 2008
50
2
0
Hi, maybe you can help me.

Last night I unlocked my N5 using CF-Root, and flashed TWRP using Flashify. However, when I plug my N5 into my home computer it doesn't ever show up under 'My Computer' with other removable storage devices. It is present in the device manager under 'Android Phone -> Google Nexus ADB Interface'.

I've tried restrarting my computer, uninstalling the drivers and reinstalling them. Developer mode is enabled and if I switch from MTP to PTP then is shows up under removable storage, but I only have access to the DCIM folder. Switching back to MTP makes it disappear.

On my work computer it shows up correctly no problem.

My personal computer has had multiple installations of WugFresh Root toolkit and ADB/SDK files for my previous Galaxy Nexus and Nexus 7 but I uninstalled most of that before setting up the N5.

Thanks!


same issue on my side...I canot use MTP only PTP...I also tryed new drivers from SDK but has not solved the problem
Alex
 

MaxRabbit

Senior Member
Oct 21, 2010
778
227
73
Austin
Hi, maybe you can help me.

Last night I unlocked my N5 using CF-Root, and flashed TWRP using Flashify. However, when I plug my N5 into my home computer it doesn't ever show up under 'My Computer' with other removable storage devices. It is present in the device manager under 'Android Phone -> Google Nexus ADB Interface'.

I've tried restrarting my computer, uninstalling the drivers and reinstalling them. Developer mode is enabled and if I switch from MTP to PTP then is shows up under removable storage, but I only have access to the DCIM folder. Switching back to MTP makes it disappear.

On my work computer it shows up correctly no problem.

My personal computer has had multiple installations of WugFresh Root toolkit and ADB/SDK files for my previous Galaxy Nexus and Nexus 7 but I uninstalled most of that before setting up the N5.

Thanks!

This is a really strange problem :-/ what does it show up as when you are in device manager on your work computer?
 

JonnyRock

New member
Sep 24, 2010
2
0
0
This is a really strange problem :-/ what does it show up as when you are in device manager on your work computer?

It shows up as a 'Portable Device' -> 'Portable Media Player' (I was thinking it was a 'Device with Removable Storage').
I have full access to the internal file folders here at work.
 

MkVsTheWorld

Senior Member
Aug 29, 2010
236
38
0
Baltimore
Here's a suggestion for something to add to the OP.

"Be sure to use the CORRECT adb/fastboot commands, double-check the path on all commands, and double-check the existence of each file you are working with."

I hate to admit this, but I couldn't figure out why nothing was appearing in the device list when I did "adb devices", while the phone was in Fastboot. I did everything from A-Z and tore my hair out for 30 minutes until it hit me, my phone's in Fastboot. I've been messing with Android for 3+ years and made a newbie mistake lol.

Sent from my Nexus 5 using Tapatalk
 

igotdez

Senior Member
May 30, 2011
248
37
58
Hi, maybe you can help me.

Last night I unlocked my N5 using CF-Root, and flashed TWRP using Flashify. However, when I plug my N5 into my home computer it doesn't ever show up under 'My Computer' with other removable storage devices. It is present in the device manager under 'Android Phone -> Google Nexus ADB Interface'.

I've tried restrarting my computer, uninstalling the drivers and reinstalling them. Developer mode is enabled and if I switch from MTP to PTP then is shows up under removable storage, but I only have access to the DCIM folder. Switching back to MTP makes it disappear.

On my work computer it shows up correctly no problem.

My personal computer has had multiple installations of WugFresh Root toolkit and ADB/SDK files for my previous Galaxy Nexus and Nexus 7 but I uninstalled most of that before setting up the N5.

Thanks!
I have the same problem and done the same exact things u did. any help?
 

Whyzor

Senior Member
Jul 7, 2011
714
352
0
I'm having no luck with unlocking bootloader of my Nexus 5 today. I've unlocked previous Android devices fine, but this one for some reason it's not detecting it in USB drivers. It shows as Other devices -> Nexus 5 in device manager, but when I select update driver & navigate to the dir where Android SDK/extras/google/usb_driver

Windows was unable to install your Nexus 5
Windows could not find driver software for your device.

I updated the OTA that came right away earlier, maybe this caused the Windows USB drivers to not work match the updated OTA build? Is there a way to ensure that old windows driver is uninstalled? I can only select 'uninstall', but not the 'remove old driver files' some docs mention. Also when I connect my Nexus 4 it's fine, and enabling debugging mode prompts for to allow the security fingerprint of the PC. But this prompt doesn't appear on Nexus 5, not sure if it's supposed to happen AFTER the PC is able to communicate with the N5 or not, which is the step that I'm stuck on. Tried it on another Windows 7 system and same problem.

UPDATE: Well my Nexus 4 worked fine along with adb until a few minutes ago, after toggling the Debugging Mode on the phone, it's not recognized on Windows now either. So definitely think it's a Windows 7 or Google USB Driver issue. Any pointers on how to start over (without reinstalling Windows) would be appreciated.

UPDATE 2: For future reference, I got around my Windows driver issue by going into Nexus - Settings - Storage - USB computer connection, toggle to Camera (PTP) and Media device (MTP), that reinitialized windows to recognize it in Device Manager again. Stupid Windows.
 
Last edited:

dbareis

Senior Member
May 14, 2010
195
34
0
dennisbareis.com
same issue on my side...I canot use MTP only PTP...I also tryed new drivers from SDK but has not solved the problem
Alex

I'm not sure what happened but on my WINDOWS 7 (64 bit) OS I had to modify "%WINDIR%\inf\wpdmtp.inf" as shown here: "http://forum.xda-developers.com/showpost.php?p=37930602&postcount=937". I then uninstall the device and drivers and performed a hardware scan to get it to work. I also added a "...PID_4EE2&MI_01" line but I am not positive that was required.

Hope that helps someone.
 

buhbuh

Member
Sep 14, 2012
17
0
0
UPDATE 2: For future reference, I got around my Windows driver issue by going into Nexus - Settings - Storage - USB computer connection, toggle to Camera (PTP) and Media device (MTP), that reinitialized windows to recognize it in Device Manager again. Stupid Windows.

That... Thankyou for that info.
I was able to get ADB to work but was not able to get the device to popup as a storage device. That fixed it. Thanks!
 

highend01

Senior Member
Nov 22, 2011
51
8
0
I'm not sure what happened but on my WINDOWS 7 (64 bit) OS I had to modify "%WINDIR%\inf\wpdmtp.inf" as shown here: "http://forum.xda-developers.com/show...&postcount=937".

Thanks, that link was really helpful! I struggled with the correct detection before (seems I had some old drivers for my last phone on that windows installation...)
 

MaxRabbit

Senior Member
Oct 21, 2010
778
227
73
Austin
I'm having no luck with unlocking bootloader of my Nexus 5 today. I've unlocked previous Android devices fine, but this one for some reason it's not detecting it in USB drivers. It shows as Other devices -> Nexus 5 in device manager, but when I select update driver & navigate to the dir where Android SDK/extras/google/usb_driver

Windows was unable to install your Nexus 5
Windows could not find driver software for your device.

I updated the OTA that came right away earlier, maybe this caused the Windows USB drivers to not work match the updated OTA build? Is there a way to ensure that old windows driver is uninstalled? I can only select 'uninstall', but not the 'remove old driver files' some docs mention. Also when I connect my Nexus 4 it's fine, and enabling debugging mode prompts for to allow the security fingerprint of the PC. But this prompt doesn't appear on Nexus 5, not sure if it's supposed to happen AFTER the PC is able to communicate with the N5 or not, which is the step that I'm stuck on. Tried it on another Windows 7 system and same problem.

UPDATE: Well my Nexus 4 worked fine along with adb until a few minutes ago, after toggling the Debugging Mode on the phone, it's not recognized on Windows now either. So definitely think it's a Windows 7 or Google USB Driver issue. Any pointers on how to start over (without reinstalling Windows) would be appreciated.

UPDATE 2: For future reference, I got around my Windows driver issue by going into Nexus - Settings - Storage - USB computer connection, toggle to Camera (PTP) and Media device (MTP), that reinitialized windows to recognize it in Device Manager again. Stupid Windows.
Thank you for sharing your solution.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 45
    Are you getting errors like "device not found" or "device offline" while trying to run ADB commands? Here's a quick way to troubleshoot your problem on Windows.

    Steps
    1. Ensure USB Debugging is enabled in Developer Options.
    2. Verify current Google USB Driver is installed and that Device Manager is using that driver.
    3. Update to latest version of ADB.

    • 1. Ensure USB Debugging is enabled in Developer Options.
    Enable Developer Options by going to Settings -> About Phone and tapping on "Build Number" multiple repeated times. You will be greeted with "You are a developer."

    Now, under Settings -> Developer Options, ensure you check the box for "USB debugging."

    • 2. Verify current Google USB Driver is installed and Device Manager is using that driver.
    You may skip this step if Device Manager lists your phone as "Android Phone -> Android Composite ADB Interface." If it does not, this is likely your root cause.

    Go to the Google USB Driver page and download the latest driver directly from Google. Extract the zip file to a folder you know and will remember in the future.

    Open up Device Manger in Windows with your Nexus 5 connected. Whatever your Nexus 5 is currently detected as, right click on it and select Properties. Then, in the Driver tab, hit "Uninstall." If available, select "Delete the driver software for this device." and hit "OK." It will remove the old drivers.

    Restart your computer.

    After restarting, reconnect your Nexus 5. It should be recognized as an unknown device in the Device Manager. (If it isn't, try the previous driver deletion steps again.)

    Right click on the unknown Nexus 5 device, choose Properties, and in the Driver tab again select "Update driver." Browse your computer manually by putting in the path to the new Google USB Drivers you unzipped to a folder of your choice in the beginning of this step. Choose next and your drivers should install! You'll know everything completed successfully when you see the phone listed under "Android Phone -> Android Composite ADB Interface" in Device Manager.

    This is the most finicky process, so don't be afraid to reboot your computer a time or two and repeat these steps if they don't work on the first try.

    • 3. Update to latest version of ADB.
    This is a crucial step. The new version of ADB is required to work with the "USB debugging authorizations" setting.

    Perhaps you know how to update ADB, in which case, just do it. However, here's a detailed manual approach to download JUST the adb suite from the SDK:
    Go to the Google Android SDK website and choose "Use An Existing IDE" and click the "Download the SDK Tools for Windows." This will allow you to download only an 80 MB file rather than the whole 400 MB suite.

    Install the SDK tools exe to a folder of your choosing.

    Run SDK Manager and uncheck everything except for "Android SDK Platform-tools." This is the ADB and Fastboot bundle. Install that.

    Navigate to your SDK Path as indicated at the top of your Android SDK Manager window. You will now see a freshly downloaded platform-tools folder containing ADB.exe, Fastboot.exe, and a host of other files. That folder is now your updated, portable ADB tools folder. You can move it anywhere you like as long as you run ADB from a command prompt window set to that directory.

    After you've followed these procedures, running "ADB Devices" should trigger a prompt on your device to accept the RSA fingerprint of your computer. Accept it, and now all should be working as intended!

    Questions? Ask below!
    6
    Crowd-sourced solutions.

    Windows 8 Diagnosis
    Yorus said:
    The following worked for me, since all of the suggestions mentioned here didn't work for me:
    If you use a Windows 8.1 enterprise N or KN edition, install the Microsoft Media Feature Pack :
    http://support.microsoft.com/kb/2929699/en
    Sounds too simple to be true but work instantly for me.
    Hope it works you some of the people here looking for a solution

    Setting up ADB and Fastboot commands to work from ANY path (credit to original author in quote).
    Setup, Preparation and Prerequisites

    • ADB and Fastboot Installation
    1. Download the full Android SDK here (scroll to the bottom of the page>DOWNLOAD FOR OTHER PLATFORMS>SDK Tools Only) or get a slimmed version containing only the essential components here (Thanks @El Daddy)
    2. Extract the zip and place the android-sdk-windows folder on the root of your hard drive. (the path should be like this: C:\android-sdk-windows)
      **If you chose to download the slimmed sdk skip to step 5**
    3. Only if you downloaded the full sdk: Go into the folder and run SDK Manager.exe. Install the following packages (there are a total of 4 packages):
      - Tools > Android SDK Tools, Android SDK Platform-tools
      - Extras > Android Support Library, Google USB Driver

    4. Only if you downloaded the full sdk: Go back into the android-sdk-windows directory, and you should see a new folder named platform-tools. If not, repeat the step above.
    5. Open a command prompt window and run "sysdm.cpl" (without the quotes) and a new window should popup. Go to the Advanced tab > Environmental Variables
    6. Now focus your attention to the System variables box (the lower box). Scroll down and look for the Path variable > highlight it > click Edit > go all the way to the end of the Variable value text box, and paste the following entry:
    7. Code:
      ;C:\android-sdk-windows\platform-tools
      (OR WHATEVER PLATFORM-TOOLS DIRECTORY YOU PICKED)
    8. Click OK then close all of the System Properties windows
    9. You should now be able to use adb/fastboot commands no matter what location your command prompt is in. To confirm that it is indeed working, open a command prompt window and enter "adb version" (without the quotes). If it displays "Android Debug Bridge version x.x.xx" it is working. If it is gives an error saying that adb is not a recognized command, it has not been successful. Carefully repeat the steps above if this is the case.

    The importance of being careful with your command choices.
    "Be sure to use the CORRECT adb/fastboot commands, double-check the path on all commands, and double-check the existence of each file you are working with."

    I hate to admit this, but I couldn't figure out why nothing was appearing in the device list when I did "adb devices", while the phone was in Fastboot. I did everything from A-Z and tore my hair out for 30 minutes until it hit me, my phone's in Fastboot. I've been messing with Android for 3+ years and made a newbie mistake lol.

    Fixing MTP device not showing up after installing ADB drivers.
    I'm not sure what happened but on my WINDOWS 7 (64 bit) OS I had to modify "%WINDIR%\inf\wpdmtp.inf" as shown here: "http://forum.xda-developers.com/showpost.php?p=37930602&postcount=937". I then uninstall the device and drivers and performed a hardware scan to get it to work. I also added a "...PID_4EE2&MI_01" line but I am not positive that was required.

    Hope that helps someone.

    You should also mention what worked for me in post #16 (& confirmed by a few others in other threads). That is to toggle Settings - Storage - USB Connection type from Camera to Mass storage & also the debugging mode on & off.

    Op might wanna tack this onto the bottom of the main post as a last resort for folks to "start over" and be sure they have no old drivers installed.

    http://www.nirsoft.net/utils/usb_devices_view.html

    i had to use this program (right click run as admin if permissions are set) to remove EVERY single android related driver in order to get mine working.. turns out i had so many old ones in my system and some i couldn't remove from the device manager, the buttons wouldn't become click able..

    I've tried everything and cannot get the authorization prompt to pop up on my Nexus5 so when I run adb devices the phone shows up as "unauthorized". Any suggestions? This is with updated sdk and USB drivers. Device manager shows phone as "Android Phone->Android Composite ADB Interface" and "Portable Device->Nexus 5". Tried toggling between MTP/PTP, USB Debugging on/off, stopping and starting the adb server (latest version 1.0.31).

    Thanks in advance!

    EDIT: Finally got the ba$tard! Run this for some adb debug logging:

    adb kill-server
    set ADB_TRACE=all
    adb nodaemon server

    Go and look back at the output from the start for any errors. In my case it couldn't mkdir in c:\users\administrator, which for me doesn't exist. I changed the Windows environment variable "ANDROID_SDK_HOME" to point to "C:\users\<my account dir>", closed the DOS window, re-ran the commands and I got prompted for the permission on my phone. Yee ha! Now I can fire up hello world with the SDK on my phone. Praise be to Google search for turning up this thread that told me about the debug logging.

    I just rooted my N5 (using the guide on this forum so I had no other drivers other than Google's SDK) and after unlocking my bootloader windows did not recognize my phone so I couldn't go further. Upon checking device manager I saw something called "AOSP on Hammerhead", a quick online search found a lot of very complicated answers (uninstall all drivers, restart, install adb drivers was one example).

    Instead of all that I just right clicked "AOSP on Hammerhead", chose Update Driver, manually choose driver, went to "Android bootloader", chose the default driver from "Google inc" manually and that for some reason worked.

    I figured this might help someone since the other solutions I found really were very long.

    Questions? Ask below!
    3
    I just rooted my N5 (using the guide on this forum so I had no other drivers other than Google's SDK) and after unlocking my bootloader windows did not recognize my phone so I couldn't go further. Upon checking device manager I saw something called "AOSP on Hammerhead", a quick online search found a lot of very complicated answers (uninstall all drivers, restart, install adb drivers was one example).

    Instead of all that I just right clicked "AOSP on Hammerhead", chose Update Driver, manually choose driver, went to "Android bootloader", chose the default driver from "Google inc" manually and that for some reason worked.

    I figured this might help someone since the other solutions I found really were very long.
    3
    I'm having no luck with unlocking bootloader of my Nexus 5 today. I've unlocked previous Android devices fine, but this one for some reason it's not detecting it in USB drivers. It shows as Other devices -> Nexus 5 in device manager, but when I select update driver & navigate to the dir where Android SDK/extras/google/usb_driver

    Windows was unable to install your Nexus 5
    Windows could not find driver software for your device.

    I updated the OTA that came right away earlier, maybe this caused the Windows USB drivers to not work match the updated OTA build? Is there a way to ensure that old windows driver is uninstalled? I can only select 'uninstall', but not the 'remove old driver files' some docs mention. Also when I connect my Nexus 4 it's fine, and enabling debugging mode prompts for to allow the security fingerprint of the PC. But this prompt doesn't appear on Nexus 5, not sure if it's supposed to happen AFTER the PC is able to communicate with the N5 or not, which is the step that I'm stuck on. Tried it on another Windows 7 system and same problem.

    UPDATE: Well my Nexus 4 worked fine along with adb until a few minutes ago, after toggling the Debugging Mode on the phone, it's not recognized on Windows now either. So definitely think it's a Windows 7 or Google USB Driver issue. Any pointers on how to start over (without reinstalling Windows) would be appreciated.

    UPDATE 2: For future reference, I got around my Windows driver issue by going into Nexus - Settings - Storage - USB computer connection, toggle to Camera (PTP) and Media device (MTP), that reinitialized windows to recognize it in Device Manager again. Stupid Windows.
    3
    I think I've tried pretty much every solution in this thread. The problem I'm having is that there is no device listed in my Device Manager under Other Devices. I do get Android Device -> Google Nexus ADB device but if I try to update the drivers for that I get a message that the drivers are up do date.

    But the main problem is that I don't get a device in Explorer that I can drag and drop to. I'd like to be able to just plug my phone into my computer and drag files to it. That is the biggest frustration I'm having right now. Windows 8 btw. If anyone has any help that hasn't already been suggested, or something I may be missing, please let me know.

    That's what i had. Make sure usb debugging is off. Put it in mtp mode and plug in. Find that Android device, update driver and manually pick one yourself. Find the one that says composite or mtp driver and pick it

    Sent from my Nexus 5 using Tapatalk
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone