Question Disable doze?

Search This thread

96carboard

Senior Member
Jul 17, 2018
958
585
This is an issue with the introduction of doze. I can confirm that on every single Android phone I've used since doze was introduced "think it was marshmallow, could be wrong". I have experienced this issue with all my pixel phones up to 4xl, Galaxy s21 Ultra, and OnePlus 7 Pro and 8 Pro. Executing "dumpsys deviceidle disable" via rooted device in terminal or the adb command via computer fixes the issue 100% every time. I also experience no extra battery drain. Google simply needs to get rid of doze it's no longer needed. I carry an iPhone along with my android of choice and only when device idle is disabled do I get my notifications instantly just like I do without fail on my iphone. It's very depressing to have to jump through hoops to get important instant notifications on an Android phone.

If I were to guess, all your notifications go through gooble, right? Software that gets notified directly doesn't have the doze problem because those programs can be selectively granted unrestricted battery access.

But the goog notifications problem is that there are a bunch of separate parts that it has to feed through, and while they do force some of it unrestricted, it seems that the unrestricted state misses some important component.

The ultimate solution, therefore, is to wean yourself off of goog.
 

amwbt

Senior Member
A lot of these notifications I won't get unless I unlock my screen. Or I plug it into a charger. This is directly due to the device idle, I have tested everything over my career with Android and it is simply linked to device idle you will not convince me otherwise. I've been using Android since Android was developed.
 
  • Like
Reactions: xalyy

amwbt

Senior Member
The only app that always comes through directly and instantly every time even if I haven't used my phone in 10 plus minutes is the Google messaging app. Everything else has been delayed 5 10 20 minutes and then sometimes not even tell like I said I unlocked my phone or I plug it into a charger.
 
  • Like
Reactions: xalyy

96carboard

Senior Member
Jul 17, 2018
958
585
No sir. It's not all Google apps. Happens to MyQ app which tells me when my garage door opens and closes. Facebook Messenger, discord, Verizon messages Plus. There are others I just can't remember them off the top of my head.

I didn't say "google apps" I said software that USES gooble for transferring notifications.
 

96carboard

Senior Member
Jul 17, 2018
958
585
Even if that were the case that's still stupid because there's so many apps out there that have to use Google's software I mean it's Google, Android is Google so they just need to fix it. Not all the apps that I use connect through Google for notifications.

Not correct, Android is NOT GOOBLE. Android is AOSP. Gooble is closed source crap that gets mixed into Android.

How do you know if something connects through or not?
 
  • Angry
Reactions: xalyy

amwbt

Senior Member
Not correct, Android is NOT GOOBLE. Android is AOSP. Gooble is closed source crap that gets mixed into Android.

How do you know if something connects through or not?
Like I said, wether it is or not. It's a problem that Google needs to fix. I don't know how you use your phone, but you can't simply stop using apps that connect through Google when almost everything you use connects through Google if you need automated home items that use Google home. Plus all kinds of other apps. We're talking about Android devices that the public use not people like you that may run asop or custom roms. It's something that Google can fix, and they need to fix it. That's simply all I'm saying and disabling device idle fixes that problem for me for every app that I need it too and will help the majority of the public that use these phones and want to use the apps that they want to use, even if they so happen to be Google apps.
 
  • Like
Reactions: xalyy

96carboard

Senior Member
Jul 17, 2018
958
585
Like I said, wether it is or not. It's a problem that Google needs to fix. I don't know how you use your phone, but you can't simply stop using apps that connect through Google when almost everything you use connects through Google if you need automated home items that use Google home. Plus all kinds of other apps. We're talking about Android devices that the public use not people like you that may run asop or custom roms. It's something that Google can fix, and they need to fix it. That's simply all I'm saying and disabling device idle fixes that problem for me for every app that I need it too and will help the majority of the public that use these phones and want to use the apps that they want to use, even if they so happen to be Google apps.
I honestly couldn't care less what "other people" use. Nor do I care if they fix whatever stupid problem there is that is making notifications not work correctly.

In fact, I'd go so far as to say that in the long run it would be a LOT BETTER if they KEPT it nice and broken, because that will prompt software developers not to rely on their broken services to deliver messages to users.

I do NOT have any of their closed binary components installed. I do NOT use anything that sends notifications via their services. I absolutely refuse to have them monitoring traffic to and from my devices. I *have* written my own push notifications service for some things that I use.

I firmly believe that the best way forward for everyone (except those trying to make a profit out of spying on people) is to ensure that there is no reliance on any closed source software components.
 
  • Angry
  • Like
Reactions: zaptastic and xalyy

amwbt

Senior Member
Hey man I understand exactly what you're saying. I don't like it either, but I'm not in the same wavelength as you are as far as how to use android. I can install custom roms root devices and all that stuff but I don't go that far into it I just need a device that works and delivers notifications when I need them. But I commend you for everything you just said because that would be great.
 

RetroTech07

Senior Member
Apr 24, 2021
369
275
Google Pixel 2 XL
Google Pixel 6 Pro
One of my biggest gripes about Android is the fact that notifications are often delayed. This is because Google has implemented doze - a feature which saves battery life. That's great 'n all, but I absolutely need my notifications ASAP as they're paramount to my business.

I've used the following adb command for a while now to disable doze: adb shell dumpsys deviceidle disable. I know this only works until you restart your phone, but I don't mind doing the command line once a week.

However, it looks like this command does not work for the Pixel 6 Pro. I'm not sure why, but it just doesn't. At first, I thought it may have been an Android 12 issue, but that turned out to be completely incorrect as my new S22 Ultra that's on Android 12 suffered the same delayed notifications ailment, but was remedied by the aforementioned adb command. Now my S22 Ultra gets Gmail/push notifications immediately and on time. So it might be the SoC that's to blame for some reason.

I like the Pixel 6 Pro, I really do. I enjoy Google's UI, the physical look of the phone, etc. but I cannot keep a phone that does not receive notifications on time. Is there a different adb command or a way to disable doze to get notifications on time on the Pixel 6 Pro?

And before anyone recommends it - yes I've tried not optimising Gmail, different email apps, and all the app workarounds - nothing works. Same applies for the S22 Ultra and all my previous Android phones. Only disabling doze allows for push notifications to come through on time.

Any help would be greatly appreciated as I'm not keen on keeping this S22 Ultra, but will if there's no genuine workaround for disabling Doze on the Pixel 6 Pro.

Cheers!
Try running this command to disable doze and see if it helps you:

Code:
adb shell dumpsys deviceidle disable

You can also try to whitelist one app to see if notifications come through normally...

Code:
adb shell dumpsys deviceidle whitelist +<package name>

I hope this helps.
 
Last edited:

remoh

Member
Feb 6, 2008
21
3
Try running this command to disable doze and see if it helps you:

Code:
adb shell dumpsys deviceidle disable

If you have root get DozeOff from F-Droid, it does (only) this automatically on reboot.
Im my case, with MIUI, the ONLY way to get Notifications from Gmail working without unlock. All other apps get notifications without problems. Disabling Battery optimization for gmail does not help.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hey man I understand exactly what you're saying. I don't like it either, but I'm not in the same wavelength as you are as far as how to use android. I can install custom roms root devices and all that stuff but I don't go that far into it I just need a device that works and delivers notifications when I need them. But I commend you for everything you just said because that would be great.
    2
    Hi
    I assumed just like you that the problem is with doze .
    But , after using the adb command everything works fine except Gmail.
    So I replaced Gmail with other email client and now everything just fine.
    2
    I have seen one user report that the adb command to disable doze does work on the Pixel 6 Pro. Not sure how accurate that report was though.

    Maybe also try adb shell dumpsys deviceidle disable whitelist + <app package name>

    You may want to check what app bucket the apps you want instant notifications for are in (Developer Options>Standby Apps). If they are in either Active or Working Set you "should" be getting notifications on time. If they aren't set to one of those categories you can try changing it to Active or Working Set, although the app may just change it back.

    @AhsanU
    1
    One of my biggest gripes about Android is the fact that notifications are often delayed. This is because Google has implemented doze - a feature which saves battery life. That's great 'n all, but I absolutely need my notifications ASAP as they're paramount to my business.

    I've used the following adb command for a while now to disable doze: adb shell dumpsys deviceidle disable. I know this only works until you restart your phone, but I don't mind doing the command line once a week.

    However, it looks like this command does not work for the Pixel 6 Pro. I'm not sure why, but it just doesn't. At first, I thought it may have been an Android 12 issue, but that turned out to be completely incorrect as my new S22 Ultra that's on Android 12 suffered the same delayed notifications ailment, but was remedied by the aforementioned adb command. Now my S22 Ultra gets Gmail/push notifications immediately and on time. So it might be the SoC that's to blame for some reason.

    I like the Pixel 6 Pro, I really do. I enjoy Google's UI, the physical look of the phone, etc. but I cannot keep a phone that does not receive notifications on time. Is there a different adb command or a way to disable doze to get notifications on time on the Pixel 6 Pro?

    And before anyone recommends it - yes I've tried not optimising Gmail, different email apps, and all the app workarounds - nothing works. Same applies for the S22 Ultra and all my previous Android phones. Only disabling doze allows for push notifications to come through on time.

    Any help would be greatly appreciated as I'm not keen on keeping this S22 Ultra, but will if there's no genuine workaround for disabling Doze on the Pixel 6 Pro.

    Cheers!
    1
    Disabling battery optimization (long press app icon - app info - battery) essentially turns off doze for that particular app. If it's just emails/Gmail you're worried about, do that for the Gmail app. You'll theoretically get your emails on time, and the rest of your phone can zzzzzzzz in peace.

    Also of note, Samsung changes a **** ton of the aosp code before using it for their OneUI ROM. It very well may be an Android 12 change than Samsung either reverted or did something else with.