Disable WiFi? ? ?

[email protected]il.com

Senior Member
May 11, 2014
69
21
0
Hi

Does anyone know a way to keep WiFi from switching ON?

Iv'e tried the settings.apk to turn it OFF but it seems to reactivate itself. Or another app is switching on.
Trying to find an app that will do it, but no luck so far.
This would be simple on a regular android device.

I prefer a wired connection and would like the WiFi to stay OFF.

Thanks
 
  • Like
Reactions: trevmar

Y314K

Senior Member
Dec 29, 2008
1,489
487
0
Hi

Does anyone know a way to keep WiFi from switching ON?

Iv'e tried the settings.apk to turn it OFF but it seems to reactivate itself. Or another app is switching on.
Trying to find an app that will do it, but no luck so far.
This would be simple on a regular android device.

I prefer a wired connection and would like the WiFi to stay OFF.

Thanks
Just go to Settings/System/Network & press the 3 _ line button for any Wifi Network you had saved. Now it should not be able to connect to any Wifi. And it shouldn't try as long as you have an Ethernet cable plugged in...
 
  • Like
Reactions: [email protected]

[email protected]

Senior Member
May 11, 2014
69
21
0
Just go to Settings/System/Network & press the 3 _ line button for any Wifi Network you had saved. Now it should not be able to connect to any Wifi. And it shouldn't try as long as you have an Ethernet cable plugged in...
Thanks

I was able to get it to forget my network as you suggested.

The FireTV seems to have the WiFi signal turned on even when connected through ethernet.

I've tried a few WiFi manager apps to disable WiFi completely.

My WiFi signal detector always shows a signal from the AFTV, except when it's unplugged.
 
  • Like
Reactions: trevmar

Hill16

Member
Jun 26, 2014
28
4
0
Thanks

I was able to get it to forget my network as you suggested.

The FireTV seems to have the WiFi signal turned on even when connected through ethernet.

I've tried a few WiFi manager apps to disable WiFi completely.

My WiFi signal detector always shows a signal from the AFTV, except when it's unplugged.
Yeh - I think I have the same issue. My connection showing wired, I ran a speedtest and getting 45mb (I have 120mb braodband).
The Remote App also works which tells me I am still wireless.
 
  • Like
Reactions: trevmar

[email protected]

Senior Member
May 11, 2014
69
21
0
Disable wlan module ? ?

I tried to disable the wifi module (wlan.ko in /system/lib/modules) by renaming it, but it just created a new copy.

There must be an app to freeze or disable somewhere.
 
  • Like
Reactions: trevmar

Y314K

Senior Member
Dec 29, 2008
1,489
487
0
Yeh - I think I have the same issue. My connection showing wired, I ran a speedtest and getting 45mb (I have 120mb braodband).
The Remote App also works which tells me I am still wireless.
I tried to disable the wifi module (wlan.ko in /system/lib/modules) by renaming it, but it just created a new copy.

There must be an app to freeze or disable somewhere.
Wonder if one only uses the Wired option since the first Setup will it make a difference.. Doubt it.. But wonder... Maybe it has to do with the new FW that includes the Remote app support...
 
  • Like
Reactions: trevmar

jokatsim

Member
May 31, 2013
8
0
0
Wonder if one only uses the Wired option since the first Setup will it make a difference.. Doubt it.. But wonder... Maybe it has to do with the new FW that includes the Remote app support...
Anyone wondering what type of connection your remote has and probably get an answer on why WiFi is always on?
 

Bailx

Senior Member
Feb 24, 2012
103
22
38
just a thought, but maybe an app like d-vasive would do the trick... just disable wifi through the app (and leave bluetooth on for the remote)
 
Dec 5, 2019
7
0
0
My WiFi signal detector always shows a signal from the AFTV, except when it's unplugged.
The Amazon Fire TV stick broadcasts its own wireless signal even while connected via ethernet.

Peer-reviewed scientific papers on health effects of wireless radiation are abundant. Here's 1: ehtrust.org/science/research-on-wireless-health-effects/
Kids are way more vulnerable because they absorb way more radiation. Pisses me off that I can't see a way to disable it. IoT devices should come with a way to disable broadcasting a signal and default set to 'off'!

Does anyone know of a way to disable the function that makes the Amazon Fire TV stick broadcast it's own IoT wireless signal?

Any help would be much appreciated! thanks
 

Pgold1

New member
Jan 19, 2020
1
1
0
I would also like to disable wifi on the firestick as well. I do not want wifi signals coming from the firestick trying to find a wifi connection if it is plugged in via ethernet. I am trying to avoid EMFs exposure.
 
  • Like
Reactions: ldeveraux

TimmyP

Senior Member
Mar 5, 2008
282
47
48
The remote is WFD (Wifi Direct, not Bluetooth) and there is no way to turn this off. Wifi for data is off when it is plugged in as wired.
 

treboR2Robert

Senior Member
Jan 23, 2012
63
46
38
I too have got rid of EVERYTHING wifi or bluetooth in my home.

I was hoping i could disable bluetooth and wifi completely on the fire tv stick 4k.

I am using my infrared TV remote to control it through CEC.

I connected to it remotely via ADB and executed these two commands

adb shell settings put global bluetooth_on 0

adb shell svc wifi disable

Unfortunately although the commands seemed to work, the fire tv is still emitting huge amounts of EMF.

Any clever people here have any ideas to disable Bluetooth and wifi completely ?

Thanks in advance
 

treboR2Robert

Senior Member
Jan 23, 2012
63
46
38
For anyone who is interested I found a way to do this and it is VERY simple.

How to enable Apps from Unknown Sources on an Amazon Fire TV or Fire TV Stick

From the Fire TV or Fire TV Stick's home screen, scroll to “Settings”.
Next, scroll to the right and select “My Fire TV”. ( ...
Next, scroll down and select “Developer options”.
Then select “Apps from Unknown Sources” to turn the option to “ON”.

THEN

Search for and install "downloader" on the fire stick

Use downloader to download and install an app called "Smart Quick Settings" i got it from here but the apk is available other places too.

Open Smart quick settings and toggle wifi and bluetooth off, and that's it all done... Simple :)

I have confirmed using my RF meter that it is no longer transmitting anything at all bluetooth or wifi.

One thing to watch though is if you restart the fire stick or shut it down then bluetooth automatically turns itself back on, as long as you remember to just go back into "smart quick settings" and turn it back off then its no problem but personally i set my tv CEC settings to not send shut down or wake up commands so when i turn my tv off the fire stick just stays on all the time.
Only if it needs a restart for updates does it get restarted.

Hope this helps someone :)
 
Last edited:
  • Like
Reactions: Barney22

AmznUser444 Dev

Senior Member
May 19, 2019
721
98
28
Turning off the Bluetooth on your Fire TV and keeps turning on that you gets hijacked on Bluetooth is called Bluejacking.

To disable the Bluetooth completely that you don't needed. You have to disable the Bluetooth Share app on it.
 

Barney22

Member
Jan 12, 2021
5
0
1
For anyone who is interested I found a way to do this and it is VERY simple.

How to enable Apps from Unknown Sources on an Amazon Fire TV or Fire TV Stick

From the Fire TV or Fire TV Stick's home screen, scroll to “Settings”.
Next, scroll to the right and select “My Fire TV”. ( ...
Next, scroll down and select “Developer options”.
Then select “Apps from Unknown Sources” to turn the option to “ON”.

THEN

Search for and install "downloader" on the fire stick

Use downloader to download and install an app called "Smart Quick Settings" i got it from here but the apk is available other places too.

Open Smart quick settings and toggle wifi and bluetooth off, and that's it all done... Simple :)

I have confirmed using my RF meter that it is no longer transmitting anything at all bluetooth or wifi.

One thing to watch though is if you restart the fire stick or shut it down then bluetooth automatically turns itself back on, as long as you remember to just go back into "smart quick settings" and turn it back off then its no problem but personally i set my tv CEC settings to not send shut down or wake up commands so when i turn my tv off the fire stick just stays on all the time.
Only if it needs a restart for updates does it get restarted.

Hope this helps someone :)
Hi, I have used the above method to try and turn off wifi on firestick and everything has gone well with "smart quick settings" now on the firestick as an app but when I get onto the page with all the different settings on it it wont let me scroll down to wifi settings to turn it off(it wont let me scroll down to any of the settings on page 1 or 2). Would appreciate any help on how to overcome this or if anyone has found a different method to disable wifi/Bluetooth settings on the Kindle firestick,
Thanks Barney
 

treboR2Robert

Senior Member
Jan 23, 2012
63
46
38
Hi, I have used the above method to try and turn off wifi on firestick and everything has gone well with "smart quick settings" now on the firestick as an app but when I get onto the page with all the different settings on it it wont let me scroll down to wifi settings to turn it off(it wont let me scroll down to any of the settings on page 1 or 2). Would appreciate any help on how to overcome this or if anyone has found a different method to disable wifi/Bluetooth settings on the Kindle firestick,
Thanks Barney

It doesn't look like anything is moving but it actually is.

For bluetooth I think i just press the down button 3 times ( just count how far down it is) and the click select on the remote and you will see it toggle the setting on and off.

to turn it back on you have to press right after going down to the option, again you don't see anything move but it does move.
 

Barney22

Member
Jan 12, 2021
5
0
1
It doesn't look like anything is moving but it actually is.

For bluetooth I think i just press the down button 3 times ( just count how far down it is) and the click select on the remote and you will see it toggle the setting on and off.

to turn it back on you have to press right after going down to the option, again you don't see anything move but it does move.
Thanks for the reply,
Tried it but when we click on it to try and alter Bluetooth it automatically switches
from Smart Quick settings to the firestick settings page and when we try to alter Wifi settings it sends us to the firestick network page which shows we are connected to Ethernet, when we press select on this it asks for an IP address-unsure which IP address to put in.