• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Disabling Moisture sensor?

Search This thread

MazAbdullah

New member
Jun 20, 2015
2
0
Hi, A couple of days ago I had the misfortune of getting "Moisture in the usb port" notification and since then my G6 won't charge when turned on (it does when it's off but that's not a real solution).

I've tried a lot of things, but none work.

Is there any way to disable the "moisture sensor"?

I was thinking there has to be a way to disable it by messing with the kernel or maybe a custom a rom.

I am not a developer but I can tinker with the code, I just need some pointers or anyone willing with some experience willing to help. Or maybe even some documentation (I don't know if I'll be able to parse it or not but it's worth a shot)

PS. I have ruled out hardware issues as best I can. If it is still a hardware issue then I guess I'll have to replace the charging port and the parts with it.
PPS. I can't have it replaced because there is no official store or anything else here and I have the canadian model. (h 873)
 

Jose1927

New member
May 27, 2018
1
0
Same issue here

I am having the same problem after the update a couple days ago. Never had issue until the recent update. I have looked through all settings and can’t find how to turn off.
 

gabytzubc

Senior Member
Aug 12, 2014
372
118
It an option or should be in the hidden menu settings. Just like this
 

Attachments

  • Screenshot_2018-05-27-18-18-04.png
    Screenshot_2018-05-27-18-18-04.png
    156.5 KB · Views: 7,834

chakchak

Senior Member
Mar 31, 2011
99
44
Houston
I have both ..but didn't try on my g6 becoz I didn't had problems..I will check now.. the print is from my v30

the reason I asked you because thats only on LG V30, not on LG G6 with Nougat. :eek:

---------- Post added at 09:17 AM ---------- Previous post was at 09:17 AM ----------

I had previously checked for this setting when having moisture issues. It was not there on Nougat. However on Oreo it is there. NiceView attachment 4513327View attachment 4513328

Sent from my LG-H870 using Tapatalk

A really good new for me, thanks for letting me know :highfive:
 

christopherrrg

Senior Member
Sep 15, 2011
1,835
881
32
Hamilton
the reason I asked you because thats only on LG V30, not on LG G6 with Nougat. :eek:

---------- Post added at 09:17 AM ---------- Previous post was at 09:17 AM ----------



A really good new for me, thanks for letting me know :highfive:

For future reference the numbers in the beginning spell LGMENU on the dialer and the 3 digits at the end is whatever your device model number/name is.

So essentially this works on ALL LG phones.
 
  • Like
Reactions: pikui and Andvoid

jdock

Senior Member
Dec 27, 2011
248
63
Turning this setting off did not make any difference for me and I've seen other reports of that as well.
Someone said you can kill off "LG System Services" - yeah, that stops the notification, but for me still doesn't let the phone charge.
The first time this happened a couple days ago I was able to charge with the power off, and the warning actually went away for most of yesterday, but came back last evening. It's gone away occasionally but my phone still will not charge via USB. Now even with the phone off, I get a pictorial version of the same warning on the screen.

It's off to second-year promise land for me.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    the reason I asked you because thats only on LG V30, not on LG G6 with Nougat. :eek:

    ---------- Post added at 09:17 AM ---------- Previous post was at 09:17 AM ----------



    A really good new for me, thanks for letting me know :highfive:

    For future reference the numbers in the beginning spell LGMENU on the dialer and the 3 digits at the end is whatever your device model number/name is.

    So essentially this works on ALL LG phones.
    1
    *#546368#*873#

    Type that in your dialer and it will open the settings he posted above.

    Sent from my LG-H873 using XDA Labs
    1
    I had previously checked for this setting when having moisture issues. It was not there on Nougat. However on Oreo it is there. NiceView attachment 4513327View attachment 4513328

    Sent from my LG-H870 using Tapatalk