Disabling standby/sleep entirely for Tasker AutoRemote

Search This thread

jgariano

Member
May 2, 2011
9
0
Short version:
Is there a way, with or without root, to completely disable standby/sleep mode on an Android tablet?

Long version:
I have a Pixel C tablet (running Android 7.1). I've written a set of Tasker profiles and tasks that wait for IFTTT Maker messages via AutoRemote and then act on them. I've got these profiles and tasks running on the Pixel C tablet, and am invoking various IFTTT activities from my and my wife's phones. Basically, the Pixel C tablet is acting as a home automation server that's commanded by IFTTT via AutoRemote.

I've noticed that it works well (~5 second delay) when the tablet screen is on. That delay is the time it takes to go out to IFTTT and back, and is acceptable. But when screen is off, it can take a long time to respond to the IFTTT commands (sometimes a minute or more). I know it's not the Internet itself, because when I unlook it's screen, I'll sometimes see a bunch of toast AutoRemote toast messages show up from a while ago that I sent while it's screen was off. I'm assuming this has to do with the tablet's standby/sleep mode. I've set both Tasker and AutoRemote to not do battery optimization, which I thought would keep those processes from dozing off. But that didn't fix things.

If needed, I'd be willing to have the tablet never go into any type of standby mode, even if that required root. I don't use the tablet much for other purposes, it's usually just plugged in sitting on a desk. Does anyone know of a way to fully disable sleep mode like that, or at least prevent all processes related to Tasker/AutoRemote/incoming IFTTT messages from sleeping?

Thanks,
Joe