• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[DISCONTINUED][ROM][OFFICIAL][gta4xlwifi][10] LineageOS 17.1 for Galaxy Tab S6 Lite (Wi-Fi)

Search This thread

Linux4

Senior Member
1607247455067.png

LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions:
Note: You may use Odin instead of Heimdall, for this you will need to rename the recovery image to recovery.img and pack it into a tar archive.

Downloads:

Warning: 17.1 is now discontinued, use 18.1 instead

Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:

Did you--
wipe:
restore with titanium backup:
reboot after having the issue:

Are you using--
a task killer:
a non-stock kernel:
other modifications:

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


Support
Telegram group

Contributors
Linux4
Source Code: https://github.com/LineageOS
 
Last edited:

Michael Ion

Member
Jun 1, 2016
11
0
any plans the lte edition, it really is sad people dont make anything for this version I don't actually care for the lte I just happened to have bought it second hand. EDIT: nevermind just saw the actual version
 

Beneter

Senior Member
Jul 19, 2015
50
99
Works great for me!
For anyone interested: Netflix and Nanolx microG patcher do not work out-of-the-box.

Edit: Netflix does work after using MagiskHide Props and selecting the Galaxy Tab S5e Fingerprint, clearing the Playstore Cache and activating Magisk Hide for Netflix.
 
Last edited:

bose301s

Senior Member
Mar 3, 2010
312
44
Carrboro, NC
OK, I have followed the directions on the LineagOS Wiki, got the bootloader unlocked, went into the system again, got onto the WiFi, verified that Allow OEM Unlock was greyed out in the on position. I then flashed the LineageOS Recovery in ODIN and booted into it, then did a Factory Reset/Wipe Data and then used adb sideload to install the latest nightly and ARM64 Stock OpenGAPPs and then reboot, I am then stuck on the boot screen for LineageOS. Any ideas on what I need to do?
 

mu1989

Senior Member
Feb 22, 2020
102
33
OK, I have followed the directions on the LineagOS Wiki, got the bootloader unlocked, went into the system again, got onto the WiFi, verified that Allow OEM Unlock was greyed out in the on position. I then flashed the LineageOS Recovery in ODIN and booted into it, then did a Factory Reset/Wipe Data and then used adb sideload to install the latest nightly and ARM64 Stock OpenGAPPs and then reboot, I am then stuck on the boot screen for LineageOS. Any ideas on what I need to do?

Have you taken the correct gapps version, for Android 10???
First lineage flashing, then rebooting and then gapps flashing, the first time
 

dgo65

Member
Jan 6, 2021
7
0
Thank you Linux4. I love LineagOS.
I have an Installation generic Problem for this device.
I you have any Idea...Perhaps you already had this...
Thank you for your job.
Best Regards.
 

SvenHee

Senior Member
Sep 11, 2014
175
17
Ede
I tried installing the update 0601 yesterday and that went wrong, kept booting to twrp.

I did a factory reset an installed the same version again but it seems to be throwing all kinds of problems.
At first some but not all apps would not start.
I factory-reset again and installed agian.

Now apps do start but not all apps reinstalled from the google backup.
I now want to install autodesk sketchbook but I get a message to place an sd card, which in fact is present and can be read.

I just now looked at what is available in the internal storage but that seems litterally all to be mangled, even though the apps I could install all seem to work.
Not a single recognizable folder present.

Did I omit anything with wipe/factoryreset?
 

Linux4

Senior Member
I tried installing the update 0601 yesterday and that went wrong, kept booting to twrp.

I did a factory reset an installed the same version again but it seems to be throwing all kinds of problems.
At first some but not all apps would not start.
I factory-reset again and installed agian.

Now apps do start but not all apps reinstalled from the google backup.
I now want to install autodesk sketchbook but I get a message to place an sd card, which in fact is present and can be read.

I just now looked at what is available in the internal storage but that seems litterally all to be mangled, even though the apps I could install all seem to work.
Not a single recognizable folder present.

Did I omit anything with wipe/factoryreset?

Please just stick to lineage recovery,
I'm almost sure all of these are being caused by TWRP.
Probably the reboot to twrp thing was even caused by TWRP messing with FBE again ... Did it show "Android Rescue Party Trigger" maybe ?
 

Linux4

Senior Member
Thanks for the quick reply!
Is this a general lineage twrp thing, or specific to the s6-L?

I had read the guide saying to install lineage recovery but not to only use it.
Will give it a go later today.

It should be a general problem on every device running a ROM with FBE enabled but decryption not working in TWRP
Actually you can use twrp as long as you don't touch /data (wipe and such things) but looks like OTAs through twrp don't work too..
Or did your gapps addon.d maybe not run after the OTA? That would effectively have gapps uninstalled and might cause a reboot to recovery too
 

dgo65

Member
Jan 6, 2021
7
0
It should be a general problem on every device running a ROM with FBE enabled but decryption not working in TWRP
Actually you can use twrp as long as you don't touch /data (wipe and such things) but looks like OTAs through twrp don't work too..
Or did your gapps addon.d maybe not run after the OTA? That would effectively have gapps uninstalled and might cause a reboot to recovery too
I had the same problem with an installation with Heimdall. After that I have installed the version 1230 without problem
 

dgo65

Member
Jan 6, 2021
7
0
Thank you Linux4. I love LineagOS.
I have an Installation generic Problem for this device.
I you have any Idea...Perhaps you already had this...
Thank you for your job.
Best Regards.
At the end I found the solution. After the "Preparing for installation" process I had to follow this procedure.
Before to follow with the installation.
Only if anybody as the same problem.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    1607247455067.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions:
    Note: You may use Odin instead of Heimdall, for this you will need to rename the recovery image to recovery.img and pack it into a tar archive.

    Downloads:

    Warning: 17.1 is now discontinued, use 18.1 instead

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


    Support
    Telegram group

    Contributors
    Linux4
    Source Code: https://github.com/LineageOS
    1
    Looks awesome man. Why Android 10 when you have an unofficial build of 11?

    Development of 10 (LOS 17.1) has reached maturity and stability enough, and thanks to having @Linux4 on our side and his work / dedication, to push into Lineage's "official" status. While the 11 (LOS 18.1) builds are not yet "official" yet, and in some ways still a big WIP.

    You might notice plenty of other devices never end up with an "official" build of LOS / certain versions. Sometimes it's even just a matter of if the dev just doesn't want to bother submitting an application to Lineage to bring it to official status. Or maybe certain hardware components aren't working and / or never feasibly will outside of stock (Samsung is famous for keeping some of their device drivers / kernels completely closed-source. Also I ditched Samsung phones after Galaxy S5 because they locked down the Snapdragon variants so hard, even on previously unlockable carrier variants like T-Mobile - while many regions particularly outside of USA had Exynos variants with unlockable BL and such).

    Anyway, I did have a question for ya @Linux4: I just flashed the 01/13/2021 update over installed 01/06/2021 system using Lineage Updater. This went as smoothly as anyone can ask for, except that I noticed I lost root after booting back up, and I had to flash Magisk again afterwards (can just flash the zip in Lineage Recovery, no big deal). Apparently Lineage Updater/Recovery must have ignored or missed the Magisk addon.d script? Gapps (OpenGapps "Stock") persisted though, and no Google apps / services seem wonky at all. I can only assume the Magisk addon.d script was there before OTA, but of course I can't know for sure after the fact. I checked just now and see it, so I'll keep my eyes on it when next OTA comes around. (I have 50-lineage.sh, 70-gapps.sh, and 99-magisk.sh - all looks as it should be)

    On another note - just use Lineage Recovery for now, people! Unfortunately I learned my lesson last week, when I tried to flash the OTA with TWRP and ended up in bootloop, due to ignoring warnings about FBE. Flashing back to 12/30/2020 didn't work either, whether with TWRP or Lineage Recovery, so I had to factory wipe. Oops.

    Edit: one more question: does Lineage Recovery also get updated when flashing the new system update / OTA? Or would we need to do that manually via odin / sdk tools / terminal? And (if not automatically updated) when would we know when it's actually necessary / when we should actually bother? Sorry, I'm actually new to Lineage Recovery myself... Thanks L!
    1
    Development of 10 (LOS 17.1) has reached maturity and stability enough, and thanks to having @Linux4 on our side and his work / dedication, to push into Lineage's "official" status. While the 11 (LOS 18.1) builds are not yet "official" yet, and in some ways still a big WIP.

    You might notice plenty of other devices never end up with an "official" build of LOS / certain versions. Sometimes it's even just a matter of if the dev just doesn't want to bother submitting an application to Lineage to bring it to official status. Or maybe certain hardware components aren't working and / or never feasibly will outside of stock (Samsung is famous for keeping some of their device drivers / kernels completely closed-source. Also I ditched Samsung phones after Galaxy S5 because they locked down the Snapdragon variants so hard, even on previously unlockable carrier variants like T-Mobile - while many regions particularly outside of USA had Exynos variants with unlockable BL and such).

    Anyway, I did have a question for ya @Linux4: I just flashed the 01/13/2021 update over installed 01/06/2021 system using Lineage Updater. This went as smoothly as anyone can ask for, except that I noticed I lost root after booting back up, and I had to flash Magisk again afterwards (can just flash the zip in Lineage Recovery, no big deal). Apparently Lineage Updater/Recovery must have ignored or missed the Magisk addon.d script? Gapps (OpenGapps "Stock") persisted though, and no Google apps / services seem wonky at all. I can only assume the Magisk addon.d script was there before OTA, but of course I can't know for sure after the fact. I checked just now and see it, so I'll keep my eyes on it when next OTA comes around. (I have 50-lineage.sh, 70-gapps.sh, and 99-magisk.sh - all looks as it should be)

    On another note - just use Lineage Recovery for now, people! Unfortunately I learned my lesson last week, when I tried to flash the OTA with TWRP and ended up in bootloop, due to ignoring warnings about FBE. Flashing back to 12/30/2020 didn't work either, whether with TWRP or Lineage Recovery, so I had to factory wipe. Oops.

    Edit: one more question: does Lineage Recovery also get updated when flashing the new system update / OTA? Or would we need to do that manually via odin / sdk tools / terminal? And (if not automatically updated) when would we know when it's actually necessary / when we should actually bother? Sorry, I'm actually new to Lineage Recovery myself... Thanks L!

    Magisk's addon.d just doesn't work if /data is encrypted..
    Also for lineage recovery there's a setting "Update Recovery" in Developer Settings which will automatically update recovery
    Btw on 18.1 this setting moved to Setupwizard and Updater settings.
    1
    i will receive this tablet in days, how is s-pen support with lineage os?
    Better than stock. Tilt is borked in stock last time I checked.
    1
    Any idea how to get rid of the horrid initial warnings during boot?

    There's a way, but I wouldn't recommend doing it, there's a pretty high chance of hardbricking your device if you mess up bootloader splash images ...
    IMHO it's not worth the risk