• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, logins not working, and more. To discuss, use this thread.

[DISCONTINUED][ROM][OFFICIAL] LineageOS 16.0 for Xiaomi Mi A1

HidekiRyuga

Active member
Apr 12, 2014
332
77
28
Shibuya
i'm also running microg and went the same path, so there's at least two of us :) you need to upgrade your firmware for the fingerprint scanner to work. i had the same issue but after flashing the latest (firmware_V10.0.6.0.PDHMIXM.zip) via twrp it works (including LTE bands).
can any body tell me how to get the full capacity i.e. 64 gb as when i installed lineage 16 official rom on my xiaomi m1 on original software the resulting system is only 32 gb.is there any way to get the other slot storage to system

You wanna destroy your system? That's impossible, a/b system is really good imo, Mi A1 is lucky to have that partition.
 
  • Like
Reactions: saaad56

bmccoy11

New member
Dec 30, 2013
183
80
0
Seattle, WA
bmccoy.me
Hello all! Does somebody have the same bug that WiFi reconnects nearly every 10 seconds? I did a clean Install and everything is working great except for that reconnects. No matter what wifi i am using. Maybe flex can look into this.
I've had a similar problem too -- however, my connection usually drops every 2-5 minutes instead and my WiFi often remains off when my phone is in standby until it's turned back on, resulting in tons of dropped VoIP calls, excess cellular data usage (thanks to it constantly being active whenever my WiFi connection drops), and late notifications. I've heard of a myriad of other users with WiFi problems on this phone but I haven't seen anyone else report the same exact problem I have right now, and this is after a complete low-level/EDL restore of my phone's partitions to the way they were when I first bought it. When reverted back to Oreo, my device doesn't have these problems but as soon as I flash the stock Pie ROM the constant network drops come back. My router is an ASUS RT-AC68U and no other devices on my network have had this. Has @flex1911 or any other kernel dev for this phone looked into (or even heard of) this issue at all?
 

flex1911

Recognized Developer / Retired Forum Moderator
Feb 12, 2013
999
7,533
93
18
Volgograd
I noticed that kernel changes don't show in lineage changelog, I wonder why does that happen? I also wanted to ask if you gonna use the new firmware that just got released yesterday? Thanks
Kernel merges usually bypass gerrit and that's why they don't appear in the changelog.
About the new firmware - I want to be sure that it's stable and can be used globally.
 

mac-duff

New member
Jan 27, 2011
247
38
0
Hello,
yesterday I updated my device as flex1911 described from 15.1 to 16.0 and everything worked and stills works without a problem (mindthegappas, magisk).

However, I have a question about Lineage OS 16. When I set my clock on the left side of the status bar, the alarm clock icon is displayed correctly on the right hand side. But when I set the clock to the right side, the alarm clock is only displayed as a dot. Is there a way to have the clock and the alarm clock symbol on the left hand side at the same time?

Thanks
Stephan
 

saaad56

New member
Mar 13, 2010
17
0
0
Thank u for the advice but original software of the phone show me the full capacity of the storage despite the a/b slots also present.how is that done;i was wondering thanks for the reply btw
 

spfmuntz

New member
Feb 24, 2016
56
24
0
1- March Firmware
2- Unlocked bootloader
3- Custom TWRP booted from fastboot
4- Wipe ///
5- Lineage installed
6- custom twrp booted again
7- opengapps nano installed
8- custom twrp booted again
9- magisk installed
10- magisk manager installed
11- API2 Enabled with commands
12- Gcam installed
13- My daily-use apps installed
14- Magisk removed
15- Pokemon Go Installed
16- rebooted to bootloader
17- Splash Screen flashed
18- rebooted

Everything working fine, i'm here just to say: Thank you, awesome work; i was tired of ram and background apps bugs on stock Pie (never lost 4g with pie update, wifi working fine with bluetooth, etc...) and three monthly updates didn't solved anything
 

fhsd22

New member
Oct 30, 2016
49
2
0
Can anyone teach me how to move from Lineage OS 16 to roms like Havoc OS having hard time because when I flash official twrp using boot twrp of Lineage it shows system is destroyed, I want to change to other roms. ? please help!
 

rkview37

New member
Jan 15, 2017
151
183
0
Can anyone teach me how to move from Lineage OS 16 to roms like Havoc OS having hard time because when I flash official twrp using boot twrp of Lineage it shows system is destroyed, I want to change to other roms. ? please help!
after booting lineage twrp wipe system,data,dalvic cache &then flash other custom rom
after that flash twrp installer what u prefer

without deleting lineage os u cant use other twrp
& u have to first flash a custom rom to install any twrp permanantly
 
Last edited:

rexendz

New member
Sep 13, 2016
35
4
0
ZAM
Hello my friend, I have another custom rom installed and I would like to try this rom. I have a flashed twrp installer and currently have twrp as my recovery. Can I flash Lineage OS without hotbooting your twrp variant and just use my installed twrp? Does twrp remain after flashing lineage? Thank you my friend.
 

gartzen

New member
Apr 11, 2012
198
55
0
Hello my friend, I have another custom rom installed and I would like to try this rom. I have a flashed twrp installer and currently have twrp as my recovery. Can I flash Lineage OS without hotbooting your twrp variant and just use my installed twrp? Does twrp remain after flashing lineage? Thank you my friend.
Nope and nope.

But you can hotboot twrp anytime to install any other twrp/rom.
 

cheffy11

New member
Jan 16, 2013
340
87
0
Warwick
Can anyone teach me how to move from Lineage OS 16 to roms like Havoc OS having hard time because when I flash official twrp using boot twrp of Lineage it shows system is destroyed, I want to change to other roms. ? please help!

Hello my friend, I have another custom rom installed and I would like to try this rom. I have a flashed twrp installer and currently have twrp as my recovery. Can I flash Lineage OS without hotbooting your twrp variant and just use my installed twrp? Does twrp remain after flashing lineage? Thank you my friend.

Read the thread. Don't be lazy. All info has been said a thousand times in this thread already.
 

priban

New member
Oct 6, 2009
67
8
0
Solutions

I've had a similar problem too -- however, my connection usually drops every 2-5 minutes instead and my WiFi often remains off when my phone is in standby until it's turned back on, resulting in tons of dropped VoIP calls, excess cellular data usage (thanks to it constantly being active whenever my WiFi connection drops), and late notifications. I've heard of a myriad of other users with WiFi problems on this phone but I haven't seen anyone else report the same exact problem I have right now, and this is after a complete low-level/EDL restore of my phone's partitions to the way they were when I first bought it. When reverted back to Oreo, my device doesn't have these problems but as soon as I flash the stock Pie ROM the constant network drops come back. My router is an ASUS RT-AC68U and no other devices on my network have had this. Has @flex1911 or any other kernel dev for this phone looked into (or even heard of) this issue at all?
I think i solved this problem and another one i had regarding the update.

1. I realized that the connection drops, when multiple WiFi-Spots are around and you have been connected to them. It seems to me that the ROM chooses the WiFi with the strongest signal. But when there are more than 1 possible hotspots it switches between them. Try to turn one of them off and see if it solves this problem (maybe you can just remove one from the phone).

2. The second problem i had was the "data corrupt" message when trying to update. I tried it multiple times and did everything exactly like described. Yesterday i tried it again with no luck, so i decided to "repair or change filesystem" the data partition (on both slots).
I just used "change filesystem -> format partition with ext4" (even though it was ext4 before). But after that the update process went through without problems.

Maybe this helps some people. Now the ROM is working flawlessly! Good work!
 
  • Like
Reactions: drrossum

vvenancio

New member
Apr 20, 2018
6
1
0
I think i solved this problem and another one i had regarding the update.

1. I realized that the connection drops, when multiple WiFi-Spots are around and you have been connected to them. It seems to me that the ROM chooses the WiFi with the strongest signal. But when there are more than 1 possible hotspots it switches between them. Try to turn one of them off and see if it solves this problem (maybe you can just remove one from the phone).

2. The second problem i had was the "data corrupt" message when trying to update. I tried it multiple times and did everything exactly like described. Yesterday i tried it again with no luck, so i decided to "repair or change filesystem" the data partition (on both slots).
I just used "change filesystem -> format partition with ext4" (even though it was ext4 before). But after that the update process went through without problems.

Maybe this helps some people. Now the ROM is working flawlessly! Good work!
Hey! I'm having that "data corrupt" after I try to update, can you give the full step-by-step to use your solution, sorry, it's the first time i'm trying a custom rom and I'm feeling a little lost here.
 
Our Apps
Get our official app! (coming soon)
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone