[discontinued][ROM][unlocked][suez] Lineage-14.1 [26 SEP 2019]

Status
Not open for further replies.
Search This thread

DragonFire1024

Senior Member
Mar 27, 2017
4,688
1,873
40
Fort Lauderdale
www.twitter.com
I spoke too soon about my court TV problem being fixed. I just went to that site and stream live, and the error message no longer came up. But I didn't watch to see what actually occurred. Now I see that the video plays for only about one second and then freezes. Audio is fine.

Don't know if this helps any, but I get perfect audio. It's as if the video is playing, but the picture is just black. No error messages come up for me generally. But I can always hear the audio, just never see the video, which kind of seems a bit odd to me. That that seems to be the only issue with video I have, otherwise I can put on a video and listen to the audio all day long. By the way this applies to the YouTube app on the latest build. I don't generally watch videos in articles or search feeds so I can't speak for their functionality in those terms.

Sent from my Amzn Fire HD10 using XDA Labs
 
Last edited:

Ziona

Senior Member
May 4, 2019
562
354
Caribbean
Don't know if this helps any, but I get perfect audio. It's as if the video is playing, but the picture is just black. No error messages come up for me generally. But I can always hear the audio, just never see the video, which kind of seems a bit odd to me. That that seems to be the only issue with video I have, otherwise I can put on a video and listen to the audio all day long. By the way this applies to the YouTube app on the latest build. I don't generally watch videos in articles or search feeds so I can't speak for their functionality in those terms.

Sent from my Amzn Fire HD10 using XDA Labs

Some of you are having really weird problems while tings are great for most ppl , its almost like few ppl are dirty flashing the ROM again after installing the fix lol .
OK try this ,
let see if we maybe can pin down your true problem , Using a root explorer app navigate to system > etc , an in that folder scroll an find - media_codec_google_video.xml , also find media_codec_ffmpeg.xml . Confirm if they are both their report back if an when located .
 
Last edited:
Some of you are having really weird problems while tings are great for most ppl , its almost like few ppl are dirty flashing the ROM again after installing the fix lol .
OK try this ,
let see if we maybe can pin down your true problem , Using a root explorer app navigate to system > etc , an in that folder scroll an find - media_codec_google_video.xml , also find media_codec_ffmpeg.xml . Confirm if they are both their report back if an when located .

I ended up clean-flashing the whole thing again, and video works fine for me.
 

sga999

Senior Member
Mar 13, 2012
808
112
Some of you are having really weird problems while tings are great for most ppl , its almost like few ppl are dirty flashing the ROM again after installing the fix lol .
OK try this ,
let see if we maybe can pin down your true problem , Using a root explorer app navigate to system > etc , an in that folder scroll an find - media_codec_google_video.xml , also find media_codec_ffmpeg.xml . Confirm if they are both their report back if an when located .
I have both of those files, but I have an 's' on codec. That's probably what you meant.

I have only installed the ggow 14.1 rom one time, and I copied the unzipped files from the OMX fix into system/lib. YouTube works fine after copying those files. It is only Court TV live stream that I am having the problem with. Before the fix, the symptom was that I would get an error message about incompatibility, and video would not play at all. Once I applied the fix, that message is gone. Now the video displays very briefly, then freezes, with audio working perfectly. Maybe someone can try this on courttv.com and see if they get the same thing.
 

Ziona

Senior Member
May 4, 2019
562
354
Caribbean
I have both of those files, but I have an 's' on codec. That's probably what you meant.

I have only installed the ggow 14.1 rom one time, and I copied the unzipped files from the OMX fix into system/lib. YouTube works fine after copying those files. It is only Court TV live stream that I am having the problem with. Before the fix, the symptom was that I would get an error message about incompatibility, and video would not play at all. Once I applied the fix, that message is gone. Now the video displays very briefly, then freezes, with audio working perfectly. Maybe someone can try this on courttv.com and see if they get the same thing.
Well right now am only using my ford on 14 by ggow this had the same problem as Suez why I made the fix at first, courtTv.com works for me so question which browser are you using for streaming video like that on ?
 
Last edited:

sga999

Senior Member
Mar 13, 2012
808
112
Download and try the original Opera with VPN not the mini ..
Yes, Opera VPN works. But here's the strange thing. The exact same problem occurred with ggow's 12.1 lineage ROM. I told him about this problem, and he fixed it in his next release. I did not need to use another browser. So maybe when he returns, he can figure out the fix he used then and the same can be implemented now. I guess it's possible that I still have some older files, even though I did copy the ones from the OMX fix. But I don't see how I could screw that up. Also the behavior did change once I put that fix in.. I no longer get an error message, so it obviously had some effect.
 

Ziona

Senior Member
May 4, 2019
562
354
Caribbean
Yes, Opera VPN works. But here's the strange thing. The exact same problem occurred with ggow's 12.1 lineage ROM. I told him about this problem, and he fixed it in his next release. I did not need to use another browser. So maybe when he returns, he can figure out the fix he used then and the same can be implemented now. I guess it's possible that I still have some older files, even though I did copy the ones from the OMX fix. But I don't see how I could screw that up. Also the behavior did change once I put that fix in.. I no longer get an error message, so it obviously had some effect.

Did Opera make any difference with video stream play on courtTv not the VPN ?
So why did you not just flash the OMX zip I posted that's better it contains all needed omx libs an its safe has been downloaded hundreds of times for 3 months used on ford ,Austin, Suez & mustang . What app do you use for VPN because its only supported via third party apps on this los 14.1 & yea he maybe could take a look into VPN, I also have made many fixes for these devices helping out support ggow with 14.1 los, he will be away for a moment dealing with a few personal tings !
 
Last edited:

sga999

Senior Member
Mar 13, 2012
808
112
Did Opera make any difference with video stream play on courtTv not the VPN ?
So why did you not just flash the OMX zip I posted that's better it contains all needed omx libs an its safe has been downloaded hundreds of times for 3 months used on ford ,Austin, Suez & mustang . What app do you use for VPN because its only supported via third party apps on this los 14.1 & yea he maybe could take a look into VPN, I also have made many fixes for these devices helping out support ggow with 14.1 los, he will be away for a moment dealing with a few personal tings !
I'm confused. I thought you asked me to try the original Opera with VPN, not Opera Mini. That's what I did. I have not installed any thing else related to VPN. I only installed the app that you suggested, and it did work.

As far as installing your zip, I read a post about using something from a thread that was already done in Ford and Austin. That's what I used, not realizing that you have posted some other zip. I will go back and look for that.

---------- Post added at 02:26 PM ---------- Previous post was at 02:01 PM ----------

I'm confused. I thought you asked me to try the original Opera with VPN, not Opera Mini. That's what I did. I have not installed any thing else related to VPN. I only installed the app that you suggested, and it did work.

As far as installing your zip, I read a post about using something from a thread that was already done in Ford and Austin. That's what I used, not realizing that you have posted some other zip. I will go back and look for that.
I just flashed your zip from post 248. I had previously been using the link that was provided in post 245, and I had used the OMX fix from there. I had made an incorrect assumption that you were just repeating what that other post had said 3 posts earlier. In any case, it still doesn't work when browsing with chrome for Court TV live stream after flashing your zip. It is very weird that I can keep tapping the screen constantly, and instead of freezing, the video will keep playing.
 

Ziona

Senior Member
May 4, 2019
562
354
Caribbean
I'm confused. I thought you asked me to try the original Opera with VPN, not Opera Mini. That's what I did. I have not installed any thing else related to VPN. I only installed the app that you suggested, and it did work.

As far as installing your zip, I read a post about using something from a thread that was already done in Ford and Austin. That's what I used, not realizing that you have posted some other zip. I will go back and look for that.

---------- Post added at 02:26 PM ---------- Previous post was at 02:01 PM ----------


I just flashed your zip from post 248. I had previously been using the link that was provided in post 245, and I had used the OMX fix from there. I had made an incorrect assumption that you were just repeating what that other post had said 3 posts earlier. In any case, it still doesn't work when browsing with chrome for Court TV live stream after flashing your zip. It is very weird that I can keep tapping the screen constantly, and instead of freezing, the video will keep playing.

I do mean Opera, I wanted you to play the videos in court TV with that an say if it plays video & audio !
The VPN ting was just a bonus if needed .
They are both my fix libs in those post but different , one has just the 32 bit libs to manually install and the next has both the 32bit an 64bit omx libs an is flashable !

Opera is better than chrome, it will play almost any ting on web sites plus you can sign in your Google account on it that will sync all bookmarks an you can share them an history with your other devices an PC .
 
Last edited:

DB126

Senior Member
Oct 15, 2013
15,252
10,034
I'm confused. I thought you asked me to try the original Opera with VPN, not Opera Mini. That's what I did. I have not installed any thing else related to VPN. I only installed the app that you suggested, and it did work.
Opera has a toggle (in settings) to toggle VPN on/off. You may also have different experiences toggling 'data saver' on/off as some rendering takes place off device when data saver is enabled.

As for Chrome vs Opera I only use the latter.
 

sga999

Senior Member
Mar 13, 2012
808
112
I do mean Opera, I wanted you to play the videos in court TV with that an say if it plays video & audio !
The VPN ting was just a bonus if needed .
They are both my fix libs in those post but different , one has just the 32 bit libs to manually install and the next has both the 32bit an 64bit omx libs an is flashable !

Opera is better than chrome, it will play almost any ting on web sites plus you can sign in your Google account on it that will sync all bookmarks an you can share them an history with your other devices an PC .
Yes, I installed the Opera VPN app and tested the court TV problem, and the problem did not occur. So I guess you thought I installed the app and didn't test after that? That would be pretty crazy of me!

I realize there are other ways to get things to work. As I mentioned with the Miracast problem, I could use an app. But I would like to see the built-in cast feature work. Same thing here. I would like to continue using Chrome and see this work with court TV. It did work with ggow's lineage 12.1 version with his August 11th release. It had not worked in his initial release.

---------- Post added at 03:54 PM ---------- Previous post was at 03:41 PM ----------

Opera has a toggle (in settings) to toggle VPN on/off. You may also have different experiences toggling 'data saver' on/off as some rendering takes place off device when data saver is enabled.

As for Chrome vs Opera I only use the latter.
I tried Opera VPN with Court live stream, all settings of VPN on/off and data saver on on/off, and all cases work properly.

Can anyone else try this with Chrome? If someone else says it works, then I will know there is something wrong in my system. If everyone sees it fail, that will tell me it is not specific to me. It is live stream that fails, not the older videos that are further down on the page.
 

DragonFire1024

Senior Member
Mar 27, 2017
4,688
1,873
40
Fort Lauderdale
www.twitter.com
Well I sort of got the camera to work and it's launching icon to appear. I downloaded the Google camera for nougat and installed it like a regular app then made it a system app. I then unpacked the APK and extracted the library files from it. The camera will launch, but aside from that that's all it will do. It crashes when any button is pressed besides the rotate button (at least I think it's the rotate button it may flip the camera from front to back). Touching any other buttons including the button to snap a picture will cause the application to crash. So all I get is a black screen. Maybe it's just a coincidence, but it seems a bit odd that the camera presents a black screen while playing videos on YouTube and other applications and website also cause a black screen. Maybe the two are connected?

Sent from my Amzn Fire HD10 using XDA Labs
 

Ziona

Senior Member
May 4, 2019
562
354
Caribbean
Well I sort of got the camera to work and it's launching icon to appear. I downloaded the Google camera for nougat and installed it like a regular app then made it a system app. I then unpacked the APK and extracted the library files from it. The camera will launch, but aside from that that's all it will do. It crashes when any button is pressed besides the rotate button (at least I think it's the rotate button it may flip the camera from front to back). Touching any other buttons including the button to snap a picture will cause the application to crash. So all I get is a black screen. Maybe it's just a coincidence, but it seems a bit odd that the camera presents a black screen while playing videos on YouTube and other applications and website also cause a black screen. Maybe the two are connected?

Sent from my Amzn Fire HD10 using XDA Labs

Well anything can be a possibility but I doubt it solely because if that were the case upgrading the OMX libs would have done nothing to play videos for us , the camera is broken in all these devices part way do to not having the exact blobs for the camera which is not open source software , an will take a dev like ggow awhile if ever to create a blob shim that will match a work like the original does . this feature is broken on most fire tablets upgraded to nougat cause lollipop an nougat work very different not all files will run !

Try this Camera out ; https://forum.xda-developers.com/showpost.php?p=80420517&postcount=121
 
Last edited:
  • Like
Reactions: kokos76

DragonFire1024

Senior Member
Mar 27, 2017
4,688
1,873
40
Fort Lauderdale
www.twitter.com
I actually got video working by looking over all the hardware library files as well as the ones in vendor, framework files jar files all of them anything that had any visual relation to cameras video or imaging. and the only thing I managed to get working was video. Much to my surprise it's working. if anyone would like to try and repeat what I've done to get there video to work I will gladly repeat my steps.

---------- Post added at 03:17 PM ---------- Previous post was at 03:15 PM ----------

Well anything can be a possibility but I doubt it solely because if that were the case upgrading the OMX libs would have done nothing to play videos for us , the camera is broken in all these devices part way do to not having the exact blobs for the camera which is not open source software , an will take a dev like ggow awhile if ever to create a blob shim that will match a work like the original does . this feature is broken on most fire tablets upgraded to nougat cause lollipop an nougat work very different not all files will run !

Try this Camera out ; https://forum.xda-developers.com/showpost.php?p=80420517&postcount=121

Nope sorry I cannot get any camera application to work at all not even Amazon stock application that came with the tablet. About the best I can do is get Google camera to fully boot and open, to a black screen but if any buttons are pressed the app will crash. Not having a camera doesn't bother me all that much, it's not like they're actually pretty good quality ones on this device anyways. But it is very nice to have video working. I've tried almost every camera I could think of including some from various older ROMs I've had for other devices. And not a thing.
 

Ziona

Senior Member
May 4, 2019
562
354
Caribbean
I actually got video working by looking over all the hardware library files as well as the ones in vendor, framework files jar files all of them anything that had any visual relation to cameras video or imaging. and the only thing I managed to get working was video. Much to my surprise it's working. if anyone would like to try and repeat what I've done to get there video to work I will gladly repeat my steps.

---------- Post added at 03:17 PM ---------- Previous post was at 03:15 PM ----------



Nope sorry I cannot get any camera application to work at all not even Amazon stock application that came with the tablet. About the best I can do is get Google camera to fully boot and open, to a black screen but if any buttons are pressed the app will crash. Not having a camera doesn't bother me all that much, it's not like they're actually pretty good quality ones on this device anyways. But it is very nice to have video working. I've tried almost every camera I could think of including some from various older ROMs I've had for other devices. And not a thing.

That's the first one I got to work on the Ford , Austin tablets well.
The stock camera's all models would just load normally but taking a pic would just never save it only make a empty camera folder , trying to save video would give error an force closes .
What symptoms does the stock camera have for you !
 
Last edited:
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 52
    Disclaimer
    Code:
    /*
     * I am not responsible for bricked devices, dead SD cards, thermonuclear war,
     * or you getting fired because the alarm app failed.
     * Please do some research if you have any concerns about features included
     * in the products you find here before flashing it!
     * YOU are choosing to make these modifications.
     */
    LineageOS needs no introductions. This version of LineageOS-14.1 is a highly customised version solely for the Amazon Fire HD10

    - EVEN MORE IMPORTANT: This ROM only works on devices using the bootloader hack. See <<< HERE >>> to unlock your devices.

    - IMPORTANT: Do not update Magisk via the Magisk Manager App, your device will enter a bootloop if you do. Instead update Magisk via TWRP only. If you do this by accident then it is recoverable by just flashing the latest version of the ROM again (with gapps etc as required).

    Rules
    - Please search the thread before asking questions
    - Please try to stay on topic, I know it's not always possible
    - Please report bugs here
    - Report only one issue per bug report
    - When reporting bugs please post a logcat and/or dmesg containing pertinent information regarding the issue...
    - Saying something isn't working without proper explanation will not attract any attention.

    Known Issues
    - Wired headphones do not work
    - Camera does not work
    - OMX is only partially working

    Prerequisites for Installation
    - Clean installation is required coming from lineage-12.1
    - Unlocked Bootloader
    - TWRP Installed

    Initial Installation
    or coming from another rom
    - Enter TWRP
    - Enter wipe option
    - Format Data
    - Then swipe to factory reset
    - Copy the ROM to your device
    - Copy optional zips like gapps and magisk to device if required
    - You also have the option of using micro-g framework
    - Flash ROM, then optional zips
    - Reboot
    - And Enjoy :D

    Upgrading to a new version
    - Copy the ROM to your device
    - Flash ROM
    - And Enjoy :D

    Downloads
    *** Please do NOT create any mirrors ***
    Lineage-14.1 for Amazon Fire HD10"

    Source Code
    - Kernel Source: https://github.com/ggow/android_kernel_amazon_mt8173-common
    - Suez Tree: https://github.com/ggow/android_device_amazon_suez
    - mt8173-common Tree: https://github.com/ggow/android_device_amazon_mt8173-common

    Thanks
    - @k4y0z and @xyz` for the bootloader hack
    - @Goayandi for the mt8173 resources
    - LineageOS

    Note
    Their is a issue with video playback do to the omx library files. This is a link to flash a fix in recovery for this problem below.
    https://forum.xda-developers.com/showpost.php?p=80762749&postcount=248

    XDA:DevDB Information
    LineageOS, ROM for the Amazon Fire HD 8 and HD 10

    Contributors
    ggow, Ziona
    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.x

    Version Information
    Status: Testing

    Created 2019-09-26
    Last Updated 2020-08-11
    35
    OMX FIX FOR VIDEO PLAYBACK

    FLASH VIA RECOVERY

    FIX'S YOUTUBE , FACEBOOK , LOCAL & WEB PLAYBACK

    (No more video black screen or glitches)

    :good:
    21
    Project is definitely not dead. There is a lot of activity from various people since I have been absent. Hope everyone has had a good Christmas and wish everyone a great new year.

    Things should start settling down for me in the new year, hopefully by the end of the first quarter.
    19
    @ggow Any news about the new build with working OMX?

    Not had a chance to do anything as yet. Busy with work, high stress and need to focus on that for the moment. When that passes then I can start to do more again.
    19
    Just a quick note, progress has been slow this week due to time constraints.

    Interviewing for another job this week and away on business next week.
    Things will start progressing once I get through the hump.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone