• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[DISCONTINUED][ROM][UNOFFICIAL][gta4xl][10] LineageOS 17.1 for Galaxy Tab S6 Lite (LTE)

Search This thread

mu1989

Senior Member
Feb 22, 2020
102
33
I have installed the Nov 8th update but i'm having an issue with BT. Audio works great on the tabs speakers but when using BT it glitches a lot. It sounds like a CD when someone bumps the table, it skips the music not matter what app i use (spotify, youtube, youtube vanced, music, simple music player, NewPipe), more so when i'm trying to use the tab for other tasks and the music is in the background playing. I saw your instructions on how to grab a log file but i'm unsure on how to do that. I am currently on the sm-p610 tab. Other than that I think LOS runs amazingly well and I thank you for taking your time to do this. I'm looking forward to upgrading to LOS 18. Any help you may be able to provide will be greatly appreciated.

Android 10 November 8th, 2020
the november 8th link from this thread
picogapps

Yes to wiping (was coming from stock, did not need a backup)
yes to rebooting

no task killers
still "stock" LOS 17.1 no other kernel
no other mods



https://forum.xda-developers.com/ga...om-lineageos-18-0-galaxy-tab-s6-lite-t4191805

So now I heard 4 hours at a time with the tab via a bluetooth system.
I had no problems with the connection and yes I walked with the tray once through the whole house (3 floors). As I said, had no connection problems
What kind of Bluetooth system do you have?
 

eluminx

Member
Dec 15, 2009
48
1
https://forum.xda-developers.com/ga...om-lineageos-18-0-galaxy-tab-s6-lite-t4191805

So now I heard 4 hours at a time with the tab via a bluetooth system.
I had no problems with the connection and yes I walked with the tray once through the whole house (3 floors). As I said, had no connection problems
What kind of Bluetooth system do you have?

First of all thank you for the quick replies, didn't think I would get help so fast. So i'm using an LG soundbar, model number SK4D(E7) as well as 2 Monster BTW249 speakers. I get the same "sympton" with both BT systems. I left the tab on for about 3 hours and my wife told me it didn't skip at all the whole time I was gone. But now as soon as I double tab the screen to wake it up, the audio stops for about 10 sec before continuing. Also, as i'm using it now it still "skipping" the audio. Any type of task i do gives it this effect, swiping up to get the apps, swiping down, opening apps, etc. It does this for a good 5-10 minutes after the screen goes off. After that it does not skip the audio. If i don't tap the off button to put the screen off and just let the screen turn off by itself, it still has the same problem. It'll skip the audio for a few minutes before eventually working as intended.

Here is another weird thing that was happening before but it's not anymore. A couple days ago when this "skipping" was happening, the little volume bar would pop up and the icon to silence the calls and notifications would blink for about 2 seconds, as if i was pressing it. This would happen without my input of course, but as i've said it is no longer doing that. Now it's just the audio skips.
 
Last edited:

mu1989

Senior Member
Feb 22, 2020
102
33
First of all thank you for the quick replies, didn't think I would get help so fast. So i'm using an LG soundbar, model number SK4D(E7) as well as 2 Monster BTW249 speakers. I get the same "sympton" with both BT systems. I left the tab on for about 3 hours and my wife told me it didn't skip at all the whole time I was gone. But now as soon as I double tab the screen to wake it up, the audio stops for about 10 sec before continuing. Also, as i'm using it now it still "skipping" the audio. Any type of task i do gives it this effect, swiping up to get the apps, swiping down, opening apps, etc. It does this for a good 5-10 minutes after the screen goes off. After that it does not skip the audio. If i don't tap the off button to put the screen off and just let the screen turn off by itself, it still has the same problem. It'll skip the audio for a few minutes before eventually working as intended.

Here is another weird thing that was happening before but it's not anymore. A couple days ago when this "skipping" was happening, the little volume bar would pop up and the icon to silence the calls and notifications would blink for about 2 seconds, as if i was pressing it. This would happen without my input of course, but as i've said it is no longer doing that. Now it's just the audio skips.

Okay, these have a good quality (actually) you use all three at once (means all with the tab together and multiroom) or do you connect only one device always at the same time?
Have you looked up the developer settings? And there the settings try to refine?


I'm going to go back from 18 to 17.1 today and test it again, but the audio codes and bt are actually the same
 
Last edited:

eluminx

Member
Dec 15, 2009
48
1
Okay, these have a good quality (actually) you use all three at once (means all with the tab together and multiroom) or do you connect only one device always at the same time?
Have you looked up the developer settings? And there the settings try to refine?


I'm going to go back from 18 to 17.1 today and test it again, but the audio codes and bt are actually the same

one device at a time, i didn't know Android could do simultaneous audio broadcast. Just tried changing some settings on the dev options with no success. It also seems to be sporadic with some apps. On spotify it skips pretty often but spread out, like after minutes. With youtube vanced is annoying enough that it's unbearable to listen to anything. With Newpipe is about the same as with spotify but with Tunein it'll only skip when the tab is actively being used, if the screen is off tunein will work just fine for hours. This happens with both speaker systems, the LG sound bar and with the monster BTW249s (just tried to do simultaneous audio but it does not work btw).
 

mu1989

Senior Member
Feb 22, 2020
102
33
one device at a time, i didn't know Android could do simultaneous audio broadcast. Just tried changing some settings on the dev options with no success. It also seems to be sporadic with some apps. On spotify it skips pretty often but spread out, like after minutes. With youtube vanced is annoying enough that it's unbearable to listen to anything. With Newpipe is about the same as with spotify but with Tunein it'll only skip when the tab is actively being used, if the screen is off tunein will work just fine for hours. This happens with both speaker systems, the LG sound bar and with the monster BTW249s (just tried to do simultaneous audio but it does not work btw).

I am sorry
I believe you that they have the problems, but unfortunately I can not simulate them, my only suggestion I can offer them is that they upgrade to Lineage 18, we also have a telegram group where they can get further help,
Just look at the comment I linked above
 

eluminx

Member
Dec 15, 2009
48
1
I am sorry
I believe you that they have the problems, but unfortunately I can not simulate them, my only suggestion I can offer them is that they upgrade to Lineage 18, we also have a telegram group where they can get further help,
Just look at the comment I linked above

Sorry for the lack of response. So i took the plunge and upgraded to LOS 18 and everything is right with the world. I tried it yesterday for about 5 hours running on LOS 18 with the LG Soundbar and it only hiccuped about once or twice. Seems like it's working just fine now. If it's as you say it is, and i believe it to be, that LOS 18/17 use the same drivers for BT i have no idea what could've been causing the issue on 17. Either way, thanks for the help, i can finally enjoy the tab :good:
 
  • Like
Reactions: mu1989

eluminx

Member
Dec 15, 2009
48
1
Well the issue is back, the tab has been working well but for the past 2-3 days it has begun having the same problem I was having with LOS 17. The audio is back to "skipping" on both of my BT speakers. Not really sure how to try and capture the issue to display it here.
 

coilbio

Senior Member
Apr 22, 2011
209
41
I use a tablet as my cars stereo. I'm looking to but this lte one on sale. Is it easy to install viper4android?

On the tab S4 it had to be baked into the rom, other attempts to install would break all audio. Any advice appreciated
 

aut92

Member
Feb 13, 2018
12
0
View attachment 5149161
Code:
/*
* Your warranty is now void.
*
* We are not responsible for bricked devices, dead SD cards,
* thermonuclear war, or you getting fired because the alarm app failed. Please
* do some research if you have any concerns about features included in this ROM
* before flashing it! YOU are choosing to make these modifications, and if
* you point the finger at us for messing up your device, we will laugh at you.
*/



FEATURES
  • SELinux enforcing
  • Improved Performance
  • Flip cover working
  • Touchscreen input disabled while using SPen
  • SPen tilt orientation working
  • Latest Linux 4.14.x kernel
  • ROM is signed with my developer keys

KNOWN ISSUES
  • Miracast not working (Google removed it in AOSP Pie)
  • You tell me

DOWNLOAD

Warning: 17.1 is now discontinued, please use 18.1 instead

INSTALLATION
  • Follow the instructions at the TWRP Thread to install TWRP
  • If coming from another ROM (Stock ROM, GSI or whatever) you need to wipe data and cache
    Also be sure your /data is ext4, if not format /data to ext4 (in TWRP at "Advanced Wipe" -> Select Data -> "Change Filesystem")
  • Put the ROM zip on your external sdcard (if you are already on my LineageOS and have decrypted /data you might also put it in internal storage) and flash it using TWRP
    Optional:
  • Flash GApps
  • Flash Magisk

SUPPORT

Telegram support group


THANKS TO

@modpunk
@derf elot

I used their source code for LineageOS for Galaxy S10 series (which I have also contributed to) as base for my ROM.

XDA:DevDB Information
lineage-gta4xl, ROM for the Samsung Galaxy Tab S6 Lite

Contributors
Linux4
Source Code: https://github.com/gta4xl

ROM OS Version: Android 10
ROM Kernel: Linux 4.x
Based On: LineageOS

Version Information
Status:
Beta
Current Beta Version: 0.8
Beta Release Date: 2020-09-23

Created 2020-09-23
Last Updated 2020-12-15
I know this is discontinued but may I ask what setting it would be to turn on and off the magnetic cover on such apps as tasker etc please?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    1607247455067.png

    Code:
    /*
    * Your warranty is now void.
    *
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.
    */



    FEATURES
    • SELinux enforcing
    • Improved Performance
    • Flip cover working
    • Touchscreen input disabled while using SPen
    • SPen tilt orientation working
    • Latest Linux 4.14.x kernel
    • ROM is signed with my developer keys

    KNOWN ISSUES
    • Miracast not working (Google removed it in AOSP Pie)
    • You tell me

    DOWNLOAD

    Warning: 17.1 is now discontinued, please use 18.1 instead

    INSTALLATION
    • Follow the instructions at the TWRP Thread to install TWRP
    • If coming from another ROM (Stock ROM, GSI or whatever) you need to wipe data and cache
      Also be sure your /data is ext4, if not format /data to ext4 (in TWRP at "Advanced Wipe" -> Select Data -> "Change Filesystem")
    • Put the ROM zip on your external sdcard (if you are already on my LineageOS and have decrypted /data you might also put it in internal storage) and flash it using TWRP
      Optional:
    • Flash GApps
    • Flash Magisk

    SUPPORT

    Telegram support group


    THANKS TO

    @modpunk
    @derf elot

    I used their source code for LineageOS for Galaxy S10 series (which I have also contributed to) as base for my ROM.

    XDA:DevDB Information
    lineage-gta4xl, ROM for the Samsung Galaxy Tab S6 Lite

    Contributors
    Linux4
    Source Code: https://github.com/gta4xl

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status:
    Beta
    Current Beta Version: 0.8
    Beta Release Date: 2020-09-23

    Created 2020-09-23
    Last Updated 2020-12-15
    2
    FAQ

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    2
    CHANGELOG

    2020-12-15
    • Update to Linux 4.14.210
    • Add glove mode / high touch sensitivity mode
    • 2020-12-05 system securitypatch
    • Netflix now works without liboemcrypto disabler (L3 only, Samsung doesn't seem to allow L1 with custom ROM installed)
    • 2020-11-01 vendor securitypatch

    2020-11-19
    • Fixed RIL on LTE variant

    2020-11-08
    • Fix SPen tilt orientation issue (tilt_x and tilt_y were swapped)
    • Don't limit system inode count (should fix flashing bigger gapps packages)
    • Update Linux to 4.14.203
    • 2020-11-05 system securitypatch


    2020-10-15
    • Turn display off when closing flip cover
    • Fix audio output over usb-c
    • Improve audio quality

    2020-10-08
    • Change SPen pointer to stock one
    • SELinux enforcing on LTE variant
    • Fix DT2W on LTE variant by updating dtbo sources from decompiled stock ones
    • Fix display bugs on LTE variant by updating dtbo sources from decompiled stock ones
    • Update to Linux 4.14.200
    • Fix bluetooth issues
    • 2020-10-05 system security patch

    2020-09-25
    • Enable nightlight (thanks to erfanoabdi)
    • Fix /system_root mounting issues in TWRP

    2020-09-24
    • Update blobs to P61*XXU2BTI3, 2020-09-01 vendor security patch
      • Improves GPS speed

    2020-09-23
    • Initial release
    2
    Installed Lineage and it was booting, but had some problems with installing Gapps.
    After 3 attempts succeeded with installing Open Gapps pico from sd-card.
    In the first 2 attempts, TWRP gave error "failed to mount '/system_root"
    I found this: https://github.com/topjohnwu/Magisk/pull/2496 , probably due to dynamic partitions.

    Wifi, Bluetooth, pen are working, but gps is not working.

    Yes, TWRP's support for dynamic partitions is still not fully finished.
    Gps is working for me, but it takes a very long time initializing, that should be fixed with the next update (I'm currently working on including Samsung's september secpatch update on which gps seems to work faster)
    2
    I have uploaded an updated version with september vendor security patch which should also fix the gps issues