• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[DISCONTINUED][ROM][Z3TC] LineageOS 15.1 SGP621 [UNOFFICIAL]

Search This thread

koron393

Senior Member
Jan 25, 2014
226
641
Saitama
d.hatena.ne.jp
  • Like
Reactions: olavinto

6months&2legs

New member
Apr 17, 2020
3
3
Toulouse
Issues with lOs 15.1 on SGP612 (wifi, 32Go) Solved

Hi everyone,
I managed to install lineageOs 15.1 on my Xperia Z3 tablet compact SGP612 (wifi, 32Go) with windows 10. I had lots of difficulties to succeed and thanks to confinement of the Covid I had some time to gather all informations from the web. I resumed the process which have worked for me and have listed major issues I have experienced.
If you are like me with your old wifi Z3TC, the desire to keep it few more years, no idear of what you are doing and you want to learn something new, this is for you.
First of all, thanks everyone for all your hard work on the previous years ! :good:

Preliminary :
I am a completely beginner on android customisation, excuse me, if the terms are not adequate and feel free to correct me.
I have unlocked and root my device. More info here.
All drivers should be installed, if you have issue with adb and fastboot, monitor the state of the link in the device manager (no warning should be displayed)

Steps :
  1. Flash the firmware with Sony Mobile Flasher 0.9.28.0 (by Androxyde) I had issues here, see [Issue 1]
    Firmware 23.5.A.1.291 downloaded with XperiFirm_5.4.0 (by_Igor_Eisberg)
    NOT NECESSARY ! Unless your firmware does not work anymore or you want to lose time discovering new issues during 3 days like me :eek:
  2. Flash TWRP 3.3.0-0 on boot, see [Issue 2]
  3. In TWRP, Wipe Dalvik, Sytem, Cache and Date
  4. In TWRP, install lineage 15.1-20190922-unofficial-z3tc.zip, see post #3 [Issue 3]
  5. In TWRP, install Gapps zip, ARM 8.1 nano for me (optional)
  6. In TWRP, install SuperSU-v2.82 (201705271822) for me
  7. Reboot system
The tablet boot on LineageOs 15.1 ! :victory:

[Issue 1] Flashing firmware failed, Error - null in flashtool
First time with flashtool 0.9.28.0 was great all worked fine, but it failed when I tryed to flash again (flashing from start to restart with a clean firmware after some deep modifications for fun :D)
The issue in flashtool was :
Code:
17/042/2020 11:42:38 - INFO  - Selected Bundle for Sony Xperia Z3 Tablet Compact(SGP612). FW release : 23.5.A.1.291. Customization : Xperifirm
17/042/2020 11:42:38 - INFO  - Preparing files for flashing
17/042/2020 11:42:38 - ERROR - null
17/042/2020 11:42:38 - INFO  - Cannot open bundle. Flash operation cancelel
  • Solution:
    Download old version of flashtool 0.9.22.3
    Recreate a clean .ftf bundle (maybe not necessary)
    Flash the device and reboot
  • Causes:
    I do not know, there are similar issues on the web, I thought of USB buffer parameter may have changed between version, but it doe not explain why it worked with the first try.

[Issue 2] Device does not boot on TWRP when I flash on recovery,
  • Solution :
Do not flash on boot but on recovery :
Code:
Fastboot flash boot twrp.img
  • Causes:
    I do not understand, try first the official method suggested here
    I found the solution here
    There are stories of "dual boot" or something like that but I did not investigate

[Issue 3] Error 7 during zip install of LineageOs in TWRP 3
  • Solution :
    Install recent version of TWRP like 3.3.0-0, TWRP 3.0.2 Windy does not seems to work
  • Causes:
    I do not know, the subject was developed in the thread

I hope this message could help lost people, I just want to share and resume the process I used.
Thanks again for all the great work done and shared, LineageOs 15.1 is much smoother than the official android rom 6.0. The only issue I had for know is the light sensor which do not work, the subject was discussed in the thread but I did not found the solution. That is a small price and does not matter. ;)
Cheers
 

djibux

Member
Dec 6, 2015
22
1
Hi everyone,
I managed to install lineageOs 15.1 on my Xperia Z3 tablet compact SGP612 (wifi, 32Go) with windows 10. I had lots of difficulties to succeed and thanks to confinement of the Covid I had some time to gather all informations from the web. I resumed the process which have worked for me and have listed major issues I have experienced.

[…]

Awesome summary man! Thanks.

Thanks you also @evil-god for the amazing work on that project.
I hope you'll find the time for 17.1 ;)
 

Justinbridou

Member
Feb 27, 2018
24
10
I wiped all and re-install lineage build 2019.09 + gapps arm 8.1 mini (same as before), but skipped supersu.
It does still crash when launching pingtools (didn't tried Firefox preview)
But I noticed something : pingtools crash if launched with wifi connected (2.4g or 5g).
If launched with wifi off: it works... Until I enable wifi..then it will freeze a few seconds & reboot.
Anything can be done?
 

affidable

New member
May 2, 2020
3
2
Hi everyone,
I managed to install lineageOs 15.1 on my Xperia Z3 tablet compact SGP612 (wifi, 32Go) with windows 10. I had lots of difficulties to succeed and thanks to confinement of the Covid I had some time to gather all informations from the web. I resumed the process which have worked for me and have listed major issues I have experienced.
If you are like me with your old wifi Z3TC, the desire to keep it few more years, no idear of what you are doing and you want to learn something new, this is for you.
First of all, thanks everyone for all your hard work on the previous years ! :good:

Preliminary :
I am a completely beginner on android customisation, excuse me, if the terms are not adequate and feel free to correct me.
I have unlocked and root my device. More info here.
All drivers should be installed, if you have issue with adb and fastboot, monitor the state of the link in the device manager (no warning should be displayed)

Steps :
  1. Flash the firmware with Sony Mobile Flasher 0.9.28.0 (by Androxyde) I had issues here, see [Issue 1]
    Firmware 23.5.A.1.291 downloaded with XperiFirm_5.4.0 (by_Igor_Eisberg)
    NOT NECESSARY ! Unless your firmware does not work anymore or you want to lose time discovering new issues during 3 days like me :eek:
  2. Flash TWRP 3.3.0-0 on boot, see [Issue 2]
  3. In TWRP, Wipe Dalvik, Sytem, Cache and Date
  4. In TWRP, install lineage 15.1-20190922-unofficial-z3tc.zip, see post #3 [Issue 3]
  5. In TWRP, install Gapps zip, ARM 8.1 nano for me (optional)
  6. In TWRP, install SuperSU-v2.82 (201705271822) for me
  7. Reboot system
The tablet boot on LineageOs 15.1 ! :victory:

[Issue 1] Flashing firmware failed, Error - null in flashtool
First time with flashtool 0.9.28.0 was great all worked fine, but it failed when I tryed to flash again (flashing from start to restart with a clean firmware after some deep modifications for fun :D)
The issue in flashtool was :
Code:
17/042/2020 11:42:38 - INFO  - Selected Bundle for Sony Xperia Z3 Tablet Compact(SGP612). FW release : 23.5.A.1.291. Customization : Xperifirm
17/042/2020 11:42:38 - INFO  - Preparing files for flashing
17/042/2020 11:42:38 - ERROR - null
17/042/2020 11:42:38 - INFO  - Cannot open bundle. Flash operation cancelel
  • Solution:
    Download old version of flashtool 0.9.22.3
    Recreate a clean .ftf bundle (maybe not necessary)
    Flash the device and reboot
  • Causes:
    I do not know, there are similar issues on the web, I thought of USB buffer parameter may have changed between version, but it doe not explain why it worked with the first try.

[Issue 2] Device does not boot on TWRP when I flash on recovery,
  • Solution :
Do not flash on boot but on recovery :
Code:
Fastboot flash boot twrp.img
  • Causes:
    I do not understand, try first the official method suggested here
    I found the solution here
    There are stories of "dual boot" or something like that but I did not investigate

[Issue 3] Error 7 during zip install of LineageOs in TWRP 3
  • Solution :
    Install recent version of TWRP like 3.3.0-0, TWRP 3.0.2 Windy does not seems to work
  • Causes:
    I do not know, the subject was developed in the thread

I hope this message could help lost people, I just want to share and resume the process I used.
Thanks again for all the great work done and shared, LineageOs 15.1 is much smoother than the official android rom 6.0. The only issue I had for know is the light sensor which do not work, the subject was discussed in the thread but I did not found the solution. That is a small price and does not matter. ;)
Cheers

Hi,
I've succeeded in installing this LineageOS 15.1 on my SGP611 also thanks to the quoted message. Nevertheless, it contains some inaccuracies reported in its "Issue 2" I wish to fix with this reply. I started from a full stock configuration, therefore I am going to post the whole procedure in the following. Skip "Step 1" if you already have an unlocked device.

Step 1: Unlock Bootloader
It comprises of 2 main components, which are comprehensively detailed in this website. More specifically:
  1. Obtain your unlock code here. Just select your device at the end of the page and follow the instructions.
  2. Unlock the bootloader following the instructions in here. It goes through installation of ADB/Fastboot and USB driver, things that are also reported somewhere else in the forum.
I want to report a problem I had at #2 of the former list, it might be helpful for some user. Once my device was in fastboot mode, the command fastboot devices gave no output. This should be related to the USB drivers. I solved by following this. This is NOT MANDATORY, try only if you experience my same problem.

Reboot your device and load the files required for the following steps.

Step 2: Install TWRP
  1. Download the latest TWRP for scorpion_windy, which is 3.0.2-0 from here. Contrarily to what reported in the quoted message, this is going to work. See "Step 3".
  2. Flash the TWRP in the boot partition, as reported in the quoted message:
    Code:
    fastboot flash boot twrp-3.0.2-0-scorpion_windy.img

Step 3: Edit LineageOS zip file
Trying to flash the lineage15.1-20190922-unofficial-z3tc.zip indeed outputs ERROR 7 in TWRP, failing the installation. I solved this issue following what reported here. There you find an explanation of the problem as well.
This solves the issue reported in the quoted message, which was solved mentioning the use of TWRP 3.3.0-0 which actually does not exist for this device.

Step 3: Final installation process
  1. Reboot to recovery mode:
    Code:
    fastboot reboot recovery
  2. Flash the edited .zip file of LineageOS
  3. Flash GApps and SuperSU as reported in the quoted message

Step 4: Fix Recovery partition
After OS installation, you will not be able to reach the recovery again, as it was installed in the boot partition. Hence, reboot in fastboot mode, connect to the computer and run:
Code:
fastboot flash recovery twrp-3.0.2-0-scorpion_windy.img

Step 5: Enjoy!

I hope this message will be helpful. Thanks to all the contributors.
 
  • Like
Reactions: 6months&2legs

Justinbridou

Member
Feb 27, 2018
24
10
Hi,

I've succeeded in installing this LineageOS 15.1 on my SGP611 also thanks to the quoted message. Nevertheless, it contains some inaccuracies reported in its "Issue 2" I wish to fix with this reply. I started from a full stock configuration, therefore I am going to post the whole procedure in the following. Skip "Step 1" if you already have an unlocked device.

(....)
It a bit different to what I did... Would you mind confirm that either firefox preview
https://play.google.com/store/apps/details?id=org.mozilla.fenix
Or pingtools:
https://play.google.com/store/apps/details?id=ua.com.streamsoft.pingtools
Does not make it crash?

So far, it's the only 2 apps I installed that make the tablet reboot a few second after launching them (if Wi-Fi connected).


Envoyé de mon ONEPLUS A6013 en utilisant Tapatalk
 
Last edited:

Justinbridou

Member
Feb 27, 2018
24
10
I tried both with Wi-Fi connected only. Firefox Preview makes it freeze and reboot. Pingtools seems to work properly.
Thanks for confirmation! At least, it seems to be an issue not linked to my tablet.

By the way, I re-flashed with your last proposal (with modified zip).
It works fine with twrp 3.0.2.0 (well except still the 2 apps that make it reboot) thanks for the detailed explanation!



Envoyé de mon ONEPLUS A6013 en utilisant Tapatalk
 

najkon1

Member
Jun 10, 2020
5
0
None of the guides are working for me!

Hi,

I'm really new to all this. I have followed the instructions but am unable to get the Z3 tablet compact recognised by my computer in fastboot mode. This means I can't unlock bootloader or install TWRP.
I have the bootloader unlock code but it just say waiting for devices when I try to do anything with it.

I really want to bring my Tablet up to date, any help would be much appreciated. Sorry if this is such a stupid request.

Thank you
 

6months&2legs

New member
Apr 17, 2020
3
3
Toulouse
Hi,

I'm really new to all this. I have followed the instructions but am unable to get the Z3 tablet compact recognised by my computer in fastboot mode. This means I can't unlock bootloader or install TWRP.
I have the bootloader unlock code but it just say waiting for devices when I try to do anything with it.

I really want to bring my Tablet up to date, any help would be much appreciated. Sorry if this is such a stupid request.

Thank you

I cannot post link yet sorry, so search "HardReset.info: Fastboot Mode SONY SGP611CE Xperia Z3 Tablet Compact" in google, maybe it can help you.
You can also look in windows device manager if you have installed the correct drivers (no warning icon displayed) when tablet plugged.
Asking is not stupid, not taking time to find an answer is ;)
 

najkon1

Member
Jun 10, 2020
5
0
I cannot post link yet sorry, so search "HardReset.info: Fastboot Mode SONY SGP611CE Xperia Z3 Tablet Compact" in google, maybe it can help you.
You can also look in windows device manager if you have installed the correct drivers (no warning icon displayed) when tablet plugged.
Asking is not stupid, not taking time to find an answer is ;)

Hi, thanks for responding.

I have made loads of progress. I managed to get TWRP on, go through the process of flashing Lineage OS.

It says error command log, not sure what that means, but I can't do anything else without getting the OS on. I have wiped everything via TWRP too.

I have read that after this I need to install gapps which I have downloaded and maybe SuperSU which I have also downloaded.

Any help from here would be much appreciated?

If you need any further information to help, let me know please.
 

6months&2legs

New member
Apr 17, 2020
3
3
Toulouse
Hi, thanks for responding.

I have made loads of progress. I managed to get TWRP on, go through the process of flashing Lineage OS.

It says error command log, not sure what that means, but I can't do anything else without getting the OS on. I have wiped everything via TWRP too.

I have read that after this I need to install gapps which I have downloaded and maybe SuperSU which I have also downloaded.

Any help from here would be much appreciated?

If you need any further information to help, let me know please.

Be more specific about the error you got, you can paste the code here and/or refer to the FAQ of TWRP.
Note that gapps is optional and SuperSu should be installed last. Refer to the steps described in the original post of the thread, those in my first post #204 and others recent comments, specially corrections in #213 by affidable
 

Top Liked Posts

  • There are no posts matching your filters.
  • 22
    1000px-LineageOS_Logo.svg.png

    LineageOS
    Sony Xperia Z3 Compact Tablet SGP621
    LTE ONLY¹

    ¹WIFI SGP611 untested build available

    In the beginning credits goes to:

    the AICP rom team
    LineageOS & CM (R.I.P.) team
    the OmniRom team
    the Carbon Rom team
    Community

    Google Apps:
    https://opengapps.org/ <- untested, i never used gapps. Please leave a review which one are the best.

    Bugs:

    You tell... :p

    If you want the device to run the ROM "rooted", enable develper settings and enable it.

    It is STRONGLY recommended to fully wipe your device before flashing and please avoid restoring system apps and system data with Titanium Backup as this can cause stability issues that are very hard to debug.
    If you believe you know what you're doing - then fine, go ahead, but please don't complain if you experience any strange behavior.

    How to flash for the first time:
    (Again: Don't do it if you don't know it!)

    1. Download the ROM and GApps and transfer them to your device.
    2. Boot to recovery (TWRP recommended).
    3. Wipe the System, Cache, Data and ART/Dalvik cache.
    4. Flash the ROM Zipfile.
    5. Flash the GApps (optional, needed for e.g. Google Playstore to work).
    6. Reboot and set up your device.

    XDA:DevDB Information
    [ROM][Z3TC] LineageOS 15.1 SGP621 [UNOFFICIAL], ROM for the Sony Xperia Z3 Tablet Compact

    Contributors
    evil-god
    Source Code: https://gitlab.com/sony_scorpion

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.4.x
    Based On: LineageOS

    Version Information
    Status:
    Testing
    Current Beta Version: 20181223
    Beta Release Date: 2018-11-24

    Current Release Candidate Version: 20190422
    Release Candidate Date: 2019-01-06

    Created 2018-11-24
    Last Updated 2019-04-22
    20
    Reserved

    build 2019.09
    Changelog:
    update to september security patch level

    LTE SGP621
    https://drive.google.com/open?id=18JuMT-gd755aY4zgwWbR-qQWxFsVO6Ng

    just in case, fastboot RC02 images !NOT FOR TWRP!
    https://drive.google.com/open?id=1nXmltIsN_KYCTt-JH697MUb6FQ3jhTeY

    WIFI SGP611
    https://drive.google.com/open?id=12hGd50HJZWDovFTYg1bjWYNhZGT4ACsf

    just in case, fastboot RC02 images !NOT FOR TWRP!
    https://drive.google.com/open?id=10SUeWMpNJmDFJXH5Hx_tfshDVsdsLj_i
    9
    Is this ROM still alive?. I'm wondering whether to get rid of my tablet but I'll keep it if there is a good ROM still developing
    new build is uploading now, but just a security update to 2019.04.05
    my new job "eats" my free time, but should be better in a few weeks, then the migration to los16.0 is planed

    Hello.
    Tell me how to upgrade from Lineage OS 15.1 version 20181223 to Lineage OS 15.1 version 20190106 without losing user data and losing system settings?
    just install without make a total wipe, format only cache and dalvik, should work
    9
    @evil-god
    Is this still in active development? Or is it dead?

    hi, its not dead, but suspended. i got los-17.1 running, but ambient light sensor (automatic brightness for display) isnt working, so i dont release it.
    source are on gitlab, see first post.
    8
    hey, sorry for the long silence, still working on the 16.0 build, main problem is video recording and nfc.
    15.1 update will follow after google sec release, i think about 5. of march.
    greets