• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[DISCONTINUED][ROM][Z3TC] LineageOS 15.1 SGP621 [UNOFFICIAL]

Search This thread

PureMAD4

Senior Member
Jan 11, 2008
123
20
Sorry if this is an annoying question but I did a full clean install and was thinking of installing magisk again. I had a quick look but couldn't find a definitive answer on which version to use. Can I use the latest? Or should I use 18.1 . What version has anybody found works best?
Forgot to say thank you. Loving the rom

Update : The latest magisk seems to be working well with this Rom which is awesome. So no need to downgrade magisk like in some other roms
 
Last edited:

najkon1

Member
Jun 10, 2020
5
0
The error I got says

E: unknown command [log]
E: unknown command [log]

It progresses as if it working then right at the f end this message comes up.

I am installing the zip from my sd card, I don't know if that makes a difference.

I followed the instructions Error 7 message but can't get past this, do you have any ideas?

BTW the full error is on my tablet and I don't know how to upload the photo on here from my phone.
 

najkon1

Member
Jun 10, 2020
5
0
Being a complete noob, I was able to find the answers all over these threads. For me the trick was once you get past 1 stumbling block, you're flying.

I had a fault with the camera which I thought this might fix, but it's probably a hardware issue.

I'm going to try and sort the light sensor now, because it's too bright!
 

Ren Hayashi

Senior Member
Sep 23, 2010
81
11
@evil-god
Quick question. I really want to try lineageos 17.1. The zip that I found for your link is only under 50 kb, compared to about 390 mb for version 15.1. So I flash 15.1 then 17.1 over it? Thanks.

Edit: Okay, that was definitely not the right ROM image haha (invalid). Using lineage os 15.1 in the meantime. Can't wait to run 17.1 on this tablet.
 
Last edited:

corb06

Senior Member
hi, its not dead, but suspended. i got los-17.1 running, but ambient light sensor (automatic brightness for display) isnt working, so i dont release it.
source are on gitlab, see first post.

Finally got 15.1 working on my 611 after 10 hours of work. Had to install FUll Gapps to be able to sign in on Edge browser. Dont know why.
Anyways, are you still suspended with development or will there be 17.1 release?
 

olavinto

Member
Jun 6, 2013
7
3
Karkkila
Finally got 15.1 working on my 611 after 10 hours of work. Had to install FUll Gapps to be able to sign in on Edge browser. Dont know why.
Anyways, are you still suspended with development or will there be 17.1 release?
Have you had any problems with wifi? My 611 drops it constantly so the tablet is pretty much unusable because wifi works only for a couple of minutes, then the signal strength drops to about 50 % for another couple of minutes at which time nothing moves although the link stays up. Everything else except this and the new Firefox seems to work fine. Battery usage feels pretty bad also but the battery might just be dying of old age. The last Floko served me well prior to this for a long time (if only I had kept the downloads I'd go back to it). Now I'm just waiting for 17.1 to come out too (or it's back to stock and eol for this old tablet).
 

corb06

Senior Member
Have you had any problems with wifi? My 611 drops it constantly so the tablet is pretty much unusable because wifi works only for a couple of minutes, then the signal strength drops to about 50 % for another couple of minutes at which time nothing moves although the link stays up. Everything else except this and the new Firefox seems to work fine. Battery usage feels pretty bad also but the battery might just be dying of old age. The last Floko served me well prior to this for a long time (if only I had kept the downloads I'd go back to it). Now I'm just waiting for 17.1 to come out too (or it's back to stock and eol for this old tablet).

Have only had a couple of hours with the tablet today, and so far no issues with Wi-Fi. I do have some kind of "OK Google" Voice model download error popping up all the time in notifications. Also Google Music and Google has crashed a couple of times. But hope its just a one time event during my setup of 50+ apps. Dont use Google Music anyways =)
Too early to say if battery is bad or good for me but Im guessing they can´t beat Sonys stock battery handle with their Stamina mode all all that.
Anyways, very happy I managed to root and install this rom, tablet got a new life and feels very fast. Incredible design for being 5-6 years old when I think about it. So thin compared to many other tablets.
Edge browser seem to be working just fine now, havent tried FireFox, but we use Edge on all our devices to keep em synced.
 

corb06

Senior Member
Have you had any problems with wifi? My 611 drops it constantly so the tablet is pretty much unusable because wifi works only for a couple of minutes, then the signal strength drops to about 50 % for another couple of minutes at which time nothing moves although the link stays up. Everything else except this and the new Firefox seems to work fine. Battery usage feels pretty bad also but the battery might just be dying of old age. The last Floko served me well prior to this for a long time (if only I had kept the downloads I'd go back to it). Now I'm just waiting for 17.1 to come out too (or it's back to stock and eol for this old tablet).

Been using tablet now for a couple of days. Battery handeling is really bad compared to stock. Get about max 2-3 hours screen time during a 16 hour period. I set the battery saver to balanced, but doesnt really help much.
What I think would help is some kind of way to shut down Wifi when sleep. I think Sony had that in Stock, cause the tablet would last for days on standby and about 7-10 hours screen time on one charge.
Anyways, biggest hickup is normal web surfing. No matter what website I try to reach it takes at least 10 seconds after I press enter for anything to happen in the browser. Tried 3 diffrent browser, about the same results.
 

olavinto

Member
Jun 6, 2013
7
3
Karkkila
So it's pretty much useless for you too or at least I'd imagine that it's pretty frustrating to wait for a website to load (or these days it is anyway). Power consumption seems to be a problem with the rom also since it's bad for you too. Let's hope that 17.1 comes along soon and improves things! And thanks for replying!
 

corb06

Senior Member
So it's pretty much useless for you too or at least I'd imagine that it's pretty frustrating to wait for a website to load (or these days it is anyway). Power consumption seems to be a problem with the rom also since it's bad for you too. Let's hope that 17.1 comes along soon and improves things! And thanks for replying!
I noticed an big improvement in website loads when going over to 2,4 Ghz Wifi instead of our 5 Ghz. No idea why. I also found and app to turn off Wifi after 10 min, and that helped a lot for standby time. Last night tablet used 1% standby during 8 hour sleep. https://play.google.com/store/apps/details?id=de.j4velin.wifiAutoOff
 

olavinto

Member
Jun 6, 2013
7
3
Karkkila
I managed to get the last Floko version and the tablet is working fine again. Or at least much better: no network problems and power usage also dropped although the battery has probably lost quite a lot of life too. The new Firefox works too.

Might it be possible to get some kind of an update about version 17 because it seemed like it was almost ready except for the light issue? Like next month, this year, 1 quater of 2021 or something... ?
 

corb06

Senior Member
I managed to get the last Floko version and the tablet is working fine again. Or at least much better: no network problems and power usage also dropped although the battery has probably lost quite a lot of life too. The new Firefox works too.

Might it be possible to get some kind of an update about version 17 because it seemed like it was almost ready except for the light issue? Like next month, this year, 1 quater of 2021 or something... ?

Hey! I would like to try that too. Sent you a PM =)
 

eboIa

Senior Member
Dec 28, 2010
181
41
Budapest
Hi All!

Could anybody please help me with a latest working TWRP included boot image for this LineageOS 15.1 system for SGP611 (scorpion_windy)?

- With the latest official TWRP 3.0.2.0 I can not install LOS 20190922 what is of course the problem of the old TWRP as mentioned in https://forum.xda-developers.com/showpost.php?p=78323545&postcount=16,
- but with fastboot flashed boot image of the RC2 or also 20190922 LOS I could not boot into recovery (as the image is just 7,5MB vs official TWRP 12,7 this is maybe because the boot image simply does not have TWRP but I don't know). When the notification LED started to flash pinky and I try to press once or press more times the [VOL+], the LED just switch to yellow and the device reboot into normal mode again.
- Sadly I simply can not find anywhere a downloadable 3.2.x.y, or 3.3.x.y (of maybe newer if there is) TWRP image.

As after a lot of years yesterday I made a decision to unlock BL to flash LOS I'm a little bit confused now.

Please PM a link or post here if there is public availability, and very lot of thanks for it in advance!
 

corb06

Senior Member
Hi All!

Could anybody please help me with a latest working TWRP included boot image for this LineageOS 15.1 system for SGP611 (scorpion_windy)?

- With the latest official TWRP 3.0.2.0 I can not install LOS 20190922 what is of course the problem of the old TWRP as mentioned in https://forum.xda-developers.com/showpost.php?p=78323545&postcount=16,
- but with fastboot flashed boot image of the RC2 or also 20190922 LOS I could not boot into recovery (as the image is just 7,5MB vs official TWRP 12,7 this is maybe because the boot image simply does not have TWRP but I don't know). When the notification LED started to flash pinky and I try to press once or press more times the [VOL+], the LED just switch to yellow and the device reboot into normal mode again.
- Sadly I simply can not find anywhere a downloadable 3.2.x.y, or 3.3.x.y (of maybe newer if there is) TWRP image.

As after a lot of years yesterday I made a decision to unlock BL to flash LOS I'm a little bit confused now.

Please PM a link or post here if there is public availability, and very lot of thanks for it in advance!

Just sent you a PM
 

McSting

New member
Oct 5, 2020
1
0
SGP621 with LOS pls help

Hi All,

can anybody tell me, if its possible to install LOS on a SGP621 (LTE) device? The bootloader is already unlocked through sony services. I was also able to flash TWRP 3.0.2 to the recovery partition.
If its possible:
- Which steps I have to follow now? (does the steps in the OP still apply)
- Which LOS image I can use?
- Which TWRP I have to use (if 3.0.2 doesn't fit?
- What steps I have to follow to install the LOS image?

If its possible, please provide some download links, thx.

I hope someone can help me. I like the tablet but android 6.01 is old and without security patches....

Thx in advance
McSting
 
Last edited:

steigerth

Member
Aug 20, 2017
11
1
Hi All,

can anybody tell me, if its possible to install LOS on a SGP621 (LTE) device? The bootloader is already unlocked through sony services. I was also able to flash TWRP 3.0.2 to the recovery partition.
If its possible:
- Which steps I have to follow now? (does the steps in the OP still apply)
- Which LOS image I can use?
- Which TWRP I have to use (if 3.0.2 doesn't fit?
- What steps I have to follow to install the LOS image?

If its possible, please provide some download links, thx.

I hope someone can help me. I like the tablet but android 6.01 is old and without security patches....

Thx in advance
McSting

I was able to install the latest version with TWRP 3.0.2. I followed the steps outlined in this post:
https://forum.xda-developers.com/showpost.php?p=82459153&postcount=213 (see the end of the post and carefully change the LOS image zip file as stated.) I edited the ZIP file directly within 7Zip. At first I expanded the archive and edited the file and then I compressed it again but this did not work. After I edited the file inside 7Zip it worked. I did not investigate what the problem was.

I have a SGP612 (WIFI version with 32 GB) and it works very well with LOS 15.1.
The image for the LTE version is indicated on the first post of this thread. I guess it will work.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 22
    1000px-LineageOS_Logo.svg.png

    LineageOS
    Sony Xperia Z3 Compact Tablet SGP621
    LTE ONLY¹

    ¹WIFI SGP611 untested build available

    In the beginning credits goes to:

    the AICP rom team
    LineageOS & CM (R.I.P.) team
    the OmniRom team
    the Carbon Rom team
    Community

    Google Apps:
    https://opengapps.org/ <- untested, i never used gapps. Please leave a review which one are the best.

    Bugs:

    You tell... :p

    If you want the device to run the ROM "rooted", enable develper settings and enable it.

    It is STRONGLY recommended to fully wipe your device before flashing and please avoid restoring system apps and system data with Titanium Backup as this can cause stability issues that are very hard to debug.
    If you believe you know what you're doing - then fine, go ahead, but please don't complain if you experience any strange behavior.

    How to flash for the first time:
    (Again: Don't do it if you don't know it!)

    1. Download the ROM and GApps and transfer them to your device.
    2. Boot to recovery (TWRP recommended).
    3. Wipe the System, Cache, Data and ART/Dalvik cache.
    4. Flash the ROM Zipfile.
    5. Flash the GApps (optional, needed for e.g. Google Playstore to work).
    6. Reboot and set up your device.

    XDA:DevDB Information
    [ROM][Z3TC] LineageOS 15.1 SGP621 [UNOFFICIAL], ROM for the Sony Xperia Z3 Tablet Compact

    Contributors
    evil-god
    Source Code: https://gitlab.com/sony_scorpion

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.4.x
    Based On: LineageOS

    Version Information
    Status:
    Testing
    Current Beta Version: 20181223
    Beta Release Date: 2018-11-24

    Current Release Candidate Version: 20190422
    Release Candidate Date: 2019-01-06

    Created 2018-11-24
    Last Updated 2019-04-22
    20
    Reserved

    build 2019.09
    Changelog:
    update to september security patch level

    LTE SGP621
    https://drive.google.com/open?id=18JuMT-gd755aY4zgwWbR-qQWxFsVO6Ng

    just in case, fastboot RC02 images !NOT FOR TWRP!
    https://drive.google.com/open?id=1nXmltIsN_KYCTt-JH697MUb6FQ3jhTeY

    WIFI SGP611
    https://drive.google.com/open?id=12hGd50HJZWDovFTYg1bjWYNhZGT4ACsf

    just in case, fastboot RC02 images !NOT FOR TWRP!
    https://drive.google.com/open?id=10SUeWMpNJmDFJXH5Hx_tfshDVsdsLj_i
    9
    Is this ROM still alive?. I'm wondering whether to get rid of my tablet but I'll keep it if there is a good ROM still developing
    new build is uploading now, but just a security update to 2019.04.05
    my new job "eats" my free time, but should be better in a few weeks, then the migration to los16.0 is planed

    Hello.
    Tell me how to upgrade from Lineage OS 15.1 version 20181223 to Lineage OS 15.1 version 20190106 without losing user data and losing system settings?
    just install without make a total wipe, format only cache and dalvik, should work
    9
    @evil-god
    Is this still in active development? Or is it dead?

    hi, its not dead, but suspended. i got los-17.1 running, but ambient light sensor (automatic brightness for display) isnt working, so i dont release it.
    source are on gitlab, see first post.
    8
    hey, sorry for the long silence, still working on the 16.0 build, main problem is video recording and nfc.
    15.1 update will follow after google sec release, i think about 5. of march.
    greets