[Discussion] Google Pay Magisk Discussion Thread

Search This thread

Garbonzo17

Member
Oct 5, 2014
30
10
USNF has issues as you'll see here... So

... Don't put gms (Play Services) in denylist for ANY USNF builds. (Only needed for custom ROMs integrating @kdrag0n's SNF or their own solutions for S/N / PI)...

Please be specific what you mean by


... Are you getting the "Google Pay is Currently Updating..." Screen that never goes away? Other?... PW
No, but I got everything working again. And my fix isn't gonna jive with what I am seeing here (I don't believe).
I currently have also made the cardinal sin of changing MORE than one thing at the time... so I am NOT 100% why it works now...
1st (and probably NOT relevant) I have GPS (only com.google.android.gms nothing else) and Google Wallet on denylist. Set Enorce DenyList=off though, so I am even more confused that I was... (but this is how my OnePlus 6t is set, so I did same)
2nd I switched from Displax v2.1 mod back to 2.0 (I think I was originally using that from when I did the whole Tmo conversion of this phone back in December...
3rd I went through the process of uninstalling wallet (actually disabled again in addition to uninstalling updates), dumping updates for play store/services and storage/cache, rebooted, and cards added fine without the red circles telling me contactless no good cuz I suck!

So, it is probably #2 or #3 (I feel like probably the steps in #3), and I really have to (and hate) to move on with my day, this has eaten enough, but I feel like I understand marginally more than I did.. and it was your posts both in this thread and others that you linked to that got me to the goal (even if it may be temp, considering I don't know what blew it up a few days ago, but from what I am reading I am certainly not the only one having these issues... and guys like you doing the lords work in making stuff work for those of us that like to tinker...

THANKS (to everyone, really) for this community.
-G
 
  • Like
Reactions: ipdev and pndwal

pndwal

Senior Member
No, but I got everything working again...
I currently have also made the cardinal sin of changing MORE than one thing at the time... so I am NOT 100% why it works now...
1st (and probably NOT relevant) I have GPS (only com.google.android.gms nothing else)
Play Services is generally referred to as gms, not GPS...

But gms in denylist with USNF?... Why? ... USNF will hide that itself as denylist prevents zygisk modifications in gms... If denylist is not enforced and proper hiding modules source denylist for convenience there is usually no conflict, but both Shamiko (or other) and USNF will be competing to hide root from attestation/droidguard (com.google.android.gms.unstable) and/or main (com.google.android.gms) process...
and Google Wallet on denylist. Set Enorce DenyList=off though, so I am even more confused that I was...
Zy-USNF works w/o denylist enforced as it does its own process hiding (unlike Riru-USNF which used MagiskHide's hidelist) since denylist breaks modifications in 'denied' processes... It's denying Magisk modifications...

Long explanation: Denylist can hide root from gms, but then the primary fix, which uses Zygisk to inject code into gms to register the fake keystore that produces the exception which causes our fallback to basic attestation will be broken!!! (... because denylist prevents zygisk modifications in processes as mentioned above.)
... but from what I am reading I am certainly not the only one having these issues...
No... Stay on any of @Displax's modded builds for now... PW
 

pndwal

Senior Member
... and now still having no luck with getting wallet/pay to work...
... Are you getting the "Google Pay is Currently Updating..." Screen that never goes away? Other?... PW
Yeah, I am.
Cleared play & wallet cache & data, downgraded from 2.4 to 2.3.1 v2.1
Now it's stuck on Google Pay updating.
How long does it usually take for that to clear?
Nice interception of that ball! 😉

Answered here:
https://forum.xda-developers.com/t/magisk-module-universal-safetynet-fix-2-4-0.4217823/post-88092445

Hope it helps...

🤠 PW
 
  • Like
Reactions: wfred

bombadier

Senior Member
Jul 3, 2010
3,641
3,562
The Burgh
LG G Watch R
Samsung Galaxy Tab S2
I have just had a strange experience, wallet was working fine on Thursday, went to pay for a takeaway tonight and wallet payment was rejected with the message your phone doesn't meet security requirements, checked play integrity API checker and my device was failing meets_device_integrity, my banking app is still working, read some of these comments and downgraded from USNF 2.4.0 official to USNF 2.3.1_2.1 MOD by Displax and rebooted my phone, after rebooting I passed meets_device_integrity, still had the error in wallet so wiped cache and reloaded the app, error message is gone, will see if wallet works tomorrow at the shops but not sure what the issue was other as 2.4.0 just randomly stopped working

Update not tried to use wallet yet but am still getting the error when opening the app, have deleted my bank card and added it again which was successful, just need to test making a payment

Update Google wallet seems to be working just made a payment
 
Last edited:

Garbonzo17

Member
Oct 5, 2014
30
10
I have just had a strange experience, wallet was working fine on Thursday, went to pay for a takeaway tonight and wallet payment was rejected with the message your phone doesn't meet security requirements, checked play integrity API checker and my device was failing meets_device_integrity, my banking app is still working, read some of these comments and downgraded from USNF 2.4.0 official to USNF 2.3.1_2.1 MOD by Displax and rebooted my phone, after rebooting I passed meets_device_integrity, still had the error in wallet so wiped cache and reloaded the app, error message is gone, will see if wallet works tomorrow at the shops but not sure what the issue was other as 2.4.0 just randomly stopped working

Update not tried to use wallet yet but am still getting the error when opening the app, have deleted my bank card and added it again which was successfull, just need to test making a payment
If you re-added the cards and it seems normal when you attempt a (dry) purchase, you should be good to go. (I was in your situation earlier in the week, and have been using everything fine for the last 3 days or so)
I am still unclear as to what caused working installs (using USNF2.4.0 official) to just stop working...
But as long as people better with these things than are working on this situation (and USNF2.3x/displax holds) I feel pretty good about things!
Thanks again to @pndwal and others for taking the time to explain things slowly enough for non-coders to follow.

-g
 

cmstlist

Senior Member
Jan 11, 2010
3,374
524
Toronto
Google Pixel 4a
Just wanted to report on Pixel 6a this seems to have worked?

I removed 2.4.0, added the above mod, then before any reboots I did a force-close + cache clear on Play Store, Wallet and Play Services. Did not wipe data of any. Then reboot. On first open of Wallet app it still complained. But then after quitting and reopening the app, no further complaints.

EDIT: Yes it worked. The error appeared when I tried to make a payment at a cafe this morning. After doing the above I went grocery shopping and was able to pay again.
Follow up: this weekend I've been often getting the message about my device not meeting security requirements, when opening Wallet app. It's especially prone to happen when I launch it from the Wallet quick settings tile. But after getting the message, the contactless symbol is not crossed out, and payments still work 🤷‍♂️

Clearly there's something going on that could use another fix.
 

pndwal

Senior Member
Follow up: this weekend I've been often getting the message about my device not meeting security requirements, when opening Wallet app. It's especially prone to happen when I launch it from the Wallet quick settings tile. But after getting the message, the contactless symbol is not crossed out, and payments still work 🤷‍♂️

Clearly there's something going on that could use another fix.
Are you using a custom ROM? If so, which? PW
 

pndwal

Senior Member
No, stock Pixel 6a on latest Android 13, latest Magisk. Universal SafetyNet Fix V2.3.1-MOD_2.1 by kdragon, modded by Displax
mmm... Then it may have just been a glitch... I've seen this inexplicably before also...

You could try earlier @Displax mod builds that don't build Hide "Enable OEM Unlock" setting... @kdrag0n was concerned that this might cause per-device breakages and @Displax has agreed that it shouldn't be merged in official USNF, although it caused no problems for me (Xiaomi RN8T)...

Summary: You need neither:
Updated 2.1:
Hide "Enable OEM Unlock" setting
nor:
Updated 2.0:
Bypassing DEVICE_INTEGRITY for devices that shipped with Android 13+ (Pixel`s 7 )
but you do need:
Updated:
Drop fingerprint to lowest possible (6.0) to ensure that no one use same Android version
... 😶 PW
 

cmstlist

Senior Member
Jan 11, 2010
3,374
524
Toronto
Google Pixel 4a
mmm... Then it may have just been a glitch... I've seen this inexplicably before also...

You could try earlier @Displax mod builds that don't build Hide "Enable OEM Unlock" setting... @kdrag0n was concerned that this might cause per-device breakages and @Displax has agreed that it shouldn't be merged in official USNF, although it caused no problems for me (Xiaomi RN8T)...

Summary: You need neither:

nor:

but you do need:

... 😶 PW
Sure I'll try the older mod. On first reboot no complaint from Wallet, Safetynet still passes. Will see if it stays consistent.
 

cmstlist

Senior Member
Jan 11, 2010
3,374
524
Toronto
Google Pixel 4a
mmm... Then it may have just been a glitch... I've seen this inexplicably before also...

You could try earlier @Displax mod builds that don't build Hide "Enable OEM Unlock" setting... @kdrag0n was concerned that this might cause per-device breakages and @Displax has agreed that it shouldn't be merged in official USNF, although it caused no problems for me (Xiaomi RN8T)...

Summary: You need neither:

nor:

but you do need:

... 😶 PW
Update: No I'm having the same experience as before. Open Wallet and get the warning, but then it seems to work anyway.
 

pndwal

Senior Member
Update: No I'm having the same experience as before. Open Wallet and get the warning, but then it seems to work anyway.
mmm... Just checked mine and strangely enough I can now confirm you are not alone:
IMG_20230206_054914.jpg

... I've just cleared Google Play services data and tried opening Wallet but it's icon was removed from app drawer in lauuncher... Opened Play Store and wallet is still there:
IMG_20230206_060417.jpg

But after opening from here:
IMG_20230206_055816.jpg

... This isn't completing... Again...

Will get back to this later... 😬🤔🙃 PW
 

cmstlist

Senior Member
Jan 11, 2010
3,374
524
Toronto
Google Pixel 4a
mmm... Just checked mine and strangely enough I can now confirm you are not alone:
View attachment 5828739
... I've just cleared Google Play services data and tried opening Wallet but it's icon was removed from app drawer in lauuncher... Opened Play Store and wallet is still there:
View attachment 5828747
But after opening from here:
View attachment 5828749
... This isn't completing... Again...

Will get back to this later... 😬🤔🙃 PW
Interesting, that's MORE non functional than mine
For me it's just sporadic and no failed payments so far. Except for last weekend when I was still on USNF 2.4.0. It seems like there are different conflicting sources of checks going on and having some kind of race condition. Sometimes the successful check wins, sometimes the unsuccessful wins. On my device the unsuccessful check lives just long enough to give me an error, then the successful check appears to take over 🤔
 

bombadier

Senior Member
Jul 3, 2010
3,641
3,562
The Burgh
LG G Watch R
Samsung Galaxy Tab S2
Interesting, that's MORE non functional than mine
For me it's just sporadic and no failed payments so far. Except for last weekend when I was still on USNF 2.4.0. It seems like there are different conflicting sources of checks going on and having some kind of race condition. Sometimes the successful check wins, sometimes the unsuccessful wins. On my device the unsuccessful check lives just long enough to give me an error, then the successful check appears to take over 🤔
After my spot of bother yesterday since going back to Displax's version of USNF (That fixed the failed meets_device_integrity), I was still getting the error message after wiping wallet's cache, since deleting payment method and adding my card I have had no further error messages in wallet and can make payments
 

cmstlist

Senior Member
Jan 11, 2010
3,374
524
Toronto
Google Pixel 4a
After my spot of bother yesterday since going back to Displax's version of USNF (That fixed the failed meets_device_integrity), I was still getting the error message after wiping wallet's cache, since deleting payment method and adding my card I have had no further error messages in wallet and can make payments
Good to know, but it seems all the anecdotes here are along the lines of "Aha! I did X and that fixed it... [insert 1-7 days] nope that didn't fix it"
So I think there will have to be some new fix/patch developed to deal with a new behaviour.

I'm taking this phone on vacation in 2 weeks for a 5-week vacation to mostly Australia. If Pay fails, no sweat, I can still use the physical cards in my wallet. But two things I might hesitate with:
- Using Pay for contactless entry to the Sydney transit system. If it succeeds on the way in and fails on the way out, I'm stuck and might have to pay a fine. (It treats the phone as a different device than the physical card.) Plus if I use the same card regularly it applies fare-capping daily and weekly, and that won't work right if I start via Pay and have to switch midway to the physical card.
- Using the mobile Myki feature in Melbourne via Wallet instead of a physical card. If I load money onto mobile Myki and then Wallet fails on me, the money becomes inaccessible. Plus if I wipe GP Services it destroys the transit card and the money is not retrievable.
 

pershoot

Inactive Recognized Developer
Dec 1, 2008
7,996
4,364
Please note, Wallet started complaining (as is the case with others) when on 2.4.0 (kdrag0n). Rolled back to 2.3.1_mod_2.1 (Displax), cleared cache for Wallet (for precaution) and then updated Google Play system. After ~+24 hours, it has dropped off and no more apparent error messages (as of yet).
 
  • Like
Reactions: bigknowz and zgfg

Top Liked Posts

  • 1
    Does anyone happen to know why GPay 'Check bank balance' is not working? When I tap on the account on the 'Select account' screen, a line flashes above and disappears. Nothing else happens. Hope this is not OT here.
    I'm using same version GPay and didn't face such issue, probably it's your device app bug or something in your device. There no traces related magisk. Kindly confirm your side.
  • 2
    This is so weird. I have Galaxy S22 and Galaxy S20+, both with latest stock firmware + Magisk 25.2, I have all google apps in DenyList. Also, the ROM is heavily modified: I disable almost all Samsung Apps (except for system-critical). SafetyNetFix of latest Git-downloaded version installed, TWRP also of latest available (corsicanu's build). Everything works, but Google Wallet sometimes throws a pop-up warning about root. I usually kill the app, wipe it's cache, start it again and I can again pay without problem. Also, no matter what, contact-less payment have all checks green, despite prior toast warning. Reboot also fixes the issue (making payments possible again, in cases where cache wipe or app-kill won't work).
    If you're using the original Universal SafetyNet Fix by kdrag0n, you might wanna switch to the Displax fork linked a couple of posts above and test.

    Hope this helps.
    2
    I'm using rooted android 10 with Safetynet Pass & Play Store -Certified, but I'm still not able to activate tap to pay on Paytm app.


    It's gives me a error - "This functionality is not available due to security concerns with your device."

    How can I fix it?
    Requirements:-
    - Magisk v25.2
    - LSPosed v1.8.6
    - PrivacySpace v1.3.7 (LSPosed module app)
    - Enable Zygisk (Enforce DenyList - Disabled) under Magisk (+ download some Magisk module as shown in screenshot¹)
    Screenshot_2023-03-18-17-10-02-79_9d1fb82a3633e78ac9c37e5a64e38237.jpg

    Follow below steps to fix "This functionality is not available due to security concerns with your device" in Paytm (Tap to Tay):-
    1. Download frest original Paytm app or clear data & force stop.
    2. Open PrivacySpace app/module under LSPosed.
    3. Hidden Apps > select Paytm (+ all other modules such as Lucky Patcher, etc as show in screenshot²).
    Screenshot_2023-03-18-17-20-27-10_30686f06bc9783668a8afa418b45660d.jpg
    4. Blacklist > select Paytm.
    Note: If u want to recieve Paytm app update in Play Store then select Play Store in "Connected with Others" to unhide Paytm app for Play Store.
    Screenshot_2023-03-18-17-27-19-47_30686f06bc9783668a8afa418b45660d.jpg
    5. All Set, Try your Luck Now, and do not forget to let me know if it's work for you too.
    1
    If you're using the original Universal SafetyNet Fix by kdrag0n, you might wanna switch to the Displax fork linked a couple of posts above and test.

    Hope this helps.
    Yes, just did so. I'm using 2.4 MOD from this thread. Will see how it works
    1
    I don't prefer G Pay for anything.. Will like to stick with Paytm and try to work on fixing tap to pay
    I see you said you pass SafetyNet... But of course that's deprecated; most banks have migrated to new Play Integrity API now... Are you passing PI deviceIntegrity?...If not official Universal SafetyNet Fix will likely not help as it currently has issues... You'll need @Displax's up-to-date fork with fixes...

    Also, did you install Shamiko for proper root hiding as suggested more than once above?

    🤠 PW
    1
    Does anyone happen to know why GPay 'Check bank balance' is not working? When I tap on the account on the 'Select account' screen, a line flashes above and disappears. Nothing else happens. Hope this is not OT here.
    I'm using same version GPay and didn't face such issue, probably it's your device app bug or something in your device. There no traces related magisk. Kindly confirm your side.
  • 62
    The new Google Play services update caused this.

    Temporary workaround:

    1. Disable Google Pay/Find My Device as Device Administrators in Settings > Security & location > Device Administrators.

    2. Search "Google Play services" in the Settings search bar.

    3. Press the three dots and press "Uninstall previous updates".

    4. Download this update - https://www.apkmirror.com/apk/google-inc/google-play-services/google-play-services-14-7-99-release/
    Pick your needed edition (arm or arm64, etc.), download it and install it.

    5. Disable Background data access for Google Play Services and Google Play in their respective App Info pages.

    6. Download Google Pay from the Play Store.

    7. Set up your cards. Enjoy!

    Never EVER update Google Play services manually, until a Magisk update is available that bypasses the upgraded SafetyNet. Note that Google Play services is responsible for adding/verifying the card, not the Google Pay app! Hence why there seems to be an overlay when adding a card/verifying an existing one.

    Tested Google Pay versions:

    2.79.x-2.83.235070858 - working

    Tested Google Play services versions:

    14.7.99, 16.0.86 - working with Magisk 18.1

    14.8.49-16.x- working with Magisk 18.2 Canary
    32
    This thread is inspired by the PoGo Magisk discussion thread. It's meant to keep the clutter of "Google Pay doesn't work" posts out of the main Magisk threads.

    Please use this to discuss issues with Google Pay and possible solutions.


    There's a working solution here:
    https://forum.xda-developers.com/t/magisk-module-universal-safetynet-fix-2-3-1.4217823/post-87198517


    For general tips on first getting SafetyNet to pass fully, check here:
    https://www.didgeridoohan.com/magisk/MagiskHide#hn_SafetyNet
    29
    Ok. I tried this and it worked on gms 17.1.22, allowing one to add cards and pay in store. Warning YMMV, but this is the process I did to get this working. One caveat is that Google pay does not register the "recent transactions" on the Google pay app. Another caveat is that I suspect users will have to reverse some step if gms is updated and then reapply, but this still needs to be confirmed

    Without further ado, here is my process:

    1) download a SQL database editor. I used

    https://play.google.com/store/apps/details?id=com.tomminosoftware.sqliteeditor&hl=en_US

    2) download a terminal emulator program. I used terminus but any terminal emulator should work.

    3) make sure Google pay is forced close, if it is open.

    4) open SQL editor. Navigate to /data/data/com.google.android.gms/databases

    5) open dg.db

    6) change any value that lists "attest" in the name (first column) to 0 in the third column. Mine was showing a value of 10 in the third column for each of these values. (Column c for sqlite databse editor I used)

    7) open the terminal emulator.

    8) get root access (su)

    9) cd /data/data/com.google.android.gms/databases

    10) type: chmod 440 dg.db
    This makes dg.db read only (for owner and group, and no access for world.)

    11) reboot

    I suspect when gms is updated, one will have to go back to steps 10 and 11 and chmod 660 dg.db to allow new keys to be written to the database, and then go back and redo all these steps to reset the attestation values back to 0.

    If there is still an error, verify in sqlite database editor that all attest release keys values in dg.db are 0 when dg.db is read only (owner and group).

    Again, YMMV but this worked for me, so I give it back to the community now.

    Edit: recent activities did show up soon afterwards for the payment method.

    Cheers,
    B.D.
    27
    The app is finally public! (thanks Google for taking a week to approve this 🤦)
    I made it beta testing since I haven't tested it on much devices. If you find any problem, please open an issue here and I'll take a look at them once I return from vacation.


    Source code:

    If you are curious, the possible outcomes I've seen are:
    • 3 ticks (unrooted samsung)
    • tick/tick/x (unrooted redmi note 4 with unlocked bootloader)
    • x/tick/x (my rooted a11 op7t)
    23
    UPDATE 1/8/2022
    This app is officially discontinued in favor of a new app I published on Play Store. Read more here:

    ====================
    ORIGINAL MESSAGE:

    I just made this simple app which tells you if your device passes the new Play Integrity API (which is presumably what Google Pay and Play Store use to detect root now). If you don't trust random apks from the internet feel free not to use this. I'll upload the source code at a later time since it's very junk now (probably on github).
    You can use it to play around and see if you manage to get it to pass without having to mess with Google Pay. There are screenshots of the 2 possible outputs (pass screenshot is from an online emulator).
    Also I didn't test it much since I don't have many devices that can pass. Hope it works fine 🤞

    Hope this helps someone find a solution :)

    EDIT:
    Here is a quote from Google of what exactly "Does not meet device integrity" mean:
    The app is running on a device that has signs of attack (such as API hooking) or system compromise (such as being rooted), or the app is not running on a physical device (such as an emulator that does not pass Google Play integrity checks).
    ...
    If you are having problems with your testing device meeting device integrity, make sure the factory ROM is installed (for example, by resetting the device) and that the bootloader is locked.