• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Discussion] Mario Kart Tour + Magisk Discussion Thread

Search This thread

sun_is_shinning

Senior Member
Jul 13, 2016
470
148
Valongo
As of yesterday (Sunday 17t Oct 2021) I now get an error 806-6502 when launching the game.
Checking the error online I find it either means Safetynet failed or app downloaded from 3rd party store (ie aptoid).
I'm using a rooted Oneplus 8 pro, Android 11 (oos 11.0.8.8) and Magsk canary 23001)

The Magik app shows Safetynet pass and I have uninstalled the MK app and reinstalled from Google play but still get the 6502 error. (Obvs the MK app is in the MagiskHide list)

Does anyone have any ideas? Obviously something has changed yesterday as I play this every day :)
The same happen to me yesterday, but on the end of the day the game resume to work again.

Nothing related to rooted devices or anything, just some trouble at Nintendo itself.

Dont worry, just keep trying...the game are working fine since yesterday 23h CET.
 
  • Like
Reactions: djmarkm

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Just found a way that is more simple and works for every "root-prof" app to run almost every app that detects root.

    Requirements:
    - Android 8.0+
    - TWRP installed
    - Magisk 20.4 beta zip
    - Latest Magisk Manager apk
    - safetynet-fix-1.1.0 zip (link bellow or download the attachement from thread)
    - Patience (just kiddin)

    Safetynet fix zip link: https://github.com/kdrag0n/safetynet-fix/releases/download/v1.1.1/safetynet-fix-v1.1.1.zip

    You need to do the exact things at this order:

    1: Install Magisk 20.4 beta zip in TWRP;
    2: Reboot into system;
    3: Go to Magisk and update the manager only (not magisk);
    4: Reboot;
    5: Open Magisk Manager and in the first page on the top right click on settings, scroll down and enable MagiskHide, give another name to the magisk like "Honolulu" or something (i give that name, i know is not related but, pointless);
    6: Reboot;
    7: Go to main screen of Magisk and check if you have the random name like md5 checksum type in "installed" line bellow magisk title in blue, and within "( )" in front saying (21405) - thats the version you need to have, and if you dont see the 4 icons from the app menu's in the middle bottom of the app like "home, root, registry, modules" - if you dont see that 4 icons tab go ahead above the page and click on "install" (in front of Magisk title in blue) chose the recomended and let it flash inside the app;
    8: Reboot;
    9: Go to Magisk again and go to second icon from left to right at bottom, chose the "MagiskHide" and a list of apps just pop, enable the "mario kart" and "google services" there;
    10: Again go to the main screen of magisk, click on "Check SafetyNet" - it should now say Sucess, and have 2 checks and evalType BASIC all inside a blue square.
    11: Go to settings of your phone and clear cache + clear data from Mario Kart and Google Services app.
    12: Open magisk again and go to 4th ícon bellow at right and then select "install from storage" and find the safetynet fix 1.1.0 zip and flash it;
    13: Reboot;
    14: Go to your file manager and at root of your internal memory and sd card and check the TWRP folder - if the folder is empty just delete it, if you have backups from TWRP inside, just rename it.

    DONE! Now you can play Mario Kart, use McDonalds app and other app's that detect root (just enable them inside magisk to hide it, otherwise it wont work).
    2
    I fix the game thanks friend, I run the game with the next files..
    the instruccions are: (sorry for my english)

    1.- Install the Magisk Zip 21.4
    2.- Install the app MagiskManager 8.0.7
    3.-Install busybox module, magiskhide props
    4.-Restart phone
    5..- open terminal and write
    su
    props
    .... and set your fingerprint
    6.- restart the phone
    7.- in the magisk manager you need activate the magiskhide and set google services and mario kart tour
    8.- open magisk manager and install the module safetynet v1.1.1
    9.- restart phone
    10. detele the folder "twrp" in all's storage (internal and external) if have a backup renamed it.
    11.- check de safety status before to run the game in the main app.
    the blue screen with the text "Success" should be displayed
    12.- run the game

    NOTE: dont forget clear cache and data app (google services and mario kart) before to run the game
    1
    SafetyNet failing both checks might be because of one of your modules. A few are known to cause this, like Safetypatcher, FDE.AI and EdXposed (unless you run the current Canary release of EdXposed, v0.4.6.3 I think).

    If it's not that you can try clearing the cache for Play Services. That's been known to fix SafetyNet failures recently.
    1
    OMG wiping cache of Google Play Services did the trick, many thanks :)
    Now I try to install EdXposed again and see if securitynet still is ok.
    If not I will live without it in the future..

    Edit:
    It is also working with the latest EdXposed Canary build, many thanks for your support.

    Regards

    Sent from my SM-G960F with Tapatalk
    1
    .. with an existing "twrp"-folder on internal storage the game could crash too ..