• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Discussion] NitrogenOS Oreo 8.1.0 [Out of Order]

Status
Not open for further replies.
Search This thread

iAmWiz

Senior Member
Dec 8, 2015
420
120
Calabar
Sorry this is too much to ask, can anyone confirm HTTP Injector not force closing on 8.1 in this ROM?

Without that app, I won't be able to use this ROM.

Someone help me? It was force closing from my end, I'm reverting back to Omni. Thanks

Sent from my ONEPLUS A3000 using XDA Labs
 

rankin1

Senior Member
Oct 10, 2014
266
73
I'm using a modded version and it's working fine for me

---------- Post added at 11:59 PM ---------- Previous post was at 11:57 PM ----------

Yup I can confirm its force closing
 
  • Like
Reactions: iAmWiz

otto888

Senior Member
Just installed this ROM, and it ran great while setting it up. Rebooted and got the "To start Android, draw your pattern" screen. Recovery can decrypt fine with any pattern, but any pattern I use says it's incorrect. Is there any way to bypass this without wiping? Just going to wipe and make sure not to enable secure start again. Glad I had a recent backup of the whole phone.
 
Last edited:

bhanuprasad1981

Senior Member
Mar 7, 2012
96
6
hyderabad
Tried installation but I am failing with gapps error
Here is process
1.Wiped data ,cache, dalvik & system
2.flashed ob28
3.flashed latest Nos 8.1 zip
4.try flash 8.1 gapps but boom error
I get error "this gapps is compatible with latest 8.1 rom I should install compatible 7.1.2 gapps"

What am I missing ?
 

arifqur

Senior Member
Nov 12, 2005
3,698
1,111
Tried installation but I am failing with gapps error
Here is process
1.Wiped data ,cache, dalvik & system
2.flashed ob28
3.flashed latest Nos 8.1 zip
4.try flash 8.1 gapps but boom error
I get error "this gapps is compatible with latest 8.1 rom I should install compatible 7.1.2 gapps"

What am I missing ?

Flashed ob28 firmware or the complete rom?
 

parag60288

Senior Member
Feb 26, 2013
338
66
Mumbai
OnePlus 7T
Moto G40
Root Issue?

I flashed NOS8.1 + 8.1 gapps.
Rom is awesome & pretty stable.
But i am facing strange issue with SuperSU SR5. I flashed SR5 & Rom is rooted but i cannot fine SuperSU app in app drawer.
It has default root action as "Granted".
Anyone had this issue?

Edit: I had to install SuperSU SR5 apk & everything is fine now. But Dont know why this might had happened!!
 
Last edited:

bhanuprasad1981

Senior Member
Mar 7, 2012
96
6
hyderabad

Attachments

  • Screenshot_2017-12-10-02-52-59.png
    Screenshot_2017-12-10-02-52-59.png
    137.2 KB · Views: 528

arifqur

Senior Member
Nov 12, 2005
3,698
1,111
The 8.1 version seems much snappier then the last 8.0 Oreo version.
Great stuff man. I hope these devs can open a proper thread here for discussion.
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 42
    There is an official Thread now, so this Thread is out of order!
    https://forum.xda-developers.com/on...ice-development/rom-nitrogen-os-beta-t3737654

    NitrogenOS!

    Important!
    I am NOT the owner or developer of this ROM!
    All credit goes to @xyyx
    We are all very thankful for his work!

    Please if you want to post something on this thread, do NOT
    -post something that was already said before
    -tell us bugs which are already well known
    -ask for new features as I am not the developer!
    -blame @xyyx for bugs or better, don't mention him at all!


    _________________________________________________________________________

    Downloads
    Link to the ROM

    OpenGApps unofficial

    Magisk Beta
    Firmware for OP3

    unofficial TWRP


    ________________________________________________________________________________________


    What is currently not working?
    - VoLTE, but Vo2G is working fine.



    Please do NOT tell us bugs which are already well known!
    It can be very annoying if everybody is reporting the same bug again and again.



    _____________________________________________________________________________________


    Credits:
    xyyx for his wonderful ROM!
    @topjohnwu for Magisk!
    @eng.stk for TWRP!
    @Nezorflame for his OpenGapps build server!
    @jamal2367 for the Firmware zips!

    28
    They gave you a solution you don't want to try. If you aren't willing to change something to make it work then don't post issues and ask for help

    ---------- Post added at 07:58 AM ---------- Previous post was at 07:57 AM ----------


    At the end of the day it's your ROM.

    Frankly all this VoLTE talk is incredibly annoying. If people want it so bad, they can learn to code and make their own.

    VOLTE is the main reason why I don't make thread here. Because volte's guys are very annoying. I tried caf telephony. It has some trouble with AOSP code. And I don't want to use hacks from Omni.

    As I wrote in Kenzo's thread:

    Attention:
    I don't force you to use my ROM. I fix bugs that doesn't require many commits from CAF.
    If you don't like something, please, use another ROM and don't write in this thread. Please.
    23
    We should really curb this VoLTE thing for now because it's taking over the thread again it would seem. Just wanted to put the info up a little higher.

    For those of you who need VoLTE, there is currently no support on this ROM. The ROM developer does not use it, and doesn't want to code a workaround like in Omni. If you need VoLTE, I'm sorry to say it but you should go on Omni for now at least. Currently it also appears that magisk workarounds and system file editing doesn't really help either.

    The reason it isn't working is because the caf telephony sources have not been updated for Oreo, so that means that developers cannot get it to work officially because they need the base code to build on. Omni developer Maxwen decided to code support for it himself and that's why it works. It is safe to say that when the caf sources are released that all 8.0/8.1 AOSP ROMs will support VoLTE due to it being much easier and quicker to build off.

    Currently, if you depend on VoLTE, you're outta luck. If you have it but don't need it, switch your networks to GSM/wcdma if you can't disable VoLTE while keeping LTE connection.

    Just keep in mind that ROMs come AS IS, and you really don't have a right to complain too much. This is especially the case here on this thread. The developer here didn't even publish this ROM to XDA which means they didn't want to deal with the XDA community or anything. They make this ROM for themselves, and it's still nice enough that they let us use it. Some developers in the past when they haven't shared work on XDA flip out (within reason) when someone else does it, so thank you to the developer for being so chill about it!
    17
    My VOLTE was going away after one reboot on latest OOS beta FW...

    All those VoLTE posts are USELESS.

    Once for all, no Oreo ROM will be able to fix it because it's UPSTREAM CAF thing. So stop flooding with 'it works', ' oh s*** it went away after a reboot' 'i tried firmware xyz and it doesn't work'

    It's a chipset manufacturer driver not yet available for 8.1.So if VoLTE is vital for you just don't use those roms and use STABLE roms. Using experimental ROMs has a price, be ready to pay it.
    16
    Can someone share screenshot of this new fresh UI because mine is the same like previous..

    Here you go.