[Discussion] PokeMon Go Magisk Discussion Thread

Search This thread

mlizmore

New member
Sep 28, 2020
4
0
I have followed this guide* on a rooted S5 Neo with android version 7.0, security patch August 1, 2017, Magisk manager 20.4 and 7.5.1 and Smali patcher 0.0.6.9. I am still getting rubber banding. Have adjusted the location settings to GPS only, disabled improve location accuracy. Am using the paid version of FakeGPS Route, which is also on the specified settings including expert mode with disabled fused location service. Does anyone have any other troubleshooting advice for how to stop rubber banding? I have followed every step, looked at youtube guides, been to XDA Developers etc. Really have tried my best to use due diligence before resorting to posting a comment for assistance.

Basically, I completed Method 2 of rooting my phone (rooted method with Magisk), found there was way too much rubber banding, decided to follow this guide for Method 3 and it's the exact same. This is really frustrating. The only two things I have noticed is that when I go into developer settings and select mock location app, then set it to FakeGPS Route, I exit out and go back into developer settings and there is no app selected. Maybe this has something to do with it? I have no idea. The second thing is that when I am in my basement I don't have any issues with rubber banding. Is this a coincidence? Isn't Smali supposed to apply a patch to hide mock location status with signature spoofing? Seems odd to me.

If anyone can provide any further explanation or information it would be greatly appreciated. Thank you in advance.

*Guides on r/pokemongospoofing I followed,
reddit.com/r/PokemonGoSpoofing/comments/8ytjz5/expert_mode_for_fake_gps_and_routes/
reddit.com/r/PokemonGoSpoofing/comments/glxdfv/rooted_method_1_smali_patcher_guide_for_android/
 

resarfekim

Senior Member
Jan 26, 2011
496
105
I have followed this guide* on a rooted S5 Neo with android version 7.0, security patch August 1, 2017, Magisk manager 20.4 and 7.5.1 and Smali patcher 0.0.6.9. I am still getting rubber banding. Have adjusted the location settings to GPS only, disabled improve location accuracy. Am using the paid version of FakeGPS Route, which is also on the specified settings including expert mode with disabled fused location service. Does anyone have any other troubleshooting advice for how to stop rubber banding? I have followed every step, looked at youtube guides, been to XDA Developers etc. Really have tried my best to use due diligence before resorting to posting a comment for assistance.

Basically, I completed Method 2 of rooting my phone (rooted method with Magisk), found there was way too much rubber banding, decided to follow this guide for Method 3 and it's the exact same. This is really frustrating. The only two things I have noticed is that when I go into developer settings and select mock location app, then set it to FakeGPS Route, I exit out and go back into developer settings and there is no app selected. Maybe this has something to do with it? I have no idea. The second thing is that when I am in my basement I don't have any issues with rubber banding. Is this a coincidence? Isn't Smali supposed to apply a patch to hide mock location status with signature spoofing? Seems odd to me.

If anyone can provide any further explanation or information it would be greatly appreciated. Thank you in advance.

*Guides on r/pokemongospoofing I followed,
reddit.com/r/PokemonGoSpoofing/comments/8ytjz5/expert_mode_for_fake_gps_and_routes/
reddit.com/r/PokemonGoSpoofing/comments/glxdfv/rooted_method_1_smali_patcher_guide_for_android/

Try removing your phone cover (assuming you're using one), cover the back/sides of your phone with aluminum foil (cut for camera, ports etc) and replace cover.
Install and run "GPS Test". You want to see almost no satellites.
 

Vinayakn73

Senior Member
Aug 15, 2014
304
75
Mumbai
I have done all the steps needed. But Pokemon go is detecting real location.

unlocked bootloader of redmi note 9 pro Europe global version.

as twrp not available I rooted phone manually by patching boot file in magisk manager.

Installed gps joystick generated in privacy unlocked mode and also hid magisk manager with different name.

hid pokemon go, google play services and google play in magisk hide.

installed smali patcher module

set my gps app as a mock location app in developer options.

Enable indirect mocking and enable system mode unchecked (anyway both settings are grayed out can't change)

in magisk both cts and basic checks are failing (I don't know if it is necessary to play pokemon go)

after doing all this pokemon go is still at real location. I just don't know what I am missing please help. I can play on my old redmi with same steps followed but can't make it work on my friend's new redmi note 9 pro.
 

SebaS-DG

Senior Member
Aug 21, 2011
318
31
So, I have a redmi note 8, note 8T, note 9S and they have the same problem:

While I use a route or walk with the lock gps option, with root method to spoof, my phones stop auto walking in the gamewhen I turn off the screen.

With the game on the screen or in the background (in home screen or any app like whatsapp and others) it walks well.

Sometimes it walks, like today, I turned off the screen 10 times, and the 10 times walked with the screen on, and no more. I toght its fixed, I was happy, but the bug is here again, and I dont use the 9s for anything else.

My main phone is remdi note 7 and it walks well, like me second redmi note 7 and note 6 pro and note 3 SE

I talked to the app builder "gps jostick" but he cant help, and I offered to pay him, but he dont have time to "debug"

Anyway, I tried many options in the phone, others roms, but is always the same...


Any one who help me to fix this, I can pay paypal credit.

Root method, magisk updated to today, smali updated, gps joystick tested in the last 3 versions.

All power battery options I can find, turned off, Im testing with wifi, many options of the GPS tested (google accuracy on or off tested), no Jumping or unstable location.

I used only one gps app.

And I forgot to say, the gotcha keep working with the screen off. It keeps catching and spinning in the stucked place.

EDIT 2:

after more testing, it seems it is not complety "stucked" at the placeone phone walks in 12 minutes 1.39 kms (in the eggs distance); the phone with the problem seems to be moving but very slow: 0.45 kms in 12 minutes

With the screen on, and game running in the background or in the screen, it should walk the same distance, I alredy test both with the screen on, just in case.

one more test of 18-19 minutes

redmi note 7 1.87
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 33
    01/11 INFO for Samsung Galaxy users searching for a Safetynet (SN) Green Response

    EDIT 18/11/16:

    It seems red CTS response in SN might not work with all phones, therefore I suggest you use an enforcing kernel to get a green screen response while using this tutorial.

    In case this method doesnt work in your phone, you might want to consider a new method using Magisk V9 and System Xposed + Root Switch (just to hide Xposed). This method will probably work in all phones and not just on Samsung phones.

    EDIT 07/11/16:

    1. It seems SN is now detecting if your SELinux Status is Permissive. This means 3 things, first, that you in fact can start the tutorial with a RED screen as long as Pokemon Go works fine (so even with red screen, open POK Go and see). Second, that only if you use a Enforcing kernel you wil get a green response (I guess this is important for users of other apps, not pokemon go at the moment. And thirdly, Arters Kernel (or any other SELinux permissive kernel) will show you a RED screen but it will let you play)
    2. Latest superSU SR3 works fine as well, and it doesn't take long to boot. So you might want to give it a try.

    -----
    Updated info for Samsung Galaxy users searching for a Safetynet (SN) Green Response after Oct. 31 update.

    First of all, I apologize for posting this here (because it doesn't involve Magisk) but I'll do it because I know it is mainly Magisk users who were affected by the update and because I didn't find another proper thread to post it (Suhide is not also used). So if anyone find a better/more proper thread to post it just let me know and I will move it. :good:

    [] Confirmed working until now on:
    - Galaxy S6/Galaxy S6 Edge running Alexis Rom 7.1.1 with Arter Kernel and version SR2 of SuperSU
    - Galaxy S7 with stock rom and kernel BUT using version SR1 of SuperSU instead of version SR2, also, using Custom Rom (Superman Rom 1.15.5 with superstock kernel)
    - Galaxy S7 Edge with stock rom and kernel using version SR2 of SuperSU
    - Sprint Note 5 with stock rom using version SR2 of SuperSU

    - S6 Edge + (European Version)

    * Galaxy S5 seems to need a different procedure, look for CM rom and for its proper method if you happen to have this phone.

    *What is working: Root (with SuperSU) + Custom Rom/Custom Kernel/Stock Kernel/PermissiveOrEnforcing SELinux status + Pokemon GO lastest version with GREEN/RED response in Safetynet Helper (depending on your SELinux state, which usually depends of your kernel) and working Xposed Modules related to Pokemon Go (Snorlax latest version)

    *What is not working: Other modules not related to Pokemon Go, like YouTube adaway or XtouchWiz are not working while Xposed is "disabled" (they won’t work while you play Pokemon Go, but if you "enable" Xposed Framework they will work just fine, so you can use your phone normal with all the modules and just disable Xposed when playing Pokemon Go).
    -----
    *Files you will need: ADB drivers for your specific Samsung model // RootPatch files (all the credits go to the original author Shakalaka) // SR2-SuperSU-v2.78-SR2-20161029143931.zip (all the credits go to the original author Chainfire) // RootSwitch-1.3.3.2.zip (Shakalaka again! I like his name :)) // Xposed Framework 86.1 or 86.2 (xposed-v86.1-sdk23-arm64-custom-build-by-wanam-20160904.zip or xposed-v86.2-sdk23-topjohnwu.zip (all the credits go to their respective authors) // Your Rom files and TWRP 3.0.2 (only if you decide to start from zero) // Proper uninstallers for Magisk/Xposed/Suhide/Root/etc // Arter Kernel (only if you want to change yours).

    * The first step is to have your phone working and communicating with your PC through ADB mode. A simple search will point you in the right direction of how to have your phone working properly in ADB mode. Different methods may be needed according to your model, but usually it’s just a matter of installing the proper drivers. Also, extract in one folder of your PC the files from the archive RootSwitch (RootPatch).

    * You need to start all the procedure with a GREEN SN response! OR WITH A RED RESPONSE (but only if Pokemon Go works fine even with the RED response, so open the app and try even if it is RED)
    -----
    1- Get your rom back to its initial Safetynet GREEN status (this obviously means that you need to uninstall root). You can do this in many different ways:

    The first one and most recommended is to fully uninstall Xposed + fully uninstall Magisk + uninstall previous related apks. ALSO, if you had suhide please uninstall it properly. You can do this by flashing their respective uninstall zip files in recovery and uninstalling the related apps normally in system mode. You can follow this steps to do so:
    a. Uninstall Makisk Manager apk and Root Switch apk: just through the normal uninstall procedure of any app you have in your phone.
    b. Uninstall Xposed: Flash in recovery xposed-uninstaller-20160211.zip (if you were using Wanams 86.1 version) or xposed-uninstaller-topjohnwu-20160820.zip (if you were using topjohnwu 86.2 version). Then wipe dalvik/cache.
    c. Uninstall Magisk V8: Flash in recovery Magisk-unistaller-20161004.zip. Then wipe dalvik/cache.
    d. Uninstall Suhide (only in case you were using it) by flashing suhide-rm-v0.51.zip
    e. Reboot into system
    f. Open Safetynet Helper App (you can download it from the Play Store) and check your response.

    If you are lucky you will have a GREEN response in Safetynet and, of course, you won't have root, and Xposed app will show a red screen saying framework is not installed. Consider yourself lucky! :)

    If after doing this steps you get a blue screen in Safetynet, then probably you may have the same case of my phone/Rom and you will need to do the following steps:

    a. If you use Arters kernel, then just reflash it and wipe dalvik/cache. Then SN should return a GREEN response.
    b. If you use another custom kernel, then try reflashing it. Keep in mind 2 things: Arters kernel doesn't include root by default, so that is why it always works fine just by reflashing it, with no further steps needed. BUT if your kernel auto roots your phone, then you will need to flash it, then reboot into system and unroot in the same way you usually do (probably with SuperSU app option or through recovery flashing the respective unroot zip file)

    The idea is to have your Rom with a GREEN Safetynet response, with no root and with no Xposed. This is needed to make things work properly, because only by starting with a GREEN response the rest of the guide will work.

    If none of the options until here worked, then I'm afraid this is your last option:

    a. Reflash a Stock Firmware from Sammobile. A stock kernel/rom should not triger Safetynet, it should be green and with Pokemon Go working. This will leave you with stock recovery/kernel (so you will need to flash TWRP 3.0.2 in Odin if you want to make nandroid backups) and you will have to use your Rom as Stock.

    ( ) AGAIN, supposing you are using a Custom Rom that uses SuperSU root. Reflash your kernel, unroot with SuperSU app, then check Safetynet, if it is green you don´t need to change your current kernel. If its blue, then you will probably need a different kernel for your phone. Those kernels that come with no root has better chances of helping you get a GREEN SN response.

    *Please BE SURE to use only kernels that are specific for your devices, don't 'break' your device unnecessarily.
    ** If you didn't Wipe Dalvik/Cache during the previous steps, please Wipe Dalvik/Cache before you continue, as some Xposed files only dissapear with this.
    ***Suggestion for S6 and S6 edge users: I use Alexis ROM and Arter Kernel on my Galaxy S6 Edge, if you have never tried a Custom Rom for your Galaxy S6, you can be sure this Custom ROM+Custom Kernel is one the best combinations available for our phone models. Latest version 7.1.1 works fine.

    ---- CHECKPOINT 1----: reboot/double check that SN is GREEN/PASSING and that POKGO works fine, if you did well on the previous steps your Safetynet Helper result should be GREEN. If you are with a different screen report and tell which kernels/roms you are using and which ones did you tried, because having a blue/red screen is probably related to your kernel/rom choice or with an unsuccessful uninstalling procedure of previous Xposed/Magisk. If you are GREEN in Safetynet Helper, I suggest you make a full nandroid backup (or at least of the boot.img part, it will save you some time and troubles later)
    ----
    2- Search for the folder were you extracted the RootSwitch patch files. You need 2 files: custom_ramdisk_patch.sh and dot.supersu. Then, supossing you already have your ADB drivers working, connect your device to your USB port and accept the connection in your device. Then inside the folder where you have your ADB files press Ctrl + Shift + Right click on a free space of the folder to open the right click menu to select the option "open a new command window here". A CMD window should open, type: adb devices , and if your drivers were installed correctly you will see your device listed. If you don't see your device listed then don't continue, just search for the proper way to have your phone working with ADB mode and try this step again.

    Now reboot your phone into TWRP recovery (leave the USB cable connected to your PC) and in the CMD (same black window from the last step type: adb push custom_ramdisk_patch.sh /data
    And press enter. You will see that a file was transfered/pushed to your phone. Then in the same window type: adb push dot.supersu /data/.supersu
    And press enter again. You will also see that another file was transferred.

    Then in your phone press the Install option and flash the SR2-SuperSU-v2.78-SR2-20161029143931.zip file in systemless mode.
    * In my phone/Rom in autoinstalls in Systemless mode by default. BUT If your phone/Rom doesn't do this then you will need to type the command: echo "SYSTEMLESS=true" > /data/.supersu in TWRP Terminal option before flashing the file (note that there will not be any confirmation, you just type the comand and press the big arrow/enter, a new line should begin with # symbol, that's all, there is no other confirmation.
    ----
    3- After flashing SR2-SuperSU-v2.78-SR2-20161029143931.zip reboot into system mode and open the superuser app once and then close it. Confirm that root is working in your phone (if booting takes longer than normal then you are probably rooted. If booting is very fast, then probably you didn’t install root properly). You can confirm that you have root by opening an app that uses root (like Adaway or TitaniumBackup), it will ask for root permissions. If root is working, then you can continue with the next steps.

    **If you find something saying that "binaries need to be updated" it is because root wasn't installed properly, reboot once and check again (sometimes rebooting makes root work properly). If it says the same then reflash again the SuperSu file doing the same procedure. If even like this it doesn't work, then try the same procedure BUT WITH VERSION SR1 of superuser (SR1-SuperSU-v2.78-SR1-20160915123031.zip). Some users have reported this fix the "update binaries" problem in some devices.

    * Please keep in mind that NO Suhide flash is needed! It will trigger SN. Don’t flash any Suhide.
    ----
    4- Install Root Switch 1.3.3.2 apk file. Open it once, it should ask for root permissions, accept them and then close the app and open it again. Now press the root “disable” switch. NO XPOSED OPTION SHOULD BE AVAILABLE AT THIS POINT OF THE GUIDE, if you have something saying “magisk is not supported” or “Systemless Xposed is not supported” then I suggest you read and redo the first steps of the guide again in order to uninstall all properly.
    ----
    5- Check your SN response. It should be green if you did everything well.

    ---- CHECKPOINT 2----: With SuperSU + Root Switch “disabling” root you should have root working properly and with a GREEN/PASS Safetynet response. Check that in fact it is working for you. If you have a blue/red screen, then reopen the Root Switch app and try enabling and disabling root again.
    If this doesn’t work, then probably you have a Samsung device were this method doesn’t work.
    If you do have everything in order, REENABLE ROOT IN THE APP!, then reboot into recovery and make a full nandroid backup!! Here is not optional. Just do it! :)…you don’t want to do all this steps again :).
    ----
    6- Flashing Xposed: my advice is to use Wanams Samsung Xposed file. Flash it in recovery mode and then reboot and install the latest Xposed apk (by topjohnwu). You could also use the old Xposed apk, it is up to you. You should now have a green screen saying you have framework installed and working properly.

    * Keep in mind some things when flashing Xposed files:
    a. If you had any different version of Xposed installed and you didn’t uninstall it properly, then it will probably cause problems. Uninstall Xposed with the proper zip file as mentioned in previous steps.
    b. Important fact! every time you uninstall Xposed you need to WIPE DALVIK/CACHE. Otherwise files will remain triggering Safetynet and messing with the installation of other Xposed versions.
    c. If you have a red screen on Xposed app reboot into recovery and flash again Xposed. Then only to options that would work are when you get a green screen or a yellow/orange screen (mentioning that the framework is installed)
    * If Wanams version doesn’t install properly, then you can try to install version 86.2 in SYSTEM mode. The installer has to mention it is installing in SYSTEM mode. Otherwise it won’t work/it won’t be hidden.
    Continue to the next steps when you have Xposed installed properly.
    ----
    7- Open Xposed app and grant root acces to Xposed (to do this press soft reboot option in the app and it will ask for root permissions). Install your Xposed modules, activate them and reboot.

    ----
    Safetynet should be Blue (failing now) up to this point because it detects Xposed. When you double check that Xposed is installed and your modules are working normally you can continue to the next steps (hidding Xposed so you can play Pokemon Go while Snorlax is doing its magic)

    ----CHECKPOINT 3----: Safetynet should fail and give you a blue screen but root and your xposed modules should be working. Try with other modules like Youtube Adaway or just make sure they are working. Only if Xposed modules are working, continue with the next steps.
    -----
    8- Open the RootSwitch-1.3.3.2 apk again and this time you should have a Switch for Xposed as well. Disable ONLY Xposed first (the second option/switch at the bottom) and it will soft reboot (it is normal and necessary to make the hide trick work)!
    ----
    9- Open the Xposed apk and if everything went well it will show a yellow screen BUT your Pokemon modules will be working (Snorlax).
    ----
    10- Open the RootSwitch-1.3.3.2 apk again and this time disable root. Both switches should be gray/disabled. Then go and open the Safetynet app and it the response should be GREEN. If you have made it this far go and try Pokemon GO and check that in fact Snorlax is working. If it is working…you already know what to do: make a full nandroid backup and keep it safe in your pc ;).
    * Keep in mind that TWRP full backups are usually big files and might take a lot of space from your storage. I usually only keep the last backup (where everything is working).
    -----
    11. Lastly, TO KEEP IN MIND: when you reboot your phone your Xposed modules (Snorlax) will probably not work anymore after reboot. To make things work properly after a reboot:
    a- Open Root Switch app
    b- Enable root and then Xposed (it will soft reboot)
    c- Do a normal reboot (Xposed screen should be green and safetynet should be failing)
    d- Open again root switch app and disabled Xposed again (it will soft reboot)
    e- Then disable root and you are good to go. Snorlax should be working fine again.
    I am sure that at least the latest version of Snorlax is working until the date of this post (01/11), but I haven´t tried other versions of it.
    ----
    12- Enjoy the game with the proper IV’s!!
    ----

    [ ] If this was helpful to you I would like to ask for 2 things:
    1- Press the thanks button ;)
    2- The most important. Please mention me (quote is to long:eek:) on your post specifying which phone model did you use, which rom, which kernel and if you did any other step to make it work. Only like this I can keep the post updated with the Samsung models that have been confirmed working.
    Also, if you have troubles, post your basic information so people can help you: phone, rom, kernel, your last working checkpoint of the guide :good:

    Thanks a lot!.:highfive:
    26
    [size=+2]
    This thread has been created to reduce the amount of clutter in the main Magisk thread, please discuss Magisk + PokeMon Go here.
    [/size]
    17
    Alright, this is nasty.

    I've updated to v0.115.2 on my _stock, unrooted_ Note 4 (it was rooted before, and has its Knox fuse blown,. but has been compoletely unrooted and reflashed to stock since then; system status is "Official"). It immediately gave me the unauthorized device error. I double-checked to make sure nothing was left behind from the former root - I even went as far as installing TWRP to check the data & cache partitions for any root residue, finding nothing, and then again reflashing a full stock ROM using Odin. I checked again for root-related apps, as well as anything Niantic may consider a cheating app (like Calcy IV), and get rid of everything that could even be remotely suspicious. No dice, still unauthorized device.

    What finally got it to work shocked me beyond belief. I went through the internal & external SD card, and deleted everything related to rooting (flashable-looking zips, APKs of root-related apps, logfiles, Titanium Backup, any folder with "root", "magisk" or "xposed" in its name, etc - many of them stuff I copied over from my previous phone, never installed on this one). And magically, Pokemon Go started working!

    Bottom line: Pokemon Go is abusing its storage read permissions to scan the storage for evidence of rooting. Magisk will need to redirect Pokemon Go's storage accesses to controlled "sandbox" directories, and prevent it from reading the real internal or external storage. (Simply blocking storage access won't work, as the game actually writes to internal storage.)
    17
    List of files, P-go trying to access before crash:
    In my case, problem caused by busybox installer and crashes happened on unrooted device too.
    Code:
    /system/xbin/su
    /data/app-lib/net.snclab.RootKeepSurvival-1
    /data/data/com.saurik.substrate
    /data/data/com.ramdroid.appquarantinepro
    *My case* /data/data/stericson.busybox
    /lib/libAndroidCydia.cy.so
    /system/bin/app_process64_original
    /data/app/net.snclab.RootKeepSurvival-1.apk
    /su/bin/su
    /system/bin/failsafe/su
    /system/usr/we-need-root/su
    /system/bin/su
    /data/local/su
    /data/local/bin/su
    /system/lib/libsupol.so
    /.subackup
    /data/app/stericson.busybox-2.apk
    /data/app/com.RootBackupKeeper13_3-1.apk
    /dev/com.koushikdutta.superuser.daemon/server
    /system/etc/.installed_su_daemon
    /data/data/com.devadvance.rootcloakplus
    /data/data/com.koushikdutta.superuser
    **Use MgiskHide**/magisk
    /lib/libsubstrate-dvm.so
    /data/app/org.projectvoodoo.otarootkeeper-1.apk
    /system/xbin/amphoras
    /dev/com.mypackagename.superuser.daemon
    /dev/com.koushikdutta.superuser.daemon
    /data/data/com.amphoras.hidemyrootadfree
    /data/app-lib/sa.root.toolkit-1
    /data/app-lib/com.troy1103.hideyourroot-1
    /data/app-lib/com.formyhm.hideroot-1
    /data/data/de.robv.android.xposed.installer
    /data/app-lib/com.jrummy.busybox.installer-1
    /dev/com.thirdparty.superuser.daemon
    /system/xbin/daemonsu
    /lib/libAndroidLoader.so
    /data/app-lib/com.RootBackupKeeper13_3-1
    /data/data/com.noshufou.android.su.elite
    *Not Issue*/system/bin/ls
    /data/data/com.amphoras.hidemyroot
    *Not issue*/system/bin/toolbox
    /system/etc/init.d/99SuperSUDaemon
    /lib/libSubstrateRun.so
    *Not Issue* /dev/null
    /data/dcata/com.jrummy.busybox.installer
    /system/lib64/libsupol.so
    /data/app-lib/org.projectvoodoo.otarootkeeper-1
    /system/app/Superuser.apk
    /data/local/xbin/su
    /data/data/com.noshufou.android.su
    /data/data/com.RootBackupKeeper13_3
    /server
    /data/data/com.mypackagename.superuser
    /sbinpolicy
    /vendor/lib/liblog!.so
    /data/data/net.snclab.RootKeepSurvival
    /data/app/sa.root.toolkit-1.apk
    /data/data/com.formyhm.hiderootPremium
    /dev/.su.d
    *Not Issue*/system/bin/cat
    *Not Issue*/system
    /data/data/com.chelpus.lackypatch
    /bin/sh
    /bin/app_process_init
    /data/data/com.zachspong.temprootremovejb
    *Not Issue*/proc/self/status
    *Use MagiskHide* /sbin/su
    /lib/libDalvikLoader.cy.so
    /data/data/sa.root.toolkit


    My remarks:
    *Use MagiskHide* - Magisk hide taking care of this file. See in the thread. You can also unroot device to remove this.
    *Not Issue* - Normal system file that the application need to work.
    *My case* - Application that causes P-go to crash even without root. This is non busybox. This is only Installer/updater. Uninstalling the application not removing bb, but, in my case, resolving the problem.
    Uncommented lines: Parts of another rooting applications (not Magisk) or Xposed or unwanted by Niantik apps, that you need to hide or remove to get P-go stable.
    16
    Anyone who would like to test adding pokemon go to magiskhide early.. you can do this without a updated manager.

    This seems to have fixed the crashing for me.

    Open a terminal emulator and punch in the following:
    Code:
    su magiskhide --add com.nianticlabs.pokemongo

    EDIT: Some users reporting issues with the one line, if this includes you try the following:

    Code:
    su
    magiskhide --add com.nianticlabs.pokemongo
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone