[DISCUSSION] Xposed for Lollipop

Search This thread


Senior Member
Sep 24, 2014
Baldwin Park
@doubtfire1, yikes about getting stuck. I should've mentioned that the UNITY Xposed installer also acts as an uninstaller if you flash it a second time.
Looks like your particular ROM might not be compatible in some way.

ZTE Axon 7 A2017U, B12 SL!M6 DF!NR ROM, Multiboot, XDA Legacy


Senior Member
Sep 24, 2014
Baldwin Park


Senior Member
Feb 7, 2017
My old tablet works under Kit Kit 4.4.2.
I use Xposed Framework and its modules installed via Xposed Installer v. 2.6.1

Now I want to try Magisk on my tablet instead of SuperSu (the latest versions of Magisk support KitKat).

My question is: Will I have problems with the Xposed Framework installed not as a Magisk module?


Senior Member
Jan 27, 2018
Samsung Galaxy S8
Samsung Galaxy S9
My old tablet works under Kit Kit 4.4.2.
I use Xposed Framework and its modules installed via Xposed Installer v. 2.6.1

Now I want to try Magisk on my tablet instead of SuperSu (the latest versions of Magisk support KitKat).

My question is: Will I have problems with the Xposed Framework installed not as a Magisk module?

No it shouldn't. Since in general xposed doesn't require root and will still work without Personaly I like to keep the 2 seperate.
I would recommend a full backup with twrp In case something does go wrong.
  • Like
Reactions: marcdw and amg314


Jun 9, 2019

i try to install the unisntaller but it says rm: can't remove '/system/framework/XposedBridge.jar': Read-only file system. Can anyone help? thanks


Senior Member
Feb 7, 2017


  • Screenshot_2019-06-10-08-50-39.jpg
    121 KB · Views: 433


Senior Member
Feb 7, 2017
xposed uninstaller 20180117-arm-zip, xposed v86.1-sdk22-arm, twrp is 3.2.1-1 for sm t280

As you installed systemless xposed v86.1-sdk22-arm, you can uninstall it using Magisk Manager Recovery Tool V2.1 ALPHA by Pzqqt https://forum.xda-developers.com/attachment.php?attachmentid=4757812&d=1557687217
You should install this *.zip in TWRP and delete Magisk Xposed module.

Or you can use manual method: 'I'm gonna tell you how to UNINSTALL this if you've got stuck in a bootloop.'

For your own risk!
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1268
    It seems that many people have waited for this moment, and here we are:

    Xposed for Lollipop is finally here!

    You can use this thread for discussions. Please check the read-only thread for the download links and official updates.

    Edit by @Darth.

    Rovo89 has been kind enough to let us add a few things to help stop the repeated questions that are asked here.... And thanks to RootSU, we'll be able to add a FAQ........ So...

    Please read post 2 below.... Very carefully before posting a question here.
    This thread was just started an already it had to be cleaned from pointless posts. Use the thanks button. Do not make pointless posts in the thread.

    I understand You guys are excited but really? Come on.

    If you dont have something constructive to post then dont. Do not clutter this thread Or it will be closed and only opened when the OP has something to post.
    Unofficial Q&A


    If you have questions about which Xposed version to use, read this post and use the table to identify the correct version for your device.

    If you encounter any issue or things are still unclear, try to search this thread by using the Search function before posting anything. Lots of issues/questions have already being asked and/or solved. If this doesn't work, please include information about your device, its current Android version, the files you tried to flash/install and steps to reproduce the issue in your post. This way other members are able to help you in a timely manner.

    Hey everyone,

    Since the primary thread information was taken to a read-only thread, the regulars here have been answering the same questions with even mor frequency, so here we hope to address some of those basic questions in brief:

    Q: What does "Alpha" mean?
    Software goes through several stages before final release. Alpha and Beta are a couple. Beta is usually released strategically to experienced testers to get feedback and find bugs. Alpha is less mature than Beta and is often not released outside the company that produced it. We're very lucky to get alpha releases, but beware, it is expected to be buggy and you should be experienced in Android usage before taking on Alpha testing.

    Q: What do I need to do BEFORE flashing Xposed?
    A full Nandroid Backup of your system (preferrably by using your recovery). If something goes horribly wrong during flashing/installation, you can revert all changes made to your system quite easily.

    Q: What recovery can I use?
    The latest zips provided by @rovo89 are now signed, so any recovery should work now (including cyanogen recovery) however, Philz recovery struggles to mount system correctly and detects the recovery sdk 19 instead of the ROM recovery. You can try manually mounting system in recovery first (instructions are lower down this thread) though, you should probably move over to TWRP now.

    Some of the unofficial versions are not signed zips, so you'll need a recovery that can turn off signature verification. TWRP is probably the best bet all round, as cyanogen recovery doesn't allow this.

    Q: Which is the right Xposed for me?
    It's all getting rather confusing.

    Here's what you need to know...

    Almost all android devices have an ARM based CPU. A small handful of those are 64 bit (ARM64), released this year. Obviously the ones that are not 64 bit are 32 bit.

    All ARM version 7 CPUs are 32 bit. Although all ARM version 8 CPUs were designed as 64 bit, some only operate in a 32 bit mode.

    A small set of android devices now run 32 bit Intel CPUs, referred to as x86.

    What you first need to do is find out what CPU your phone has. If its intel x86, that's quite easy to find out by reading the specs.

    For others, try this:

    Google "your phone CPU? “ to get the CPU name.
    Google "your CPU ARM Version?“ to get the ARM version.


    Google "Nexus 6 CPU" - answer Snapdragon 805
    Google "snapdragon 805 ARM version?" - answer ARMv7

    NOTE: For Snapdragon CPU's, check this Wikipedia article.

    You can also use AIDA64 from the Google Play Store or apkmirror.com, which will tell you what ARM version you have (look for Instruction Set). Quite easy way.

    Then use that information to use the table below to find the right version for your device (The second table is for users with a TouchWiz-based ROM, so mostly Samsung users. The first one is for all other users.) Links to the Xposed versions are given below the image.

    EDIT: the flow chart, which was used in the past to identify the correct Xposed version one needs has been replaced by a table, which should be easier to read.

    How to read the table:
    If you do not know how to read the table, it is very easy. If you have a Samsung device (either with stock ROM or TouchWiz-based custom ROM), use the second table ("TouchWiz-based ROMs (Samsung users)"). If not, use the first table. Then identify your CPU ARM version as described above as well as your Android version. With those information available, go to the corresponding field in the table and that's it, you have just identified the required Xposed version for your device.


    Download threads:

    Q: Does this work on my rom/device?
    It should work. You can search the thread to see if anyone else got it to work, or you can do what everyone else does - backup and try it for yourself.

    Q: What files do I need?
    The Xposed installer (.apk) and the flashable Framework (.zip)

    Q: Error in Xposed app "xposed not yet compatible with SDK 22 or your processor architecture (armeabi-v7a)" and may also refer to libdvm.so
    This happens if you are using the legacy KitKat Xposed app (Xposed Installer v2.7 or below). Uninstall it and ensure you are running the latest alpha (currently: XposedInstaller_3.0_alpha4.apk) from the official rovo89 thread.

    Q: Error in recovery, "wrong sdk version / wrong arm version". How to solve?
    Read this error very carefully.

    If it says "Wrong SDK version: 22, expected 21 - 21", it means you're flashing the SDK 21 version on an SDK 22 based ROM.

    Similarly, if it says "Wrong SDK version: 21, expected 22 - 22", it means you're flashing the SDK 22 version on an SDK 21 based ROM*

    You're flashing the wrong zip for your ROM. Use the table above to identify the correct zip for you.

    *Note, All 5.0.x ROMs are SDK21 based. All 5.1.x ROMs are SDK22 based. You're flashing the r

    There is a similar, but slightly different error. If it says "Wrong SDK version: , expected 22 - 22" or it says If it says "Wrong SDK version: , expected 21 - 21" , then something else is wrong. Note the blank space after "version:"? This means it cannot determine your SDK version from the /system/build.prop.

    Withing the flashable zip is an updater-binary that reads your build.prop before flashing. The line of code looking for that is below:
    ui_print "! Wrong SDK version: $API, expected $XMINSDK - $XMAXSDK"
    See how where the blank space is, here, it says "$API"? That is a variable that is defined below:
    API=$(cat /system/build.prop | grep "ro.build.version.sdk=" | dd bs=1 skip=21 count=2)
    ...Which basically says:

    Look for "ro.build.version.sdk=" in build prop, then save next 2 characters as API$

    If $API is blank, it means it cannot find "ro.build.version.sdk=21" or "ro.build.version.sdk=22" in your build.prop.

    One of two reasons cause this.

    1) It's not in your build.prop (well that is extremely unlikely)
    2) The updater-binary cannot mount /system properly.

    So to troubleshoot, check that "ro.build.version.sdk=" exists exactly in build.prop and that there are 2 characters after it. If there are, then API should NOT be blank and probably means system is not mounting, in which case, you can try mounting system via the recovery menu. If that still doesn't work, open a terminal emulator at the root folder (in TWRP) and type the following 2 commands:
    mount -o ro /system 
    mount -o rw,remount /system

    Please also note that if this gives an error such as "cannot find system" then you may need a different recovery.

    The same as above can also happen with the arm version, so if you know you're flashing the correct arm version for your device, then it's probably a system mounting issue.

    Q: I can't find the latest Alpha, help!
    There are 2 parts of Xposed. There is the app (.apk) and the framework (a flashable .zip) and you need both.

    The latest version of the app so far is alpha 3. When we talk about alpha 4 etc, these updates are just to the framework (zip). The zips are not named "alpha" though. The zips have a date in the file name instead. Read rovo89's posts clearly as he gives you that date when there is an update announcement.

    Q: What is Armv7? Will it support my CPU? What about Armv8 / 64 Bit / Intel CPUs
    Armv7 is a CPU architecture. If you have a mainstream phone released since 2010, you most likely have Armv7. All Qualcomm and Exynos CPUs since then have been based on Armv7. Armv8 however is the architecture used in the new 64bit CPUs.

    Intel CPUs are x86. They are not officially supported.

    Q: Does this work on Android JellyBean/KitKat/Marshmallow?
    No. It's only for Lollipop.

    Q: Where can I find the uninstaller?
    In the link found in post #1 or - in case you use wanam or arter97's version - in the corresponding threads.

    Q: What's this red error about not being able to install the framework within the Xposed Installer app?
    It's not an error. It simply states that the framework can only be installed by recovery - which we know as we have already done it.

    Q: Xposed won't work. All the files are present and correct. What to do?
    Check the logs in the app. If you see a line that says "found /data/data/de.robv.android.xposed.installer/config/disabled" then delete that "disabled" file and reboot. It should work.

    If it doesn't work, try to do a soft reboot from within Xposed Installer app (Xposed Installer -> Framework -> Soft Reboot). Root permission has to be granted to the Xposed Installer app to do so (will be asked when clicking on the Soft Reboot button for the first time).

    Q: I get in a bootloop, what to do?
    The first thing to try is wiping "dalvik" and cache via recovery. If this doesn't work, ensure you have flashed the correct Xposed version (this applies for Samsung users mostly). Else you can provide a log file which you can grab via ADB (search for "How to logcat" if you don't know how) and upload it either here (don't forget to link rovo89 in your post) or to rovo89's github repo (better option)

    Q: TWRP states "not enough space in system". What is this about?
    Not really related to Xposed, it just means that your system partition doesn't have enough free space to install Xposed. Maybe create some space by deleting Google related-apps from system that you don't need or that can be downloaded from Play Store. Ask in your device forum if you need specific advice.

    Q: How do I update the Xposed framework to a newer version?
    You can dirty flash it through recovery (don't uninstall/wipe anything before flashing). Afterwards, wipe cache/dalvik and reboot. That's it.

    Device Specific

    Q: My LG device has Weather and Smartcover force closes. What to do?
    Those issues are fixed with Xposed framework v80 and later. If you encounter such issue, update the Xposed framework to version v80 or higher. If you are unable to update to v80 or later, you need to disable these apps before flashing. You can disable them afterwards, please see this post: http://forum.xda-developers.com/showpost.php?p=59929667&postcount=5122.

    Q: I get a low on space error on my Moto. What to do?
    The first thing to try is wiping "dalvik" and cache via recovery.

    Q: It does not work on my Huawei/Xiaomi device. What to do?
    Chinese OEMs change a lot of the original Android code base, so most likely Xposed is not compatible with those devices (yet). There might be some compatibility in the future, but don't expect it in the next few days.

    Q: It does not work on my MIUI device. What to do?
    There is an XDA thread by SolarWarez dedicated to Xposed for MIUI-based devices.

    Xposed MIUI
    Look I already posted a warning. And people dont want to listen so let me make this very clear. The next pointless post will have this thread closed and only opened for the OP.

    If you are posting a bug then you better have a logcat to go along with it. If it doesnt work because you didnt read the OP then too bad.
    I just did a quick clean up for the last few pages and removed around fifty posts. I'm keeping this thread closed for a bit so that everyone gets this message. (Thread reopened.)

    Please remember the following -- it takes less than five minutes and avoids frustration for you and everyone subscribed to the thread:
    • Read the first post and try to search the thread (there's a handy search button which usually does an alright job). Many of your questions are already answered.
    • Do not ask about supported modules here. Check the module's thread instead. If a module isn't working, post in its thread -- not here.
    • Telling people to search/complaining about the noise only adds to the noise. Please, either provide them with an answer (and let them know they could've found it if they searched), or report the post and don't reply. If it's answered in the OP, just report it and move on.
    • If you're reporting a bug, include a logcat if the device isn't booting or a log from the Xposed Installer if the framework isn't activating (do check the OP first, as some issues are mentioned there).