Downgrading with HiSuite (No Internet connection errror)

Search This thread

Nicobisgaard

New member
Mar 1, 2021
3
0
11
So i've tried all of the solutions to getting GMS and not had any luck so far unfortunantly.
I've gathered from various forum threads that i need to downgrade from build 11.0.0.168 to something like 10.0.0.xxx, before i can use Googlefier

I can't get HiSuite 10.0.0.510_OVE to work (Get an error on my phone about the app needing location permission, which i can't toggle on anywhere), so i am using HiSuite 11.0.0.510_OVE instead as instructed in a youtube video i found.
I get the software installed on PC+Phone and press "Update" and get no error messages, only a note that i am using the latest version.
Then i run the proxy as described in:

The proxy runs fine seemingly,

But when i press update now i get the "No internet connection. Please check your network Settings." Error.
I can't find many posts about this issue when i google, except this one:
I've tried everything suggested there with no luck. I don't have any anti-virus installed except Windows, and i disabled that entirely for this.

Any ideas on how to fix the "No internet connection" issue would be greatly appreciated.
 

kh4lzd

New member
Feb 28, 2021
2
1
3
i get a little bit different problem here, im trying to downgrade my P40 Pro ELS-LGRP4 10.1.0.166 to ELS-LGRP4 10.1.0.131 using hisuite + hisuite proxy combination, hisuite proxy run fine without problem, but when i try to check update from hisuite, it's always show "you're now using the latest official version" without "switch to another version" options.
I already try hisuite from different version (10.1.0.550, 10.0.0.510, 10.0.1.100), and try hisuite proxy from different version (1.8.8(latest), 1.8.6, and bender007 modification), but the result always same, it's always showing "you're now using the latest official version".

this is the steps I already taken to run hisuite proxy before running hisuite:
1. open hisuite proxy
2. fill the Packaget URL box with ELS-LGRP4 10.1.0.131 firmware url from firmware finder, fill the the version box with ELS-LGRP4 10.1.0.131 string from firmware finder; (in another test, i try to fill cust pkg, preload pkg and the version string, tick point version, tick CUST PKG box, tick Preload PKG)
3. patching httpcomponent in hisuite folder
4. run setup
5. open hisuite and connect the phone

but, whatever steps I try, hisuite always show that "you're now using the latest official version" message everytime I checking system update on hisuite

Note:
1. hisuite connection setting already ticked on proxy as the hisuite proxy recommended (127.0.0.1, port 7777)
2. already check host file, and it's normal, no hicloud whatsoever
3. no antivirus installed
4. already set windows firewall off
5. already try from different PC

maybe someone can help me too fixing this issue here?

hisuit 10.0.1.100.png
hisuite proxy 1.8.8.png
 
Last edited:
  • Like
Reactions: Nicobisgaard

Nicobisgaard

New member
Mar 1, 2021
3
0
11
I managed to downgrade from EMUI 11 to EMUI 10 without using Proxy now aswell, so i'm down to 10.1.0.176 which is a step in the right direction. But now i run into the exact same issue as you describe "You're now using the latest official version"
 

Nicobisgaard

New member
Mar 1, 2021
3
0
11
After downgrading to 176 version i could actually use the memory card method which hadn't worked before. Got everything installed now, working perfectly (no notifications yet though).
Oh the joy!:)
 

awais_666

Senior Member
Jun 29, 2013
85
6
28
After downgrading to 176 version i could actually use the memory card method which hadn't worked before. Got everything installed now, working perfectly (no notifications yet though).
Oh the joy!:)
Which firmware did you install? i tried with C636 from bender007 didn't work for me :( i got the exact same issue
 

kh4lzd

New member
Feb 28, 2021
2
1
3
After downgrading to 176 version i could actually use the memory card method which hadn't worked before. Got everything installed now, working perfectly (no notifications yet though).
Oh the joy!:)

congrats dude, I want to try to dload downgrade my device too, but I'm afraid bricking my device if its wrong flashing firmware

can u tell me what firmware did you use? is was just base package firmware? or with cust and preload package?
 

gnasher666

Senior Member
Dec 14, 2004
154
31
48
I had the same issue, could downgrade to 176 using HiSuite then I used the OTG recovery with a firmware I was able to download. Version 121 (els-nx9-10.1.0.121(C432E8R5P2)) as my phone is a C432. Worked like a charm, an OTG adapter is only a couple of £/$ Mine cost £5 for two from Amazon.
 
  • Like
Reactions: badmania98

gundammk2

Member
Mar 2, 2021
6
6
3
i get a little bit different problem here, im trying to downgrade my P40 Pro ELS-LGRP4 10.1.0.166 to ELS-LGRP4 10.1.0.131 using hisuite + hisuite proxy combination, hisuite proxy run fine without problem, but when i try to check update from hisuite, it's always show "you're now using the latest official version" without "switch to another version" options.
I already try hisuite from different version (10.1.0.550, 10.0.0.510, 10.0.1.100), and try hisuite proxy from different version (1.8.8(latest), 1.8.6, and bender007 modification), but the result always same, it's always showing "you're now using the latest official version".

this is the steps I already taken to run hisuite proxy before running hisuite:
1. open hisuite proxy
2. fill the Packaget URL box with ELS-LGRP4 10.1.0.131 firmware url from firmware finder, fill the the version box with ELS-LGRP4 10.1.0.131 string from firmware finder; (in another test, i try to fill cust pkg, preload pkg and the version string, tick point version, tick CUST PKG box, tick Preload PKG)
3. patching httpcomponent in hisuite folder
4. run setup
5. open hisuite and connect the phone

but, whatever steps I try, hisuite always show that "you're now using the latest official version" message everytime I checking system update on hisuite

Note:
1. hisuite connection setting already ticked on proxy as the hisuite proxy recommended (127.0.0.1, port 7777)
2. already check host file, and it's normal, no hicloud whatsoever
3. no antivirus installed
4. already set windows firewall off
5. already try from different PC

maybe someone can help me too fixing this issue here?

I have the same problem. Did you try sdcard method? My P40 pro is 10.1.0.176.
 

gundammk2

Member
Mar 2, 2021
6
6
3
I had the same issue, could downgrade to 176 using HiSuite then I used the OTG recovery with a firmware I was able to download. Version 121 (els-nx9-10.1.0.121(C432E8R5P2)) as my phone is a C432. Worked like a charm, an OTG adapter is only a couple of £/$ Mine cost £5 for two from Amazon.
I am 176 and c432. Will try the OTG method. Thank you :)
 
  • Like
Reactions: gnasher666

starbase64

Senior Member
Apr 3, 2007
4,337
1,686
258
I had the same issue, could downgrade to 176 using HiSuite then I used the OTG recovery with a firmware I was able to download. Version 121 (els-nx9-10.1.0.121(C432E8R5P2)) as my phone is a C432. Worked like a charm, an OTG adapter is only a couple of £/$ Mine cost £5 for two from Amazon.

dload firmware? please post a link.
 

awais_666

Senior Member
Jun 29, 2013
85
6
28
Hey guys i was in same boat like others, stuck on 176 firmware, tried this thread and download c134 firmware today, it is for people stuck on C636 i had almost given up

[GUIDE] Fix Broken OTA Updates After Downgrade & Have EMUI 11 With GMS (C636)
 

fromiOS2Android

Senior Member
Dec 29, 2018
229
68
38
Trondheim
Eh maybe i can shoot in a tip here.

I just came from 11.0.0.168. I did this
Hey guys i was in same boat like others, stuck on 176 firmware, tried this thread and download c134 firmware today, it is for people stuck on C636 i had almost given up

[GUIDE] Fix Broken OTA Updates After Downgrade & Have EMUI 11 With GMS (C636)
What do you mean stuck on c636? c636 is only the region spesification. It has nothing to do with software/firmware. Only thing you need to check is that the software i compatible to your region. 636,432 etc....
 

fromiOS2Android

Senior Member
Dec 29, 2018
229
68
38
Trondheim
Maybe this could help...

I came from 11.0.0.168. I reset my phone and am now running 10.1.0.134 software (432 region) Here is what i did:

1. use hisuite 11 to downgrade to 10.1.0.176.
2. use hisuite 10.x.x.550OVE and firmwarefinder on PC to downgrade to 10.1.0.134 (131)
3. Got error with hisuite proxy (No internet connection)
4. Remember to restart computer after change from hisuite 11 to husuite 10.
5. Now i got "You are using the latest software"
6. Use the register for proxy in firmwarefinder (at the top bar)
7. Update your computer's network connection with the correct DNS from firmware finder.
8. Now hisute proxy/firmware finder should work as before and all the files are there without error.
9. Download over the net with proxy.
10. Voila. 10.1.0.134 is installed.
11. Start from scratch with GMS (googlefier or manual)
(i did manual and use the indonesian file after donating to get no errors and notification even after restart. )
12. A fully working P40 Pro inc. GPS, GMS, Notification, Playstore and no error.
Only Google pay not working due to cts profile "false". Can only be fixed with root.

Hope this help some of you guys.
PS! After updating the correct DNS in your network card og router all the files in firmwarefinder works normally like before.

Stay safe
 
  • Like
Reactions: oslo83

leifstar81

Member
Mar 17, 2021
8
2
13
I successful passed steps 7 and 8.

7. Update your computer's network connection with the correct DNS from firmware finder.
8. Now hisute proxy/firmware finder should work as before and all the files are there without error.

After that HiSuite offers me the wished update (10.1.0.117). When I click update and confirm the privacy settings HiSuite wants to start the update progress by downloading the firmware. I then get an error message that there is no internet connection and the update is aborted.

I tried to play around with the proxy and DNS settings, but no success. Is it because the Team MT downloads are down? Or can anyone else help me with this?
 

fromiOS2Android

Senior Member
Dec 29, 2018
229
68
38
Trondheim
I successful passed steps 7 and 8.

7. Update your computer's network connection with the correct DNS from firmware finder.
8. Now hisute proxy/firmware finder should work as before and all the files are there without error.

After that HiSuite offers me the wished update (10.1.0.117). When I click update and confirm the privacy settings HiSuite wants to start the update progress by downloading the firmware. I then get an error message that there is no internet connection and the update is aborted.

I tried to play around with the proxy and DNS settings, but no success. Is it because the Team MT downloads are down? Or can anyone else help me with this?
I did restart my computer and did the prosess over again. Than it worked... Thats all i can say.
Team MT files are not down, they are Just not reachable until you change dns...
 

leifstar81

Member
Mar 17, 2021
8
2
13
I did restart my computer and did the prosess over again. Than it worked... Thats all i can say.
Team MT files are not down, they are Just not reachable until you change dns...
Thank you for your quick reply. I will try again, but these DNS settings didn't work so far. I changed the IP4 settings in the windows options -> network adapter.
 

leifstar81

Member
Mar 17, 2021
8
2
13
👍🏼👍🏼 Same as i did... I did it 2 or three times and then i started downloading👍🏼👍🏼 you could always try to change the ruter settings instead of the network adapter
I tried everything now, multiple computers, changing DNS on the network settings in windows and in the router. Nothing works. Once in between HiSuite offers me the right update, but whenever the download is initiated the connection fails. Anyone has more good hints? Because I am running out of ideas.

I have ordered a OTG cable just in case I cannot make it work. But that still leaves me with the task to find a firmware to download. I thought of the JNY-LGPR2-OVS 10.0.1.136 or 10.0.1.117. Where can I find these?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    i get a little bit different problem here, im trying to downgrade my P40 Pro ELS-LGRP4 10.1.0.166 to ELS-LGRP4 10.1.0.131 using hisuite + hisuite proxy combination, hisuite proxy run fine without problem, but when i try to check update from hisuite, it's always show "you're now using the latest official version" without "switch to another version" options.
    I already try hisuite from different version (10.1.0.550, 10.0.0.510, 10.0.1.100), and try hisuite proxy from different version (1.8.8(latest), 1.8.6, and bender007 modification), but the result always same, it's always showing "you're now using the latest official version".

    this is the steps I already taken to run hisuite proxy before running hisuite:
    1. open hisuite proxy
    2. fill the Packaget URL box with ELS-LGRP4 10.1.0.131 firmware url from firmware finder, fill the the version box with ELS-LGRP4 10.1.0.131 string from firmware finder; (in another test, i try to fill cust pkg, preload pkg and the version string, tick point version, tick CUST PKG box, tick Preload PKG)
    3. patching httpcomponent in hisuite folder
    4. run setup
    5. open hisuite and connect the phone

    but, whatever steps I try, hisuite always show that "you're now using the latest official version" message everytime I checking system update on hisuite

    Note:
    1. hisuite connection setting already ticked on proxy as the hisuite proxy recommended (127.0.0.1, port 7777)
    2. already check host file, and it's normal, no hicloud whatsoever
    3. no antivirus installed
    4. already set windows firewall off
    5. already try from different PC

    maybe someone can help me too fixing this issue here?

    hisuit 10.0.1.100.png
    hisuite proxy 1.8.8.png
    1
    I had the same issue, could downgrade to 176 using HiSuite then I used the OTG recovery with a firmware I was able to download. Version 121 (els-nx9-10.1.0.121(C432E8R5P2)) as my phone is a C432. Worked like a charm, an OTG adapter is only a couple of £/$ Mine cost £5 for two from Amazon.
    1
    I had the same issue, could downgrade to 176 using HiSuite then I used the OTG recovery with a firmware I was able to download. Version 121 (els-nx9-10.1.0.121(C432E8R5P2)) as my phone is a C432. Worked like a charm, an OTG adapter is only a couple of £/$ Mine cost £5 for two from Amazon.
    I am 176 and c432. Will try the OTG method. Thank you :)
    1
    Maybe this could help...

    I came from 11.0.0.168. I reset my phone and am now running 10.1.0.134 software (432 region) Here is what i did:

    1. use hisuite 11 to downgrade to 10.1.0.176.
    2. use hisuite 10.x.x.550OVE and firmwarefinder on PC to downgrade to 10.1.0.134 (131)
    3. Got error with hisuite proxy (No internet connection)
    4. Remember to restart computer after change from hisuite 11 to husuite 10.
    5. Now i got "You are using the latest software"
    6. Use the register for proxy in firmwarefinder (at the top bar)
    7. Update your computer's network connection with the correct DNS from firmware finder.
    8. Now hisute proxy/firmware finder should work as before and all the files are there without error.
    9. Download over the net with proxy.
    10. Voila. 10.1.0.134 is installed.
    11. Start from scratch with GMS (googlefier or manual)
    (i did manual and use the indonesian file after donating to get no errors and notification even after restart. )
    12. A fully working P40 Pro inc. GPS, GMS, Notification, Playstore and no error.
    Only Google pay not working due to cts profile "false". Can only be fixed with root.

    Hope this help some of you guys.
    PS! After updating the correct DNS in your network card og router all the files in firmwarefinder works normally like before.

    Stay safe
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone