• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Downgrading with HiSuite (No Internet connection errror)

Search This thread

nick karki

New member
May 29, 2021
2
0
Why can not downgrade? Any suggestions pls. .. IMG_20210529_085344.jpg
 

Blastyyy

New member
Jul 9, 2021
3
1
Maybe this could help...

I came from 11.0.0.168. I reset my phone and am now running 10.1.0.134 software (432 region) Here is what i did:

1. use hisuite 11 to downgrade to 10.1.0.176.
2. use hisuite 10.x.x.550OVE and firmwarefinder on PC to downgrade to 10.1.0.134 (131)
3. Got error with hisuite proxy (No internet connection)
4. Remember to restart computer after change from hisuite 11 to husuite 10.
5. Now i got "You are using the latest software"
6. Use the register for proxy in firmwarefinder (at the top bar)
7. Update your computer's network connection with the correct DNS from firmware finder.
8. Now hisute proxy/firmware finder should work as before and all the files are there without error.
9. Download over the net with proxy.
10. Voila. 10.1.0.134 is installed.
11. Start from scratch with GMS (googlefier or manual)
(i did manual and use the indonesian file after donating to get no errors and notification even after restart. )
12. A fully working P40 Pro inc. GPS, GMS, Notification, Playstore and no error.
Only Google pay not working due to cts profile "false". Can only be fixed with root.

Hope this help some of you guys.
PS! After updating the correct DNS in your network card og router all the files in firmwarefinder works normally like before.

Stay safe
Do you have the download link of hisuite 10.x.x?
 

Blastyyy

New member
Jul 9, 2021
3
1
I am out of the Huawei business, but i have it in my computer. I can check after work👍🏼 oneplus 9 pro now
Thanks. I switched to huawei p40 and it's been a real nightmare to put google services on it. I've tried a thousand different ways and none has worked. Now that I found this method it´s HiSuite that gives me this internet connection error. Tnxx for help
 
  • Like
Reactions: fromiOS2Android

pixi86

Member
Mar 10, 2013
7
0
I managed to downgrade from EMUI 11 to EMUI 10 without using Proxy now aswell, so i'm down to 10.1.0.176 which is a step in the right direction. But now i run into the exact same issue as you describe "You're now using the latest official version"
How?
I am on 11.0.0.203 and i cannot find the way to do it over HiSuite - the "try another version" is not displayed on "you are on the last version" up
I have 2 P40pro-s, one was with 10.0.0.196 and this one went with ease. Another one is a headache
 

badmania98

Senior Member
Sep 23, 2007
1,203
470
51
ROMANIA
Huawei P40 Pro
How?
I am on 11.0.0.203 and i cannot find the way to do it over HiSuite - the "try another version" is not displayed on "you are on the last version" up
I have 2 P40pro-s, one was with 10.0.0.196 and this one went with ease. Another one is a headache
No. 3
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    i get a little bit different problem here, im trying to downgrade my P40 Pro ELS-LGRP4 10.1.0.166 to ELS-LGRP4 10.1.0.131 using hisuite + hisuite proxy combination, hisuite proxy run fine without problem, but when i try to check update from hisuite, it's always show "you're now using the latest official version" without "switch to another version" options.
    I already try hisuite from different version (10.1.0.550, 10.0.0.510, 10.0.1.100), and try hisuite proxy from different version (1.8.8(latest), 1.8.6, and bender007 modification), but the result always same, it's always showing "you're now using the latest official version".

    this is the steps I already taken to run hisuite proxy before running hisuite:
    1. open hisuite proxy
    2. fill the Packaget URL box with ELS-LGRP4 10.1.0.131 firmware url from firmware finder, fill the the version box with ELS-LGRP4 10.1.0.131 string from firmware finder; (in another test, i try to fill cust pkg, preload pkg and the version string, tick point version, tick CUST PKG box, tick Preload PKG)
    3. patching httpcomponent in hisuite folder
    4. run setup
    5. open hisuite and connect the phone

    but, whatever steps I try, hisuite always show that "you're now using the latest official version" message everytime I checking system update on hisuite

    Note:
    1. hisuite connection setting already ticked on proxy as the hisuite proxy recommended (127.0.0.1, port 7777)
    2. already check host file, and it's normal, no hicloud whatsoever
    3. no antivirus installed
    4. already set windows firewall off
    5. already try from different PC

    maybe someone can help me too fixing this issue here?

    hisuit 10.0.1.100.png
    hisuite proxy 1.8.8.png
    1
    I had the same issue, could downgrade to 176 using HiSuite then I used the OTG recovery with a firmware I was able to download. Version 121 (els-nx9-10.1.0.121(C432E8R5P2)) as my phone is a C432. Worked like a charm, an OTG adapter is only a couple of £/$ Mine cost £5 for two from Amazon.
    1
    I had the same issue, could downgrade to 176 using HiSuite then I used the OTG recovery with a firmware I was able to download. Version 121 (els-nx9-10.1.0.121(C432E8R5P2)) as my phone is a C432. Worked like a charm, an OTG adapter is only a couple of £/$ Mine cost £5 for two from Amazon.
    I am 176 and c432. Will try the OTG method. Thank you :)
    1
    Maybe this could help...

    I came from 11.0.0.168. I reset my phone and am now running 10.1.0.134 software (432 region) Here is what i did:

    1. use hisuite 11 to downgrade to 10.1.0.176.
    2. use hisuite 10.x.x.550OVE and firmwarefinder on PC to downgrade to 10.1.0.134 (131)
    3. Got error with hisuite proxy (No internet connection)
    4. Remember to restart computer after change from hisuite 11 to husuite 10.
    5. Now i got "You are using the latest software"
    6. Use the register for proxy in firmwarefinder (at the top bar)
    7. Update your computer's network connection with the correct DNS from firmware finder.
    8. Now hisute proxy/firmware finder should work as before and all the files are there without error.
    9. Download over the net with proxy.
    10. Voila. 10.1.0.134 is installed.
    11. Start from scratch with GMS (googlefier or manual)
    (i did manual and use the indonesian file after donating to get no errors and notification even after restart. )
    12. A fully working P40 Pro inc. GPS, GMS, Notification, Playstore and no error.
    Only Google pay not working due to cts profile "false". Can only be fixed with root.

    Hope this help some of you guys.
    PS! After updating the correct DNS in your network card og router all the files in firmwarefinder works normally like before.

    Stay safe