• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Drivers] MS Windows x86 and x64 USB Drivers for Samsung Galaxy S

Search This thread

TGA_Gunnman

Senior Member
Feb 5, 2010
565
783
Dallas, Texas
I'm drunk so bear with me. go into device manager and browse for the driver manually ,include subdir. point to programfiles\samsung.

if that don't work use the 64bit drivers on 32bit windows. don't run setup just browse to the extracted dir from the unknown device in device manager. it worked for me at work. good night

Gunnman from Galaxy S
 
  • Like
Reactions: beards69

TGA_Gunnman

Senior Member
Feb 5, 2010
565
783
Dallas, Texas
Try both 32bit and 64 bit drivers. At work I have 32bit win7 and the 64bit drivers fixed it up. Dont run setup just go through device manager chosse the unknown device and point it to the 64bit driver directory and check include sundirs.
 

rtorbs

Senior Member
Jul 3, 2010
144
3
Halifax
Try using correct drivers for your win version but turn the phone off, connect and then power up while connected....worked fine for me after messing with both lots of drivers first and no luck :D
 

ekim213

Member
Jul 29, 2010
9
0
thanks for all of your help so far guys.. BUT i still cannot get my laptop to sync up with the phone properly (win xp pro, sp3)...
I've downloaded and installed both drivers and the computer is recognizing the external drives, but they are showing as removable disks E: and F:. when i double click to open, it is telling me to insert a disk? i feel like i'm almost there, but there is somethign i'm missing!
usb is mounted and usb storage is off. usb debugging enabled.

any help would be appreciated.
 

adm1jtg

Senior Member
Jul 26, 2010
2,769
868
Georgia
Windows drivers issue

Have you tried mounting the drives. Same thing happened to me when you have it connected to the computer drop down the usb notification and mount. The your drives should be accessible.
 

Top Liked Posts