• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question EDL mode (9008 mode) Please Help To Fix

Search This thread
Someone in the field should know enough to accept responsibility for the risks. This is the second time you are trying to imply that I am either responsible for your problem or should be responsible for fixing it. It sucks you got yourself into that situation and I do hope you find a way out. As for me, the only choice appears to be to ignore you and spare us both the frustration of going in circles.
So I’ll wait because my phone is out of warranty and I can’t send it to China :( Please let me know if you find a solution, Thank you
The ROG Phone 3 had a working EDL recovery method. The ROG Phone 5 has SOME of the files needed to replicate the same method. Some firehose files are encrypted and must be patched. A few websites with limited access are providing files they claim to be the correct firehose file, but do not give a (un)patched status.

I have never bricked my own device so bad that I could not restore with raw firmware. The worst one has required using Windows, as Mac just didn't seem to flash as effectively. This has been noted in the restore thread.

Everything I have found or considered, along with what I have and haven't tested myself is somewhere in this device's section. It is either a thread or a reply to a thread already created about the issue. It is as transparent as air.

That is literally everything I know, as I have posted over the course of various conversations. Beyond that, I search almost weekly for that one site that slips up and leaves a link to one of the firehose files they claim will work. I do not pay sites because I am not willing to risk identity theft on the hunch it may be the right file.

That said, I cannot offer anything more. No amount of begging, bashing, bargaining, or any other word that does or doesn't start with a "b" will magically make the right files or method appear in my head or on my desk.

09:40:00 -!- twistedumbrella [[email protected]] has quit [Quit: Leaving]
  • Wow
Reactions: aimsjahan

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi guys
    Please help me to solve my problem. I tried several methods but unfortunately it was not solved. Does anyone have a suitable solution?
    My Phone Rog phone 5 ww ver bootloader Locked

    What is the specific problem you are trying to fix?
    My phone (Rog phone 5) turned off and didn’t turn on!!
    After connecting to PC, it enters to EDL Mode and doesn’t exit from it!!
    Help me that how can exit it from EDL Mode and use my phone again!?

    What were you doing when it started? Did you unlock the bootloader? Was it rooted? Did you flash something?
    It went to this state when the mobile phone was finished charging

    It's a completely stock phone? You've never unlocked the bootloader or tried to flash anything?

    If that's the case, you'd be far better off contacting Asus about it. It is well within the year warranty and you may require a special cable to flash it correctly yourself. It sounds like it may be defective, so even recovering it could only be temporary.

    I talked to the support department but did not answer
    Is there a way I can do it?
    I feel my bootloader is broken

    Probably need a deep flash cable, I believe it's called
    It says they are updating the page. You probably won't hear back over the weekend and they take a couple days to reply normally. It is the safest way to restore the phone, though.

    Making cables and using software that doesn't come directly from Asus for restoring from a brick is risky. It's a last resort when they say they won't help.