EDL mode on Redmi 4 Prime

Search This thread

alreadyregistered

Senior Member
Jan 17, 2016
1,014
203
LGB3kpk.png
 

li70

Senior Member
May 5, 2010
169
32
guys, can't get to edl in anyway :(
deepflash cable not working. testpin near battery not working. testpin that is one and a bit up plus shield to the right- not working. got diagnostics 900e still. stuck at boot loop, MI appears on a second and blank screen. That happend after i tried to flash throught TWRP.
any ideas? fastboot working , but that gives nothing since locked bootloader i think ?


Same situation here :(
Tried test point and cable and no solution, screen goes black when i power on and only can go to fastboot with phone locked.
Installed Qualcomm 9008 manually but still cant flash with flashtools.
I dont know anymore what to do.
 

SAFI_AFRIDI

Senior Member
Jan 14, 2015
161
100
Peshawar
www.youtube.com
guys, can't get to edl in anyway :(
deepflash cable not working. testpin near battery not working. testpin that is one and a bit up plus shield to the right- not working. got diagnostics 900e still. stuck at boot loop, MI appears on a second and blank screen. That happend after i tried to flash throught TWRP.
any ideas? fastboot working , but that gives nothing since locked bootloader i think ?

I have the same Issue and how i resolve is as under,
1: Open The Device Back Cover.
2: Open the Shield that or on the Battery upper Side.
3: Then Remove the Battery terminal connection. (must Disconnect the Battery).
4:then Touch the Test-point as you can see in .YouTube Video
5: Then Connect the Cable.
6:Volla here you will Got the 9008 Mode.

---------- Post added at 11:31 AM ---------- Previous post was at 11:31 AM ----------

Same situation here :(
Tried test point and cable and no solution, screen goes black when i power on and only can go to fastboot with phone locked.
Installed Qualcomm 9008 manually but still cant flash with flashtools.
I dont know anymore what to do.

I have the same Issue and how i resolve is as under,
1: Open The Device Back Cover.
2: Open the Shield that or on the Battery upper Side.
3: Then Remove the Battery terminal connection. (must Disconnect the Battery).
4:then Touch the Test-point as you can see in .YouTube Video
5: Then Connect the Cable.
6:Volla here you will Got the 9008 Mode.
 
  • Like
Reactions: li70

li70

Senior Member
May 5, 2010
169
32
I have the same Issue and how i resolve is as under,
1: Open The Device Back Cover.
2: Open the Shield that or on the Battery upper Side.
3: Then Remove the Battery terminal connection. (must Disconnect the Battery).
4:then Touch the Test-point as you can see in .YouTube Video
5: Then Connect the Cable.
6:Volla here you will Got the 9008 Mode.

---------- Post added at 11:31 AM ---------- Previous post was at 11:31 AM ----------



I have the same Issue and how i resolve is as under,
1: Open The Device Back Cover.
2: Open the Shield that or on the Battery upper Side.
3: Then Remove the Battery terminal connection. (must Disconnect the Battery).
4:then Touch the Test-point as you can see in .YouTube Video
5: Then Connect the Cable.
6:Volla here you will Got the 9008 Mode.

allready tested :( i have the 9008 driver i can see it but when i try to flash it says :

[7,03 COM10]:cannot receive hello packet,MiFlash is trying to reset status!
[7,04 COM10]:eek:bject reference not set to an instance of an object.

already tried all flashtools and no solution :( tried another pc with windows 7 64bits and same thing.
even made a flashcable i have the 9008 driver and same error.
tried a lot... :(
i dont need to do the testpoint to get the 9008 just take all battery cable and it installs 9008.
 

SAFI_AFRIDI

Senior Member
Jan 14, 2015
161
100
Peshawar
www.youtube.com
allready tested :( i have the 9008 driver i can see it but when i try to flash it says :

[7,03 COM10]:cannot receive hello packet,MiFlash is trying to reset status!
[7,04 COM10]:eek:bject reference not set to an instance of an object.

already tried all flashtools and no solution :( tried another pc with windows 7 64bits and same thing.
even made a flashcable i have the 9008 driver and same error.
tried a lot... :(
i dont need to do the testpoint to get the 9008 just take all battery cable and it installs 9008.

Ok Listen Carefully and Follow as i say.
1: Reboot Device while Pressing Vol(+) and Power but when the Device Vibrate then Release the Vol(+) key and Then Press and Hold Vol(-) Key. this will take the Device to a Recovery mode.
2: Then Download Chinese Mi Pc suit and then flash it with the recovery. it will work that way. and i will try to upload a video for this but first i will check that i have one or not. and sorry i am not often online on XDA but i am online on FB often.
 
  • Like
Reactions: li70

li70

Senior Member
May 5, 2010
169
32
Ok Listen Carefully and Follow as i say.
1: Reboot Device while Pressing Vol(+) and Power but when the Device Vibrate then Release the Vol(+) key and Then Press and Hold Vol(-) Key. this will take the Device to a Recovery mode.
2: Then Download Chinese Mi Pc suit and then flash it with the recovery. it will work that way. and i will try to upload a video for this but first i will check that i have one or not. and sorry i am not often online on XDA but i am online on FB often.

Thanks for your reply,
Unfortunately i don't have recovery mode, i can only get to fastboot (Locked), and when i restart i have black screen and logo miui shows and desapears very quickly.
Any other solution? :(
 

SAFI_AFRIDI

Senior Member
Jan 14, 2015
161
100
Peshawar
www.youtube.com
  • Like
Reactions: li70

li70

Senior Member
May 5, 2010
169
32
Thanks a lot i will try this late night ;)

error communicating with port, error with flash tools beta this time, always :(

http://i.imgur.com/v6bRrCO.jpg

and with flashtools version 2016.08.30 i get

0,00 COM20]:[COM20]:start flash.
[2,00 COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[4,51 COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[7,01 COM20]:try to reset status.
[7,51 COM20]:Switch mode back
[7,51 COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[7,52 COM20]:eek:bject reference not set to an instance of an object.
 
Last edited:

SAFI_AFRIDI

Senior Member
Jan 14, 2015
161
100
Peshawar
www.youtube.com
error communicating with port, error with flash tools beta this time, always :(

http://i.imgur.com/v6bRrCO.jpg

and with flashtools version 2016.08.30 i get

0,00 COM20]:[COM20]:start flash.
[2,00 COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[4,51 COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[7,01 COM20]:try to reset status.
[7,51 COM20]:Switch mode back
[7,51 COM20]:cannot receive hello packet,MiFlash is trying to reset status!
[7,52 COM20]:eek:bject reference not set to an instance of an object.

Do you disabled the Driver Signature in the Windows 7 or not ? and i will upload the old version of the Mi Flasher for you. and also Give a try on QFIL Software, but before watch a tutorial.
 
  • Like
Reactions: li70

li70

Senior Member
May 5, 2010
169
32
Do you disabled the Driver Signature in the Windows 7 or not ? and i will upload the old version of the Mi Flasher for you. and also Give a try on QFIL Software, but before watch a tutorial.

Hi again,
Yes I did disabled the Driver signature in windows 7 and 10 64 bits.
Yeah already tried QFIL gave me an error SAHARA FAIL ERROR, try to solve this error with https://www.youtube.com/watch?v=J7Hf_eMICTs but didn't work, I’m starting to think its lost already, its like it doesn’t recognize the device just don’t get it.
I thought when driver 9008 was installed with no error I could flash with no error but isn’t the case. :(
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Redmi 4 Prime doesnt display red led on EDL. It just shows up like Qualcomm 9008 on device manager.
    1
    Thanks for the replies, I will try 1st without disassembling , if it doesn't work I will try to disassemble it.
    1
    guys, can't get to edl in anyway :(
    deepflash cable not working. testpin near battery not working. testpin that is one and a bit up plus shield to the right- not working. got diagnostics 900e still. stuck at boot loop, MI appears on a second and blank screen. That happend after i tried to flash throught TWRP.
    any ideas? fastboot working , but that gives nothing since locked bootloader i think ?

    I have the same Issue and how i resolve is as under,
    1: Open The Device Back Cover.
    2: Open the Shield that or on the Battery upper Side.
    3: Then Remove the Battery terminal connection. (must Disconnect the Battery).
    4:then Touch the Test-point as you can see in .YouTube Video
    5: Then Connect the Cable.
    6:Volla here you will Got the 9008 Mode.

    ---------- Post added at 11:31 AM ---------- Previous post was at 11:31 AM ----------

    Same situation here :(
    Tried test point and cable and no solution, screen goes black when i power on and only can go to fastboot with phone locked.
    Installed Qualcomm 9008 manually but still cant flash with flashtools.
    I dont know anymore what to do.

    I have the same Issue and how i resolve is as under,
    1: Open The Device Back Cover.
    2: Open the Shield that or on the Battery upper Side.
    3: Then Remove the Battery terminal connection. (must Disconnect the Battery).
    4:then Touch the Test-point as you can see in .YouTube Video
    5: Then Connect the Cable.
    6:Volla here you will Got the 9008 Mode.
    1
    allready tested :( i have the 9008 driver i can see it but when i try to flash it says :

    [7,03 COM10]:cannot receive hello packet,MiFlash is trying to reset status!
    [7,04 COM10]:eek:bject reference not set to an instance of an object.

    already tried all flashtools and no solution :( tried another pc with windows 7 64bits and same thing.
    even made a flashcable i have the 9008 driver and same error.
    tried a lot... :(
    i dont need to do the testpoint to get the 9008 just take all battery cable and it installs 9008.

    Ok Listen Carefully and Follow as i say.
    1: Reboot Device while Pressing Vol(+) and Power but when the Device Vibrate then Release the Vol(+) key and Then Press and Hold Vol(-) Key. this will take the Device to a Recovery mode.
    2: Then Download Chinese Mi Pc suit and then flash it with the recovery. it will work that way. and i will try to upload a video for this but first i will check that i have one or not. and sorry i am not often online on XDA but i am online on FB often.
    1
    Thanks for your reply,
    Unfortunately i don't have recovery mode, i can only get to fastboot (Locked), and when i restart i have black screen and logo miui shows and desapears very quickly.
    Any other solution? :(

    Then when you start Device in EDL mode then Use Old Mi Flash Tools. and use it, for me its work. or try to follow the following method.
    Redmi 4 Prime Unlocking Unofficialy + TWRP+Lineage OS.