Question EdXposed framework not recognizing riru

Search This thread

jwidel

Member
Jun 25, 2021
28
7
I installed riru core from magisk manager and reboot. then i installed riru apk to verify riru installed then reboot x4. installed edxposed manager and rebooted twice. everytime i try to install edxposed framework from magisk i get redirected to github riru release page. what am i doing wrong?
 

aIecxs

Senior Member
Feb 17, 2016
3,213
5
788
gitlab.com
Magisk service.d not working is that due EdXposed riru messed up something? I can see it in Magisk log but it's lying
Code:
02-10 16:22:43.785   618  1321 I : * Running service.d scripts
02-10 16:22:43.786   618  1321 I : service.d: exec [40_sdext]

dmesg
Code:
[   38.647857] type=1400 audit(1644782200.992:1609): avc: denied { ioctl } for comm="busybox" path="/mnt/media_rw/4D47-9860/.data.sdext2.img" dev="mmcblk0p1" ino=1850 ioctlcmd=0x1272 scontext=u:r:magisk:s0 tcontext=u:object_r:vfat:s0 tclass=file permissive=1

edit: moved mount script into /data/local/tmp and created helper script in service.d which calls mount script. I don't know why but it "works" (at least the mount itself, still avc: denied)
 

Attachments

  • test.tgz
    233.8 KB · Views: 30
Last edited:

aIecxs

Senior Member
Feb 17, 2016
3,213
5
788
gitlab.com
@mlgmxyysd maybe you have any idea why this is permissive=1 and do you think it's normal that we get several avc denied in dmesg on android 10? kindly refer to Magisk github issue #5476
 

aIecxs

Senior Member
Feb 17, 2016
3,213
5
788
gitlab.com
so this seems unrelated to EdXposed as it is same problem without any modules at all. Tried also Zygisk no success. I want to inject supolicy --live how do I do that?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Do not try to install the latest riru version.
    It doesn't play nice with magisk.

    Install version v25.4.4 for example.
    Have that running without any problems here.
    1
    Use LSposed. EdXposed hasn't been updated in ages.
    1
    Had same issue and solved it by installing version v25.4.4 by following the video below. You can mute it and follow instructions,works beautifully.