Edxposed installation error

adithyavr

Member
Oct 25, 2012
33
0
0
Hi all,

FIrst of all, thanks a taking out time and responding to my questions, highly appreciate it. I have a new Rog phone 3 (Android 10) that I have successfully unlocked and rooted, with Magisk 21.1 installed (manager 8.0.3). I am trying to get edxposed framework up and running.

1. I tried installing Riru v 22.0. I rebooted twice as suggested in some forums.
2. I then tried installing edxposed (Both yahfa and ) 4563 when I install it says the following

! Requirement module 'Riru - Core' is not installed
! Installation failed.

This is driving my crazy because I have installed Riru. Can anyone help me out as to what I am doing wrong. I even tried downloading the files from GIthub tried to install from storage. Same error :(
 

shadowstep

Forum Moderator
Staff member
Jun 6, 2014
4,651
9,146
263
30
Ambala
Hi all,

FIrst of all, thanks a taking out time and responding to my questions, highly appreciate it. I have a new Rog phone 3 (Android 10) that I have successfully unlocked and rooted, with Magisk 21.1 installed (manager 8.0.3). I am trying to get edxposed framework up and running.

1. I tried installing Riru v 22.0. I rebooted twice as suggested in some forums.
2. I then tried installing edxposed (Both yahfa and ) 4563 when I install it says the following

! Requirement module 'Riru - Core' is not installed
! Installation failed.

This is driving my crazy because I have installed Riru. Can anyone help me out as to what I am doing wrong. I even tried downloading the files from GIthub tried to install from storage. Same error :(
Try using Riru v21.3 instead of v22.0. Modules using Riru (including EdXposed) need to be updated to support the new changes in v22.0
 

shah22

Senior Member
Apr 12, 2017
548
168
53
Pakistan
Exactly suffering the same problem in ed exposed but the solution posted by the respected moderated works ! Just downgrade riru core to version 21.3

Sent from my hero2lte using XDA Labs
 
Last edited: