• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

EMUI 10 / Hisuite Proxy

Search This thread

intropedro

New member
Jun 14, 2015
3
0
www.intropedro.com
Thank you very much @fbriere56 for your answer

When I tried to update from 8, after downloading and transferring it to the phone, it restarted and gave an error in the "Checking File% ...". In HiSuite the new update came out but it didn't give me the number 10.0 ... I tried all 10 Full-OTAs and it did not show me anywhere.

At the end I started using the mobile and until I put the SIM I did not get the updates on the mobile and It made me update one by one (I think I did at least 6 or 7 until I reached 10)
 

j4v1lol

Member
Oct 31, 2016
43
3
Hi guys. Can I update to Android 10 directly from Android 8 or 9?

Im having gps problems and I think it is because Ota update and no full version...

I am on Clt-l29 on 10.0.0.171 version.
@fbriere56
We discussed this issue before. Many many people is having GPS problems because of this software. I even had my motherboard replaced (Before I was CLT-L09 and now I'm CLT-L29 dual sim) C432 zone.
Even with the replacement of the motherboard I have again the problem so I can ensure that it's not hardware related. The prob is my phone Views the satellites but can't use them to get a GPS lock. I do not know if updating via a FULL-OTA and not only the small OTA packages that Huawei provides could help... Maybe gps.conf is badly set? I'm desperated with this. Could you recommend me any version or what I could do? Maybe another clean install?


I got another thread:

https://forum.xda-developers.com/huawei-p20-pro/help/gps-ruined-emui-10-update-wont-hard-t4154421
Thanks
 
Last edited:

fbriere56

Senior Member
May 16, 2020
199
114
Somewhere in the forests of Canada
Hi guys. Can I update to Android 10 directly from Android 8 or 9?

Im having gps problems and I think it is because Ota update and no full version...

I am on Clt-l29 on 10.0.0.171 version.
@fbriere56
We discussed this issue before. Many many people is having GPS problems because of this software. I even had my motherboard replaced (Before I was CLT-L09 and now I'm CLT-L29 dual sim) C432 zone.
Even with the replacement of the motherboard I have again the problem so I can ensure that it's not hardware related. The prob is my phone Views the satellites but can't use them to get a GPS lock. I do not know if updating via a FULL-OTA and not only the small OTA packages that Huawei provides could help... Maybe gps.conf is badly set? I'm desperated with this. Could you recommend me any version or what I could do? Maybe another clean install?


I got another thread:

https://forum.xda-developers.com/huawei-p20-pro/help/gps-ruined-emui-10-update-wont-hard-t4154421
Thanks

C432 ?
 

fbriere56

Senior Member
May 16, 2020
199
114
Somewhere in the forests of Canada
Yes. I managed to install 172 but it's not registered on my zone.

Yeah, I don't own every revisions of the P20 Pro, even if they are almost the same, you should try with .171. (if by registered you mean, it doesn't pass the safetynet test)

This is something I can check, give me your revision ex: CLT-LXX with the region.

I didn't have tested .174 because of the weird changelog. (version="Charlotte-L0I 10.0.0.169(C675E5R1P1)") to me it was a lost of time.

We are probably going to have a new update coming "soon", maybe the last one.

The P30 and P30 Pro are getting their new OS. (harmony..)

Everyone who has visited this thread should ask them to put back their webpage to get our bootloader code.

Anyway no one here is under warranty. That would be a good thing if they really want to do it.

For us it's just ENOPOLITIC. We don't care about the decisions of our government, it would be a good move if
they can finally go back on the subject and leave us free. We bought theirs devices, mine is still in pretty good shape and a good phone.

33,010 peoples visited this thread. It's not everyone that are going to ""spark"" their phone to get something. (if you know what I mean)

(electromagnetic fault injection)

Best regards.
 
Last edited:

j4v1lol

Member
Oct 31, 2016
43
3
Hey,

Only 171 is approved in my region. I managed to install with your guide and luckily I got no Vodafone app **** since my installation is clean.

What I discovered is that the SIM CARD was the one struggling with my GPS... Many many people could have this problem. My brother has another carrier and got no problem...
 

JuliaPiers

Member
Nov 3, 2020
6
0
I am having GPS problems too because of this software. I tried to restart my phone a few times but with no use. I think my phone sees the satellites but can't use them to get back a GPS lock. Anyways, my friend showed me a proxy which is rotating 5 million ips. So, I think I'll try that one, it seems reliable. I don't know about you guys, but when I have some problems with software I am quickly switching to a new one or I find a replacement. I like it when everything works smoothly without any issues.
 
Last edited:

fbriere56

Senior Member
May 16, 2020
199
114
Somewhere in the forests of Canada
Anyone recently tried to upgrade to .182 ? (I mean on a CLT-L04 C69 or C792)
Because when I updated like 3-4 weeks ago all of the build were not certified.

But like I said before, it was before the rollout in EU/UK etc start.

It's possible that the build is certified now. (Note also, you can downgrade to .172 after without having to do a low factory reset)

So you don't lose anything. I may try again tonight but everytime I'm not near a windows computer.

Best regards. (I tried from .172 to .18x up to .182)

There's a big chance now that some builds are certified depending of your region.
 
Last edited:

fbriere56

Senior Member
May 16, 2020
199
114
Somewhere in the forests of Canada
So again the .180 OTA is broken. Cause a bootloop when installing. So I used the full-OTA again.

10.0.0.180 is not certified for CLT-L04 C792 or C69. I will update when everything is done downloading.

Moving to .181

Well now I am at least on a 150 mbits line. I am probably doing this again for nothing. Each time CA is the last with USA.

Edit: .181 is not approved on CLT-L04 C69 and C792. (upgrading to .182 now..)

Edit #2: .182 OTA is broken too, cause a bootloop at 11% when installing.

So doing a full-OTA again with CLT-L04 C69 and C792. This is looking exactly like 3-4 weeks ago.

None of theses builds are certified in NA. I will update, anyway I don't care. Going to stay with .182 C69 or C792.

Question of time before a new build get released or certified. I expect a bump like .185

Note that I am only speaking about the CLT-L04 (N/S America) you guys in EU/UK/Poland can install .182 (certified, yes google pay and all)

Peace.
 
Last edited:

dabo2100

Senior Member
Dec 22, 2013
93
29
Cluj-Napoca
HELP

I've tried to downgrade to Emui 9.1 using HiSuite, everything went fine during the process but after the restart, I got an error message:

Your device has failed verification and may not work properly.

and the phone no longer starts again :(. I've tried already all the options available on Recovery Mode but none of them worked. My last hope is to see if there's a way to recovery/rollback the OS with HiSuite and HiSuiteProxy.

@fbriere56 I saw your comment here: https://forum.xda-developers.com/t/emui-10-hisuite-proxy.4109035/post-82844325 but what exactly do I need to do? With the phone connected with USB and in Fastboot mode, the only option available on HiSuite is System Recovery and, when I tried it says: "Your device is not supported for system recovery" :cautious:

Any help would be appreciated! 🙏 Thx!

Model: CLT-L29(C432)

EDIT: already tried this method, but when clicking System Recovery on HiSuite, it tells me: "No recovery packages for your phone model" and, this is what I added to the XML file:

XML:
<rule type="CLT-l29" cnName="P20 PRO(CLT-L29)" enName="CLT-L29" option=""></rule>
 
Last edited:

dabo2100

Senior Member
Dec 22, 2013
93
29
Cluj-Napoca

Unfortunately, it doesn't work. After setting up HiSuite-Proxy, enabling my phone model on HiSuiteConfig.XML and pointing HiSuite to proxy 127.0.0.1, port: 7777, once I click System Recovery, and finally Recover, it has thrown an error: "No Internet connection. Please check your network settings". With removing the proxy and port on HiSuite I just got: "No recovery packages for your phone model"

What else can I do? I'm running out of options and I'm a bit desperate now 😔.
 
Last edited:

redimpulse1

Member
Apr 26, 2021
8
1
This is my CLT-L29 Global can I upgrade this from the ones posted here so I can at least get my Volte option be turn on?
 

Attachments

  • Screenshot_20210520_132128_com.android.settings.jpg
    Screenshot_20210520_132128_com.android.settings.jpg
    248.5 KB · Views: 21

ultravy

Senior Member
May 22, 2013
204
70
unknow
Huawei P20 Pro
OnePlus 6
This is my CLT-L29 Global can I upgrade this from the ones posted here so I can at least get my Volte option be turn on?
You can try change preload and custom! I had gps problems after going on android 10, went back to 8.1 and just minimal change! I don't know what they messed up, in vendor partition. I stick with 9.1. use the latest hisuite proxy with hisuite ver 10 not 11, didn't worked for me!
 

Top Liked Posts