• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

EMUI 11 "power-intensive app" toggle gone?

Search This thread

methex9

New member
Dec 26, 2020
4
1
Hey guys! I finally got the EMUI 11 update a few days ago, but there is something that's driving me crazy since. My P40 Pro is googlefied, and it has been and is working perfectly with GMS, but since I updated I keep getting a notification that the Google Services Framework is a power-intensive app and Huawei recommends me force closing it. I had these before with some apps on EMUI 10 too, like with Line and Facebook, but there used to be an option to turn off the "power-intensive" notification for a certain app. With EMUI 11 that seems to be gone, and I keep getting this notification about Google Services Framework at least twice a day. It is super annoying and I can't find a way to turn it off. I checked around the Battery settings, in the app settings, but the option seems to be gone. I hope one of you figured out how to deal with this, I really don't want to downgrade but I think I will if I can't fix this issue. Looking for help, thanks in advance!
 

skylinestan

Senior Member
Apr 8, 2011
576
82
Hey guys! I finally got the EMUI 11 update a few days ago, but there is something that's driving me crazy since. My P40 Pro is googlefied, and it has been and is working perfectly with GMS, but since I updated I keep getting a notification that the Google Services Framework is a power-intensive app and Huawei recommends me force closing it. I had these before with some apps on EMUI 10 too, like with Line and Facebook, but there used to be an option to turn off the "power-intensive" notification for a certain app. With EMUI 11 that seems to be gone, and I keep getting this notification about Google Services Framework at least twice a day. It is super annoying and I can't find a way to turn it off. I checked around the Battery settings, in the app settings, but the option seems to be gone. I hope one of you figured out how to deal with this, I really don't want to downgrade but I think I will if I can't fix this issue. Looking for help, thanks in advance!

This new updates that I done last week also same with popups about battery intense app for Google framework and GMS.. solution is just ignore it from the setting in battery... maybe next update will have a fix hopefully
 

methex9

New member
Dec 26, 2020
4
1
This new updates that I done last week also same with popups about battery intense app for Google framework and GMS.. solution is just ignore it from the setting in battery... maybe next update will have a fix hopefully
Thanks for the reply! At least I know I'm not alone with the issue. Could you clarify your solution? How to ignore it in the battery settings? I couldn't find an option for it.
 

methex9

New member
Dec 26, 2020
4
1
Okay I'm back after some testing. So first thing I tried was cleaning the cache of the Play Store, Google Services and Google Services Framework -> did not help. After that I compared the version info of said apps on my P40 Pro to my Huawei Mate 20 Pro, and even though the Store was up to date, i found out that the Google Services and GSF hasn't updated on my P40 Pro. I installed an app called "Launcher Google Play Services Settings (Shortcut)", and through that I was able to update my Google Services. It didn't break the installed GMS, but didn't fix the power intensive app notification either. After that I updated the Google Services Framework manully, downloaded the exact version my Mate 20 Pro has (10-6475670). Update went well, It did not break my GMS install, everything works perfectly but hasn't fixed the notification issue. Now I'm testing a workaround that seems to be working, but I'll give it an other day to see if it really works. If it does, I'll post my solution here.
 

methex9

New member
Dec 26, 2020
4
1
So that wasn't the solution?
Happy new year guys! Sorry for the late reply, as it fixed my problem I forgot about this topic. So the workaround is pretty easy, and it's about disabling notifications for the Optimizer app. EMUI doesn't have the option to disable notifications for Optimizer by default, but it is possible with a third party app called NCleaner, search "Notification Blocker & Cleaner & Heads-up Off" in the Play store. After install it will ask for permission to access notifications, then while the Notification Cleaner is turned on, click on the 3 dots on top right corner, go to settings. Search for the Optimizer app, and click on it (no need to mess around with the toggle, click on the Optimizer itself) and a menu will pop-up where you can completely disable the notifications for said app. After you turned it off, you can actually uninstall NCleaner, and the notifications will keep being turned off for the Optimizer even if you restart your phone, except if you go to the settings of EMUI, and open the Optimizer notifications menu, it will turn itself back on automatically. So install NCleaner, disable the notification for Optimizer with the help of it, uninstall the app, and don't open the notification settings of Optimizer or you'll have to turn it off in NCleaner again. This is actually not the main functionality for NCleaner, it can also hide notifications automatically for the apps, but I think it's easier to just disable it as it is, so NCleaner doesn't have to run in the background eating up battery.
 
  • Like
Reactions: qbcgraphics

qbcgraphics

Member
May 27, 2010
25
7
Happy new year guys! Sorry for the late reply, as it fixed my problem I forgot about this topic. So the workaround is pretty easy, and it's about disabling notifications for the Optimizer app. EMUI doesn't have the option to disable notifications for Optimizer by default, but it is possible with a third party app called NCleaner, search "Notification Blocker & Cleaner & Heads-up Off" in the Play store. After install it will ask for permission to access notifications, then while the Notification Cleaner is turned on, click on the 3 dots on top right corner, go to settings. Search for the Optimizer app, and click on it (no need to mess around with the toggle, click on the Optimizer itself) and a menu will pop-up where you can completely disable the notifications for said app. After you turned it off, you can actually uninstall NCleaner, and the notifications will keep being turned off for the Optimizer even if you restart your phone, except if you go to the settings of EMUI, and open the Optimizer notifications menu, it will turn itself back on automatically. So install NCleaner, disable the notification for Optimizer with the help of it, uninstall the app, and don't open the notification settings of Optimizer or you'll have to turn it off in NCleaner again. This is actually not the main functionality for NCleaner, it can also hide notifications automatically for the apps, but I think it's easier to just disable it as it is, so NCleaner doesn't have to run in the background eating up battery.
this saved my day thx methex9(y):)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    So that wasn't the solution?
    Happy new year guys! Sorry for the late reply, as it fixed my problem I forgot about this topic. So the workaround is pretty easy, and it's about disabling notifications for the Optimizer app. EMUI doesn't have the option to disable notifications for Optimizer by default, but it is possible with a third party app called NCleaner, search "Notification Blocker & Cleaner & Heads-up Off" in the Play store. After install it will ask for permission to access notifications, then while the Notification Cleaner is turned on, click on the 3 dots on top right corner, go to settings. Search for the Optimizer app, and click on it (no need to mess around with the toggle, click on the Optimizer itself) and a menu will pop-up where you can completely disable the notifications for said app. After you turned it off, you can actually uninstall NCleaner, and the notifications will keep being turned off for the Optimizer even if you restart your phone, except if you go to the settings of EMUI, and open the Optimizer notifications menu, it will turn itself back on automatically. So install NCleaner, disable the notification for Optimizer with the help of it, uninstall the app, and don't open the notification settings of Optimizer or you'll have to turn it off in NCleaner again. This is actually not the main functionality for NCleaner, it can also hide notifications automatically for the apps, but I think it's easier to just disable it as it is, so NCleaner doesn't have to run in the background eating up battery.