• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Enable Bluetooth DUN on Sprint Touch Pro2!

Search This thread

defcon6

Member
Mar 28, 2008
7
1
This took me a while, but I finally figured it out through trial and error. I know there are a few options out there for tethering, but this has always been the preferred way to tether when I was using the Diamond. It's wireless, you can initiate the connection from the PC, and it gives you better battery life than WMWiFiRouter or HTC Wifi Sharing. Best of all, you DO NOT need to initiate a DATA connection on the phone before connecting to your PC! Just fire up the BT DUN connection on your PC, click Dial, then browse the web!


Here's how we do this:

Install DotFred's TaskManager
Click select Menu, Tab Options, Select Tab, Services. Find "CM Guardian", click and hold until menu pop up and select "Set Manual".


Make the following changes on your TP2 with a Registry editor:
1. [HKEY_LOCAL_MACHINE\Comm\InternetSharing]
Extension="" Delete the "isext.dll"
2. [HKEY_LOCAL_MACHINE\Comm\InternetSharing\settings]
ForceCellConnection="Sprint"
3. [HKEY_LOCAL_MACHINE\Software\OEM\Wmodem]
Check Profile=0
Connected=0
Multi-NAI=0
WModemDUN=0

4. [HKEY_LOCAL_MACHINE\Software\WIDCOMM\Plugin\DUNServ er\ControlPanel]
Enabled=1


That's it! Re-pair your TP2 to your PC and BT DUN should be available as one of the services. Create a new DUN profile on your PC, leave username and password blank, and set dial number as #777. Click dial and you should be able to connect... just like old times. :D
 
  • Like
Reactions: cattledogit

daddylonglegs

Senior Member
Oct 23, 2009
500
103
Vermont
Thank you so much for posting this. I have been ripping my hair out over this. However, I am on Verizon and thus my HTC Touch Pro2 has somewhat different entries in the registry than Sprint does. Does anyone know how to get DUN working with the HTC Touch Pro2 on Verizon? I bought a laptop specifically with Bluetooth just to use my phone as the modem but cannot get it working for my life.

After I did all the registry edits I could that you mentioned (even though all of them were not available since I'm on a different provider) I noticed when I try to dial out for a SPLIT second I will see "Dial Up Networking" listed under Bluetooth services. Windows promptly gives me a dialing error and that service on my phone disappears.

Anyone can give any pointers?
 

TazGrl79

New member
Aug 8, 2008
3
0
There is no "CMGaurdian" on my phone. I did a full search for it and it's nowhere to be found. I have the stock Windows Mobile 6.5 rom. But it looks like without being able to set that as manual, I have to change the registry everytime I end up having to restart my phone. But even when I do that, it still goes back to phone as modem after a few minutes instead of staying on Sprint.
 

RrenKatan

New member
Mar 25, 2010
2
0
Awesome!

Thanks for the info. The connection sharing wasn't working for me anyway.

Just an FYI, you can optionally edit the registery to set the CMGuardian to Manual.

Open a reg editor and navigate to [HKLM\Services\CMGuardian]
Locate the Index key and change the value from 2 (default) to 1.
 

wildpig1234

Senior Member
May 31, 2008
254
9
So anyone on Sprint TP2 with 6.5 stock rom actually got Wmodem to work? I've spent about 24 hr trying just about everything with no luck so far.

I made all the above reg changes, have WModem v02 installed on my TP2. Activate the wmodem prog, connect to computer with usb cable. When i try to connect on my computer, it stucked on verifying user name and pass. There is some sort of data connection going on on the phone itself, but the computer connected to the phone couldn't seem to go pass that "verifying user name and pass"

Much appreciated any help or comment. Thanks
 

ditm02

Member
Sep 6, 2008
30
0
Lake Orion
Problem tethering via Bluetooth DUN to pspgo

Ok, I am pulling MY hair out on my ATT tilt 2. I am trying to use my fone as a bluetooth modem for my pspgo.

It seems that my Tilt 2 receives the data from the pspgo, but its not sending any data to the pspgo, when I test the connection the tilt2 receives about 9-16 bytes, but it says sent: 0 bytes.

I have energyROM july 16 2010 WWE winmo 6.5
Manilla 2.5.20161332.0
Build: 23563.5.5.0

I have seen vids of people doing this on the Raphael (FUZE) and other phones
I keep getting this connection error on my psp: (8030000B) I have tried so many dial #'s, changing settings, PDAnet,

I think the problem has something to do with:

it being WinMo 6.5 or
The custom ROM has disabled something in the Bluetooth or
Since the ROM is custom, the psp wont recognize this for some reason because just like the WIFI router; the carrier doesn't know I'm tethering. or
I have the wrong Dial-up # or
Authentication settings or Initialization command is wrong or
I need to use a Proxy network
Some other reason ( The ROMS BT stack) whatever that is lol

:confused::confused::confused:

Does anyone have this or similar problem? Or know whats happening here?
Any help would be awesome!
Thank you
 

vihurricane

New member
Aug 25, 2006
2
0
Worked Perfectly

After making the changes you suggested, this worked perfectly on my TP2. It's so funny, after I initially got my TP2 and tried it, I instantly gave up. Now that I'm a month away from going to a new carrier, and most likely a Sony Ericsson Xperia X10, I got really interested in getting this working. It was a breeze using the Resco Explorer Demo with included Registry Editor.
 

ethanpil

Senior Member
Nov 20, 2007
54
2
TP2 Stock WM6.5

Doesnt work for me. I dont have CMGuardian.

I went ahead and edited the registry anyway and still didnt work even after rebooting.

I'm hoping someone can help figure this out... Trying to tether with my new Xoom! :)
 

Ferrari328

Member
Mar 24, 2008
14
0
Never mind, I did run the cab from pengc99 and it worked fine. After soft reset of the phone, it never got out of the "modem negotiating" state but running the cab again fixed it. Now if I just could find the equivalent to CMGuradian I would be all set but this is at least working.
 

zzvelik

Member
Dec 4, 2007
10
1
Bluetooth setting to ALWAYS ON?

Thanks to this thread and the pengc99 file, I successfully (quite some time ago) paired my TP2 via the bluetooth to a Nexus 7 tablet as well as an android phone, but each time I turn on the phone, I have to go through the following steps:

1. Select Communication Manager
2. Turn ON the Data Connection
2. Click on Bluetooth
3. Select one of my paired devices, such as the Nexus 7 by clicking the large "+" icon
4. Select Bluetooth Networking
5. Select the "Share Internet Connection" option
6. Click Continue on the bottom

I tried various registry edit searches here and on google, but cant' find any way to lessen these steps or preferably have the Bluetooth sharing set to ON at all times. If anyone knows how to simplify this process, please post the stops or file that will help us all.

Thanks in advance
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    This took me a while, but I finally figured it out through trial and error. I know there are a few options out there for tethering, but this has always been the preferred way to tether when I was using the Diamond. It's wireless, you can initiate the connection from the PC, and it gives you better battery life than WMWiFiRouter or HTC Wifi Sharing. Best of all, you DO NOT need to initiate a DATA connection on the phone before connecting to your PC! Just fire up the BT DUN connection on your PC, click Dial, then browse the web!


    Here's how we do this:

    Install DotFred's TaskManager
    Click select Menu, Tab Options, Select Tab, Services. Find "CM Guardian", click and hold until menu pop up and select "Set Manual".


    Make the following changes on your TP2 with a Registry editor:
    1. [HKEY_LOCAL_MACHINE\Comm\InternetSharing]
    Extension="" Delete the "isext.dll"
    2. [HKEY_LOCAL_MACHINE\Comm\InternetSharing\settings]
    ForceCellConnection="Sprint"
    3. [HKEY_LOCAL_MACHINE\Software\OEM\Wmodem]
    Check Profile=0
    Connected=0
    Multi-NAI=0
    WModemDUN=0

    4. [HKEY_LOCAL_MACHINE\Software\WIDCOMM\Plugin\DUNServ er\ControlPanel]
    Enabled=1


    That's it! Re-pair your TP2 to your PC and BT DUN should be available as one of the services. Create a new DUN profile on your PC, leave username and password blank, and set dial number as #777. Click dial and you should be able to connect... just like old times. :D
    1
    Just wanted to add that I found this thread useful, got the registry entries and made a cab for it. This is for Sprint only! Download, install, and go, no need for registry editing!