Enable ECG(BP Featur) On Non-Samsung Phones for Galaxy Watch 3, Active 2 Step-By-Step

MRSA99

New member
Dec 28, 2020
1
0
1
Sorry bro I still can't reach connection no RSA request , restart everything PC and Watch multitle times, switch off all firewalls even add your rules (I have same ports like you) and still nothing :crying: . Sometimes I even haven't got error message just switcher is blue ON and nothing happened( same issue in Tizen studio and device manager too) I try connect via sdb tools and there sometimes type you already connected sometimes type connection failed :(. I'll try search some another solution, but I'am afraid my PC is broken :confused: :laugh: . Damn Samsung is bastard. Sell products like no alert for non Samsung phone users and then you got update with functions but ONLY for S phones :(
Hi, did you manage to get the RSA request on the watch?

I have been trying fot the last day to get it, tried every mentioned solution... no luck
weird thing is: it worked last week!

Does anybody else have tips how to get the watch to connect to device manager, especially to get the RSA key on the watch?
 

iamsumitkumar

New member
Jul 12, 2015
2
0
21
New Delhi
Thank you very much!! @xxstd

I had some problems running "sign.bat" due to relative path command routes, but after "customizing" the script changing to absolute path, all went ok.
I've signed BP.tpk and ECG.tpk and both are running OK in my GW3. I live in Spain, and here in Europe neither ECG nor BP are approved, so it is not the reason your BP tpk is not working IMHO.
Can you help me with this as I am also unable to run the sign.bat command as it is giving some java related errors
 

thanito

Senior Member
Jul 10, 2008
1,015
115
93
My Samsung health app stopped syncing my BP data from Samsung health monitor on my galaxy watch active 2. Health monitor version is 175Caravana.

Any way to fix it? Permissions are on, developer mode enabled in app. CTJ5 firmware on the watch.

Thanks!
 

jerryjbrillrice

New member
Dec 3, 2020
2
0
1
Been following the steps and able to enjoy BP and ECG function on my GWA2 SM-R820. However recently after the CTJ5 version update, ECG function is not usable (some times can't proceed to take readings when fingertip is placed on the button, most of the time readings are like crazy fluctuations for a few seconds before stopping). Not sure it is due to the update or a faulty button? Anyone is facing the same issue after the update? Anyone knows how to work around it?
Hello appreciate if anyone here can help? Apparently my brother's GWA2 also showing the same issue (erratic readings and stops at 25th second) around the same time as mine when taking an ECG. Many said that the issue are likely caused by faulty ECG sensor but could the ECG sensor be faulty and unreliable so fast as our watches are not even 5 months old? Would love to believe it is likely a software issue rather than hardware as the chances of coincidence are kinda narrow? @xxstd @adfree
 

Nima79

Senior Member
Jul 22, 2010
170
25
58
10. Once it find your watch turn the connection switch to on. and close pop-up windows. At this time, you should able to see lots of debugging information from Device Manager. (If you don't see debug information, try these steps: 1. Turn off your windows firewall 2. turn off bluetooth&GPS on your watch 3. reboot your watch )
thanks alot i did it / only in this level i got problem.
device manager cant recognize my watch ( even after trun off gps/ bluetooth / windows firewall / restart windows and watch ) i had to add my watch to it with IP ( after conected watch to wifi network go to wifi setting and find the ip and add it
manually to device manager after that need to confirm conection on watch . just it )
 

Machpants

New member
Jul 22, 2010
3
0
21
AWESOME - thanks for this, followed it and it worked perfectly. ECG and BP both working in New Zealand with Pixel 3A. Neither are available here officially yet :)
 

Olympus593

Senior Member
Aug 8, 2010
157
53
48
Open a command prompt window with admin rights in folder Fit2installer and run the following command:
sdb uninstall com.samsung.health.samd.bp

After, repeat the step 19 with BP.tpk, it will work.
I'm getting and error when trying to uninstall it:
Code:
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[start] val[uninstall]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[appid] val[com.samsung.health.samd.bp.bp-service]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[appid] val[com.samsung.health.samd.bp.bp-home]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[appid] val[com.samsung.health.samd.bp.home]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[appid] val[com.samsung.health.samd.bp.ecg-home]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[appid] val[com.samsung.health.samd.bp.ecg-service]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[appid] val[com.samsung.health.samd.bp.widget]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[install_percent] val[4]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[install_percent] val[9]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[error] val[-4]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[end] val[fail]
processing result : Operation not allowed [-4] failed
spend time for pkgcmd is [984]ms
If trying to install the BP.tpk as per step 19:
Code:
.\sdb install .\install_me\BP.tpk
WARNING: Your data is to be sent over an unencrypted connection and could be read by others.
pushed                         BP.tpk   100%       1977KB           0KB/s
1 file(s) pushed. 0 file(s) skipped.
.\install_me\BP.tpk              1266KB/s (2025436 bytes in 1.561s)
path is /home/owner/share/tmp/sdk_tools/BP.tpk
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[start] val[update]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[install_percent] val[10]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[error] val[-1]
__return_cb req_id[1] pkg_type[tpk] pkgid[com.samsung.health.samd.bp] key[end] val[fail]
processing result : General error [-1] failed
spend time for pkgcmd is [1759]ms
Ony ECG working here. Tizen 5.5.0.1.
 

DEKAPITAT0R

New member
Jan 11, 2021
1
0
11
THANK YOU! It worked like a breeze (except for the slow samsung servers). Alongside with the installation of the ecg-file, the installation of the BP-file worked as well as that after one restart of the Health Monitor App on my Pixel 3 (in Germany).
 

jadonv

New member
Jul 11, 2012
1
0
21
I got this up and running 🙏 but would love to get the blood oxygen working too.

Im currently in canada with XAC firmware... so in order to unlock it do i need to reload the firmware from scratch and change the region?

I have the most up to date version of the SH and modded SHM from the states but it doesn't show up in app.

Here is the video I saw on the process for changing region:


I assume I would do this and then re do the process on this thread..

Thanks in advance if you've managed to get it all working and can help out :D

HACKTHEPLANET :alien:
 

lordmada

Member
Mar 18, 2014
21
2
23
Thanks bro. Worked successfully on Oneplus McLaren Pro and Galaxy Watch 3

Note these tips as mentioned :

1. Make sure that you have copied your cert files from your cert location to 'cert' folder inside 'fit2installer'

2. DON'T run sign.bat as administrator

3. Remember to turn off watch bt before scan watch via Device manager and TURN IT ON again after FINISHING installing your apps

4.At last step, You will need to clear storage of Samsung health monitor app in your phone in order to make it pair successfully with your watch
 
  • Like
Reactions: galaxys

LarsAhl

New member
Jan 15, 2021
1
0
11
Than you for this guide, I got everything to work, except my watch is draining battery like never before.
Is there anyway to totally factory reset it (like it was before)? If did a hard reset but it didn't help 😒
Very grateful for some help here!
 

GW2_MAX

New member
Jan 17, 2021
1
0
1
Hi all, hope some guy could help me, i'm stuck into problems. I'm in Italy and have a Huawei Mate 10 Lite. I followed the procedure fairly easily, but at the end I got 2 problems:
1) While installing the BP.tpk with Tizen, i get the following error: "Processing Result: General error [-1] failed". What should i do?
2) ECG installed correctly, i see the icon on the watch and SHM on the phone connects with the watch. But in order to access Samsung Health Monitor (175 mod4), it seems that Samsung Health (standard green app) is required, but the access it's impossible: the wheel icon is showed for an infinite time.... Skippinkg Samsung Health installation/registration didn't work for me, as I'm not able to access SHM (orange/purple app) without Samsung Health; in this case it keeps me on "create your profile" screen....
Could you please help with the above? Thanks in advance!